Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
renjithis

Manual hackintosh installer USB creation - kernel panic

7 posts in this topic

Recommended Posts

Hi,

I am trying to create a mountain lion (10.8.3 or 10.8.0) hackintosh USB. These are the steps that I followed :

created 2 partitions : 200mb and rest of the pendrive (15GB)

marked 200mb partition as bootable

formated both as hfs+

dd if=boot0 of=/dev/disk1 bs=440 count=1

dd if=boot1h of=/dev/disk1s1

mounted 200mb partition and copied boot

mounted 15GB partition

mounted BaseSystem.dmg anc copied its contents into 15GB partition using rsync -Pah

removed System/Installation/Packages

copied Packages from mounted InstallESD.dmg to System/Installation (again using rsync -Pah)

copied mach_kernel from InstallESD.dmg to 15gb partition

 

I tried using cp -a instead of rsync, but no success.

 

The chameleon/chimera starts successfully, but would kernel panic just after the installer boot process creates RAM Disks. please see the attached image

 

post-930818-0-22935000-1365166843_thumb.jpg

Share this post


Link to post
Share on other sites

hello

 

something wrong there...

 

why don't u use pandora ?

 

http://www.insanelym.../11-pandoraapp/

 

good hack

 

I would like to learn to do it manually. I have used utilities like #####, myHack, etc, but want to know how these applications do it. Can you tell me what is wrong and how I can correct it?

 

PS : Where can I get the source code for Pandora.app ?

Share this post


Link to post
Share on other sites

Thanks...

After reading http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/ , I thought OSx86 supported Pandora app because it was OSS. Sorry for the misunderstanding

The major difference I can see from the Olarila post method and the one I used seems to be copying the contents of BaseSystem.dmg. While I was copying the contents after mounting, they recomend restoring the DMG to the destination partition. I will check it out

Share this post


Link to post
Share on other sites

Thank you for the answers, I was able to create the USB manually. As described in the linked posts, the USB boots properly when BaseSystem.dmg is restored to the drive, instead of rsync ing it like I was doing. Does this mean that BaseSystem.dmg has some non-file data (like boot sector data, etc) that won't get copied to USB when using rsync?

When I tried to extract the BaseSystem.dmg using pk7zip (in Linux), I got a few files in a directory named '[]' with the filenames containing Inode-<somenumber> these files and the directory '[]' are not exactly files that are seen when BaseSystem.dmg is mounted.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×