Jump to content
InsanelyMac Forum
qwertzuiop258

Internal kyboard and touchpad of laptop don't work

Recommended Posts

Hello everyone,

 

during my install of Mountain Lion 10.8.2 on my laptop (signature), the keyboard, touchpad and trackpad worked fine. Even when I fixed the install, when booting with bootloader on USB to the new install, it worked. But when I reboot without the USB installation media, I come to the login screen, but my keyboard, touchpad and trackpad don't work anymore.

 

So it must have been one on the Kexts, I think. I copied all kexts with contained PS2 in their name froom /E/E/ (usb boot stick) to /S/L/E/ (hard drive) and rebuilt the kext cache, because I use Kernel cache to speed up my boot process.

 

I installed it as proposed in this forum:

 

http://forum.thinkpads.com/viewtopic.php?f=32&t=105334

 

I decided to set my UEFI/BIOS to "Legacy BIOS", so I replaced OSInstall and OSInstall.mpkg by the ones provided the link to osx86.net .

I did all he said in his first post, but I used Kext Wizard instead of Kext Utility. (I would prefer to do this in Terminal, but I don't know how to use the command kextcache correctly.)

 

Please help me how to solve this problem. Maybe I just need the correct PS2 Kexts.

Share this post


Link to post
Share on other sites
Advertisement

I can boot into the disk if I use the bootloader on my installation USB drive. This should also work, I think. I will try it After School, thx!

Share this post


Link to post
Share on other sites

Here is a list of everything I did since my last post:

 

1) Reinstalled ML 10.8.2 to the hard disk. (bootflags -v -x)

2) Rebooted with bootloader on usb to my new install with bootflags -v -x (otherwise it would hae stucked.)

3) Installed Chameleon to the hard drive (the version that he provided in the thinkpads.com forum) http://forum.thinkpads.com/viewtopic.php?f=32&t=105334

4) Copied Kext Wizard, Chameleon Wizard and DSDT Editor into /Applications from the hard disk.

5) I copied all kexts inside /S/L/E/ into a new folder on my desktop , as a backup.

6) Started Kext Wizard an installed all kexts from "Post Install"/Extra/Extensions/. (Post Install.zip can be downloaded from the forum.)

7) Recreated Cache with Kext Wizard.

8) Made a new backup of all files in /S/L/E/ to a new folder on my desktop, so i had 2 different backups.

9)Copied DSDT.aml and SMBIOS.plist from "Post Install"/Extra/ to /Extra/ from my hard drive.

10) I created my own SSDT.aml like he said in the forum. I have the same as he (i5-2520m).

11) Opened DSDT Editor and imported the file, then IASL & Compile , and saved as /Extra/SSDT.aml on my hard drive.

12) I executed the 2 perl commands he posted in the forum.

13) Launched Chameleon Wizard and set options: GUI enabled, Time Out 5 seconds, System Type:Laptop , Use Kernel Cache , Generate P-States, generate C-States, dropp SSDT (so that I can use my own one), Restart Fix

14) Launched [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and installed Intel E1000e (driver for my ethernet card)

15) Started Kext Wizard again and created new cache.

16) I typed following commands:

 

sudo chown root:admin /

this worked.

 

sudo kextcache -system-prelinked-kernel

this hasn't worked because I booted in safe mode (-x

sudo diskutil repairPermissions /

After this I wanted to reboot, BUT: when diskutil was about 70% my laptop powered off due to low battery. I haven't noticed this because there was no battery icon in the top panel :(

 

17) I recharged my laptop.

18) After my laptop was charged fully, I tried to reboot without my usb stick.

19) It didn't work because of "Still waiting for root device"(only when without -x). That was also on my first install of ML, I reused the perl script I got from Internet. It patches IOAHCIBlockStorage to delay its start by 200ms. (this perl script is for sandybridge motherboards, and it worked for my laptop)- i booted with usb stick bootloader to hard drive, and executed the script. (while safe boot)

20) reboot, bootloader on usb, hard drive ( -v)

21) have done all commands in the .rtf you provided

22) reboot, -v only from hard drive

23) 3D acceleration worked!

24) something broke login after next reboot, i forgot for now, i will post if it comes to my mind, sorry i have to go to bed.

Share this post


Link to post
Share on other sites

Hello again,

I found out why I couldn't login: because I left the keyboard and mouse connected on the USB ports during shutdown. In the morning I rebooted with -v and bootloader on my hard drive, and I could login to my Desktop.

 

What works:

 

3D acceleration

Ethernet

Battery Plugin in the Panel with % displaying (current 45 %)

Spotlight also works

AppStore ( I downloaded XCode)

Webcam

----------

What doesn't work:

 

Wifi ( I expected that because in the thinkpads.com forum he had to install an other Wifi pci card) I will use an usb wifi dongle.

Bluetooth ( It doesn't work anymore.)

Internal Keyboard, Touchpad and Trackpad ( for now, I'm using USB Keyboard and mouse)

----------

Not tested:

 

VGA

DisplayPort

Expresscard

SD Card reader

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Good evening to all. So, I have an external 1TB seagate HD and it always reads normally, but now when I plug it into my HACK it just does not read, it does not even appear on the disk utility. The light always turns blue from the HD without blinking. However I plugged it into windows, on a macbook and it worked normally. I already formatted my hack but it did not work. Thank you in advance for the help and sorry my bad english   my kexts: AppleALC.kext FakeSMC.kext IntelGraphicsFixup.kext IntelMausiEthernet.kext Lilu.kext WhateverGreen.kext VoodooHDA.kext USBInjectAll.kext NvidiaGraphicsFixup.kext   GTX 1080 Windforce core i5 7º generation 8gb Ram H170M Plus BR    
    • WOL packet is reaching the machine from LAN and from WAN (set with port forwarding), tested with "nc -l -u 9".
    • For me the forum seems reasonably OK, except whenever I see the word 'LOADING' - like when clicking another page of a thread - when it just stops completely and never returns.   I use an adblocker, so adverts aren't slowing me down.  Browsing the forum indexes is not too bad, as is clicking to view any thread.  Ditto clicking a link in an email notification to go to a particular post in a thread.  Sometimes it takes maybe five seconds to load a page, which is a bit too long.  But it's not terrible.   But then whenever I click on any other thread page, which tries to do the in-page content load (without a full page refresh), I see LOADING and then nothing further happens, even after minutes.   It's definitely not related to which content is loaded, but rather how it is loaded.  For example if I go to the index for this forum, then click directly to page 11 of this thread, it loads in 1-5 seconds.  But if I click the link to page 11 within the thread, it never comes back.  I just see this, forever:     This stuck issue seems to me likely something broken (code or configuration?) rather than a general slowdown.  But maybe there's also a general slowdown, especially for those who are seeing adverts.
    • This is as far as I can get with the AMD kexts and the device ID added. They load but the frame buffer isn't loaded. I've tried loading all 7 frame buffers included in the X1000 kext with no luck. From the tests Gigamaxx did there seems to be more luck spoofing as Intel graphics there. More support may come from integrated Vega though, hard to tell.    
    • as documented here it is a sample rate standard and i have also tested it and i can confirm that it works with my audigy rx at least, i have to test it with other cards   https://github.com/audiojs/sample-rate


×