Jump to content

Search the Community: Showing results for tags 'keyboard'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 53 results

  1. Hi everybody, First this is my first post on this forum so I hope Im creating a topic at the right place Im french, so sorry for my bad english So I recently made a Hackintosh Laptop (on a ROG GL553VD-DM078T ) This laptop is based on a i7 7700HQ and a GTX1050. I installed MacOS Sierra using the Clover bootloader and succesfully installed the kexts needed but one of them is causing trouble. I Broke my internal ethernet Port so I must use a USB-C ethernet dongle in order to acces the internet ( The Integrated Wifi chipset isn't compatible so that's my only way to connect.) Without the UsbInjectAll.kext everything works exept my laptop keyboard wich use USB (yes, the internal ASUS Aura keyboard use USB interface, not PS2 or IC2 ). But if I load the UsbInjectAll kext the keyboard works, but the USB-C ethernet dongle is no more recognized at all ( not even in the system report menu) The weird thing is that if I plug a USB stick in the USB-C port, it works, but the ethernet dongle won't. So now I have 2 options : -or I load the UsbInjectAll kext and I get my keyboard to work -or I disable the UsbInjectAll kext so i can get back my ethernet USB-C dongle to work, but no more keyboard.... Can someone explain why do this happen ? Is there a way to get both The Ethernet dongle and my internal keyboard to work at the same time ? If Needed, I can provide more information about the hardware Used etc. Have a good Day/night
  2. Hi everybody, I'm new here and French. I success to hack my Asus X751LJ and pass it to High Sierra 10.13.6, not easily, and everything works except the keyboard and the touchpad. I tried VoodooPS2Controller, ApplePS2SmartTouchpad, even VoodooI2C, but nothing works... Could someone help me? Is there a DSDT problem? Witch kext should I use? I post my ACPI and Kexts folders and my IOReg. Please... Help me. I'm desperate... MacBook Pro de Candrahm.ioreg Archive.zip
  3. So here's a fun little problem I'm having: I multiboot with several other systems, and of course I've been using GRUB for a long time. Now, GRUB is able to boot OS X directly, which is nice, but it has it's limitations. Chameleon, the default bootloader for hackintoshes, is able to chainload GRUB, and GRUB is able to chainload chameleon, it's all very impressive, but one thing impresses me more about GRUB, namely that it is able to make the buttons on my trackpad work. In other words, when I chainload into chameleon and boot OS X 10.6.6, neither my keyboard nor my mouse buttons work at all! What's even worse is that my trackpad reacts just fine to input, I can move my pointer around, but even that doesn't seem to interact with anything, the dock doesn't pop up when I hover over it. I've burned through several VoodooPS2 kexts and the Apple kexts, but the ones that worked all ceased to function when I booted through chameleon. I would just continue to boot via GRUB, but I'm stuck at 800x600 resolution here, and I kinda want to be booting from chameleon before I take any more cracks at fixing that, just in case I have to work with DSDT files, which GRUB cannot load. Also GRUB forces verbose boot, and I want OS X largely because it's pretty, I get my verbosity fix from Arch linux. Oh, and this is a Samsung N210, which has an intel N450 motherboard, trackpad vendor unknown.
  4. Hello! I'm finally back to my headaches on Snow Leopard! I was using Windows 8 for a while (the consumer preview one) and I was not willing to have to format my hd to install mac os x all over again (I even thought I had forgotten how to work around the stuff) but here I am, with SL 10.6.8 running smooth on my old slugish machine. Although everything's running smooth (well, almost everything) one bug is really annoying me. I'm an enthusiast and I'm trying to learn japanese, and so I do need japanase input capabilities on my computer (and I must say, windows 8 had a great input method, as good as mac os x), but my SL installation refuses to give this in a smooth method. Kotoeri works great just to input hiragana or katakana, but when I try to input kanji it doesn't run properly. When I press the spacebar once it comes up with the first kanji, okay, everything's fine, but when I hit spacebar again it gives a hiccup and then erases everything I wrote, giving me a space only where it should pop up a floating menu for me to choose which character I want. For instance, if I want to write 人 using the pronunciation じん and not ひと I simple can't, because the first kanji to come up for じん is 陣 and if I hit the spacebar again to offer me the other choice it just lags and give me a blank space. See the video I made to show how bad it is. Here it crashed several times (I trimmed the video to make it shorter): http://www.youtube.com/embed/P8faHUVoFb4 Does anyone knows how to fix this up? I really couldn't find it anywhere on the internet...
  5. VENDUTA Come da titolo, vendo una tastiera apple in alluminio, con filo, quindi niente sbattimento di batterie confezione con accessori, scontrino, un anno di garanzia PERFETTA, come nuova 30€ + ss
  6. genben

    Add Brightness Keys to DSDT?

    I read around for some time on how to add Keyboard Keys of my HP Mini to the DSDT, so OS X can use them. Yet I only found 2 or 3 people saying that they were able to add the Brightness Keys, but I can't find any information or code snippet! I already have an fully working DSDT for my machine, but how to find out the Mapping and what code to add?
  7. I just updated my Dell Latitude E6400 (with NVIDIA Quadro graphics) to Snow Leopard 10.6.8 However, the built-in trackpad and keyboard do not work when I boot up from Chameleon (I used the latest Chameleon wizard)!! The keyboard and trackpad only work when I boot up from the XBooter CD (which was the only way for me to successfully install Snow Leopard). The battery indicator only shows up when I boot from XBooter, but does not appear when I boot up from Chameleon. The Appstore only works when I boot up from Chameleon. WiFi, Bluetooth, and the SDHC card slot do not work for both Chameleon and XBooter. I have already installed all kexts and dsdt for my model. The keyboard and trackpad stop working after an extended period of use when I boot from the XBooter CD. Also, in what position is the switch for the radio antenna to be on? To sum it up: Works for XBooter: Keyboard/Trackpad (Limited functionality) Battery Indicator (I used the Voodoo kext) Sound Doesn't work for XBooter: Appstore Works for Chameleon: Appstore Sound Doesn't work for Chameleon: Keyboard Trackpad Battery Indicator Doesn't work for both Chameleon and XBooter Wifi Bluetooth Mute Please provide feedback so I can get my Hackintosh up and running. If anyone can provide feedback on how to upgrade to Lion, that would be great. I have already tried xMove, but the installation gets stuck at the Apple logo when I boot up from the installation partition. Any help would be greatly appreciated. Thanks!
  8. DanielJanashvili

    Mouse USB issues

    OK, i managed to install the OSX almost perfectly, my last problem that i couldn't fix is that every time i start my pc the mouse is not working. re-plugging the usb seems to make it work but still every time the pc goes to sleep or if i reboot, i need to connect the mouse right after it boots up. Anyone knows a solution? Motherboard: Gigabyte p55m-ud2
  9. Hello guys, Sorry for my bad English. I need your help to solve this problem: I can’t move my mouse and my keyboard don’t work on installation screen of Mountain Lion 10.8.2 This is my config : • Gigabyte P55-UD3L (AHCI and HPET64bits configured bios) • CPU I5-760 • ATI4830 or NVIDIA GTX450 (I can swich) • USB mouse • I have a USB keyboard and a PS2 keyboard (I can swich too) I have a fully working (sound, Ethernet, video, keyboard and mouse) snow leopard OS on my 500GB western digital hard drive. I tried to install mountain Lion with ######, with legacy USB option, but I’ve got the grey screen freezed. With –v I cannot see the last line before the Pc (hackintosh) reboot… So I tried with MyHack. And it worked with ATI4830 without any boot command I can go until this screen http://www.cachem.fr...s-x-10.8-pc.jpg I cannot move my Mouse and keyboard Before asking for your help I tried by myself to do this : • Putting the GTX450 but I have the Grey Freezed screen and as far i can the installation screen with the ATI card I think its not a PCI card problem. The GTX450 is brand new and fully working on windows8. • I tried with the PS2 keyboard-> nothing changes • I tried –x -> nothing changes • PCIRootUID=1 -> nothing changes • GraphicsEnabler=No -> nothing changes • Cpus=1 -> nothing changes • USBBusFIX -> I can’t move my keyboard or mouse • Turn Off Legacy USB in bios -> The USB KEY cannot boot, nothing happen • I putted two kext in Extra folder of MyHack USB key hopping that it wil lunch this as drivers but othing more: IOUSBFamily.kext (but as my USB key is recognized it was ok) and VoodooPS2Controller.kext but nothing changes… • I putted my P55-UD3L DSTD (renamed in DSTD.aml) in this folder and lunched it in the boot command DSTD=/Extra/DSTD.aml -> Grey Screen with the black centered spinning weel during hours… Do you think buying an APPLE keybord would do something ? If you have any solution even weird even difficult I will try. If ti works you will have my eternal gratitude and the feel that you helped a man somewhere on earth. Florian.
  10. On 10.7 and 10.8 i can remove that setup within files Info.plist on /S/L/CoreServices/Setup Assistant.app/Contents But there is no files Setup Assistant.app on 10.9. Can you help me with this? *i guess i can simply insert USB Keyboard. but i does'nt have any usb keyboard.
  11. xx77aBs

    Keyboard problems

    Hello! I'm very happy Hackintosh OSX Lion 10.7.4 user Well, I was until I've discovered that I can't type "<" or ">" (without quotes ). I am from Croatia so I'm using Croatian keyboard layout. The problem is that my keyboard doesn't have that <> key (right next to the left shift). There is picture of my keyboard: http://173.203.87.117/BioSurplusImages/aa19561_1.jpg And because I am using Croatian keyboard layout, SHIFT + . or SHIFT + , doesn't give > or <, they give : and ; (that's default for Croatian layout). Is there any other way (except changing the keyboard) to type < and > characters? I've noticed when I press Option (alt) + . or , I get ≥ or ≤. I don't need this characters, so is there a way to rebind these keys to < and >? Thanks
  12. Hackintosher1

    Control Volume with Keyboard?

    Hi I made this topic to get help on controlling volume with the internal keyboard. The slider at top right on menu bar works and audio works with patched AppleHDA. But seems like somethings missing.. I think I need to assign the keys to volume up/volume down. The closest I can get is by enabling accessibility settings to enable on-screen control - still not able to adjust with keyboard. These controls appear: https://www.dropbox.com/s/bis3qa2ro1goyfd/Skjermbilde%202014-07-15%20kl.%2001.11.08.png?m= The kext Im using for keyboard is Rehabman's VoodooPS2Controller.kext
  13. Hi, I tried to install iATKOS S3 V2 on my old Acer Extensa 4620 (not 4620z). The installation worked (though I had to remove the battery), and i could not boot into the OS. So i tried -v -x, and it worked, and I could set it up. But the verbose mode showed a lot of errors about something like AppleUSBUHCI.kext not loading or something. The main issue is that my trackpad isnt working, usb mouse not working, wireless mouse also tried, not working. But the keyboard is working.! Any suggestions on how to get back my mouse(stuck on top left of screen)?? (Last resort, I can install it again, if someone tells me what drivers to enable, because the last install worked on some random selection of drivers) Thanks in advance ---------------------------------- SYSTEM SPECS (if required) [ If any more required, ask) ---------------------------------- Model : Acer Extensa 4620 Processer: Intel Core 2 Duo 2 GHz RAM : 3 GB DDR2 Graphics / Display : Mobile intel 965 express chipset family (I also see X3100 somewhere) BIOS : (Dont know for sure) Phoenix v1.00PARTTBL HDD : 160GB ?? In dxdiag, I found PS/2 devices connected :: HID Keyboard Device Standard PS/2 Keyboard PS/2 Compatible Mouse HID Compliant mouse. And also, my mouse and keyboard both worked DURING the install, but not after it ???? Edit: Reinstalling with the proper drivers might be better, if somebody provides me with a list of drivers
  14. Hi, I maked a little program in c++ to enable the keyboard led backlight. It simulates the KLM of MSI on windows. This can works on windows / linux / mac. Please note this project is Work in Progress, so you can report bugs or fix it and send me a pull request if you want. Source code: https://github.com/PaNaVTEC/MSI_GT_GE_Led_Enabler The usage: Usage [NORMAL MODE]: msiledenabler -mode normal -color1 <valid_color> [-color2 <valid_color>] [-color3 <valid_color>] -level <valid_intensity_level> Usage [GAMING MODE]: msiledenabler -mode gaming -color1 <valid_color> -level <valid_intensity_level> Valid intensity levels: [0,1,2,3] Valid Colors: [black|red|orange|yellow|green|sky|blue|purple|white] Example usage: ./msiledenabler -mode normal -color1 blue -color2 green -color3 yellow -level 0 Downloads: https://github.com/PaNaVTEC/MSI_GT_GE_Led_Enabler/downloads Known bugs: Colors are not working OK, example: blue is red.... I will fix asap.
  15. Hey guys, I was able to get full working brightness on my HP notebook running Yosemite (full specs should be in the sig) Now all I need to do is get the brightness keys mapped. This should be the easy part, but I'm having some troubles. On my notebooks keyboard, the F2 and F3 keys are the brightness down/up. Following these two guides: https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller/wiki/How-to-Use-Custom-Keyboard-Mapping and https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller I've installed the VoodooPS2 debug kext which shows in Console the key codes for the keys I'm hitting. So I've figured out that pressing JUST the FN key, or just the F2 key doesn't show anything at all in Console, but every time I press the FN key and the F2 key at the same time, this is shown sending key 3c=78 down sending key 3c=78 up and for FN + F3 sending key 3d=63 down sending key 3d=63 up and doing some research, I see that the ADB code for brightness down is 0x91, and 0x90 for brightness up. These translate to 145 and 144 in decimal, so I tested this out by holding command and then typing 145. Sure enough, my brightness turned down, and command + 144 turned it back up. This is where I think I go astray; according to the guides, I think this means that the codes that I'll be putting underneath the 'Custom ADB Map' section should be this <string>3c=91</string> <string>3d=90</string> So I go to the release version of VoodooPS2Controller.kext, secondary click > Show package contents, > Contents > Plugins > VoodooPS2Keyboard.kext > secondary click > Show Package Contents, > Contents > Info.plist and edit that file to try and map a single press of my F2 key to what the ADB code for brightness down is (0x91) However I can't get this to work. The brightness doesn't change, but if I load the debug kext I can still use command+145/144 to adjust my brightness, so I know it's just user error I'm seeing. is my code wrong? Also; because a single press of the 'F2' or 'F3' key doesn't generate any any PS2 scan codes at all, does that mean that mapping JUST this key(without the FN) key will be impossible? I would like to be able to adjust my brightness without holding down FN like I can on Windows, but I don't see how it will if it doesn't generate it's own scan code under VoodooPS2. Any help is greatly appreciated my friends. buttcrap
  16. Not sure if everybody here will be interested, but I was talking to some guys that do custom keycaps, I pitched him this design: but they said they could not make singles, only in bulk. Don't mind the colors and size. So I'd like to ask if everybody would be interested in purchasing. It's for a Ducky Zero Shine backlit mechanical keyboard. I haven't gotten their reply as to how many they'd need for them to push through with the manufacture, but they said the design is feasible.
  17. adriangb

    Keyboard Shortcut Problem

    Hi, a couple moths ago I was writing a whole bunch of papers and got fed up with having to normalize the text after pasting into Pages, so I looked up how to change command-v to command-shift-v, and it worked. But now I cant change it back, and I've tried everything I can think of. The only thing I can figure out is that it's probably applied to the whole system (I have issues in finder, safari, etc with c&p), but I may just have been stupid enough to apply it to certain apps. There were a lot of different ways to acheive the same result, but I'm not sure how I ended up doing it.
  18. Hi, I wanna make a Hackintosh from my laptop with Windows 8 installed on it using VMWare, I followed this tutorial, from step 7 it started going wrong; my mouse nor keyboard are working in the virtual machine. I'm stuck on the language screen. I'm using a Logitech M705 wireless mouse, my keyboard is integrated in my laptop and that isn't working either (the touchpad on my laptop also doesn't work) I tried using a wired mouse but that didn't fix it. Yes I used VMware unlocker, and I don't think I installed vmware tools, I tried it by pressing the 'install vmware tools' button but got an error saying 'Could not find component on update server. Contact VMware Support or your system administrator.'. Can someone help me please? I'm using VMware workstation 9. Thanks
  19. EDIT2: So I solved it by installing USB Rollback via [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to the Installer partition, this gave me a kernel panic that said "No HPETs available", I solved this by installing AppleIntelCPUPowerManagement.kext via [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to the Installer partition too, this allowed me to install Lion. The problem I've got now is that the USB doesn't work in Lion, and I can't install USBRollback due to that.. I started a new thread: http://www.insanelymac.com/forum/index.php?showtopic=274039 Hi! I've followed tonymacx86's guide with xMove and all of that, and I've made an Installer partition by buying Lion from the AppStore. I boot to Chimera, press some key in order to get to the other partitions, choose Installer. After that I'm booted in to the installer, but when the Apple logo shows up my keyboard and mouse (both USB) shut down, and when I'm in the installer they don't start either, so I can't do anything. I've tried to unplug and insert them again, but they don't get detected. My motherboard is a GA-P55M-UD2, and I used [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] (if that makes any difference at this stage..). Also; I don't know if it will help or whether it's related, but I've got a problem in Chimera too. If I reboot from OS X my keyboard doesn't seem to give any input in Chimera (but it's still on, in contrary to the problem above) which makes it that I can't select any other partitions. This problem doesn't occur when I make a cold/fresh boot, i.e. shut down the computer and start it manually. Thanks EDIT: So I saw some suggesting you install USB Rollback to the Installer via [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], and that at least fixed the power to the keyboard and mouse and my hopes were up for a while, until... What do I do?!
  20. Trung_Nguyen

    Dell backlit keyboard

    Hello everyone, I am trying make the fix keyboard backlight on Dell Latitude E6230. It currently works but the macOS not recognized it. There is a keyboard shortcut which had 6 states of bright. I'm using IOWMIFamily to use the display brightness shortcut(Fn Up/Down) Is there a way to make the Ultimate keyboard backlight slider like in Debian? Thanks. P/s: By the way, what is the ADB codes for VidMirror? I want to remap it because it controlled by PS2 and currently map to cmd+P(print) Thanks again DSDT.zip
  21. SavageAUS

    Corsair Peripherals

    Ok so im looking at doing some upgrades to my input devices and have found some that i like. Keyboard: Corsair Gaming Strafe RGB Mechanical Keyboard Cherry Brown https://www.pccasegear.com/products/33308/corsair-gaming-strafe-rgb-mechanical-keyboard-cherry-brown Mouse: Corsair Glaive RGB Gaming Mouse - Black https://www.pccasegear.com/products/39190/corsair-glaive-rgb-gaming-mouse-black Does the corsair software work on mac yet? Does anyone use any other above with macOS and have any feedback for me? Any feedback at all would be appreciated.
  22. Hello everyone, during my install of Mountain Lion 10.8.2 on my laptop (signature), the keyboard, touchpad and trackpad worked fine. Even when I fixed the install, when booting with bootloader on USB to the new install, it worked. But when I reboot without the USB installation media, I come to the login screen, but my keyboard, touchpad and trackpad don't work anymore. So it must have been one on the Kexts, I think. I copied all kexts with contained PS2 in their name froom /E/E/ (usb boot stick) to /S/L/E/ (hard drive) and rebuilt the kext cache, because I use Kernel cache to speed up my boot process. I installed it as proposed in this forum: http://forum.thinkpads.com/viewtopic.php?f=32&t=105334 I decided to set my UEFI/BIOS to "Legacy BIOS", so I replaced OSInstall and OSInstall.mpkg by the ones provided the link to osx86.net . I did all he said in his first post, but I used Kext Wizard instead of Kext Utility. (I would prefer to do this in Terminal, but I don't know how to use the command kextcache correctly.) Please help me how to solve this problem. Maybe I just need the correct PS2 Kexts.
  23. thexorg

    Remap keyboard

    Hi, i've got OSX El Capitan working in my TP X220. Everthing works fine, but the End / Pos1 keys which are working as PageUp / PageDown keys (i've got those keys on my keyboard and they are working as expected). How can i fix this / remap them? Xorg
  24. I have a problem with the SL installation on my PC. I'm using Empire EFI and a 10.6.3 Retail DVD. Everything seems to be working fine, I can get to the installation screen where you select the language without any problems. But then I'm stuck. I can't use my USB-Mouse, nor does my USB-keyborad work. As soon as booting from the SL DVD begins their lights turn off and they are not usable anymore. I tried to unplug them and plug them back or change ports, but nothing worked. All of the USB ports seem to be unrecognized. In another forum someone was told to use these bootflags: USBBusFix=Yes , UHCIreset=Yes and EHCIhard=Yes. I tried all of these, but they didn't help either. How can I fix the USB problem? Help is much appreciated!
  25. Hi guys., As the title says,I have been able to install dp2 on a usb hd and am able to boot into it by clover legacy mode,but can't reach the desktop as I can't enter the user name and pass word as my touchpad and key board are not working. I am able to boot the install only if I attach a usb mouse.But that can't enter the username/password etc and I am stuck at that step. If I do not attach the usb mouse the boot stops with the following screen as shown by another poster:. http://www.insanelymac.com/forum/topic/298750-chameleon-r2377-os-x-yosemite/page-5#entry2030272 I have a working 10.9.3 on the same machine and touchpad/keyboard work well by the vodoops2controller.kext. But my dp2 install is not loading this.I have tried putting this in both the clover/efi /kext folder only and also in that plus s/le together but still no go. I used BOOT USB OS X YOSEMITE V1(Clover/Chameleon to make the install usb. and am using the latest fakesmc.kext and vodoops2controller.kex tby rehabman. So what do I do? Is this a kernel cache issue as to why the ps2 kext is not loading. My specs are in the signature. Please advise Thanks
×