Jump to content

[AMD][GUIDE] ★★★ How to get full 64-bit AMD Snow Leopard 10.6.8 (ARCH=x86_64!) ★★★

What AMD processor(s) you have?  

88 members have voted

  1. 1. What AMD processor you have?

    • FX (15h / Bulldozer)
    • Phenom II (K10.5)
    • Athlon II (K10.5)
    • Sempron (K10.5)
    • Turion II (K10.5)
    • Phenom (K10)
    • Opteron (K10)
    • Athlon X2 (K10)
    • Athlon (K10)
    • Sempron (K10)
    • Other (K8 and below)

33 posts in this topic

Recommended Posts

SmrtMouth, which kernel do you use to boot up with arch=i386 -force64 ?


On my very first attempt to patch files, I deicided to use Nawcom Legacy Kernel V2. But with this kernel as soon as I've oppened the Terminal application, I got there some error regarding dyld files and the patching tool didn't work for me with Nawcom's kernel and flags arch=i386 -force64. I dont remember the correct error message I got with this kernel, but it was 100% something about dyld error and only with -force64.


But with AnV Kernel V2 I've succesfully patched everything and there were no errors in Terminal application regarding dyld files. So you can also give it a try with fresh installation and latest AnV V2 kernel, it might help you so it did for me.


Here is what I did after fresh install of 10.6.8 :

  • Put AnV V2 kernel into root directory and renamed it to legacy_kernel
  • Rebooted my computer with flags:
  • legacy_kernel arch=i386 -force64 -v maxmem=4096

    You might need to add some other flags for your specific system and depending on installed kexts.

  • Put files from first post (Amd_insn_patcher and Pre-patched QuickTimeComponents) into /usr/bin directory
  • Followed instructions for using patcher (easily found via Google)
  • Downloaded Sinetek Phenom II kernel, renamed it into legacy_kernel and replaced existing one in root directory
  • Booted with flags:
  • legacy_kernel arch=X86_64 -v

    On this step you might also need to add some specific flags for your system.

As I said before, system works great in 64-bit mode for me after doing all this and installing rest of kexts for my system. I'm even able to use software like GarageBand, which never worked on my hackintosh setup before. I'm also able now to launch some games on my machine, just tested yesterday Team Fortress 2 from Steam, which never worked before as well.



Also, Sinetek's 64-bit kernel works fine with kernel cache, so on my system I'm also using UseKernelCache=Yes flag while boothing. It has decreased my system's booting time a bit.


To be able to use flag UseKernelCache=Yes, you need to :

  • You need to do this everytime after installing new kexts to your system, so I suggest to finish with installation of network/audio/video/other kexts and only then start doing this.
  • Install all kexts from /Extra folder into /System/Library/Extension folder by using Kext Utility.
  • In /Extra folder delete file Extensions.mkext and delete there ALL existing kexts and kexts folder from /Extra directory. So you have there only *.boot.plist, smbios.plist, dsdt, bootloader themes and nothing more.
  • Open Disk Utility, check your 10.6.8 partition and use Repair Permissions option.
  • sudo touch /System/Library/Extensions

  • sudo kextcache -system-prelinked-kernel -all-loaded

  • sudo kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext -z /System/Library/Extensions/

  • Now you are done, just add the UseKernelCache=Yes flag into your *.boot.plist and restart your system. Should work without any problems, but I suggest to make first boot with -v flag to make sure everything is ok, and if something wrong you can just boot without this flag or use "No" value.


But always be sure you know what you are doing. Hope some of this info can help you with your issues. :)


Sorry I have not replied. I was studying all week for an important exam. Turns out I was using nawcom's kernel. I will try AnV's kernel later on and I will post back my results. Thanks a bunch :D!

Getting a kernel panic upon boot with sinetek kernel, then my computer instantly reboots after it flashed on the screen. Not sure what is causing this. I tried booting with -v -f npci=0x2000. Any ideas? My dyld was patched successfully.


EDIT: I can boot when setting my busratio=14 but then it is super slow like before :(. On a side note I am not using a DSDT. I'm not even sure how to compile one. Could this fix my error. My problem seems to be processor related.

Did you got any errors while updating cache, like its missing architectures for i386 and ppc? Try booting back with AnV kernel and execute sudo update_dyld_shared_cache -force once again. And after this try booting sinetek kernel.

Did you got any errors while updating cache, like its missing architectures for i386 and ppc? Try booting back with AnV kernel and execute sudo update_dyld_shared_cache -force once again. And after this try booting sinetek kernel.


Nope no errors. It boots but it is super slow. I don't think it is my dyld causing this.


Just to add, when I boot without busratio=14 and without -v, the spinning loading wheel loads normally but then I get a kernel panic. When I boot with busratio=14, the spinning loading wheel looks like its in slow motion, but I can boot into snow leopard.

Okay I seem to have fixed the slow motion issue. I reinstalled completely and tried booting without busratio=14 and now it seems to be working fine. My only remaining problem is that apps are still crashing. iMovie will not even open, GarageBand doesn't let me export, QuickTime Player crashes if I record an onscreen video, etc. I'm really stumped. Is there something I'm missing?

Steam games work on my hackintosh in sinetek's kernel. I can run Portal 2 and Team Fortress 2 just fine. For some reason Final Cut Pro X gives me a kernel panic when I do anything in it. It launches though. iLife apps seem to work now. Final Cut Pro X is the app I really want to use. It won't work. Can anyone help me out?

Nice post Deltac0.

Followed the post and been running SnowLeo 10.6.8 in 64bit fine with sinetek kernel with boot flags: busratio=16 arch=x86_64. Everything works fine, full QE/CI, HDMI audio, all 4 cpu cores work. Only problem seems to be Quicktime and iTunes crashing. Quicktime runs audio files fine but crashes or locksup playing video. Another problem is that video previews in Finder seem to cause kernel panic and restarts. Tried repatching original files using amd insn patcher, but no success.


Any help or advice please!!

  • 1 month later...
  • Create New...