Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Samsung Series 9: HD4000 QE/CI problems

16 posts in this topic

Recommended Posts

Hello all,

I'm trying to install ML (10.8) on my beautiful new samsung series 9 (np900x4c-a01us). This thing is sweet; 8GB, i5-3317U (Ivy), USB3.0, 128GBssd, **three pounds**, **15 inch screen**


Specifically, the chipset is Intel 7 Series / C216 chipset, with HD4000


I went with the tonymacx86 ###### solution, because even though I got nawcom's snow leopard solution to work, I had immense problems with functionality-- no sound, ethernet, etc. and kext installation was becoming a nightmare, and none of the others (kakewalk, iAtkos) worked.


For those who care, in order to install ML with the ###### solution, you must first install the newest BIOS using the samsung tool from their downloads page. Make the relevant bios boot-order and S3 changes, and voila! Installs.


On the first boot after install, sound, touchpad, and ethernet all work!! GLORIOUS!


After that, no such luck... I managed to patch the ethernet and sound with lnx2Mac's realtek 81xx and an older VoodooHDA, respectively. Touchpad still a no-go, but I haven't actually tried yet because bluetooth seems to work out-of-the-box and I have a sweet wireless mouse/keyboard. Wi-fi is a bust; centrino advanced-N isn't going to be working soon at all (Correct me if I'm wrong on that)


Okay, so the major issue: NO QE/CI support.


With the latest chimera installed, it DOES actually load the drivers. However, my LCD on the laptop is dark, and the external HDMI port puts out *extremely* garbled display. GraphicsEnabler=No gets me back to my LCD with no acceleration.


I read up on the issue in this thread but I'm not sure what to make of it; I've never dealt with a DSDT before and the proprietary phoenix/samsung BIOS probably won't play nice....


Does anyone have some tips on how to get past this? I'm not completely inexperienced here but I don't know much about EFI strings and DSDT even though I know in theory how they work.

Share this post

Link to post
Share on other sites

Please, can you be more specific about how to install ML on Samsung Series 9? I have an NP900X4C (15"/i7/256SSD/8GB-ram) and i was not able to boot installation. I always got Still Waiting for Root device. I tried every boot option available without success. I use MyHACK method to build ML usb pen. This evening i read you update bios to last update and i made the same thing (now i am on P04AAC), but nothing changes.

Hope you'll help me to install it :(


P.s. Please, explain me bios settings and options you used (and ML pen build method)

Share this post

Link to post
Share on other sites

OK, i solved by myself...

Just to help persons who needs, this is how i get to install ML:


Got 10.8.2 12C60. I prepared an (MBR) usb key thru myHack tool (really easy)

Two most important things:


1° You'll have to put usb key on left, on USB 2.0 port

2° In Bios, you have to choose AHCI MANUAL and AHCI Enabled, otherwise your disk will not be seen by Disk Utility


After that, you are ready to install. What to do after first boot? First of all, you'll have to catch an usb mouse (put on left!). Edit /Extra/org.chameleon.Boot.plist, in Terminal type:


sudo nano /Extra/org.chameleon.Boot.plist


and set 1600x900x32 on 1024x768x32 line.


Then remove Trackpad kext (no way to get it working as a trackpad, only as mouse):


sudo rm -rf /Extra/Extensions/ApplePS2Controller.kext/Contents/Plugins/ApplePSTrackpad.kext


I installed VoodooHDA 2.7.3 to get sound working


Then, launch myHack tool (you'll find it on /Applications) and "Run myFix", in Full mode.

Reboot, and you'll have a working system, without acceleration for now... i didn't tried any method to get QE/CI on HD4000...

Share this post

Link to post
Share on other sites

Sleep sorta works.. lid sleep dosent .. yet.. we are planing to re-do the DSDT and fix those things when time permits..

Touchpad require a valid Elan touchpad to get multi-touch to work.. the included kexts will give basic touchpad functions..


How about yours ?

Share this post

Link to post
Share on other sites

Tried DSDT.aml and SMBBios inside Bootpack, and my screen became black.

Tried EDP post-install and made configuration as it is an NP900X3C, but result is the same: black screen just before Login Screen (EDP modified /S/L/E too... fortunately i backed up before to apply it! After first reboot i had problem with VoodooHDA. Removed, i didn't have KP, but screen goes black and nothing then...)



I have an NP900X4C-A01IT... i don't know if it's the same identical... (my is an i7...)

Share this post

Link to post
Share on other sites

Ahhh.. yours might be slightly diffrent, meaning we need to set a diffrent ID in the dsdt.. can you boot without DSDT, dump your dsdt and attach it here ?



(in cham, just write DSDT=null) .. that should get you into osx...

Share this post

Link to post
Share on other sites

Have you tried using a Mac mini system definition? I think the latest would be 6,1.... You can find out on Mac tracker or geekbench. If i use my integrated graphics i get no qe/ci unless I use the Mac mini system definition. It should work without any kext modifications or anything.also since its A laptop try MacBook pro 9,2 or any other MacBook that comes with hd4000

Share this post

Link to post
Share on other sites



The best solution is to use a DSDT fix, i havent had time to look your DSDT yet.. sorry.. out on a business trip.


Until then (since we need to find your ID anyway) - give this a try:




On my 900x3c i am using ID 2.. yours might be diffrent.. please report back

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.