Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


JMicron SATA via Expresscard

9 posts in this topic

Recommended Posts

Hi everyone. I have a problem with my hackintosh recognizing my SSD Expresscard drive on boot. I have an HP DV8t Pavilion laptop, and everything working as I want but this. I can get the drive to mount when closing the lid and putting the computer to sleep then waking it. However, no matter what I try, I cannot get it recognized at boot. I initially wanted to boot os x from this drive, but it cannot be done I don't believe. I've tried many DSDT mods but haven't found one that recognizes it at boot. I am also using a jmicron ata kext. If anyone has any information, please let me know! (I attached my current dsdt.dsl, my ioReg dump when mounted, and puts my lscpi ,with jmicron sata bolded, here):



00:00.0 Host bridge [0600]: Intel Corporation Arrandale DRAM Controller [8086:0044] (rev 02)

00:01.0 PCI bridge [0604]: Intel Corporation Arrandale PCI Express x16 Root Port [8086:0045] (rev 02)

00:1a.0 USB Controller [0c03]: Intel Corporation Ibex Peak USB2 Enhanced Host Controller [8086:3b3c] (rev 05)

00:1b.0 Audio device [0403]: Intel Corporation Ibex Peak High Definition Audio [8086:3b56] (rev 05)

00:1c.0 PCI bridge [0604]: Intel Corporation Ibex Peak PCI Express Root Port 1 [8086:3b42] (rev 05)

00:1c.1 PCI bridge [0604]: Intel Corporation Ibex Peak PCI Express Root Port 2 [8086:3b44] (rev 05)

00:1c.4 PCI bridge [0604]: Intel Corporation Ibex Peak PCI Express Root Port 5 [8086:3b4a] (rev 05)

00:1c.7 PCI bridge [0604]: Intel Corporation Ibex Peak PCI Express Root Port 8 [8086:3b50] (rev 05)

00:1d.0 USB Controller [0c03]: Intel Corporation Ibex Peak USB2 Enhanced Host Controller [8086:3b34] (rev 05)

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev a5)

00:1f.0 ISA bridge [0601]: Intel Corporation Ibex Peak LPC Interface Controller [8086:3b03] (rev 05)

00:1f.2 SATA controller [0106]: Intel Corporation Ibex Peak 6 port SATA AHCI Controller [8086:3b2f] (rev 05)

00:1f.3 SMBus [0c05]: Intel Corporation Ibex Peak SMBus Controller [8086:3b30] (rev 05)

00:1f.6 Signal processing controller [1180]: Intel Corporation Ibex Peak Thermal Subsystem [8086:3b32] (rev 05)

01:00.0 VGA compatible controller [0300]: nVidia Corporation Unknown device [10de:0a28] (rev a2)

01:00.1 Audio device [0403]: nVidia Corporation Unknown device [10de:0be2] (rev a1)

02:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)

04:00.0 FireWire (IEEE 1394) [0c00]: JMicron Technology Corp. IEEE 1394 Host Controller [197b:2380]

04:00.1 System peripheral [0880]: JMicron Technology Corp. SD/MMC Host Controller [197b:2382]

04:00.2 SD Host controller [0805]: JMicron Technology Corp. Standard SD Host Controller [197b:2381]

04:00.3 System peripheral [0880]: JMicron Technology Corp. MS Host Controller [197b:2383]

04:00.4 System peripheral [0880]: JMicron Technology Corp. xD Host Controller [197b:2384]

05:00.0 SATA controller [0106]: JMicron Technology Corp. Unknown device [197b:2362] (rev 10)

ff:00.0 Host bridge [0600]: Intel Corporation QuickPath Architecture Generic Non-core Registers [8086:2c62] (rev 02)

ff:00.1 Host bridge [0600]: Intel Corporation QuickPath Architecture System Address Decoder [8086:2d01] (rev 02)

ff:02.0 Host bridge [0600]: Intel Corporation QPI Link 0 [8086:2d10] (rev 02)

ff:02.1 Host bridge [0600]: Intel Corporation QPI Physical 0 [8086:2d11] (rev 02)

ff:02.2 Host bridge [0600]: Intel Corporation Unknown device [8086:2d12] (rev 02)

ff:02.3 Host bridge [0600]: Intel Corporation Unknown device [8086:2d13] (rev 02)


Thanks in advance for any help!



Share this post

Link to post
Share on other sites

You bolded your Firewire :) Here, use this in S/L/E


:wink2: I saw that and thought I edited it and fixed it when I posted. Guess not! haha thanks! I'll check out the kext.


FYI.... Editing issues apparently in Chrome...

Edited by tical2k

Share this post

Link to post
Share on other sites

Ok so with that kext, I get the same problem. In fact I took out all references that I tried to put in for the JMicron controller in my DSDT. The devices show up in IORegExplorer on boot as PRT0/PRT1 but not mounted. Aslo the System information even recognizes it as JMicron SATA, but still no mount until I put my laptop to sleep and remount.

Share this post

Link to post
Share on other sites

I tried as with UseKernelCache=false, but didn't work. You know To test, I've been putting this kext in /Extra/Extensions. Is that correct? I have only used a few injectors, but I'm always confused on where injectors belong. Should I put it in S/L/E or E/E?



Yeah no dice on that kext either. IOReg puts it under RP08->PXSX where I see PRT0 and PRT1 but nothing under that.


System Info / Profiler whatever shows it as:


Vendor: JMicron

Product: JMB362 SATA Controller

Link Speed: 3 Gigabit

Description: AHCI Version 1.10 Supported




RP08 references IOPCIFamily.kext

PXSX references IOPCIFamily.kext

PRT0/PRT1 references AppleAHCIPort.kext


By reference I mean when I go to "Reveal Extension in Finder" it shows it. This is defying logic (well obviously not but still). By all means it seems the device is recognized but not initialized.

Share this post

Link to post
Share on other sites

Use kexts in S/L/E or they won't be cached. So here is unique situation, using expresscard, which has jmicron controller built in. Who is manufacturer of the card and do they offer a OSX driver or advertize it as Mac compatible?


or am I wrong in that assumption? reading product sheet on the card would help

Share this post

Link to post
Share on other sites

The card is http://www.wintecind.com/features/FileMate/SSD/WF_ExpressCard_SSD.html and yes its advertised as mac compatible, but no driver. The card itself DOES work in the computer under mac. I just have to put the computer to sleep and wake it up to mount. I've also used my express card slot for a smartcard reader with no problems. I do believe this is an odd corner case, though.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By End3rPwr50
      Hi, I wanted to install macOs 10.13 on my notebook.
      Here are the technical specifications:
      -Intel i7 6500U 2.50GHz Skylake (CPU)
      -12GB ram dd4 (RAM)
      -hp 81EC (MOTHERBOARD) with BIOS insyde F09
      -Intel HD Graphics 520 - AMD Radeon R7 M440 (Graphics cards)
      -Realtek PCIe FE Family Controller (Ethernet)
      -Broadcom BCM43142 802.11 bgn Wi-Fi M.2 Adapter (Wifi and Bluetooth)
      -Realtek High Definition Audio - Audio Intel® per schermi(HDMI)
      Thanks in advance

    • By Angelo_
      Hi guys, i'm trying to help a friend of mine trying to install osx(possibly high sierra) on his pc with the following specs: 
      Amd fx8350 
      Asrock 990fx extreme 3
      8gb of fury Kingston ddr3 ram(2x4)
      Radeon hd 7950
      128gb ssd( crucial m550)
      A couple of hdds I don't remember the brand(maybe a seagate barracuda and a dumb old disk for data)
      We tried to install it using the regular clover+high showers installer but we couldn't get it to reach the installer, then we tried osx-amd(don't know if i can talk about it there, sorry if i can't) and we still couldn't get to the installer.
      Is there a guide i can use to install osx in that machin, i tried to search in the forum but i couldn't find it.
    • By hopoc
      Hi Guys,
      I’m stuck with 3mb VRAM, and can’t get my screen resolution! I’ve tried to reinstall 18 times with different configurations but I can’t seem to get it right! PLEEEEASE HELP I really don’t know what to do now. I've tried Enoch but still no success!
      System Model: HP EliteBook 8570p Processor: i7-3520M CPU @ 2.90GHz, 2901 Mhz, 2 Cores GPU:  AMD Radeon HD 7570M RAM: 12GB​

    • By dfear

      I am try to install High Sierra, as per #####
      I have have successfully booted from the install usb drive and have booted into "Install macOS High Sierra". I had to add a boot flag (-no_compat_check) to the clover bootloader in order for the usb stick to boot properly. Also, at first I couldn't see the SSD drive in disk utility, but I fixed that by asking disk utility to show all drives.

      Onto the current problem. I am having major issues trying to install High Sierra to a NVMe SSD. When I run "Install macOS High "Sierra" I get the following error:

      "The version of macOS installed on this mac is newer than the version you are trying to install. When a new update is available, you can install it from the Updates plane in the Mac App Store. If you want to reinstall macOS, please use macOS recovery."

      Also, It doesn't matter if the startup volume is formatted as APFS or HFS+.

      If I format the drive using GPARTED on linux, the installer just says the startup volume doesn't have journaling enable. If I then run disk utility and enable journaling on the startup volume, then go back to the installer, I get the aforementioned error msg.

      I have the following specs:

      Asus Prime X299 Deluxe.
      ADATA 512GB NVMe SSD.

      How do I fix this issue?
    • By sergymac
      Ciao a  tutti sono nuovo di questo forum o meglio seguo con piacere e già ho alle spalle diversi progetti hackintosh ma la prima volta che mi cimento con i portatili.
      Il laptop in questione è il Pavilion 15-cb028nl e per tutti quelli che intendono acquistarlo posso dire che è abbastanza hackintosh compatible!
      Ho installato Sierra tramite immagine per laptop presa da un sito turco e dopo varie ricerche sono riuscito a far funzionare le seguenti cose:
      Audio e mic
      CPU e mobo sensors
      Video ma riconosce solo la scheda intel non la GTX1050
      Touchpad con multi gestures
      Stop e reboot 
      Adesso viene la parte complicata, vorrei effettuare la patch del DSDT per avere anche la batteria, la luminosità dello schermo de ottimizzare un po' meglio il sistema.
      Ma purtroppo è la prima volta che mi imbatto nel patchare il dsdt e qui mi fermo perchè anche seguendo le guide sia in italiano che in inglese non riesco a risolvere gli errori nella compilazione.
      Sono riuscito ad estrarre e decompilare con iasl il file originale creato da clover (F4).
      Qualcuno molto più pratico, gentile e disponibile potrebbe risolvere gli errori del dsdt, ve ne sarei grato!!!
      Per chi avesse il mio stesso portatile allego la cartella clover con tutti i kexts e il lavoro fatto fino ad ora. 
      Grazie mille!!