Jump to content

Virtual Box and Snow Leopard *SUCCESS*


75 posts in this topic

Recommended Posts

I havent seen many threads dedicated to Oracle's VirtualBox program. I talked to a mod about creating this thread for my Work In Progress (WIP) in trying to get Snow Leopard running in a Virtual Machine environment. I have personal requirements that prevent me from using bootcamp or any other dual boot configuration, so the only way for me to get OS X running on my machine is to put it in a virtual machine. Oracle's product has gotten some pretty good reviews, and the best part about it is it's FREE!


So this thread will be about my progress getting SL to run in OracleVB. For a look at the system that I'm putting it on, check this thread out.


I downloaded VB, and this is tricky because it is CONSTANTLY being updated. My recommendation (and others that I have seen here and other forums) is to stick with whichever release you downloaded. Do NOT try to update after you have the VM running. From what I have read and what others have told me, its enough of a pain in the ass getting it to work in a VM, much less getting it to work in a VM that is constantly changing.


VB Version.png


When setting up VB, there are a few things you need to do:


You select OS X server as an operating system type when creating a new virtual machine (I chose 64 bit because my processor is 64 bit)

os x 64.PNG


Choose a base memory of at least a Gigabyte. Some threads say you can get away with less - but if you are running VB on a machine with limited RAM resources, you may need to rethink that path that you are taking.


Create the new virtual hard disk, and if you are not planning on importing an image from another VM vendor, then you can use the VDI option. Dynamically allocated is fine (or so I've been told) and the recommended size is 20GB. Again with regards to resources - if you are worried about space requirements, this project may not be for you.


Once the VM is created, a few tweaks need to be done to that machine:


In the system settings, de-select the Enable EFI option

no efi.PNG


If you are going to use an .iso for your bootloader, you need to select the path to that for your image. I have redacted my .iso from the image because I am testing various Chameleon boot loaders at the moment, and I in no way want to endorse one over another.

where is my boot loader.PNG


The rest of the settings are fine for now - you can always tweak them at a later time, but this gets you to the starting point.


And this is where I am stuck - hence the reason why I am trying different boot loaders. I am currently testing one specifically for Snow Leopard that is quite handy, in that it doesn't require me to change out the disc midway thru the boot-up.


The error that I have run into - ebios read error: media error block: #x### - has been explained on various forums as a media fail error and a disc read error. Both are brand new in my case, and I have enlisted the help of a fellow InsanelyMac user that has far more experience with VB than I have to assist me. He suggested its an issue with the .iso and gave me some suggestions to try. I'll be doing this shortly, and I will post my next update to this *WIP* page then.


Thanks for reading - hope this helps others in some way. If you find an error on this page, or a better way to do something - please chime in and I'll adjust my posts accordingly. Please also be aware that since this is a Work In Progress page, you may have to keep reading down the page to find a fix to something that I did wrong previously. Once I get the whole thing ironed out, I'll make sure all the info is correct - maybe in a summary page or as a separate [how to] thread. For now - enjoy following along as I trip and stumble my way thru this experiment!

Link to comment
Share on other sites

So I implemented the suggestions that were give to me:


added to the file.PNG


and this is the error I get:


error i get.PNG


Again - these errors have been listed on various forums as a disc error or a disc drive error. I can't imagine either as the drive functions normally in Windows, and even the SnowLeopard disc is read by windows - the bootcamp portion at least.


So its off to the forums I go to try to find my fix. Hopefully I can get past this and to the install quickly. I'll keep y'all posted!

Link to comment
Share on other sites

OK - So I decided to create an ISO of my Snow Leopard DVD. I am unsure of what the issue is with the error, but since I know the drive works, and I know the DVD works (at least both in windows), I used ImgBurn to create an ISO of the DVD. I then used my favorite bootloader to boot into a GUI where I could then change the drive ISO from the boot loader to the ISO for Snow Leopard.


Hot Damn it worked!


I am now in the middle of installing Snow in the VM:







I have some time to kill now - so I decided to post this update. I wish I could have figured out why using the DVD directly was causing problems, but I'll settle for this acceptable work-around.


Next post ~30min

Link to comment
Share on other sites



This error is expected. Just shut the VM down, change the boot to the bootloader ISO and start again






This is where I am now. I have heard of other people having problems with it hanging at this point, so I am going to let it sit for a while - maybe overnight. I know that running OS X in a VirtualMachine is slow (compared to direct boot) so I'll give it some time. I'll be up for a while so...


Crossing my fingers...


I waited... like 5 minutes more and the initial setup came up.






Now I have to play. The system still requires me to boot into the bootloader, and most of the hardware doesn't work. However, I have 10.6.4 running now on my machine. I have a legit copy of the OS, its in a G5 case (so its technically Apple branded hardware) and I figured it out by searching here, and in Google, and with some help from another member here.


The guide that I used to answer a good deal of my questions can be found here. Any bootloader that pauses to give you the opportunity to change the DVD/ISO media will work using the methoud on that guide.


As I make changes and get more stuff working, I'll post what and how I did it here.

Link to comment
Share on other sites

I have run into some snags trying to customize my virtual machine:


I am stuck at 1024x768 for the moment. I have tried changing the plist file to give me a better option, but it just seems to ignore it. I have also tried modifying the VBManager program to accept different resolutions, but without success. Its not a super big deal as I never want this to run full screen (1920x1080), but it would be nice to get a widescreen resolution working.


I suspect that this is because of my inability to modify any of the system plist or kext files without the virtual machine taking a big dump down its leg. Thank the sweet baby Jesus for the snapshot feature. I took a snapshot of this system just after I got it up and running. I have also now installed a few things (like SRWare Iron) that I'd like to keep so I took a new snapshot with that. I have tried to integrate Chameleon into the VB disk image with no success so far. I have tried 2 different versions and one just sits at the grey screen with no round status indicator, and the other gives me a fatal memory fault.


I'll be playing with this some more. My three goals currently are:

get to where I can boot directly into my VB disk image

increase screen resolution

update to 10.6.8 from .3 I have now


I'll post more when I know more...

Link to comment
Share on other sites

What I know right now is that I cant get any version of Chameleon or Clover to install correctly in my Virtual Machine. One time I was able to get past the black screen of suck, and that was with the -f -v -x GraphicsEnabler=No npci=0x2000 flags. It booted into safe mode, I ran the kext wizard to fix the cache and the permissions, rebooted and nothing.


I really want to be able to not use the bootlader .ISO that I am using right now. My system is stable, sound is even working pretty reliably right now. If I could just get chameleon to install w/o ruining my system, I'd be happy.


If anyone has any ideas - please share them.

Link to comment
Share on other sites

Here are some screenshots of the errors that I get after running the 10.6.6 Combo update:


AllocateKernelMemory error.PNGverbose error.PNG


I ran the 10.6.6 legacy kernel patch after the install, then I ran the kext wizard to repair permissions.


To get to the second screen I booted with the following flags:

-f -v -x -PCIRootUID=1


I really have no idea what to do now. I think a lot of this is because I am running this legacy {censored}. I would like to upgrade to ML, but I cant until I get THIS install upgraded to 10.6.6 or better. I have no 'real mac' so I cannot download ML from there.


The gentleman who has helped me in the past warned me that VirtualBox would be a pain in the ass. Getting it up and running is easy as cake - getting it to do what you want is a HUGE pain in the ass.


I am now accepting ideas and suggestions. Don't be shy - step right up!

Link to comment
Share on other sites

So I have read some places that if you have a problem with installing Chameleon, you should try to install it manually. So, looking at guides here (albeit not a very good one) and elsewheres on the interwebs, I found what you needed to do.


Basically, you get the binaries for your favorite flavor of Chameleon - I found mine here - extract the i386 folder, run the terminal command (I don't know what to tell you if you cant boot to your disk, as the guide here doesn.t explain and assumes you know more than I do on the subject), then run the unix command fdisk as the super user. Below is a screenshot of the commands:


chameleon manual -redacted.png


I removed my personal identifying marks. There are a few typos in there, but you get the idea.


The important thing is that it DID NOT WORK.


I am becoming an expert on what doesn't work...

Link to comment
Share on other sites

In advance of you reading this post, I'd like to say I'm working from memory from like a year and a half ago here :P


1. For your resolution you need to do the following;


- Round your resolution to the nearest multiple of 8, so for example a 1366x768 display becomes 1360x768.

- Open up your .vbox file in a text editor and the following inside the <ExtraData> node.


<ExtraDataItem name="CustomVideoMode1" value="1360x768x32"/>
<ExtraDataItem name="GUI/CustomVideoMode1" value="1360x768x32"/>

Alternatively you can do this via cmd;


vboxmanage setextradata "<yourvirtualmachine>" "CustomVideoMode1" "1360x768x32"
vboxmanage setextradata "<yourvirtualmachine>" "GUI/CustomVideoMode1" "1360x768x32"


- Finally just add the Graphics Mode flag to your boot.plist with the string defined as 1360x768x32.


2. When updating to 10.6.8 from 10.6.x on Snow Leopard normally you only have to replace the following .kext;


- AppleACPIPlatform.kext

- IOPCIFamily.kext

- IOUSBFamily.kext

- IOUSBMassStorageClass.kext


In certain cases it's necessary to remove ACPI_SMC_PlatformPlugin.kext from within /System/Library/Extensions/IOPlatformPluginFamily.kext. As your screenshot is safe mode I can't really be more specific.


3. Are you even sure that you need a bootloader? If it fails without one, try removing /System/Library/CoreServices/PlatformSupport.plist and re-enabling EFI booting.

Link to comment
Share on other sites

Thanks for the reply!


1.) Its been my understanding that I can only use video modes supported by Virtualbox, and there are 5 (option 0,1,2,3,4) using OSX that supports the Graphics Output Protocal (GOP) I havent tried your settings - but I will once I get Camielion installed - see answer to question 3.


2.) Replace them with what? From where? If that is all that is required - I'll be upgrading tonight! But where do I get the replacement kext files from? Are you suggesting that I go into the binaries for the combo update?


Unfournately, my system is too fast for the -v flag to be much use when I'm NOT having an issue. The screen is a blur of information that I cant even pick anything out of - until it haults at a problem. Using safe mode was the only way to even get that info you see there - otherwise it was just the AllocateKernelMemory error with the system halted message all by its lonesome.


3.) I haven't seen any guides where you dont use a bootloader with virtualbox - however, I looked for /system/library/coreservices/platformsupport.plist and it doesnt exist on my machine!


no platformsupportDOTplist file.PNG


I have tried just straight booting into 10.6.3 with and w/o the efi in virtualbox and no go.


Looking forward to your ideas; so far they are different from the other threads I have read. And those aren't doing squat for me so far!

Link to comment
Share on other sites

Changing the resolution as described works on the VB installs I have going currently, but you are correct that there are 5 modes. Using the method I described overrides this though.


You replace them with the versions before the update. On 10.6.3 copy them all to the Desktop, then run the 10.6.8 Combo Update and before the restart you want to copy them back and rebuild their permissions using chmod + chown (see here if you're new to that). With the file in IOPlatformPluginFamily though, you just need to remove that before starting your Combo update, then you leave it.


I may be mistaken on the bootloaders, I can have another look soon if you want

  • Like 1
Link to comment
Share on other sites

Can I change using the kext wizzard? I have also run the permissions fix from terminal and thats what the thread you linked to describes so I'll get that straight.


I'm trying what you suggested right now...


I have one test VM that I was able to get Chameleon installed onto, but it still wont boot to it. I used myHack to get it done. I have been playing with the Chameleon Wizard's .boot file portion trying different options and it still wont direct boot. I have selected 32 and force 64 (not at the same time of course) and graphics enabler and the PCIRoot=1 and even the built in resolution changer there. and it still takes me back to the black screen of suck.


I'll be back in a tic with the results from your suggestions. Thanks!!

Link to comment
Share on other sites

Well spank my ass and call me Charlie! I am now running 10.6.8. Thank you for that tip. I havent found this methoud anywhere on the interwebs. Granted, I havent look everywhere, but I've been searching quite a bit. If nothing else, I can now download ML for more playing.


I do get this weird thing:

red folder icon.PNG


Know what that means?

It works, so I'm not too worried.


Gonna go try the graphics trick...


Well - the graphics trick is a fail.


I tried 1360x768x32 as you suggested with no luck, and tried 1280x1024x32 as well - knowing that is a standard resolution, and one of the supported VB modes = no dice.


I have been told that the video will not be resolved until Chameleon is installed. I dont know if this is the case or not, but your trick didnt work for me. I am wondering if its a difference in the version of VB. The version I am on is quite new, and if you're working from memory, then you are for sure not on the same DOT revision, and maybe a different root version.


I took a snapshot of the system right after successfully booting 10.6.8 so I am safe to muck around in the system files. I'm going to download ML and call it an evening. I'll play more tomorrow.

Link to comment
Share on other sites

Well - one last problem before I hit the hay...


I cant download ML because its reading my system specs wrong.


I created a SMBios.plist file, placed it in the extras folder and modified com.apple to point to that location, but the About This Mac still crashes and the App Store still no workey.


I'm tired so I'll play some more tomorrow... damned frustrating. Get one thing going, two other things fail. One step forward, two steps back... insert cliche here.

Link to comment
Share on other sites

SMBios is only read by Chameleon so that needs installing for it to point to a custom one. Same goes with the video mode, because it has to be added to the Chameleon.plist rather than the default Apple one. As for the red mark over the two .kext, it's a non-issue :P

Link to comment
Share on other sites

And I cannot get Chameleon to install at all. Or at least I cant boot to it. I have it 'installed' on this VM right now, using Enoch-rev.2064. I have selected and unselected just about every option I can think of and I cannot boot. I did find the option in org.chameleon to give me the wait.


So I took screenshots at every wait screen:

after chameleon 1.PNGafter chameleon 2.PNG

after chameleon 3.PNGafter chameleon 4.PNG

after chameleon 5.PNGafter chameleon 6.PNG

after chameleon 7.PNGafter chameleon 8.PNG


As you can see - All I get is the black screen of suck.


after chameleon 9 - options.PNG


Everything you see highlighted is a field that I have changed (one at a time) and rebooted.


It always gets stuck at the black screen of suck. The above screenshots were taken with the config listed curently in the last screen shot.


Any ideas?

Link to comment
Share on other sites

I did - fail.


Then I tried the options - fail.


Then I tried manual - fail.

Link to comment
Share on other sites

I installed Chameleon v2.1svn r2064 build date 25-09-2012. Enoch is a compiled version of that Chameleon. Downloaded from www.osx86.net/view/2981-chameleon-2.1svn-r2064.html


Thank you for all your help by the way on this! I've gotten further with your guidance than anything previously. Just wanted to thank you publicly (in addition to the thanks I've sent via PM).

Link to comment
Share on other sites

any other ideas? EPIC fail! Worse than any other product!


after chimera.PNG

Link to comment
Share on other sites

yup... I restored to the point right after the 10.6.8 upgrade and ran it.


That is what I did every time I installed different bootloaders.


ooops - no it wasnt.


I have two images both labled the same thing and I must have done something to the second. The one that is older I just ran that on... but its not much better... just the grey apple



and of course it doesn't support the wait=yes flag like chameleon does so when I do -v, it goes by superman fast and I cant see what its hanging on

Link to comment
Share on other sites


  • Create New...