Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

No acceleration on nVidia GT650m on Mountain Lion 10.8

26 posts in this topic

Recommended Posts

Hi, I heard that the nVidia GT650m works natively in Mountain Lion (thanks to the new 15" MBP (retina and non retina)) but I didn't manage to make it work.

Here is what i see in the device manager (I don't know exactly if it's called like that, I installed the French version) :



NVIDIA Chip Model :


Jeu de composants: NVIDIA Chip Model

Type: Processeur graphique (GPU)

Bus: PCIe

Longueur de la voie PCIe: x16

VRAM (totale): 0 Mo

Fournisseur: NVIDIA (0x10de)

Identifiant du périphérique: 0x0fd1

Identifiant de révision: 0x00a2

Révision de la ROM: preset 1.0.0


I have to boot with -x because It would freeze after NVDAGK100Hal loaded and registered

It hanged if I didn't put GraphicsEnabler=no (couldn't patch ROM blablabla nVidia 0mb or something like that) but I fixed it by using MacBookPro 9,1 smbios.


I'm using a Ivy Bridge based laptop. Here are the specs :




I'm sorry for non-French speaking users but it's easy to understand the specs... :D


I also installed the lastest version of chimera (1.11.1) for the HD 4000 but It won't work either (same thing freeze even if i delete the nVidia related kext)


By the way, I don't understand why there isn't any topic about the 650m, which is very common in the new MBP (There is a GTX680 Thread, why not 650m ?)


Thank you in advance !



Share this post

Link to post
Share on other sites



for the 4000




for the nvidia, for now same problem with sandy bridge cpu and optimus thecnology


if u can disable in bios the intel one, the nvidia works, the problem is mac os x don't do the switch between cards, possibly is donne by hardware, that is wat i think.


several lappy with same specs of the macbookpro2011, the second card don't work.


good hack

Share this post

Link to post
Share on other sites

Here are my DSDT(.dsl unpatched (hangs during boot if I enable it in chimera)) and my IOREG below.


artur-pt I tried that but I can't manage to make it work. Maybe I've not done correctly the step, but I didn't found my AAPL,ig-platform-id in my IOREG (Seems like it only shows the nVidia card in the ioreg file). I tried to use every string for 64mb based HD4000 (I cannot change to 96mb in the BIOS nor disable it unfortunately) and I got a black screen after that (but it seems like the hard drive still spins).


Anyway, thank you very much for your help (also a big thank you for Here To Help, I hope you will find something for us (I am not the only one who has this laptop lol : http://www.insanelymac.com/forum/index.php?showtopic=281476)

ThibaultAnd's DSDT+IOREG.zip

Share this post

Link to post
Share on other sites

Thank you Here to Help/Rampage Dev ! It now recognize my 650m as a GTX 650m with OpenCL etc. and also my HD4000 but I get a blank screen when i boot with -v GraphicsEnabler=off. I thought it was because of HD4000 but it's still the same when I remove those kext :/ GraphicsEnabler=on won't work (freeze with "couldn't patch ROM blablabla nVidia 0mb" or something like that). I can bypass this error while adding "useless" flags like usenvidiarom and vbios, but it con't work either (black screen) : It's interesting to note that it recognizes the HD 4000 as "Intel HD 4000 Mobile" (thanks to graphicsenabler).


I will add some screenshot so you can understand what I said (I can't now, I'll do it tonight (UTC+01:00)).


Anyway, Rampage Dev you made a big step for those who have a 650m since it's recognized in OSX (although it's still using HD4000 which doesn't work). Did you make other modifications in the DSDT (except for graphics) ?


Thanks again.

Share this post

Link to post
Share on other sites

@Rampage Dev


Do you see anything in my dsdt that not recognize my graphic card in ML? attached is my DSDT an IO reg






Start a new topic.


Here are 2 IOReg : There's one when I boot with a default SMBIOS and the other one is when I boot with the MacbookPro 9,1 SMBIOS (The one I always use)

Thank you very much !


Looks good as in the edits I did are working. However there is no framebuffer loaded for the Intel card. Get that card working first.

Share this post

Link to post
Share on other sites

Have you try to remove NV* kexts.. It is those kext that cause the freeze..


For Intel HD 4000 support natively, I only add device-properties hex string line in boot.plist only to got Full QE?CI support


My nVidia GT 630m not working however, it is impossible to get dual VGA in OS X ML?

Share this post

Link to post
Share on other sites

Hi AjGilee,

I removed every NV kexts and it worked, but still no hardware acceleration... It says in the System Profile that the .kext is not loaded. Besides, It seems that AGPM doesn't load at all during boot.

Can you explain exactly what you have done to make it work (such as the string you added, etc)

I tried every appl-platform-id, none of them worked... And I don't have when I do the ioreg command in the terminal, hence the fact there is no framebuffer loaded for the Intel card :/


Thank you !

Share this post

Link to post
Share on other sites

Ok, I managed to get full acceleration with the HD4000 and the framebuffers are now loaded.

,here is the new IOREG with the intel framebuffer loaded. I hope you will get us to make our 650m (and maybe other things) to work :) Thank you


Some new update, might use full, it seem not the NV* kexts that cause the freezing, the only kext that has trouble is GeForce.kext


Freeze on GraphicsEnabler=No, blank or black screen with GraphicsEnabler=Yes, nVidia ROM patching failed in Chameleon.


Any way, I managed to take some screenshots while in black screen, it seem both Intel HD 4000 and nVidia 6xx graphics suppoted natively by ML and should be OOTB.


For me it showed:

GeForce GT 630M, VRAM 1Mb, (no display attached)

Intel HD Graphics 4000 Mobile, VRAM 0Mb, (no display attached)


Both cards are reconigzed well but no display attached, usually by default the display attach on Intel with 64MB VRAM.

Share this post

Link to post
Share on other sites

I looked over the IOreg and it looks fine. The only way to get the Nvidia GPU working will be to turn off the HD4000. If you can not do this in the BIOS it will never work...

Share this post

Link to post
Share on other sites

if u can disable in bios the intel one, the nvidia works, the problem is mac os x don't do the switch between cards, possibly is donne by hardware, that is wat i think.


I have the Dell Inspiron 7720 SE with 3D screens. HD4000 doesn't exist from System Info - Graphics. But I still can't get 650m to work.


If I remove GeForce.kext, it will says NVDGK100Hal loaded and the system boots up with no screen (staying at the text-based view but I know that the system is running probably, just without a GUI screen).


I am new to this dual graphics scenario, please help. Many thanks in advance.

Share this post

Link to post
Share on other sites

It looks like the guy is using Optimus technology, and in my case I have only the Nvidia GT 650M the intel hd 4000 is always disabled in my notebook.


My case is the same as idpsystem2 but without 3D screens.


In Windows it shows only 1 VGA card that is Geforce, the Intel HD 4000 doesn´t show even in AIDA64, no traces of it.


Now I´m trying to copy the config data from iMac13,1 that looks like my pc.


Until now i copied the properties.plist, but no succes until now.


Anyone have a clue of what I am missing?

Share this post

Link to post
Share on other sites

@ThibaultAnd :

Thank for starting this topic, I have the same problem with my asus N56VZ.

I managed to make OSX to detect the Intel 4000 but I think it's not fully activated.

There are still some glitch here and there...


@Rampage Dev :

I've take a look at ThibaultAnd's dsdt and IOReg, although I'm not really understand

my DSDT is missing the Geforce part (something on Device "(PEGP)" ), I try copy and paste with no luck

can you also modify my DSDT (I,ve attached the dsdt+ioreg file and also a screenshot)



I assume you are an Indonesian?

how is the progress on your laptop, is it running smoothly?


Share this post

Link to post
Share on other sites

Yet with the same problem, full resolution, but no NVDAResman.kext, if I try to load NVDAResman.kext the boot goes on until before the mouse shows up, when the graphical interface will show up everything stops, the system freezes.


Here is my IOreg and dsdt and boot.plist and smbios.plist for you all to see, compare, throw it away, etc do anything you want with it. lol.


Help me to have any ideas, If I discover how to make it work I will put here.

Share this post

Link to post
Share on other sites

I have a similar issue - the machine is otherwise fully functional and I am running 10.8.3 (12D78) but no graphics. If you boot with NVDAStartup.kext and without GeForce.kext, the machine actually does boot but you need a second mac to share the screen and the maximum display will be 16?? by 1080. As I have my L702x hackint0sh with a nice second monitor attached, I run mine thatI way some times.


I have tried Clover but the results are not better - I believe the Ubuntu folks had similar issues and it required a kernel fix but I have NOT verified that nor been able to track it down. I would like to get a copy of the Mac VBIOS from a GT650M in a MBP or iMAC to use and I could really use a clear explanation of the source and reason behind the CVGDisplayxxx and etc. messages.


At this stage, I wish I could turn my HD4000 back on :(

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.