Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
level70steve

A 200MB "EFI System Partition" stuck on your USB drive and can't get it off?! READ THIS!

10 posts in this topic

Recommended Posts

Okay, earlier, I was not so pleased with formatting a USB flash drive in an attempt to get an OSX installation going, I should've restored with a DVD image and that was when I screwed up. Now I can't use it in Windows XP/Vista/7/8 because not only it did not appear in Computer, but it also contains a senseless 200 MB partition.

 

#1 - On windows, open Command Prompt (cmd).

 

#2 - Type "diskpart", press Enter.

 

#3 - Type "list disk", press Enter - and it will tell you which drives are which, including USB flash drives. Since I only had a hard drive and one 16GB flash image, that gave me the idea as to which disk I will take into consideration. My hard disk was 0 and my USB drive was 1.

 

#4 - Type "select disk X" where "X" is the location of your troubled USB drive. Press Enter.

 

#5 - Type "clean" and then further down the line, you will see something weird a few lines down...

 

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Administrator>diskpart

Microsoft DiskPart version 6.1.7601
Copyright (C) 1999-2008 Microsoft Corporation.
On computer: 7

DISKPART> list disk

 Disk ###  Status		 Size	 Free	 Dyn  Gpt
 --------  -------------  -------  -------  ---  ---
 Disk 0	Online		   74 GB	  0 B
 Disk 1	Online		   14 GB	14 GB		*

DISKPART> select disk 1

Disk 1 is now the selected disk.

DISKPART> clean

DiskPart has encountered an error: Access is denied.
See the System Event Log for more information.

DISKPART>

 

And so, you get an "access denied" error and another window should pop up saying that the drive needs to be formatted.

 

#6 - Close both the CMD and the Format Disk windows, hold down "Windows Key + R" to bring up a short Run window, and enter "diskmgmt.msc". Press Enter to run this command and make sure you are logged into Windows as Administrator while using Enterprise, Business, or Ultimate packages. DO NOT UNDER ANY CIRCUMSTANCE USE HOME PREMIUM/BASIC!

 

#7 - In Disk Management, your flash drive should appear in a complete black bar and all "EFI System Partitions" should be wiped out after you just got through using DISKPART. Right-click anywhere within the black bar, click New Volume, and follow the instructions that gives you.

 

#8 - Lay back because it could take a while depending on how much storage your drive has.

 

Right now, I am still trying this and so far, this method has solved most of my formatting and flash drive usage problems. Will it do the same for your flash drives?! Good luck, everyone, and make sure you are observing the OSx86 revolution even if it kills you. :)

Share this post


Link to post
Share on other sites

For the version I was using, Disk Utility wouldn't let me reformat. And their rules appear that no matter how many partitions you create in a single drive, OSX will throw in a 200MB system partition drive to begin with. Similarly, Windows Vista/7/8 would throw in a system partition when formatting a hard disk as if it was the first time. This is an option for OSX users that can't reformat a Flash drive using Disk Utility.

Share this post


Link to post
Share on other sites

No, you are wrong and this is why your post does not belong in the Genius bar (not sure where else to put it though):
Disk Utility will let you format anything but you may have to wipe whatever partition table is on it first.

Disk Utility only creates the invisible EFI partition on GUID aka GPT drives.

Look at these screenshots (sorry about the mess, i didn't write the steps in order, but you get the idea):
Partition.png Partition options.png

This is how you repartition and format a GUID drive with Disk Utility so that it can be used on Windows.

The other stuff you said is not entirely correct either:
The System Reserved partition only gets created during installation of Windows, and only when installing to a drive that is not already formatted.
It does not get created when formatting a drive from within Windows.

Share this post


Link to post
Share on other sites

This is an old thread but it did helped me to fix my non working USB that was stuck with EFI Partition.

 

I tried formatting it in OS X but it won't even recognize the USB and was causing USB ports that I inserted the disk to, to be inactive until I restart the PC.

 

Thanks for this post I finally got my USB working working again using Windows...

Share this post


Link to post
Share on other sites

This helped me delete the efi partition I accidentally on my USB drive, thanks for the simple, but easy guide :) .

Share this post


Link to post
Share on other sites

I know I was on windows 10 and just did Winkey + X and then pressed A for the admin command prompt.

Share this post


Link to post
Share on other sites

I know I was on windows 10 and just did Winkey + X and then pressed A for the admin command prompt.

 

Thanks, I learned something new today (A for elevated CMD). thats what I get for using Linux and OSX more

Share this post


Link to post
Share on other sites

Under Windows just use RUFUS, to reformat your drive...

Side benefit of RUFUS, you can create install USB sticks for Win and Linux...

And drives can be formatted GPT or MBR as FAT16/32, xFAT, NTFS or UDF...

quite a versatile tool... imho...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×