Jump to content
mitch_de

OpenCL Nbody Simulation bench (works 10.9+)

81 posts in this topic

Recommended Posts

Apple updated OpenCL Nbody Simulation  (= Galaxies) source code a few days  (FEB 2014) ago.

I compiled it and uploaded it (DL link at the end of the posting).

Much code changes compared to old galaxies OpenCL bench,  so the results arent compareable with old Galaxies anymore.

Now it shows an relative PERFORMANCE Rating value  (against an slow single core cpu) - old galaxies showed gigaflops.

Usage, very easy: OpenCL Nbody Simulation starts up in CPU Mode, you can switch by key s to  cpu multicore / GPU Mode and back to cpu.

If you have more than one GPU OpenCL device installed, you can try to switch with key g between them. (UNTESTED!)

ESC switches between window / fullscreen mode (fullscreen takes more opengl power = less OpenCL speed)
You can quit the test by using the Menue.

 

GPU

Bildschirmfoto 2014-02-16 um 11.46.57.jpg

 

CPU 

Bildschirmfoto 2014-02-16 um 11.46.44.jpg

 

NEW RESULTS (posted PAGE 4+) :

Nvidia GTX Titan : 1424 GPU

Nvidia GTX Titan : 1289 GPU

Nvidia GTX 650Ti : 408 GPU

Nvidia GT 440 : 75 GPU (10.9.2 C59)

AMD HD4670  : 72 GPU

OpenCL_NBody_Simulation.zip

Share this post


Link to post
Share on other sites
Advertisement

for nostalgias sake: gtx 480, early lion dp (80k bodies):

post-42821-1301745305_thumb.png

 

gtx 480, mountain lion dp1 (default settings):

post-42821-0-79082600-1329789390_thumb.png

 

gtx 480, mountain lion dp1 (80k bodies):

 

Share this post


Link to post
Share on other sites

Info: Galaxies uses the number of 65K (65536) as default for the star count.

The more stars the more cpu+gpu load.

Fast gpu may get a bit more Gigaflops if they use more stars - max. is 80K, than default.

HOW TO:

start terminal

Finder show package content on Galaxis

Drag & Drop galaxies (black icon) in terminal

81920 ENTER (be sure to have an space between galaxies and the 80K number

Slow gpus may not get any more Gigaflops by increasing the number - but the simulation itself will be shown very slow - takes much time to see the nice star movings.

You can use in this case better 32768 , which speeds up the simulation compared to the 65K or 80K.

Share this post


Link to post
Share on other sites

Great ! GTX 580 now pole position with 726 GigaFlops :superman:

Have you tried to increase the count of stars (read first post) from default 65K to 80K ? Maybe even a bit more gigaflops possible ;)

Also your result for 10.7.x maybe interesting (should be around 10% faster, like for others)

Share this post


Link to post
Share on other sites

Have you tried to increase the count of stars (read first post) from default 65K to 80K ? Maybe even a bit more gigaflops possible ;)

 


95-26-92-246:~ amoureux$ /Users/amoureux/Downloads/Galaxies.app/Contents/MacOS/Galaxies 153600
2012-02-22 19:01:47.294 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0
2012-02-22 19:01:47.295 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0
2012-02-22 19:01:47.296 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0

Found 1 GPU devices...
Using Device[0]: GeForce GTX 580
Using SIM: GeForce GTX 580 simulator w/ 153600 bodies...
2012-02-22 19:01:47.428 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0
2012-02-22 19:01:47.441 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0
2012-02-22 19:01:47.441 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0
2012-02-22 19:01:47.441 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0
2012-02-22 19:01:47.460 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0
2012-02-22 19:01:47.461 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0
2012-02-22 19:01:47.475 Galaxies[448:707] <GalaxiesView: 0x69113f00>, 0, 0

post-193013-0-02177500-1329923029_thumb.png

Share this post


Link to post
Share on other sites

Thanks!

Updated Galaxies: (DL first post)

- Gigaflops Meter now skaling for an max. 1024 Gigaflops

- shows number of stars (bodies) computed right of the gpu name

Bildschirmfoto 2012-02-22 um 16.17.12.jpg

Share this post


Link to post
Share on other sites

mitch_de,

 

Did you go back to the newer hwsensors with the newest version of fakesmc? I know you said it was messing with your speedstep and temps or something? Was it also affecting your graphics performance? Anyhow there were some changes made to it since then have you tried it since?

 

I left you a post over there you never responded?

 

Thanks

Share this post


Link to post
Share on other sites

EVGA 8800 GT: 227/231 Gigaflops (GL renderer/software renderer, 81920 bodies), 219/226 (65536), 189/212 (32768)

Q9550 @ 3.0GHz: 54 to 53 Gigaflops (number of bodies doesn't seem to matter)

 

This was on 10.7.3. Interesting that the software renderer with lower body counts is more than a little faster :|

Share this post


Link to post
Share on other sites

Addded some iMac 2011 results.

Indeed, stars count doesnt matter for CPU, because only 2/4/6 cores vs 16++ gpu units. Low cores count limits better gigaflops by more parallemism.

Share this post


Link to post
Share on other sites

Speedstepping works for me.

 

With the latest hwsensor newest version of fakesmc?

Share this post


Link to post
Share on other sites

my nvidia in 10.7.3

post-193013-0-82524300-1330455732_thumb.png

 

Update: I attached the displacement OpenCL benchmark (should work on 10.8 too)


Setting up Graphics...
----------------------------------------------------------------------
Creating Shadow FrameBuffer...
Creating Jitter Texture...
Loading Light Probe "stpeters_probe.pfm"
Error opening file stpeters_probe.pfm
Creating Light Probe Texture (0 x 0)....
displacement(293,0x7fff7c089960) malloc: *** error for object 0x108420bca: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

Share this post


Link to post
Share on other sites

"Error opening file stpeters_probe.pfm"

Displaces is NOT an double click to start benchmark! Read the usage in the first post!

You must first start terminal, set working directory by cd to main folder of the bench, then start the bench in the terminal. Otherwise bench fails, because it cant find any of the needed files (.pfm,....)

Share this post


Link to post
Share on other sites

"Error opening file stpeters_probe.pfm"

Displaces is NOT an double click to start benchmark! Read the usage in the first post!

You must first start terminal, set working directory by cd to main folder of the bench, then start the bench in the terminal. Otherwise bench fails, because it cant find any of the needed files (.pfm,....)

 

ок, sorry.

now i get the next result

post-193013-0-48495100-1330463684_thumb.png

post-193013-0-71278800-1330463695_thumb.png

Share this post


Link to post
Share on other sites

Results with an overclocked GTX570 run from within 10.8 (screenshots attached) :)

 

Galaxies

785 gigaflops using 81920 stars,

816 gigaflops using 262144 stars

 

Displacement

412fps

post-780955-0-99245600-1330614831_thumb.png

post-780955-0-71183400-1330615032_thumb.png

post-780955-0-52846000-1330615492_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×