Jump to content

How to know if OC is working on Hackintosh?


13 posts in this topic

Recommended Posts

Hey guys.


So, I've been trying to understand how OC works on hackintosh. So far, I have not learned much. After spending a lot of time reading threads in various forums, I'm still at square one. I've yet to find a simple, clear explanation of what is required to achieve stable OC'ing on Macs. I am, of course, a total noob. I've came across mentions of SpeedStepper and AppleIntelCPUpwm, but I still have no idea what they are (or what they do), and if I need them or not.


I've only been able to OC my system to a stable 4.4GHz on my Win7 drive just by messing with the BIOS. I have two other drives, one with Snow and one with Lion. Both Snow and Lion were made bootable with Andy's Boot CD 5. With the mentioned OC configuration, I can boot to Snow with no problem, but I don't know how to test if Snow is recognizing the OC (or if those settings are actually applied to the OS). I downloaded Geekbench, and my scores with and without the OC are the same.


My Lion drive, on the other hand, does not boot with my 4.4GHz OC configuration; I get a nasty kernel panic right after Chameleon. Again, I have no idea why. Do I need SpeedStepper for this? Is poking around with the BIOS not enough for Lion?


If anyone here can share their knowledge on this topic with me, I would very much appreciate it. So please, if you have any suggestions or if you can point me to a good OC'ing guide, I bed that you do.


Thanks in advance.


PS.- You'll find my system configuration on my signature below.

Link to comment
Share on other sites

I've overclocked my Pentium D from 2.66 GHz to 3 GHz; in Snow Leopard it is recognized and utilized.


I would try reinstalling Lion with the overclock enabled during the install. If the installer panics, post a pic here.

Link to comment
Share on other sites

I've overclocked my Pentium D from 2.66 GHz to 3 GHz; in Snow Leopard it is recognized and utilized.


I would try reinstalling Lion with the overclock enabled during the install. If the installer panics, post a pic here.


Thanks for responding. Do you think there is another alternative? I would hate to have to reinstall Lion, because I've spent the past 3 weeks installing apps, syncing mail + address book + calendar + keychains + itunes + etc, installing plugins, copying all my files, and so on.


I'm hoping this could be resolved by a simple patching or addition of kexts, or maybe even by a better understanding of SpeedStepper (see this thread). Yet again, I'm lost in that regard.


But let me ask you something: how do you know SL recognizes and utilizes you OC? Is there a command-line that can tell you the accurate speed of your CPU? Or do you use one of those benchmark programs? In either case, can you please tell me what you use?


Thanks again.

Link to comment
Share on other sites

Overclock working fine for me. Just OC'ed the usual way, with bios. No speedster or any of that rubbish, running native appleintelCPUPM, and speeds detected in bios boot up screen, and about this mac.

Your problem might be you need a different bus ratio. I remember when the first i7's came out, different ones needed a different number, think it has something to do with the multiplier, so have a look not that.

Link to comment
Share on other sites

Thanks for responding, Rorydaredking. I finally got my Lion drive to boot with working OC. Since there was the remote possibility of having to reinstall Lion, I decided to test messing with SpeedStep. It turns out my Lion drive did need it. My Geekbench score went from 12XXX to 15XXX. I followed this thread:




Since it worked on my Lion drive, and since my geekbench scores on my SL drive were also around the 12XXX, even if I could boot up with OC, I decided to test this same method on SL. For some reason unknown to me, this method did not work on SL. My geekbench score dropped down to 5XXX. I replaced the modified kexts from the method with my backed up ones, and geekbench score is at normal with 12XXX.


So, to sum up, Lion has working OC. Snow Leopard boots with OC but geekbench scores don't reflect the OC. I'm doing most of my work on Lion now, so as long as it works on this drive, I can't complain.


One last note: My "about this mac" does not reflect the OC on either drive. I will try adding this string to my smbios.plist:


<key>SMmaximalclock</key> <string>4000</string>


Thanks again for responding.

Link to comment
Share on other sites

  • 1 year later...


This is my second post, i'm italian and my english is not perfect so be patient with me!

I overclocked  my CPU into the BIOS @4.3Ghz and the RAM @2000mhz  (GA-Z77-DS3H   i7 3770K  16 gb DDR3 Corsair vengeance pro Corsair H90 cooler )


But OSX info shows that my CPU's clock is the standard 3.5Ghz (the RAM is correct @2000mhz) and also HWMonitor detect the same.


I tried to put into /Extra different SSDT but nothing changed. I also edited smbios with Chamelen Wizard in order to set the maximum clock speed of the CPU at over 4.3 Ghz and changed system definition a few times.

Geekbench score was about 13500.


When I decided to remove NullCpuPowerManagment.kext from /Extra/Extensions in my hackintosh HWMonitor recognized the OC and showed the correct CPU ratio and also my Geekbench score bumped up at 16446

But with this change made the system not working well: audio (from USB speakers and also from the jack port) was broken, internet was slow.


At the end I restored the NullCpuPowerManagment.kext and now my system is working like at the beginning: is not overcloked!


Is there a solution? Can I use my Hackintosh at the full of his performance? I want a machine that shows the correct CPU's frequency and works well. It's a dream or...?


Thank you for listening my story and for the help that you will give me.


Tiberio Galbiati

Link to comment
Share on other sites

If required (generally Gigabyte Z77 boards don't need it, ASUS boards do) patch the latest BIOS for your motherboard with PMPatch for compatibility with OS X power management.


Note that some motherboards require special tools or a specific method in order to flash a modified BIOS.


With the new BIOS flashed, first configure it like it was before, and second (if you were using a dsdt.aml) re-extract a clean DSDT from Windows using Lavalys Everest Corporate Edition (scroll down to 'discontinued') and re-patch the new DSDT. Screenshots provided for reference (thanks to an old friend of mine) - save the ACPI tables with .aml extension instead of the default .bin extension:

Everest1.png Everest2.png

If you don't have Windows installed, use a Linux live environment - Google for a how-to. Don't use a DSDT extracted from within OS X and never use a DSDT provided by a 3rd party, unless you know what you're doing - the DSDT table is not static, contents change depending on BIOS settings and revision, amount of RAM installed and other obscure things.


ssdtPRGen - make your own SSDT (while it's still useful, RampageDev's tutorial is slightly outdated, use ssdtPRGen.app, google it..) name it ssdt.aml and place it in /Extra, add DropSSDT=y to /Extra/org.Chameleon.Boot.plist.

Insert values that match your present overclock. If you change overclocking settings you'll need to run the app or script again and insert the new values.


Z77 chipset + Ivy Bridge CPU = iMac13,1 smbios: smbios.plist.zip

Use Chameleon Wizard to generate an authentic iMac13,1 serial number, I've placed a filler..

If you do everything right there's no need to set any clock frequency overrides in smbios.plist.


Grab the latest HWSensors package and edit info.plist inside FakeSMC.kext like this to match the iMac13,1:


If you're using XCode to edit the plist, first select 'show raw keys & values' from the editor menu so you can see what you're doing.

Double check that the new REV data actually sticks, save the plist to your desktop before editing it.

Only install the FakeSMC plugins you need.


Timing issues, particularly those resulting in slowdowns and stuttering sound/dropouts, can in most cases be resolved by removing forced IRQs from certain devices in your DSDT.

This allows OS X to distribute IRQs as it sees fit.


Use IORegistryExplorer (from XCode Dev Tools) to monitor your modifications:

ioreg1.png ioreg2.png ioreg3.png

Assigned IRQs for each device are visible under "IOInterruptSpecifiers".


Obviously get rid of NullCPUPM.kext, SleepEnabler.kext and anything else designed to override or block native power management from working.


Don't use /Extra/Extensions.


I can't be more specific than this, you must read, study and collect information specific to your hardware.

  • Like 2
Link to comment
Share on other sites

Thanks GV!! - that is a perfect guide for what is needed w/o getting into specifics for personal hardware.

  • Like 1
Link to comment
Share on other sites

It's really a useful guide for OC with Hackintosh.


But returning to my hardware: I read some stuff about SSDT and Power Management and I tried to do what Gringo said.


First:  there is no need to patch BIOS on Z77-based Gigabyte boards because they aren't locked by default.

Second: I found a SSDT.aml with P-States for a maximum speed of 4.7 GHz and I put it into /Extra

I also upgraded HWMonitor and FakeSMC 


Of course I removed NullCpuPowerManagement from /Extra/Extensions


And now happens a very strange thing:

when I boot on Mac OS X, HWMonitor recognizes a maximum CPU multiplier of 35

but if I go to sleep and after I wake from sleep, suddenly (by magic) HWMonitor works!  My OC is really effective only after a wake from sleep. I'm stunned.


I don't understand what happens, because also my USB 3 ports work only after a wake from sleep and before devices plugged into that ports are not recognized by the system.



I'm sorry but I still need help, thanks a lot for the time spent reading my posts and for your answers that made me happy.


Tiberio Galbiati

Link to comment
Share on other sites

  • 1 month later...

OMG  I have the exact same motherboard and CPU as you and the exact same problem.


Motherboard = Gigabyte Z77 DS3H Version 1.1

BIOS version = F9 (Current and up to date) F10 is beta so no thanks!

OC RAM = 1600MHz (correct)

Intel I7 3770K OC from stock 3.5GHz to 4.0GHz (shows up in BIOS and Windows 7 as 4.0GHz)


I am running OSX 10.9 Mavericks


CPU shows up as 3.5GHz only

No USB 3.0 (Have not tried sleep to get it working)


I would also love for someone genius to tell me how to fix this!


I bought this board as it was recommended but frankly speaking it is rubbish for hackintoshing!

Link to comment
Share on other sites


  • Create New...