Jump to content
einsteinx2

Optical drive making "boot" sound frequently

15 posts in this topic

Recommended Posts

I did a fresh install of retail Lion yesterday on my hackintosh. Since then, my optical drive has been making the "boot" sound, the one where it sounds like it's checking for a disc, about every 5-10 minutes. It's really annoying! If I open the disc drive and leave it open, it won't make the sound, but then it's just begging to get run into by someone's leg and broken.

 

Is anyone else experiencing this issue?

Share this post


Link to post
Share on other sites
Advertisement
I did a fresh install of retail Lion yesterday on my hackintosh. Since then, my optical drive has been making the "boot" sound, the one where it sounds like it's checking for a disc, about every 5-10 minutes. It's really annoying! If I open the disc drive and leave it open, it won't make the sound, but then it's just begging to get run into by someone's leg and broken.

 

Is anyone else experiencing this issue?

 

 

I had the same experience in snow leopard... but now in lion i don't experience this nice humming sound ;-) Or i am just ignoring it because of the smoothness of the OS...Wait... Aaaaah!!!! There it was again!!!!!!

 

:)

 

 

But yes, i really wanna know what is going on there... I think its a check for new discs, maybe in the iMacs the optical drive does the same, but its very quiet.... Who has a real solution?

 

Please help us! It is really ugly.

Share this post


Link to post
Share on other sites

I only started having this issue since my Lion install, never had it on Snow Leopard. I think it probably has less to do with Lion itself and more to do with the slightly different setup I did (using custom DSDT file and some different kexts now).

 

For instance, in Snow Leopard I never had working sleep. I do have working sleep in Lion, I think because of the DSDT file. I have a gut feeling that it has something to do with sleep. Did you have working sleep mode on your Snow Leopard install?

Share this post


Link to post
Share on other sites

I have the same problem. the optical drive makes the boot sound randomly. i had this problem under snow leopard and now under lion.

 

I hope that anyone can find a solution

Share this post


Link to post
Share on other sites

Y'all, too, huh? I used to have 2 DVD drives, both SATA, connected to my computer. They would both spin up at the same time, while I ran Snow Leopard. Since then, I removed one drive and upgraded to Lion, but the drive continues to spin up from time to time. Its as if the OS keeps having to ask itself, "Is there a disc there now? How about now?"

Share this post


Link to post
Share on other sites

as poster above me said this is known problem TSST drives, you can put any cd (even blank) in to make it sleep. also, this can be a cause to non-working auto sleep.

Share this post


Link to post
Share on other sites
as poster above me said this is known problem TSST drives, you can put any cd (even blank) in to make it sleep. also, this can be a cause to non-working auto sleep.

 

Hmm now that you mention it, my computer hasn't been automatically going to sleep. I have to choose it from the Apple menu manually.

 

I just popped a blank CD into the drive, so we'll see if that stops the sound. I don't mind it not auto-sleeping, but the sound of the drive is driving me crazy.

 

Btw, I have an Asus DVD burner, and I had no problem with this in Snow Leopard (though I never had working sleep, or at least I never even tried to use sleep, but also didn't have a custom DSDT).

Share this post


Link to post
Share on other sites

I found the only thing that stops this weird issue is to go into the power saving options and disable putting hard drives to sleep. it stops my DVD-RW from making those noises every 10 minutes.

 

Mine is a TS-H653R branded as HP, but it's obvious it's a TSSTcorp drive.

 

Strangely enough when I had a proper Apple iBook G3 with Tiger, the CD-ROM in that used to make the sound every 10 minutes.

Share this post


Link to post
Share on other sites
I found the only thing that stops this weird issue is to go into the power saving options and disable putting hard drives to sleep. it stops my DVD-RW from making those noises every 10 minutes.

 

Mine is a TS-H653R branded as HP, but it's obvious it's a TSSTcorp drive.

 

Strangely enough when I had a proper Apple iBook G3 with Tiger, the CD-ROM in that used to make the sound every 10 minutes.

 

as we said you can put any cd in it to make it sleep, i don't think want your hard drives to spin all the time (or do you?),

you can all check if the drive go to sleep with CHUD Tools,

http://download.cnet.com/Apple-CHUD-Tools/...18_4-25386.html

 

go to SpindownHD.app and see if your drive going to sleep

in my case if there isn't a cd in the drive i can see in the app whenever the drive go into idle state it will do the disk checking, once having cd inside, idle state is good and after i get drive sleep.

Share this post


Link to post
Share on other sites
I did a fresh install of retail Lion yesterday on my hackintosh. Since then, my optical drive has been making the "boot" sound, the one where it sounds like it's checking for a disc, about every 5-10 minutes. It's really annoying! If I open the disc drive and leave it open, it won't make the sound, but then it's just begging to get run into by someone's leg and broken.

 

Is anyone else experiencing this issue?

 

Go to System Preferences -> Energy Saver -> uncheck "Put the hard disk to sleep when possible".

This will fix the problem :(

Share this post


Link to post
Share on other sites

I can confirm that putting a CD in the drive stopped the sound. I just turned off "put hard disks to sleep" (I have an SSD anyway) so I'll see if that also fixes it. I realized I did have that unchecked in my Snow Leopard install when I didn't have the problem.

 

Thanks for all the input guys!

 

EDIT: I can confirm turning off "put hard disks to sleep" also fixes this. So if you have an SSD or otherwise don't care if your HDD sleeps, just turn that setting off in the Energy Saver of System Preferences. If you need your HDD to sleep, just keep any disc in your optical drive all the time (that is assuming that the "put hard disks to sleep" option is even working at all in these cases).

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Thanks zoltankr!

You are my idol.

10000000 years trying to solve it and the answer has been extremely easy.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×