Jump to content
RoberT_XeS

[GUIDE] Snow Leopard Retail 10.6.X on P5Q Series

Installed SNOW LEOPARD Retail Successfully  

393 members have voted

  1. 1. Were you able to install SNOW LEOPARD Retail Successfully?

    • Yes
      290
    • No
      104

507 posts in this topic

Recommended Posts

SNOW LEOPARD RETAIL 10.6.X FOR P5Q MOTHERBOARD SERIES AND OTHERS

 

This guide should work for all ASUS P5Q Series Motherboards

 

USB Method....MBR Support Included

 

 

 

 

STEP 1: REQUIREMENTS

If your Motherboard bios is not included in the link below then you can request Shamux or Smith@@ to modify Bios for you

1. Modified Bios : Here or Here

2. USB / Flash Drive: 8 GB or External HDD or a 8 GB Partition on you Internal HDD

3. Working Leopard 10.5 or any working Mac. If you do not have one then follow the guide here

4. SNOW Leopard Retail Image 10.6.0 (You can use 10.6.3 if you are installing myHack v1.1)

 

 

STEP 2: FLASHING BIOS

 

1.You can find Modified Bios for P5Q Motherboards Here

2. Save the modified Bios File to USB Flash Drive or Floppy disk or on your HDD.

3. After reboot press "DELETE" to enter setup

4. Go to section TOOLS > mark ASUS EZ Flash2 > press Enter > press OK

5. Press "TAB" > Select a key "Down arrow" or "Up arrow" saved on a floppy disk or flash-drive or HDD and select the modified Bios file

6. Press �ENTER�.

7. Select "OK" > press "ENTER"

8. System will erase the old BIOS and will write the new one

9. And in 5 seconds will automatically reboot

 

 

STEP 3: LOADING BIOS OPTION

 

CHANGE THE STORAGE CONFIGURATION IN BIOS TO AHCI. (Please note that windows might not boot if you do not have AHCI Drivers installed on Windows. Please follow the steps here under AHCI Mode if you want to install AHCI Drivers on Windows)

 

Also make sure that the Firewire option is Enabled in the Bios.

 

Suspend Mode: S3

 

Also Enable ACPI 2.0 in the Bios if you are struck in (ACPI_SMC_PlatformPlugin::start – waitForService) while booting

 

STEP 4: RESTORING RETAIL IMAGE FILE

 

1. Log into your working Leopard Machine.

2. Plug in your USB Drive

3. Open Disk Utility (FINDER > Applications > Utilities > Disk Utility)

4. Right click on the USB Drive and select Partition

5. In volume scheme select 1 Partition and name it as MAC OS X Install DVD

6. Select the Format as Mac OS Extented (Journled)

post-271572-1269076498_thumb.png

7. Now Click on Options and Select GUID Partition Table or MBR Master Boot Record and then click on Apply. (I prefer MBR)

8. Now its time to verify the Snow Leopard Retail Image you have

9. Click on Images Menu at the top and then select Scan Image for Restore

post-271572-1269076594_thumb.png

10. Select the Image File and then click on Scan

post-271572-1269076584_thumb.png

11. Now select the MAC OS X Install DVD (USB Drive) Partition and click on Restore

12. In the source select the image that you just scanned

13. In the destination drag and drop the USB drive named MAC OS X Install DVD

post-271572-1269076575_thumb.png

14. Now click on Restore. This will restore the SNOW Leopard Retail Image File to the USB drive

 

 

STEP 5: VERY IMPORTANT

 

1. Now download myHack Installer 1.0.1 from here or here Thanks to Scott aka “Conti

2. Now run the file myHack_Installer_1.0.1.mpkg and then continue. You can also use new package myHack 1.1

3. Click on Change Install Location and select the USB Drive and then click on Continue

post-271572-1269076606_thumb.png

4. Now click on Customize and select the options as shown in the image below.

post-271572-1269076464_thumb.png

5. Once done please extract the RoberT_Xes_Kexts.zip file.(If you are using myHack 1.1 then do not replace FakeSMC)

6. Copy the kexts inside and paste it to USB Drive > Extra > Extensions (use only those kexts which you need. For kext information used in my pack....Click Here )

7. This will replace the original kexts with my kexts

8. If the FakeSMC included in my package does not work for you then useFakeSMC 2.5 kext.

post-271572-1269076561_thumb.png

9. Now Reboot your System

 

If you want Dual Boot with Windows 7 then you can do the partition as I did. Refer to my Parition style at the Bottom of this post.

 

 

STEP 6: INSTALL SNOW LEOPARD

 

1. Reboot your Machine and keep on pressing F8.

2. This will give you an option to select Boot Drive

3. Select the USB Drive

4. Type in -x -vand then press Enter

5. Follow the instructions and you will get an option to select the Drive in which you want to install Snow Leopard

6. Run Disk Utility and then right click on the Drive which you want to erase and then select Erase.

7. Now close Disk Utility and then select the drive which you just formatted and then continue.

8. Now click on Customize and then unselect Language Translations and Printer Drivers.

9. Once done, restart the computer.

 

 

Troubleshooting Steps (If you face any problem while trying to Install)

 

While installing Snow Leopard, if you are receiving a kernel Panic then you can try the old modified Bios instead of the new ones.

 

Enable ACPI 2.0 in your Bios if you are stuck in (ACPI_SMC_PlatformPlugin::start – waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out) and use FakeSMC 2.5 from here (Thanks to piromanneo for this solution)

 

If you are getting Blank or Black Screen while trying to install because of your ATI Graphics card or some newer NVIDIA Graphics card then click here

 

You can try to boot with -x -v cpus=1 if you are facing problems to get the installation to start

 

 

Those who are having ATI Cards / Newer NVIDIA Cards and stuck in (ACPI_SMC_PlatformPlugin::start – waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out)...... or if you are getting a Blank or corrupt screen then please copy EVOEnabler.kext in to USB Drive > Extra > Extensions folder and then boot with -x or -x -v to resolve the issue

 

 

STEP 7: MAKING YOUR SNOW LEOPARD BOOTABLE

 

1. Boot using your USB Drive

2. This time select the drive in which you have Snow Leopard installed, type in -v and then press Enter

3. Now run the file myHackInstaller1.0.1.mpkg and then continue

4. Click on Change Install Location and select the Drive in which you have Snow Leopard Installed and then click on Continue

5. Now click on Customize and select the options as shown in the image below.

post-271572-1269076464_thumb.png

6. Once done please extract the RoberT_Xes_Kexts.zip file

7. Copy the kexts inside and paste it to SNOW Leopard > Extra > Extensions (This time use only those kexts which you need. For kext information used in my pack....Click Here)

7. This will replace the original kexts with my kexts

8. Now Reboot your System

 

Those who are not able to boot Snow Leopard using the myHackInstaller can try

PC EFI 10.6 or Chameleon RC4 from here

 

Even after trying the above steps if you are still not able to boot from the Snow Leopard Drive then follow the below steps

1. Repair the boot using Windows Vista / Windows 7 DVD and then boot into your windows or you can download PartedMagic Live CD and boot into Parted Magic and here open Partition Editor and give the Boot Flag to your Windows Drive and reboot

2. Now you will be able to boot into Windows.

3. Download Easy BCD

4. Install the software and then 'Run as an administrator'

5. Here click the Add/Remove Entries button

6. You can add Mac OS X and also Linux Entries here...save the settings and then reboot

7. Now you will be able to boot into Snow Leopard

 

 

STEP 8: INSTALLING UPDATE 10.6.X

 

1. Download the update from http://www.apple.com

2. Before installing the update, please remove SleepEnabler.kext from Snow Leopard > System > Library > Extentions and also from Snow Leopard > Extra > Extensions

3. Now Double click on the update file and install the update

4. Reboot your Computer

5. Once done you can install the latest SleepEnabler.kext from here http://code.google.c...er/updates/list

 

 

STEP 9: INSTALL DRIVERS

 

INSTALL KEXTS USING Kexthelper b7

 

SOUND ALC 1200: http://www.insanelymac.com/forum/index.php?showtopic=161430

 

LAN Atheros L1E - ATL1E: http://www.insanelymac.com/forum/index.php?showtopic=140907

 

NVIDIA: http://www.kexts.com/view/170-videocards_(....6_(86-64).html. Use any one kext from here...

 

ATI: http://www.kexts.com...php?do=cat&id=6 http://www.insanelym...howtopic=177112

 

For other Sound / Lan / Graphics Driver : http://www.kexts.com/downloads.php

 

 

 

MY SYSTEM

 

Motherboard--------------- ASUS P5Q

Storage-------------------- 1 X 500 GB SATA /3 X 160 GB SATA / 1 X 200 GB PATA / 1 X 120 GB PATA

CPU-------------------------Core 2 Duo E4600 2.4 Ghz

OS-------------------------- SNOW LEOPARD 10.6.2 / Windows 7

RAM------------------------ Transcend 4 GB 800 MHz

Graphics Card-------------- ZOTAC NVIDIA GeForce 9800 GT -GDDR3- 1GB

 

 

 

MY PARTITION STYLE

 

1st Partiton : Windows 7

 

2nd Partition: Snow Leopard

 

3rd Parition: Retail Image (I Used a 8 GB partition instead of USB Drive)

 

4th Parition: Normal Extented NTFS Drive

 

 

 

ASUS P5Q / P5Q PRO / P5Q C / P5Q L EM / P5Q VM / P5Q EM / P5Q L PRO / P5Q Premium / P5Q E / P5Q Deluxe / P5Q 3 / P5Q SE R / P5Q EM DO / P5Q SE / P5Q SE PLUS / P5Q SE R / P5Q L E / P5Q E WiFi AP / P5Q TURBO / P5Q PRO TURBO / Asus Maximus II GENE / Asus Maximus II Folmula / Asus P5Q PL VM EPU / ASUS P5B Series / ASUS P5K Series and many others

Share this post


Link to post
Share on other sites
Advertisement

I used this process but i have a problem with my graphics card its a GTX260. i cannot seem to get higher Rez and the hardware profile says i have a ATI HD??? does anyone have the right drivers for this???

Also i have a Asus P5Q-Deluxe MOBO are the drivers different to the Asus P5Q or above drivers???

cheers great work though

Share this post


Link to post
Share on other sites

Try NVEnabler maybe it should work

 

http://www.kexts.com/

 

 

I used this process but i have a problem with my graphics card its a GTX260. i cannot seem to get higher Rez and the hardware profile says i have a ATI HD??? does anyone have the right drivers for this???

Also i have a Asus P5Q-Deluxe MOBO are the drivers different to the Asus P5Q or above drivers???

cheers great work though

Share this post


Link to post
Share on other sites

Hi and first thx for the tutorial and excuse my bad english i'm a french user ,x , i read your post carrefully cause i ve already sl retail installed on my p5q following another tutorial but i want things as perfect as i can. =)

 

Anyway at the moment i've following extension in my E/E :

 

20100323-jiqb5mu74uhr6g6yjyi5bw1nw3.jpg

 

and the following in my S/L/E :

 

AttansicL1eEthernet.kext / UUID.kext / VoodooHDA.kext

 

and system running fine exept i got an error message if i send computer to sleep with usb plugged but sleep works well =)

 

I download your kext to see what you are using and there is a lot more than mine ;x can you explain what are the use for these kexts ? are they all essentials ?

 

thanks by advance and sorry for the pain of reading me :)

Share this post


Link to post
Share on other sites

AppleACPIPS2Nub.kext and ApplePS2Controller.kext are for my PS2 Keyboard and Mouse.

 

AppleIntelPIIXATA2.kext, AppleVIAATA.kext and IOATAFamily.kext to make the PATA HDD (IDE) work

 

ElliottForceLegacyRTC.kext is to resolve the CMOS Reset issue

 

EvOreboot.kext is to resolve the restart problem

OpenHaltRestart.kext to resolve the Shutdown and Restart issue

 

SMBIOSResolver.kext ---- If your memory details are not properly shown in the Profiler

 

 

So...the above kexts more or less resolves most of the issues......hence I used all those kexts.... If your system is working fine then do not install the kexts.....

 

 

You should atleast have FakeSMC.kext, NullCPUPowermanagement.kext and IOAHCIBlockStorageInjector.kextfrom my package in to the Extra > Extentions folder if you want to install Snow Leopard

Share this post


Link to post
Share on other sites

Ok thx for the answer =)

 

theses one :

 

AppleIntelPIIXATA2.kext, AppleVIAATA.kext and IOATAFamily.kext to make the PATA HDD (IDE) work

 

make me curious cause i don't know them but since i m not using my pata disk i don't need them

 

this : ElliottForceLegacyRTC.kext is to resolve the CMOS Reset issue was solved in my dsdt.aml fix

 

anyway thanks for the answers and explains about your kexts =)

 

i would just want to know if i m not missing any kext who can make my system better and your answer help me in that way =))

 

i hope you didn't misunderstood me in my post i didn't want to say "hey look my system works fine with less kexts than you" but "hum did i miss any kext in my config that could improve my osx user experience" i repeat that i was not a natural english speaker and i don't want to be misunderstood, hope there's no offense

 

have a good day =)

 

Ps : ha yes one more thing : did your computer send you an error message when you send it to sleep with usb connected on front panel ?

Share this post


Link to post
Share on other sites
Ok thx for the answer =)

 

theses one :

 

AppleIntelPIIXATA2.kext, AppleVIAATA.kext and IOATAFamily.kext to make the PATA HDD (IDE) work

 

make me curious cause i don't know them but since i m not using my pata disk i don't need them

 

this : ElliottForceLegacyRTC.kext is to resolve the CMOS Reset issue was solved in my dsdt.aml fix

 

anyway thanks for the answers and explains about your kexts =)

 

i would just want to know if i m not missing any kext who can make my system better and your answer help me in that way =))

 

i hope you didn't misunderstood me in my post i didn't want to say "hey look my system works fine with less kexts than you" but "hum did i miss any kext in my config that could improve my osx user experience" i repeat that i was not a natural english speaker and i don't want to be misunderstood, hope there's no offense

 

have a good day =)

 

Ps : ha yes one more thing : did your computer send you an error message when you send it to sleep with usb connected on front panel ?

 

 

Its always good to enhance our knowledge......your comments are always welcomed.....Even I get to test more.....Your English is good, no need to worry.....

 

Sleep works sometimes but sometimes it does not...maybe its because of my Graphics card Driver....

 

I think your system is near to perfect as sleep works most of the time except when you connect your USB....

Share this post


Link to post
Share on other sites

hey mate,

all was going well, until i needed to boot up my windows half way through.

i did this, but i needed to replace the new modded bios back to my old bios in order for my windows to boot.

i did this, made my changes (to my partitions), then went to go back to revert my bios back to the modded ones.

however, now, every time i run EZFLASH 2, it doesnt load my disks, it just keeps saying "loading".

any idea :S

and is it completely necissary to have the modded bios in order to install?

thanks alot mate

Share this post


Link to post
Share on other sites
hey mate,

all was going well, until i needed to boot up my windows half way through.

i did this, but i needed to replace the new modded bios back to my old bios in order for my windows to boot.

i did this, made my changes (to my partitions), then went to go back to revert my bios back to the modded ones.

however, now, every time i run EZFLASH 2, it doesnt load my disks, it just keeps saying "loading".

any idea :S

and is it completely necissary to have the modded bios in order to install?

thanks alot mate

 

 

Try loading your bios from the EZFLASH in the Bios.....if it is not working then try flashing you bios using the Bios Update Utility. You will find this utility on the Motherboard CD which came with the Motherboard or you can download it from the ASUS website

Share this post


Link to post
Share on other sites
Never mind spoke too soon. I had to reinstall the core part of MyHack for the third time for it to work. Really wish there was a way to get rid of the MyHack logo screen with the original osx screen during booting but I am more than happy with everything right now. Thanks again Robert

 

Before installing Chameleon remove the Boot file from the root and then install Chameleon.

 

They are just themes, you can change them if you want........Follow the instructions given below... I have included some themes

 

1. Copy the files inside Themes.zip to SNOW LEOPARD > Extra > Themes

2. Now run Theme_changer.zip and select the theme you want and reboot

Share this post


Link to post
Share on other sites

Hello

First off thank you for all your hard work with this.

I had 10.6.2 64 bit working perfectly. Now I updated to 10.6.3 and I have no sound and the new sleep enabler kext doesn't seem to work for me. It seems to put it to sleep but the fans keep running and the led stays on and it wont wake back up again. If I put the old sleep kext back in then I get a KP. If you could help I would appreciate it.

 

p5ql-pro

8800gts

q9300

8 gigs kingston hyper x

 

Thanks

Ill

Share this post


Link to post
Share on other sites

I got it all working. Even sleep. For some reason though, my usb mouse and keyboard don't work after wake up. I have to unplug and plug it bag in again then it works. Another odd thing is that I can wake it up with the mouse and then it doesn't work after that. Is there some kext that needs to be changed for that?

Share this post


Link to post
Share on other sites

Hi Robert_XeS, some questions for you! I have an ASUS P5Q-EM..

 

0. I have already installed this BIOS modified by Smith

0b. APCI Enabled, SATA set as ACHI, Fireware Enabled, SuspendMode only S3

1. I restored the image of snowleopard_10a432.dmg in my DataTraveler 16Gb through iDeneb 1.6 - Disk Utility

2. Installed "myHack_Installer_1.0.mpkg" in my DataTraveler 16Gb

2b. "myHack" also solves the problem "Retail on MBR" or I need first to fix the dmg? (my hdd uses MBR, not GUID)

2c. "myHack" also install the bootloader?

3. Now I have to drag into "Extra/Extensions" only the kexts needed..

4. So first I have removed all "myHack" default kexts and I have open your package, now..?

4b. I have a PS2 Keyboard so I need AppleACPIPS2Nub.kext and ApplePS2Controller, right?

5. I must also put video and audio kexts in the Extension folder? I have an ATI4850..

6. All my HDD & Optical Drives are SATA, as you can see in the signature, so, no ATA.kexts,right?

7. Witch other kexts I need? for Speedstep etc etc?

8. What precautions should I take to update to 10.6.3?

8b. This package of SL 10.6.3 (by AppleSupport) include all fix of earlier versions?

 

Sorry for all this questions .. and sorry also for my english .. it's a little clouded at this time of the morning. :(

 

Thanks again!

Supernova

Share this post


Link to post
Share on other sites

First off, excellent guide B) . I got mine working without any issues. I used a 10G partition for the Retail Image instead of the USB drive, and I'm assuming that I can simply just delete this partition without any issues? Please advise and thanks for the hard work.

Share this post


Link to post
Share on other sites
First off, excellent guide ;) . I got mine working without any issues. I used a 10G partition for the Retail Image instead of the USB drive, and I'm assuming that I can simply just delete this partition without any issues? Please advise and thanks for the hard work.

 

Yes...You can delete the Partition if you have done Step 7

 

Hi Robert_XeS, some questions for you! I have an ASUS P5Q-EM..

 

0. I have already installed this BIOS modified by Smith

0b. APCI Enabled, SATA set as ACHI, Fireware Enabled, SuspendMode only S3

1. I restored the image of snowleopard_10a432.dmg in my DataTraveler 16Gb through iDeneb 1.6 - Disk Utility

2. Installed "myHack_Installer_1.0.mpkg" in my DataTraveler 16Gb

2b. "myHack" also solves the problem "Retail on MBR" or I need first to fix the dmg? (my hdd uses MBR, not GUID)

2c. "myHack" also install the bootloader?

3. Now I have to drag into "Extra/Extensions" only the kexts needed..

4. So first I have removed all "myHack" default kexts and I have open your package, now..?

4. I have a PS2 Keyboard so I need AppleACPIPS2Nub.kext and ApplePS2Controller, right?

5. I must also put video and audio kexts in the Extension folder? I have an ATI4850..

6. All my HDD & Optical Drives are SATA, as you can see in the signature, so, no ATA.kexts,right?

7. Witch other kexts I need? for Speedstep etc etc?

8. What precautions should I take to update to 10.6.3?

8b. This package of SL 10.6.3 (by AppleSupport) include all fix of earlier versions?

 

Sorry for all this questions .. and sorry also for my english .. it's a little clouded at this time of the morning. :)

 

Thanks again!

Supernova

 

2b. myHackInstaller solves the MBR Problem, you can install Mac on MBR

2c. myHackinstaller also installs the bootloader, so need of installing any other bootloader

4. Yes that is right, but remember you should atleast have FakeSMC.kext, NullCPUPowermanagement.kext and IOAHCIBlockStorageInjector.kext from my package in to the extention folder

4b. Yes you need AppleACPIPS2Nub.kext and ApplePS2Controller

5. Yes you can, but if you get any Kernel Panic then remove it from the Extra > Extention folder

6. Yes...no need of AppleviaATA.kext and IOATAFamily.kext

7. I don't have any other kexts installed on my machine

8. See STEP 8: INSTALLING UPDATE 10.6.X.... I have included some new steps

8b. I think 10.6.3 Combo have all that

 

I got it all working. Even sleep. For some reason though, my usb mouse and keyboard don't work after wake up. I have to unplug and plug it bag in again then it works. Another odd thing is that I can wake it up with the mouse and then it doesn't work after that. Is there some kext that needs to be changed for that?

 

I am not sure about that issue.....sorry

Share this post


Link to post
Share on other sites

Nothing to do, I don't know if I miss something but probably have an ATI4850 card doesn't help..

May be because I don't know exactly kexts that I need to put into my Pendrive (with Snow restored).

 

Installation ends ok but when I try to start Snow for the first time with the bootloader into the Pendrive, freeze..

Share this post


Link to post
Share on other sites

Yeahh!! The problem was the 4850 but with the dev-id works wonderfully! :(

 

The only problems I have to solve now is Memory Speed, System Info show me 667mhz instead 800mhz

Another "little" problem is that the cpu seems to always work to 3,0Ghz, so i think SpeedStep don't work..

 

If you know how to solve the above problems I'm here.. but I'm already very happy!

 

My Bios already contain this Fix:

- Removed CPU Alias

- Added 2 IRQNoFlags HPET Device (Hpet Fix)

- Fix RTC (Reset cMOS Fix)

 

Kext that I used:

- ApplePS2Controller

- EvOreboot.kext

- FakeSMC.kext

- IOAHCIBlockStorageInjector.kext

 

 

Thanks Robert!! :)

Share this post


Link to post
Share on other sites

Hi,I'm new to the InsanelyMac forums and to the OSx86 project but have recentley become obssessed with installing snow leopard on my pc.

After trying several distros including leopard with no success I came across your site and got the Snowleopard 10.6.2 by hazard .iso ,modded my bios with the 2001 bios by juzzi and followed the guide, the whole install goes through as it should until the pc restarts, the intall doesn't seem to fully finish though, it says about a minute remaining and instead of a big green tick onscreen it goes straight to the text you get after you click ok to restart?The pc restarts and goes to the bootloader screen and I select snowleopard and press down then boot from verbose, the lines of text run through till I get the attatched screen?

Any help from you guys would be greatly appreciated.

thade69

mobo: ASUS P5Q PREMIUM

cpu: INTEL CORE 2 QUAD Q9300 P45 ICH10R

mem: 2XOCZ 2GB DDR2

gpu: 2xRADEON HD 4850 CROSSFIRE X

lan: MARVELL 88E8056 GIGABIT LAN CONTROLLERS

hdd: 2X74GB WD RAPTORS, 1X250GB WD, 1X500GB WD, 2X640GB WD MY BOOK, 2X1TB WD ELEMENTS

os: WINDOWS 7 ULTIMATE 64BIT

bios: MODDED P5Q PREMIUM 2001 FROM THIS SITE

SANY0131.jpg

Share this post


Link to post
Share on other sites

thanx for this great guide, but I have a problem....

 

The PS/2 mouse does not work for the install of snow leopard. The PS/2 keyboard does work

I did use the AppleACPIPS2Nub.kext and ApplePS2Controller in the RoberT_Xes_Kexts.zip but still no mouse.

 

Help Plz

 

 

 

PQ5 Pro

Q6600

4GB Ram

9600 GT

Share this post


Link to post
Share on other sites
Yeahh!! The problem was the 4850 but with the dev-id works wonderfully! ;)

 

The only problems I have to solve now is Memory Speed, System Info show me 667mhz instead 800mhz

Another "little" problem is that the cpu seems to always work to 3,0Ghz, so i think SpeedStep don't work..

 

If you know how to solve the above problems I'm here.. but I'm already very happy!

 

My Bios already contain this Fix:

- Removed CPU Alias

- Added 2 IRQNoFlags HPET Device (Hpet Fix)

- Fix RTC (Reset cMOS Fix)

 

Kext that I used:

- ApplePS2Controller

- EvOreboot.kext

- FakeSMC.kext

- IOAHCIBlockStorageInjector.kext

 

 

Thanks Robert!! :wub:

 

 

Just copy the SMBIOSResolver.kext file into Extra > Extention folder and then restart mac and it should work.

 

Hi

 

Sorry for my silly question, but you did not mention what OS you installed first , Mac or windows 7?

 

 

I installed Windows 7 first

 

thanx for this great guide, but I have a problem....

 

The PS/2 mouse does not work for the install of snow leopard. The PS/2 keyboard does work

I did use the AppleACPIPS2Nub.kext and ApplePS2Controller in the RoberT_Xes_Kexts.zip but still no mouse.

 

Help Plz

 

 

 

PQ5 Pro

Q6600

4GB Ram

9600 GT

 

May be you can try these....

VoodooPS2Controller_0.98_installer.zip

But remember you need to delete AppleACPIPS2Nub.kext before installing the above package or you’ll get a kernel panic. Delete it from System > Library > Extentions folder as well if you have it there

 

nice job

 

but what does the modified bios 1303 for p5k pro do.

Whats it instead off.Do we not need dsdt then?

 

 

I don't know what is modified in the Bios as I did not modify any of the bios....it was all done by Juzzy and some of them by Shamux. But I do know that they are necessary or else you need to DSDT.... but I am not very good in DSDT.

 

Hi,I'm new to the InsanelyMac forums and to the OSx86 project but have recentley become obssessed with installing snow leopard on my pc.

After trying several distros including leopard with no success I came across your site and got the Snowleopard 10.6.2 by hazard .iso ,modded my bios with the 2001 bios by juzzi and followed the guide, the whole install goes through as it should until the pc restarts, the intall doesn't seem to fully finish though, it says about a minute remaining and instead of a big green tick onscreen it goes straight to the text you get after you click ok to restart?The pc restarts and goes to the bootloader screen and I select snowleopard and press down then boot from verbose, the lines of text run through till I get the attatched screen?

Any help from you guys would be greatly appreciated.

thade69

mobo: ASUS P5Q PREMIUM

cpu: INTEL CORE 2 QUAD Q9300 P45 ICH10R

mem: 2XOCZ 2GB DDR2

gpu: 2xRADEON HD 4850 CROSSFIRE X

lan: MARVELL 88E8056 GIGABIT LAN CONTROLLERS

hdd: 2X74GB WD RAPTORS, 1X250GB WD, 1X500GB WD, 2X640GB WD MY BOOK, 2X1TB WD ELEMENTS

os: WINDOWS 7 ULTIMATE 64BIT

bios: MODDED P5Q PREMIUM 2001 FROM THIS SITE

SANY0131.jpg

 

 

The error message that you got is it after installing Snow Leopard by Hazard or after installing the Retail Snow Leopard using my method ?

 

Also you can try flashing the Bios once again with the modified Bios.

Share this post


Link to post
Share on other sites

Robert, First off your guide wow what a life saver! Great stuff!!!

 

I do have a couple of questions though. I have a P5Q Deluxe and followed your tutorial and worked like a champ. But there are two things that i am having issues with.

 

1) is i can not boot directly from the drive (sata drive1) I have to use the USB drive to boot the main drive with MyHack Installer.

 

2) The drive that snow leopard installed on (the main Snow Drive) shows orange as if its a external drive and not a internal. That really doesn't matter if the system will boot by its self.

 

I have installed MyHack installer 5 times and replacing with your kext each time even trying to install only the core from the installer but it just want boot with out the USB drive.

 

Any suggestions???

 

Thanks in advance!!!!

John

Share this post


Link to post
Share on other sites
Robert, First off your guide wow what a life saver! Great stuff!!!

 

I do have a couple of questions though. I have a P5Q Deluxe and followed your tutorial and worked like a champ. But there are two things that i am having issues with.

 

1) is i can not boot directly from the drive (sata drive1) I have to use the USB drive to boot the main drive with MyHack Installer.

 

2) The drive that snow leopard installed on (the main Snow Drive) shows orange as if its a external drive and not a internal. That really doesn't matter if the system will boot by its self.

 

I have installed MyHack installer 5 times and replacing with your kext each time even trying to install only the core from the installer but it just want boot with out the USB drive.

 

Any suggestions???

 

Thanks in advance!!!!

John

 

 

Copy the kext from the following link into the Extra > Extensions folder to resolve the Orange Icon

http://www.kexts.com/view/9-fix_for_orange...w_leopard).html

 

To boot from the main drive you can try installing Chameleon RC4 V3 on the main drive....

http://www.insanelymac.com/forum/index.php?showtopic=201850

 

Even then if it is not working then try removing the boot file from the root directory and then install Chameleon and then check if it is working

Share this post


Link to post
Share on other sites
Just copy the SMBIOSResolver.kext file into Extra > Extention folder and then restart mac and it should work.

 

 

 

 

I installed Windows 7 first

 

 

 

May be you can try these....

VoodooPS2Controller_0.98_installer.zip

But remember you need to delete AppleACPIPS2Nub.kext before installing the above package or you’ll get a kernel panic. Delete it from System > Library > Extentions folder as well if you have it there

 

 

 

 

I don't know what is modified in the Bios as I did not modify any of the bios....it was all done by Juzzy and some of them by Shamux. But I do know that they are necessary or else you need to DSDT.... but I am not very good in DSDT.

 

 

 

 

The error message that you got is it after installing Snow Leopard by Hazard or after installing the Retail Snow Leopard using my method ?

 

Also you can try flashing the Bios once again with the modified Bios.

 

this was using iPC OSx86 iso, also does mac support 2xati cards in crossfire?

thanks Simon

 

UPDATE: just updated bios with the 1611 for premium and rebooted , now i've lost dipslay?my monitor doesn't come on when the pc boots, any help aprecciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

×