Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
MiniBUU

SnowOSX Universal 10.6 Gold Master (10a432) v3.5 for PC

22 posts in this topic

Recommended Posts

I found this on another site, figured I share just in case anyone was curious to try it out early. Not sure where you can download it and I wont post the links here. I gather that this release is geared towards russians all though I figure its in english as well. I wont be using this but figured I share just in case.

 

Year: 2009

Version: Gold Master 10a432 v3.5

The developer: Apple + dan1234

Platform: Intel only

System requirements:

PC computer with an Intel SSSE3 processor

1GB of memory

8GB of free disk space

Interface language: English + Russian

 

The description:

The work of our companion constructed basis of Snow Leopard 10a432 userdvd

And experience of users of resources TorrentMac and AppleLife!

Suits both for GUID, and for Mbr partition scheme + integrated Russian localisation + integrated DSMOS (432) from Netkas - (Minus) other languages, the printer-drivers and cheerful voices (AdditionalSpeechVoices)!

 

In Customise:

Snow_bootloader - Loader Chameleon 9-4

NullCPUPM - disabler for IntelCPUPowerManagement

SMBIOSResolver - Mac model iMac9,1

OpenHaltRestart

SleepEnabler

PS2 - kexts for PS/2

IntelPIIXATA_Fix - The modified driver for ATA� DVD-drives

LegacyAHCIATA - Legacy kexts on Intel AHCI (SATA), Intel ATA (IDE), JMicron ATA. Are especially recommended for owners ICH9!

IOUSBFamily-build - The new version of the original driver (went together with original DVD)

Rosetta - support old applications

ATools_Snow - A folder with a system utilities and drivers

 

Into ATools folder:

/ATools/

AppCleaner.app

BetterZip.app

CandyBar.app

Change Finder

Clone X 3.app

CPU-i.app

ForkLift.app

HexEdit

iGetter.app

IORegistryExplorer.app

KCNScrew.app

Kext Utility.app

Monolingual.app

OnyX.app

OSX86Tools.app

Property List Editor.app

TinkerTool.app

Xbench.app

 

/ATools / _ Drivers/

AppleACPIPS2Nub.kext

AppleIntelPIIXATA.kext

ApplePS2Controller.kext

AppleRTL8139Ethernet.kext

CPUi_snow.pkg

dsmos.kext (from Netkas to 10a432)

HDEFInject.kext

LegacyAppleAHCIPort.kext

LegacyAppleIntelPIIXATA.kext

LegacyAppleYukon2.kext

LegacyIOAHCIBlockStorage.kext

LegacyJMicronATA.kext

NVInject.kext

OpenHaltRestart.kext

PlatformUUID.kext

SleepEnabler.kext

SMBIOSResolver.kext

TARUGA_SNOW

VoodooHDA.kext

 

/ATools / _ System/

Beta_decrypter_for_10a421a_32_64.pkg

bootsnow-9-4

Chameleon_DFE_for_Hard_Disk.pkg

Chameleon-2.0-RC2-r640.pkg

/DSDTPatcherGUI_1.0/

EFIStudio.app

Pacifist_2.6.dmg

Share this post


Link to post
Share on other sites

Pentium Dual Core E2160, MB Gigabyte G31M-S2L, 2GB RAM, 256MB GeForce 7600GT. 2 HDDs (both GPT) Had a success installing the 3.5 distro, using it for 3 days already, both 64 and 32 bit kernels work, however I spent some time to make it work, it didn't just run out of the box. Installation went fine but booting the installed system resulted in kernel panic (both x86 and x86-64). I have leo installed on a second drive, used it to fix the SL intallation. Here is what I've done:

  • booted into leo, installed Chameleon 1.0 RC1 and EFI v10 on the SL drive (replacing the loader that came by default).
  • copied the Extra folder from leo root (which had chameleon installed) to SL, removing all kexts in Extensions subfolder.
  • ran DSDT patcher to get a dump of dsdt.aml with fixes, placed it both into SL root and /Extra.
  • moved these kexts from /System/Library/Extensions to /Extra/Extensions: NullCPUPowerManagement, OpenHaltRestart, SleepEnabler, PlatformUUID, fakesmc (this one doesn't come with the distro, had to download it from netkas).
  • removed any remaining third-party kexts from /S/L/E (including dsmos)
  • got the SL drive's UUID from disk utility and placed it to boot-uuid key of /Extra/com.apple.Boot.plist
  • got the video EFI string from EFI Studio, placed it in device-properties key of /Extra/com.apple.Boot.plist
  • got the NIC's mac address and placed it in last 12 digits of SMUUID key of /Extra/smbios.plist
  • repaired ownerships of /Extra/Extensions and /System/Library/Extensions:
    chown -R 0:0 /System/Library/Extensions
    chown -R 0:0 /Extra/Extensions


after that I had a success booting the 64-bit kernel in single-user mode (-s)

  • made mkexts of system and extra kexts:
    kextcache -v l -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions
    kextcache -v l -t -m /Extra/Extensions.mkext /Extra/Extensions


     
    first successful boot to GUI, however I had some input problems - keyboard and mouse worked (mouse pointer was movable and caps lock worked on kb) but everything was unclickable\untypable. removing Graphics Mode from kernel flags key of /Extra/com.apple.Boot.plist resolved that - it booted in default 1024x768 mode but everything worked. After completing the first run wizard, I installed audio (Voodoo for SL) and video (NVinject for SL) kexts (if you checked ATools option during installation, both kexts are found in Applications/Atools/Drivers).
     
    For some reason I still had a KP when booting with x86 kernel, but booting in single-user mode and rebuilding mkexts fixed this.
     
    So, maybe this distro didn't work out of the box just on my hardware, or maybe I made some wrong\unnecessary steps, but as you can see, it would be easier to do a vanilla install (like described here) rather than messing with all this.

Share this post


Link to post
Share on other sites

For me, when I tried to do an upgrade from leo using an original .dmg image of SL, it said that I need to burn it to a DVD and rerun the installer, which I haven't done because I don't have any DL DVD-R. While it might be possible to upgrade from leo somehow, I think it's better to do a clean install on a second drive\partition because in case something goes wrong (e.g. a kernel panic when booting to SL) you will still have a working leo to be able to make modifications to SL files, though an installation DVD could also be used for that if you boot it into single user \ use a terminal app in the installer GUI.

Share this post


Link to post
Share on other sites
It doesn't work for me. When I want to boot with the Installation DVD, my computer restarts. :)

 

use -v cpus=1 feature during boot

this ll fix your problem

Share this post


Link to post
Share on other sites

If the author doesn't reply to our PMs it's maybe not safe to use.

 

Wait tomorrow and you'll be able to install a nice retail of Snow :|

Share this post


Link to post
Share on other sites
Guest cavallo
If the author doesn't reply to our PMs it's maybe not safe to use.

 

Wait tomorrow and you'll be able to install a nice retail of Snow :|

 

It is safe and faster dowloading, yesterday in less than 3 hours i downloaded, burned and installed it on Toshiba in signature.

Why i say safe?

Cause the panic i have is the same i had following the guides present in this forum.

post-194988-1251390481_thumb.jpg

Share this post


Link to post
Share on other sites

Downloaded, installed on ECS G31T-M, Q6600 processor, installs fine, but on reboot and trying to enter the operating system it stops after the NETKAS warning. Won't get past that point for any reason.

 

 

 

How do you start 32 bit mode? Is it just X32 at the command line? I'll try that when I get home.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×