Jump to content

nForce LAN driver

740 posts in this topic

Recommended Posts

Hi I am using an M4N98TD evo board, it was the last ever Nforce Chipset, it is an AMD socket board, I am using an AMD 1090T X6 processor.


The Chipset on this is the combined NF200 SLI chip with the MC78 chipset, it shows as MC72 in AIDA 64 but they were all kind of related. Although it claims to be a 980A chipset, its a rebadged 780A that has added support for DDR3 memory.


When I installed my MAC OS X, initially I was installing a Nforce LAN driver, just out of interest on a reinstall, I decided not to use it and lo and behold, the Ethernet was still detected and still worked, I haven't updated this to 10.6.8 as yet but the default IOnetworking kext is working at the minute.

  • 4 months later...

Hey guys I managed to install mavericks in my system however everytime I try to install nforcelan 64.5 or 64.6 I get kernel panic. I had this working on my mountain lion without issues. Even after remiving nvenet. Attached is a screen shot of my kp. Advice is needed.


@ jayzfelon


nForceLAN.0.64.5.kext is working fine for me in Mavericks in /S/L/E


Did you manually set ownership and permissions of the Extensions folder? See my nForce OS X Mavericks Install Guide Post #2.....:)

  • 3 months later...
  • 2 months later...

Just a heads-up. My nForce motherboard fried itself awhile ago so I have no way to test nForceLAN anymore. I will shortly post the latest code on github so that it will be readily available to anyone who wants to fix any of the remaining issues. Just send me a pull request once the repository is up.


Repository: http://www.github.com/hjelmn/nForceLAN

Bro , why you disabled wol function?

i mean this part of code:

/* disable Wakeup on LAN */
    writeRegister(NvRegWakeUpFlags, 0);
    _wolEnabled = false;

however it should be like this 

code taken from nforce4lan sources

 IOReturn com_triton_forcedeth::setWakeOnMagicPacket(bool active)
    if( active ) {
        writeRegister(NvRegWakeUpFlags, NVREG_WAKEUPFLAGS_ENABLE);
        wolEnabled = true;
    } else {
        writeRegister(NvRegWakeUpFlags, 0);
        wolEnabled = false;
    return kIOReturnSuccess;

Also .. can you release 64.5 sources?

  • 2 weeks later...

@ Savva_Mitrofanov


That is nice to know......waiting to try your modified release........ :)

  • 6 months later...

@ Yakei


I use nforcelan 0.64.5 on 1000base TX (my MOBO has dual Gigabit LAN ports) without any problems.

@ yakei


From my system.log


Jan 10 00:43:27 nForceLAN: found nVidia MCP55 Ethernet Controller device 10de:0373 with flags 0x010937fe
Jan 10 00:43:27 nForceLAN: Version 0.64.5 starting
Jan 10 00:43:27 nForceLAN: found nVidia MCP55 Ethernet Controller device 10de:0373 with flags 0x010937fe
Jan 10 00:43:27 nForceLAN: Version 0.64.5 starting
Jan 10 00:43:28 nForceLAN(en1): enabling interrupts with mask: 0x000000df and msiEnable: 0x00000001
Jan 10 00:43:28 nForceLAN(en1): Network link down.
Jan 10 00:43:30 nForceLAN(en1): Link speed now 1000Mbps(duplex = Full, flow control = Yes), code 0x10032



  • 11 months later...
  • 2 months later...

I'm having issues with ethernet on Niresh Yosemite. It's detected and other PCs on the network are even shown in Finder however Safari just loads a website for ever.

Chipset is nforce 630i. (Ignore my signature, it's for another computer).


Should I try installing this kext? If so what version? And should I remove "nvenet.kext" from "IONetworking kext"?


EDIT: The above method works. Thank you cosonic!

  • 3 months later...

Im Really struggling with this Nforce, no method posted here works for me.

can anyone please help me resolve this, i am so stuck, i want to get my LAN working because my usb ports are only working as USB1.1, making WIFI unuseable, the problem i have is my Ethernet is NFORCE.
Now, there seems to be conflicts somewhere, Especially the IONetworkingFamily kext with its Built in Nvenet kext, which always shows as NOT ENABLED during Boot, And the actual NFORCE driver makes no difference.
As far as im aware, NFORCE is the main driver, and nvenet creates the actual interface, however i cant get it working, ive tried all Nforce drivers i could find in the 0.64 region, also tried Forcedeth, still wont work, it is gigabit Lan.
The support website for my MOBO reports the LAN to be - NVIDIA Gigabit MAC---Realtek 8211CL Gigabit PHY featuring AI NET 2.

Cany anyone help with KEXT advice and making this work because im getting nowhere fast here.


Ive tried the Nforce listed in this topic, ive also tried disablemsi both false and true, ive also tried the removal of nvenet, but that completely removes any options to select Ethernet interface on reboot.


I dont know whats going wrong.

  • 2 months later...

OK. I've managed to hack something up for the nForce (5) series.

However, it's (currently) just a hack. It all started after finishing a

SL install. Everything worked great, but the NIC (onboard lan)

wasn't recognized. So no internet/network. I spent some time

attempting to find a solution that already existed. But no joy.

Anyway, the closest thing I could find was an old unfinished

nForce4 driver. Out of desparation, I took a chance, and installed

the package. Unfortunately, it failed. So I went on looking for a

solution, but again, no joy.

Well being a programmer since the mid '70's, I decided to see

what I could come up with. I've been on BSD UNIX for about 30 yrs.

and currently maintain ~100 ports. So I figured cobbling something

up for a Mac (even if it is an AMD based one) should be fairly simple.

Turns out it is. Anyway I hacked on the failed nForce4 version that failed

the install. It's unfortunately Linux based. But in spite of that, I managed

to at least get it to connect me to the internet/network.

This is NOT something I'm going to attach to this post. But rather a "heads up"

that I'll be creating an nForce5 version suitable for all of you out there

suffering without a network on your new hackintoshes.

Thus far, I've managed support for the Vitesse 8601 chipset -- cause that's

what I have :P

But when finished:

It'll be BSD based, support both the Vitesse 8601, and the Realtek 8201CL chipsets.

I should have something suitable for broad testing fairly soon. I should probably

create a separate post/thread to announce it. So simply perform a serch for nForce5,

or follow/watch/friend me. :)


All the best to you!




  • Create New...