Jump to content

VMware Native Install of OSX Server, AND Leopard, Screenshots Attached

19 posts in this topic

Recommended Posts

I have completed both Leopard and OSX Server native installs successfully on VMWARE Server 2.0.

I used the Jas 10.5.2 DVD for Leopard, and the Jas 10.5.2 DVD WITH the OSX Server DVD for OSX Server install.


Everything but sound works, even ethernet.


Instructions For Leopard and VMWare Server 2.0:

First , install Deamon tools, and create a Virtual Drive, and mount the JaS 10.5.2 DVD image, found on TPB.

1. Open up the console for VMware Server 2.0

2. Click Create new virtual machine

3. Select Custom, and create a virtual machine as Linux, Other 64bit.

4. Add the hardware you wish, a harddisk with 25-50GB of space (You can use IDE or SCSI), you do not have to allocate all at once.

Add a ethernet card, and make it bridged if you have a router, and NAT if you dont.

Add a CDROM, and click host, and select the drive letter of the virtual deamon tools drive.




5. Finish creating you virtual machine.


7. Open the VMX file for your virtual machine with TextPad or some other text editor.

8. This is what mine looks like:

RemoteDisplay.depth = "16"

RemoteDisplay.vnc.enabled = "true"

RemoteDisplay.vnc.password = "somepassword"

RemoteDisplay.vnc.port = "5900"

bios.bootDelay = "9000" <--------- This one is KEY

chipset.onlineStandby = "FALSE"

config.version = "8"

deploymentPlatform = "linux" <--------- This one is KEY

displayName = "Leopard"

ethernet0.addressType = "generated"

ethernet0.allowGuestConnectionControl = "FALSE"

ethernet0.features = "1"

ethernet0.networkName = "Bridged"

ethernet0.present = "TRUE"

ethernet0.virtualDev = "e1000"

ethernet0.wakeOnPcktRcv = "FALSE"

ethernet1.addressType = "generated"

ethernet1.allowGuestConnectionControl = "FALSE"

ethernet1.features = "1"

ethernet1.networkName = "Bridged"

ethernet1.present = "TRUE"

ethernet1.virtualDev = "e1000"

ethernet1.wakeOnPcktRcv = "FALSE"

extendedConfigFile = "Leopard.vmxf"

floppy0.present = "FALSE"

guestOS = "otherlinux-64"

ide0:0.allowGuestConnectionControl = "FALSE"

ide0:0.deviceType = "cdrom-raw" <---------- This one is KEY

ide0:0.fileName = "G:"

ide0:0.present = "TRUE"

memsize = "2048"

numvcpus = "2"

nvram = "Leopard.nvram"

isolation.tools.hgfs.disable = "true" <---------- This one is KEY

mks.keyboardFilter = "off" <---------- This one is KEY

mks.maxRefreshRate = "60" <---------- This one is KEY

mks.noEmulateResolution = "true" <---------- This one is KEY

svga.autodetect = "true" <---------- This one is KEY

pciBridge0.present = "TRUE"

powerType.powerOff = "soft"

powerType.powerOn = "default"

powerType.reset = "soft"

powerType.suspend = "hard"

scsi0.present = "TRUE"

scsi0.sharedBus = "none"

scsi0.virtualDev = "lsilogic"

scsi0:0.fileName = "Leopard.vmdk"

scsi0:0.mode = "independent-persistent"

scsi0:0.present = "TRUE"

scsi0:1.fileName = "Leopard_1.vmdk"

scsi0:1.mode = "independent-persistent"

scsi0:1.present = "TRUE"

scsi0:2.fileName = "Leopard_2.vmdk"

scsi0:2.mode = "independent-persistent"

scsi0:2.present = "TRUE"

virtualHW.productCompatibility = "hosted"

virtualHW.version = "6"

scsi0:0.redo = ""

scsi0:1.redo = ""

scsi0:2.redo = ""



10. Fire up your VM, and press the ESC key when it asks.

11. Select your CDROM

12. Press F8, and key in -v, then enter, and then go right into the installer.

13. Press language, then continue.

14. Go to Utilities, then Disk Utility

15. Select your hard disk, and format it with either MBR, or GUID, which ever you prefer

16. Select Continue, and Customize.


18. Skip the DVD Check, then continue and wait for the install to complete.

19. Now the fun part. DO NOT LET IT RESTART!!!!!!!!!!!!!

20. Before you let it restart, go to Utilities, and open the Terminal

21. From the terminal, excecute the following commands

a. /Volumes/<YOUR LEAPORD VOLUME>/usr/sbin/mkextunpack -v -d /Volumes/<YOUR LEAPORD VOLUME>/System/Library/Extentions /System/Library/Extensions.mkext

b. /System/Inst<TAB>/CD<TAB>/M<TAB>/Con<TAB>/M<TAB>/<TAB> /System/Installation/Packages/Patches/AppleACPIPlatform.pkg

c. Install that package to your Leopard Drive.

d. Once finished, dont let it restart, GO BACK TO TERMINAL AND PRESS CONTROL+C to Kill your Installer session.

e. /System/Inst<TAB>/CD<TAB>/M<TAB>/Con<TAB>/M<TAB>/<TAB> /System/Installation/Packages/Patches/AppleAHCIPort.pkg

f. Install that package to your Leopard Drive.

g. Once finished, dont let it restart, GO BACK TO TERMINAL AND PRESS CONTROL+C to Kill your Installer session.

h. /System/Inst<TAB>/CD<TAB>/M<TAB>/Con<TAB>/M<TAB>/<TAB> /System/Installation/Packages/Patches/Kernel.pkg

i. Install that package to your Leopard Drive.

j. Once finished, dont let it restart, GO BACK TO TERMINAL AND PRESS CONTROL+C to Kill your Installer session.

k. /System/Inst<TAB>/CD<TAB>/M<TAB>/Con<TAB>/M<TAB>/<TAB> /System/Installation/Packages/Patches/AppleSMBIOS.pkg

l. Install that package to your Leopard Drive.

m. Once finished, dont let it restart, GO BACK TO TERMINAL AND PRESS CONTROL+C to Kill your Installer session.

22. Do the same for Boot.pkg and boot_efi_mbr.pkg if you partitioned with MBR and want to use the darwin boot loader, or boot_efi_guid.pkg if you partitioned with GUID.

23. # mount, make note of your /dev/diskXsX for your Leopard drive

23. cd /

24. umount /Volumes/<LEOPARD>

25. fdisk -e /dev/diskXsX

26. From the fdisk prompt, type flag 1 <ENTER>, update <ENTER>, write<ENTER>, quit<ENTER>.

27. /Volumes/<LEOPARD>/usr/bin/vi /Volumes/<LEOPARD>/Library/Preferences/SystemConfiguration/com.apple.Boot.plist

28. Add the following.

a. Kernel Flags, -v

b. Timeout, 9

c. Graphics Mode, 1024x768x32@60 (Or whatever you want)

d save with :wq!

29. # shutdown -r now



30. Once you reboot, if you get a blank black screen, or a blank screen with boot error, then your disk is not bootable. Go back in Terminal after booting from DVD again, and preform steps 22-26 AGAIN and AGAIN until it boots to the Leopard drive. IT WILL WORK, be persistant.


31. Once you are in, go through the first run setup and thats all folks!




OSX Server is a little more steps, but basically the same. I will post those instructions sometime soon.




35966914gn8.th.jpg 92463727hx1.th.jpg 85144744gu9.th.jpg 88594500fs7.th.jpg


96396866ea7.th.jpg 43792131qn6.th.jpg 97616420jn9.th.jpg 36075969cu5.th.jpg


10ab8.th.jpg 11vq0.th.jpg 12uv3.th.jpg 13qs0.th.jpg




I will post instructions, as well as where to find the DVDs you need, as well as a Full Vmware Package for OSx Server.

Link to comment
Share on other sites

OK thanks. I am setting up a Server 2 beta 2 machine just to try out my instructions on that version. Pity Server 2 is such a mess in the UI department!

Link to comment
Share on other sites

  • 1 month later...

My 10.5.1 kalyway turn in cycles after the background image appears. I wait it for 3 hour without result. The vm (workstation exp beta 6.5) appears to run normally, it runs for task manager and consumes a little of cpus.

Tried with vm 6 workstation, same problem.

Tried with other realease (leo4allv3) idem!


any suggestion?

Link to comment
Share on other sites

@Sgherzos: I have the same issue, but I haven't changed the VMWare machine settings at all. Zeph and Leo4All both boot with the background, but installer never comes up. At office, but will try some things out when home and will report back.

Link to comment
Share on other sites

  • 2 weeks later...



I have followed your VMware instructions to the letter and when I boot up my VM, I get a message that the CPU has been disabled. Having used the -v option, I see there is a kernel panic:


panic(cpu 0 caller 0x001ABE49): "commpage no match on last routine"@/Volumes/disk1s2/leo_xnu/xnu-1228/osfmk/i386/commpage/commpage.c:422

Debugger called: <panic>

Backtrace, Formate - Frame : Return Address (4 potential args on stack)

0x152bbe68 : 0x12b0e1 (0x4583fc 0x152bbe9c 0x133285 0x0)

0x152bbeb8 : 0x1abe49 (0x462860 0x4000 0x2000 0x1)

0x152bbf38 : 0x1ac0a9 (0xffff0000 0x517ec4 0x0 0x523f80)

0x152bbf88 : 0x181fa7 (0x2c2f010 0x1 0x0 0x53f000)

0x152bbfa8 : 0x137d47 (0x0 0x0 0x137cd8 0x0)

0x152bbfc8 : 0x19f3bc (0x0 0xffffffff 0x1a202a 0x0)

Backtrace terminated-invalid frame pointer 0


BSD process name corresponding to current thread: Unknown


Mac OS version:

Not yet set


Kernel Version:

Darwin Kernel Version 9.2.0: Tue Fe {can't see the rest}



I get the EXACT same CPU Disabled message when I try to run Leo4vmware 10.5.2.


I'm trying to run this on a Macbook Pro 4,1 edition (latest, 2.6 Ghz).


So you ask, if I have a Macbook Pro, why do I want to run OSX86? The answer is simple. I develop on Linux and need to run VMs for Windows and OS X. The JaS AMD version for 10.4.8 runs great in VMware. But Leopard seems to have problems.


Hope you can shed some light.

Link to comment
Share on other sites

  • 2 months later...
  • 9 months later...

  • Create New...