Jump to content

ATI Mobility Radeon X2300 now WORKS CI/QE !


  • Please log in to reply
247 replies to this topic

#81
GTOnizuka

GTOnizuka

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
Yeah this is also my problem, but i'm trying to fix it...be patient...thanks :P

//EDIT: on may 9th i'm going to have a 20mb dsl connection so after that, i'll try to get a copy of the os and to make tests for myself, because now i have a stupid connection that make me to download at 20kb/s (fake dsl). Anyway, if i'll have some results i'll post something here.

#82
GTOnizuka

GTOnizuka

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
Hi all, just postng a curious test to do...if anyone wants ;)

My idea it's to use my ATIX1000 kext (modded for X2300) + ATIinject (with EDID) to try if we can get major resolution (i can not do it by myself because i think that EDID it's different for every pc, so if a i make a kext with my EDID, for example, it's not sure to work with yours and back). So with this test we can see if: 1) our EDID it's the same and 2) if we can unlock screen resolution (and maybe mouse tearings...).

I'll do them by myself after 9th of this month...until now i'll wait for your posts (just let me know if you succed or not and what is your computer, if ASUS, SONY, etc.).

...Waiting for you guys, try it ONLY in a test system... :)

#83
tqtyygtwwx

tqtyygtwwx

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
hey man ,
i see your display is ATI x2300,,you say you can work with QE/CI and can be change the resolution 1280x800x32

at last ,how to get resolution 1280x800x32???help me


my friend is ASUS F3jr I was get open QE/CI mouse tearing was fix it..but i can't get the resolution 1280x800x32

why??

I was Darwin bootloader com.apple.boot.plist.....add

<key>Boot Graphics</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1280x800x32</string>

and GTOnizuka say~~may be the x2300 was open the QE/CI the resoltion was lock~~~beacuse I can change resolution///////

but why somebody can used the resolution 1280x800x32????

#84
GTOnizuka

GTOnizuka

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
The answer is simple: the chipset of X2300 into Sony Vaios (because only there the resolution is unlocked) is different (i think) from our ASUS laptops, or mnaybe the monitor that they used is more compatible than ours. Or another time is motherboard chipset, how it use it or how osx use it...In fact the first post of this topic tell that he unlocked QI/CE for X2300 in sony vaios, but no one trust that it function on ALL x2300. Anyway i'm trying to get the differences to make a single kext (or a set of) to make this as simple as possible (for now we can unlock QI/CE that make the system more usable than software mode i think...).

I promise you that i'll do what i can to make this thing function. Only be patient and ask, tell or propouse something new to try, and remember: we can do anything if we want :(

#85
0xf0bd

0xf0bd

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
installed kalyway 10.5.2 on asus f3jr (ati X2300)
installed your kext
QE/Ci is working, but no proper resolution (editing the plist didn't help)
Also i've noticed some visual artefacts (white flashing stripes) in Graph application (in 3D mode)

#86
GTOnizuka

GTOnizuka

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male

installed kalyway 10.5.2 on asus f3jr (ati X2300)
installed your kext
QE/Ci is working, but no proper resolution (editing the plist didn't help)
Also i've noticed some visual artefacts (white flashing stripes) in Graph application (in 3D mode)


Thanks for the report, but did you try with EDID for the resolution?

#87
0xf0bd

0xf0bd

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Thanks for the report, but did you try with EDID for the resolution?

mm...
No, i didn't. I don't know how to do this. Can you tell me? I'm noob :hysterical:
Thanks. ;)

#88
GTOnizuka

GTOnizuka

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
Post 82 or if you're lazy click here :(

#89
0xf0bd

0xf0bd

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Thanks for the report, but did you try with EDID for the resolution?

i've modified ATInject,
then i've installed ATInject and ATINDRV and got black screen.
i've also tried to use old ATINDRV (from 10.4) and original 10.5.2
tried to replace some settings like IONDRVDevice to IOPCIDevice etc ...
nothing changed
MY EDID:
00FFFFFF FFFFFF00 320C00C1 00000000 00100103 80211578 0AB37099 59538D27 23505400 00000101 01010101 01010101 01010101 0101EA1A 00805020 10301820 44004BCF 10000019 00000000 00000000 00000000 00000000 00000000 00FE004C 47506869 6C697073 4C43440A 000000FE 004C5031 35345730 312D544C 4432005F


#90
GTOnizuka

GTOnizuka

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
Thank you very much for your report, maybe we'll have to wait for next 10.5.3 relase to see if we will get something new for us...until now i think that we had tryied all and we had no result (apart QI/CE).

Thanks for all your time spent into this research with me and i hope we'll find a solution as soon as possible. Until there i wish you nice days :)

#91
GloomeRy

GloomeRy

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Russia
Anybody test it with GFX-EFI?

#92
Dainix

Dainix

    Level 12 Warmage

  • Members
  • PipPipPipPip
  • 204 posts
  • Gender:Male
  • Location:In a Toaster Oven
  • Interests:15% APR for three years. After that, it's 20%.
Sorry, but if this is based off the old X1000 series cards, all you're doing is beating a dead horse, because these problems have already been solved to the extent where anymore would require a driver rewrite.

To get QE/CI to work is simple. All that requires is adding the device ID of your card to its corresponding extension. External monitor support? Natit works wonders.

Because this is a mobile video card, everyone wants the capability of changing resolutions on the internal display. Nope. It will not happen.

The only driver with LVDS support is the Wormy driver. This driver works with the X1600, X1800, and X1900. It's not backwards compatible.

So I guess I'll say it like I did in the X1400 thread: The driver will display in VESA mode, and only in VESA mode, unless you find a way to include LVDS support in the core driver itself.

#93
sinnsyk

sinnsyk

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
i tried to install iATKOS v2.0i to see if that would work better, but all I got was a stopping loader and no macOSX. Didn't have much time to experiment but it was very strange. On iATKOS v1.2i (or something like that) it worked, but without the video card properly. I have an ASUS A8Jr...

stupid apple. Why not install an x2300 in macbooks and let us have fun with their OS too...

#94
pere

pere

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 726 posts
ok, so wich Natit should we use to get the second monitor working??

#95
sinnsyk

sinnsyk

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
i just saw when looking for a driverpackage on the ATI website that the ATI Radeon Mobility x2300 is filed under the HD2000 series of the mobility cards... like so:

from: http://ati.amd.com/p...play/index.html

Desktop Graphics Processors

* ATI Radeon HD 3800 Series
o ATI Radeon HD 3800

Notebook Graphics Processors

* ATI Mobility Radeon HD 2000 Series
o ATI Mobility Radeon HD 2600 XT
o ATI Mobility Radeon HD 2600
o ATI Mobility Radeon HD 2400 XT
o ATI Mobility Radeon HD 2400
o ATI Mobility Radeon HD 2300
o ATI Mobility Radeon X2500
o ATI Mobility Radeon X2300

* ATI Mobility Radeon X1000 Series
o ATI Mobility Radeon X1900
o ATI Mobility Radeon X1800 Series
o ATI Mobility Radeon X1700
o ATI Mobility Radeon X1600
o ATI Mobility Radeon X1450
o ATI Mobility Radeon X1400
o ATI Mobility Radeon X1350
o ATI Mobility Radeon X1300

* ATI Mobility Radeon AGP Graphics Processors
o ATI Mobility Radeon 9800
o ATI Mobility Radeon 9700
o ATI Mobility Radeon 9600
o ATI Mobility Radeon 9200
o ATI Mobility Radeon 9000
o ATI Mobility Radeon 7500

Motherboard Chipsets with Graphics Processors

* ATI Radeon Xpress
o ATI Radeon Xpress 1250 Series for Intel
o ATI Radeon Xpress 1100 Series for AMD
o ATI Radeon Xpress 1100 for Intel Notebooks
o ATI Radeon Xpress 200M for Intel Processors
o ATI Radeon Xpress 200M for AMD Processors

Could this mean that this card is not a x1000 family card but an HD2000 family card and that HD drivers with a little bit of a tweaking could possibly work? I'm a complete driver-hackintosh-noob so i can't do anything with this info but i hope someone else could try this?

grtz

#96
pere

pere

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 726 posts
Hi, Sinnik.
Thats the first think we tried, but its id (718A) belongs to x1350 family, maybe framebuffer belongs to an HD2xxx family, but no injector recognizes it like that, so the only way to get 1280x800 (and just on sony models) is hardcoding into boot.plist.
Now what will be nice is to make external monitor works, so if you want to help, you are wellcome.

#97
Dainix

Dainix

    Level 12 Warmage

  • Members
  • PipPipPipPip
  • 204 posts
  • Gender:Male
  • Location:In a Toaster Oven
  • Interests:15% APR for three years. After that, it's 20%.
I used NatitX1300.kext to get my X1400 to work with an external monitor. If the HD2300 is based off of this chipset, give that a shot.

#98
iMorocco

iMorocco

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Location:Morocco
The Mobility HD2300 (7210) is in the exact same situation as X2300, it belongs to the X1000 family and uses Caretta. you get CI&QE 1024x768 with internal LCD but no resolution change.

#99
pere

pere

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 726 posts

I used NatitX1300.kext to get my X1400 to work with an external monitor. If the HD2300 is based off of this chipset, give that a shot.


Hi.
I have the internal LCD working with 3d and opengl, and 1280x800 resolution hardcoded into com.apple.boot.plist, if i use natit x1300 (or any other), then i got my lcd on a very nice black color and no output on external monitor, so i have tried to erase some options on natit so it will not affect the internal lcd and only give support to external, but no avail, does any of you know something can point me where to tweak?.
Thanks.

#100
Dainix

Dainix

    Level 12 Warmage

  • Members
  • PipPipPipPip
  • 204 posts
  • Gender:Male
  • Location:In a Toaster Oven
  • Interests:15% APR for three years. After that, it's 20%.
While the computer is starting up, make sure that you redirect your display to the external one and keep the internal LCD blank. There should be a key combination on your keyboard that does that for you.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy