Jump to content

ATI Mobility Radeon X2300 now WORKS CI/QE !


  • Please log in to reply
247 replies to this topic

#181
tatpoo

tatpoo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
This is my first post here, please be easy on me.

I have a Sony Vaio FW17 foreign version, installed with Kalyway 10.5.2

ATI Radeon HD 3400 Series graphic card. DEV ID 9504

I tried everything from this forum.

I have already installed the ATIRadeonx1000.kext, and removed all the old kext that came with Kalyway. input /<key/>Graphics Mode/</key/>
/<string/>1280x800x32/</string/>
in, com.apple.Boot.plist

according from "system profile" the graphic card has been installed as HD3400,

but I still can't get 1280x 800 nor QE/CI/OpenGL, not to mention about the DVI and HDMI output.

Can anyone help me with the 1280x800 resolution ?

THANKS!!

#182
fred9113

fred9113

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Beijing China

This is my first post here, please be easy on me.

I have a Sony Vaio FW17 foreign version, installed with Kalyway 10.5.2

ATI Radeon HD 3400 Series graphic card. DEV ID 9504

I tried everything from this forum.

I have already installed the ATIRadeonx1000.kext, and removed all the old kext that came with Kalyway. input /<key/>Graphics Mode/</key/>
/<string/>1280x800x32/</string/>
in, com.apple.Boot.plist

according from "system profile" the graphic card has been installed as HD3400,

but I still can't get 1280x 800 nor QE/CI/OpenGL, not to mention about the DVI and HDMI output.

Can anyone help me with the 1280x800 resolution ?

THANKS!!



The problem is : You have a different graphic card.

#183
tatpoo

tatpoo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

The problem is : You have a different graphic card.


thanks, I have double check with below site "

http://www.pcidataba...ails.php?id=240

my card ID is 95C4 which show that my graphic card named as

ATI Mobility™ Radeon HD 3450 with that ID number.

Is that any other suggestion you have?

#184
xwind

xwind

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Is there a way to change resolution on the fly?

I tried SwitchResX but it gives no effect, no custom resolution appears in menu.
But QE/CI enabled.

#185
Scripty

Scripty

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Romania
So I've tried several times to do this but it doesn't work. When I restart Mac OS everything is white: the background, the dock, the windows. Anybody had the same problem. I have an Asus F5VL laptop, I tried iPC version of osx86, 10.5.6 and 10.5.7. Can anyone help?

#186
dedmakarmd

dedmakarmd

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Somebody running this video card on Samsung R60plus? My problem - I can not install a graphic update (from Software Update), because it requests the kernel Vanilla. Try to start the OS with the function of vanilla -v cpus=1, it displays Posted Image
I have a Intel Core 2 Duo T5750 (2.0 GHz) and has support for SSE3, installed Mac OS X 10.5.7.
How to fix a mistake?



#187
SHANTI127

SHANTI127

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
People help me with my graphics card ATI Radeon HD 2300 or (01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M71 [Mobility Radeon X2100] [1002:7210] (rev ce)) can not find anything on the video card. HELP!

#188
Shamansky

Shamansky

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi.

I have a Samsung R60plus FE02 laptop, with Ati X2300 card, but my device id is 0x7188 instead of 0x718A.

I tried every method, with the same result: weird images, kernel panics, vertical bars, etc. I never got the right resolution, neither hardware acceleration.

Are there any hope? Or... Is this topic lost forever?

:)

I have this Samsung too, my iDeneb 10.5.6 found videocard with such devID 0x7188. Any solution for this card?


Any solution for this card?

The Mobility HD2300 (7210) is in the exact same situation as X2300, it belongs to the X1000 family and uses Caretta. you get CI&QE 1024x768 with internal LCD but no resolution change.



#189
blackmambo787

blackmambo787

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
hi guys,
It's passed quite a long time from my last post in this forum, i'm still trying to change resolution on my notebook asus with ati x2300.I have already tried all the possible attempts which people suggested me.
I wonder if now there is some way to fix this problem, maybe now if i upgrade the version to the new one (if there is)it works.
Right now i have 10.5.5 version and i can't change resolution to 1280x800, but it works only 1024x768!

Please help me

Thank you in advance.
Fede

P.s:i have found this http://forums.gentoo...33-start-0.html , but i don't understand completly the procedure, does anyone can help me?does it work for asus notebook too?

#190
mattcabb

mattcabb

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

P.s:i have found this http://forums.gentoo...33-start-0.html , but i don't understand completly the procedure, does anyone can help me?does it work for asus notebook too?


this is for linux. not os x.

#191
PHPhantom

PHPhantom

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey Guys, where can i get Pere's 10.5.5 + the ATIRadeonX1000 extension? I have ASSUS F3JR. I see that people say it is working fine with it, but i can't get a link to it...
Please help

#192
vsbalint

vsbalint

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
To change resolution use the RadeonHD.kext developed by Dong. You can find it here in the forum

#193
sadkiller

sadkiller

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
mine is 690t, x1270, tried the 10.5 kext. firstly can change to 1280x1024. but the cursor is the white square. tried to change Cursur to faulse. then never go to system again. 



will try the Radeon10.6 now to see the result. 

#194
dimak08

dimak08

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I Used solution in first post - nothing.

I install RadeonHD.kext by Dong - kernelpanic

I Used GTOnizuka's solution - nothing.


There are more ideas how to set resolution 1280x800?

My VideoCard is Ati Radeon Mobility X2300 (devid: 0x718a)

#195
wb_vova

wb_vova

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
hi all) I have some problem with my Asus F3jr. I have no driver for ATI Mobility Radeon X2300 (0x718a) mac os X. please give me a link wher I can download this f.... driver. thank you for understanding)

PS you can write to my r-mail vovafast@ukr.net

#196
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

hi all) I have some problem with my Asus F3jr. I have no driver for ATI Mobility Radeon X2300 (0x718a) mac os X. please give me a link wher I can download this f.... driver. thank you for understanding)

PS you can write to my r-mail vovafast@ukr.net


It for ATI Mobility Radeon X2300 you will receive CI/QE.
Attached File  ATIRadeonX1000.kext.zip   427.52KB   262 downloads
It for reception of the resolution
Attached File  RadeonHD.kext.10.5.zip   171.46KB   206 downloads

http://www.insanelymac.com/forum/index.php?s=&showtopic=190586&view=findpost&p=1339582



#197
Scripty

Scripty

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Romania
First off all, I have an ASUS F5VL laptop.
I used iPC 10.5.6 version cause that was the only one who could identify my HDD. Regarding ATI x2300, my model is 0x718a. I didn't install any video driver at first installation, but I installed RadeonHD.kext with ketxhelper ( I don't recall the exact name) and it worked. I just had to change the resolution from system preferences. The only problem was that the cursor doesn't display properly. I don't know if it's of any help, but I installed probably all the PCI Patches from iPC.
I am trying now to update to 10.5.8 through the software update and I'll keep you posted, maybe it helps someone.
PS: I enabled Quartx GL from OSX Tools before restarting

Update: I updated to 10.5.8 but the cursor didn't change and my sound is gone, but everything else seems good

#198
adamsweeting

adamsweeting

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 253 posts
I've got Dong's Framebuffer working on my Compaq 6910p - so I can use full resolution, which is nice.

The problem I have is with getting QE/CI working! It's driving me mad.
The machine has a Mobility X2300, but the Dev ID is 7188 (not 718a) - If I edit the Info.plist in the ATIRadeonX1000.kext and then also do the edit to the binary file I still do not get harware acceleration.

I just get bad artifacts when moving a window, and system profiler still doesn't see QE/CI enabled. Even though the kext is loaded.

Anyone know how to change DevID's on these cards? - Or a solution to get QE/CI?!

This is the last thing to get working... I have working Audio, network (wired), and now working Res change. So damn close!

#199
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

I've got Dong's Framebuffer working on my Compaq 6910p - so I can use full resolution, which is nice.

The problem I have is with getting QE/CI working! It's driving me mad.
The machine has a Mobility X2300, but the Dev ID is 7188 (not 718a) - If I edit the Info.plist in the ATIRadeonX1000.kext and then also do the edit to the binary file I still do not get harware acceleration.

I just get bad artifacts when moving a window, and system profiler still doesn't see QE/CI enabled. Even though the kext is loaded.

Anyone know how to change DevID's on these cards? - Or a solution to get QE/CI?!

This is the last thing to get working... I have working Audio, network (wired), and now working Res change. So damn close!


Try it.

Attached Files



#200
adamsweeting

adamsweeting

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 253 posts
Hey thanks vladlenas.... I'll give it a shot





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy