Jump to content

AppleHDA Patcher Results


  • This topic is locked This topic is locked
243 replies to this topic

#141
wbpluto

wbpluto

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
Computer Type: laptop(Lenovo TianYi F50A, Intel ICH7-M Chipset)
Sound Card Vendor: Realtek
Sound Card Model: AL262
Vendor Id: 0x10ec0262
Subsystem Id: 0x17aa8a2d

Working: Internal speakers
Not Working: Internal bass speaker, Mic, Headphones

Patcher Version used: 1.16, 1.20
System Version: Leopard 10.5.0 / 10.5.1

obs: Somebody told me AppleHDAPatcher don't support ICH7-M, It's really? When I use the patcher, it always told me "Unsupported Realtek Chipset"
and I have a question that if I must delete current AppleAzaliaAudio.kext before using AppleHDAPatcher??


Please help me, Thank you very much!!




Here is my dump file from Ubuntu 7.04:
Codec: Realtek ALC262
Address: 0
Vendor Id: 0x10ec0262
Subsystem Id: 0x17aa8a2d
Revision Id: 0x100002
Default PCM:
	rates [0x560]: 44100 48000 96000 192000
	bits [0xe]: 16 20 24
	formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
Node 0x02 [Audio Output] wcaps 0x11: Stereo
  PCM:
	rates [0x560]: 44100 48000 96000 192000
	bits [0xe]: 16 20 24
	formats [0x1]: PCM
Node 0x03 [Audio Output] wcaps 0x11: Stereo
  PCM:
	rates [0x560]: 44100 48000 96000 192000
	bits [0xe]: 16 20 24
	formats [0x1]: PCM
Node 0x04 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x05 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x06 [Audio Output] wcaps 0x211: Stereo Digital
  PCM:
	rates [0x560]: 44100 48000 96000 192000
	bits [0x1e]: 16 20 24 32
	formats [0x1]: PCM
Node 0x07 [Audio Input] wcaps 0x10011b: Stereo Amp-In
  Amp-In caps: ofs=0x08, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-In vals:  [0x00 0x00]
  PCM:
	rates [0x160]: 44100 48000 96000
	bits [0x6]: 16 20
	formats [0x1]: PCM
  Connection: 1
	 0x24
Node 0x08 [Audio Input] wcaps 0x10011b: Stereo Amp-In
  Amp-In caps: ofs=0x08, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-In vals:  [0x00 0x00]
  PCM:
	rates [0x160]: 44100 48000 96000
	bits [0x6]: 16 20
	formats [0x1]: PCM
  Connection: 1
	 0x23
Node 0x09 [Audio Input] wcaps 0x10011b: Stereo Amp-In
  Amp-In caps: ofs=0x08, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-In vals:  [0x00 0x00]
  PCM:
	rates [0x160]: 44100 48000 96000
	bits [0x6]: 16 20
	formats [0x1]: PCM
  Connection: 1
	 0x22
Node 0x0a [Audio Input] wcaps 0x100391: Stereo Digital
  PCM:
	rates [0x560]: 44100 48000 96000 192000
	bits [0x1e]: 16 20 24 32
	formats [0x1]: PCM
  Connection: 1
	 0x1f
Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-In vals:  [0x80 0x80] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x80 0x80]
  Connection: 6
	 0x18 0x19 0x1a 0x1b 0x1c 0x1d
Node 0x0c [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
  Amp-Out vals:  [0x19 0x19]
  Connection: 2
	 0x02 0x0b
Node 0x0d [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
  Amp-Out vals:  [0x00 0x00]
  Connection: 2
	 0x03 0x0b
Node 0x0e [Audio Mixer] wcaps 0x20010e: Mono Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00] [0x00]
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
  Amp-Out vals:  [0x00]
  Connection: 2
	 0x02 0x0b
Node 0x0f [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x10 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x11 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x12 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x13 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x14 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x083e: IN OUT HP Detect
  Pin Default 0x99130110: [Fixed] Speaker at Int ATAPI
	Conn = ATAPI, Color = Unknown
  Pin-ctls: 0x40: OUT
  Connection: 2
	 0x0c* 0x0d
Node 0x15 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x083e: IN OUT HP Detect
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
	Conn = 1/8, Color = Black
  Pin-ctls: 0x20: IN
  Connection: 2
	 0x0c 0x0d*
Node 0x16 [Pin Complex] wcaps 0x40010c: Mono Amp-Out
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80]
  Pincap 0x0810: OUT
  Pin Default 0x99130120: [Fixed] Speaker at Int ATAPI
	Conn = ATAPI, Color = Unknown
  Pin-ctls: 0x40: OUT
  Connection: 1
	 0x0e
Node 0x17 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x18 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x08173e: IN OUT HP Detect
  Pin Default 0x01a19840: [Jack] Mic at Ext Rear
	Conn = 1/8, Color = Pink
  Pin-ctls: 0x24: IN
  Connection: 2
	 0x0c* 0x0d
Node 0x19 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x08173e: IN OUT HP Detect
  Pin Default 0x99a3014f: [Fixed] Mic at Int ATAPI
	Conn = ATAPI, Color = Unknown
  Pin-ctls: 0x24: IN
  Connection: 2
	 0x0c* 0x0d
Node 0x1a [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x08173e: IN OUT HP Detect
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
	Conn = 1/8, Color = Black
  Pin-ctls: 0x20: IN
  Connection: 2
	 0x0c* 0x0d
Node 0x1b [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x08173e: IN OUT HP Detect
  Pin Default 0x0121441f: [Jack] HP Out at Ext Rear
	Conn = 1/8, Color = Green
  Pin-ctls: 0xc0: OUT HP
  Connection: 2
	 0x0c* 0x0d
Node 0x1c [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x0820: IN
  Pin Default 0x593301f0: [N/A] CD at Int ATAPI
	Conn = ATAPI, Color = Unknown
  Pin-ctls: 0x00:
Node 0x1d [Pin Complex] wcaps 0x400000: Mono
  Pincap 0x0820: IN
  Pin Default 0x40168a2d: [N/A] Speaker at Ext N/A
	Conn = Digital, Color = Purple
  Pin-ctls: 0x00:
Node 0x1e [Pin Complex] wcaps 0x400380: Mono Digital
  Pincap 0x0810: OUT
  Pin Default 0x01451130: [Jack] SPDIF Out at Ext Rear
	Conn = Optical, Color = Black
  Pin-ctls: 0x00:
  Connection: 1
	 0x06
Node 0x1f [Pin Complex] wcaps 0x400280: Mono Digital
  Pincap 0x0820: IN
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
	Conn = 1/8, Color = Black
  Pin-ctls: 0x00:
Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono
Node 0x21 [Volume Knob Widget] wcaps 0x600080: Mono
Node 0x22 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
  Amp-Out caps: N/A
  Amp-Out vals:  [0x00 0x00]
  Connection: 9
	 0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x0b
Node 0x23 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
  Amp-Out caps: N/A
  Amp-Out vals:  [0x00 0x00]
  Connection: 9
	 0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x0b
Node 0x24 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
  Amp-Out caps: N/A
  Amp-Out vals:  [0x00 0x00]
  Connection: 9
	 0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x0b
Codec: Generic 11c1 Si3054
Address: 1
Vendor Id: 0x11c11040
Subsystem Id: 0x11c10001
Revision Id: 0x100200


#142
McDead

McDead

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Computer Type: MoBo Gigabyte M68SM-S2 (Nforce 6)
Sound Card Vendor: Realtek
Sound Card Model: ALC888

Working: Internal speakers
Not Working: other outputs and input

Patcher Version used: 1.20
System Version: Leopard 10.5.1

Couldn't get it to work with other dumps so i share it with you.

Attached Files



#143
xandasbolas

xandasbolas

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Computer Type: Laptop Inspiron 630m
Sound Card Vendor: Sigmatel
Sound Card Model: STAC 92XX
Vendor Id: 0x83847690

Working: Headphones and internal speakers
Not Working: mute with headphones. mic not tested

Patcher Version used: 1.16
System Version: Tiger 4.8

Obs: Thanks to "spikegotti".I use her files.
http://forum.insanel...o...4890&st=80#


#144
barrylev

barrylev

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Computer Type: Laptop - Medion MEDION MD 96519
Sound Card Vendor: Realtek
Sound Card Model: ALC883
Vendor Id: 0x10718227

Working: Top Speakers, Mic, Spdif
Not Working: Line Out & Headphone

Patcher Version used: 1.2
System Version: Leo 10.5.1

Without line or headphone out, its no good to me.

I prefer the natit clone method, at least it helps me use the headphone jack.
ALC 883 - If running the new 8.8.1 kernel, multichannel out and audio in using a Natit clone method

ps. attached is the linux code dump from ubuntu live cd.

Attached Files

  • Attached File  cod1.txt   9.09KB   34 downloads


#145
xghost

xghost

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Germany
Laptop: Medion MD 95500
Soundcard Vendor: Realtek
Soundcard Model: ALC 880
Vendor ID: 10ec0880
Subsystem ID : 0x8800000

Working: Line Out (Analog 2ch)
Not Working: Internal Speakers, Line In (although shown in system preferences), Headphones, Digital Out

Patchers Used: all HDAPatchers (when using them nothing works), Beta4some_861_880_models.zip (resulting in whats written above)
Sound makes some crappy noises when volume is set at 100%

System Version: JAS Mac OSX 10.4.9 with 8.8.1 kernel


Codec dump made with Ubuntu Live CD:

Attached Files



#146
mac_cute

mac_cute

    InsanelyMac Cute

  • Retired
  • 3,587 posts
  • Gender:Female
  • Location:Bqto./Lechería,VEN
Computer type:PC
Sound card vendor:Realtek
Sound card model:ALC883
Vendor ID:0x10ec0883
Working:Internal speakers
Not working: -Headphones
-Internal mic
-Line-in
Patcher version used:1.17
System version:Leopard 10.5.1

Working:none detected with patcher 1.20

Codec form Linux

Attached Files



#147
creal

creal

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
ALC260 Outputs WORKING!!!!!!!!!!

Computer Type: laptop Sony vaio VGN-A417M
Sound Card Vendor: Realtek
Sound Card Model: ALC260
Vendor Id: 0x10ec0260

Working: Line Out, Headphones
Not Working: Mic, Llne in, SPDIF Out

Patcher Version used: 1.20
System Version: xXxTiger 4.11/Kalyway Leopard 10.5.1 EFI

thx Taruga

Attached Files



#148
patroche

patroche

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
working on p5kr with AppleHDA Patcher 1.20
generated my own codec dump
attached file on:
http://forum.insanel...showtopic=83793

(dident make tests concerning whats working or not, output is ok, gonna update the post later)

#149
limneos

limneos

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Greece
Computer Type: PC Asus P5LD2-X/1333 Intel 945 + ICH7 2GB RAM INTEL 4500 2.2 Core2Duo
Sound Card Vendor: Realtek
Sound Card Model: ALC662
Vendor Id: 0x10ec0662
Subsystem Id: 0x10438249

Working: Line Out, Mic In, Line In, Digital Out (all tested)
Not Working: Volume Control (appears a "blocked" icon when I press volume up and down keys , plus in audio preferences "The select device has no audio controls"). However, the Mute - Unmute control works fine.

Patcher Version used: 1.20
System Version: Leopard ToH 10.5.0 updated to 10.5.1 (EFI 8 +Vanilla)

obs: ALC662 Rev 1.txt from Ubuntu (I modified the subsystem ID ,it was different)

AppleHDA Patcher - 2006/2007 by Taruga v1.20                                                                       * Patching AppleHDA.kext to 0x10ec0662				Done* Checking AppleHDA for patch						Done0001f4a0	cmpl	$0x10ec0662,%eax00020584	cmpl	$0x10ec0662,%eax* Checking for SPDIF Out                           		Detected* Checking for SPDIF In  							Not Detected* Using the following nodes in pathmap	 Back Mic: 9 34 24	Line In  : 8 35 26	Speaker  : 20 12 2	Spdif Out: 30 6* Copying new config to destination					Done* Repairing Permissions								Done* Deleting Extensions Cache								Done

Note to Taruga:
- It seems ALC662 does not support the Volume Knob Widget. I found the datasheet from Realtek which
says something like this , so I guess another method is used for volume sliders support.
Here's the datasheet , in case you need to check this out.

http://www.realtek.c...alc662_v1.0.pdf

Hi to everyone. Amazing work to all, thumbs up to Taruga.
This is my first post on the forum.It's been with no doubt the most useful place to make this work.

Attached Files



#150
libaisi

libaisi

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Computer Type: MCP61

Codec: Realtek ALC861-VD
Address: 0
Vendor Id: 0x10ec0862
Subsystem Id: 0x10ec0862
Revision Id: 0x100001

System Version: AMD 10.5.1
Patcher Version used: 1.18 1.19 1.20 TarugaALC862Installer1 TarugaALC862Installer2

ALL NOT WORK ! ! ! :rolleyes:

Attached Files

  • Attached File  862.txt   6.88KB   22 downloads


#151
astronaft

astronaft

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
Computer Type: PC ( motherboard INTEL BLKDP35DPM)
Sound Card Vendor: SigmaTel
Sound Card Model: STAC9271D
Vendor Id: 0x83847627

Working: nothing
Not Working: nothing
Patcher Version used: 1.14, 1.16, 1.20
System Version: Leopard 10.5.1 (vanilla)

I had to use STAC9271D_0x83847627_testing.zip.
Internal Speaker, Digital out, Line In is visible in Sound Preferences,
but all not working




Help me, please!

#152
Kamil666

Kamil666

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
SigmaTel CXD9872AKD - Ventor 8384 Device 7664
Anyone can help making my internal Microphone work? Everything else works !

Attached Files



#153
Rackers

Rackers

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Computer Type: PC; MSI i975x
Sound Card Vendor: Realtek
Sound Card Model: 882
Vendor Id: 0x10ec0882

Working: - Line Out, Microphone, SPDIF out, Headphones, Keyboard Volume Control and Mute, Line In
Patcher Version used: 1.20
System Version: Leopard 10.5.1 (vanilla)

Used this 882 codec dump, http://psykopat.free...realtek/882.txt

#154
Roshan rAO

Roshan rAO

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Mangalore
Computer Type: PC (Intel 915 gav)
Sound Card Vendor: Realtek
Sound Card Model: ALC880
Vendor Id: 0x10ec0880

Working: Nothing
Not Working:

Patcher Version used: 1.1.5
System Version: Leopard 10.5

obs: i'm a n00b to leopard so could u please tell me wht shoud i do once u give me the file

thanks :(
Here is the Linux dump

Attached Files


Edited by Taruga, 03 February 2008 - 08:05 AM.
http://forum.insanelymac.com/index.php?act=attach&type=post&id=19374


#155
ra9na

ra9na

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Computer Type: Laptop Quanta KN1 aka Gericom Supersonic 1st PCI E
Sound Card Vendor: Realtek
Sound Card Model: ALC260
Vendor Id: 0x10ec0260

Working: Line Out, SPDIF Out
Not Working: Mic, Headphones

Patcher Version used: 1.2.0
System Version: Kalyway Leopard 10.5.1
obs: Made my own codec dump(by the way I had to dump codec #0 NOT #1. #1 is something totally different), but I had to null SPDIF In to make it work.

Attached Files



#156
vitamin

vitamin

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Computer Type: PC (Intel D915GUX)
Sound Card Vendor: Realtek
Sound Card Model: ALC880
Vendor Id: 0x10ec0880

Working: Nothing
Not Working: Everything

Patcher Version used: 1.20, beta4some861_880models.zip
System Version: Tiger 4.11

Linux dump from Knoppix 5.1.1 attached.

Attached Files



#157
Wayfarer247

Wayfarer247

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 282 posts
Computer Type: PC XPS Dell: (WG855)
Sound Card Vendor: SigmaTel
Sound Card Model: STAC9227
Vendor ID: 0x83847618

Working: Everything that I have tested! Headphones and speaker sound. Don't have a mic, but it says it should work.
Not working: Nothing important.

Patcher Version used: 1.20 - Didn't work
1.19 - Didn't work
1.15 - Worked!
System Version: 10.5.0 (Leopard)

Obs: Basically, if it initialyl doesn't work, then try another version of Targuga's patcher. Thank you so much, my hackintosh now has sound! Brilliant!!!

Attached Files



#158
towhite

towhite

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Taruga...
this is my linux codec dump for my soundcard AD1981 SoundMax
thanks alot for your effort...i hope get better result on next patcher..
Bravo..

-----------------------------------------------------------------------------

Codec: Analog Devices AD1981
Address: 0
Vendor Id: 0x11d41981
Subsystem Id: 0x103c30a2
Revision Id: 0x100200
Default PCM: rates 0x07f, bits 0x0e, types 0x1
Default Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Default Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Node 0x02 [Audio Output] wcaps 0x30311: Stereo Digital
PCM: rates 0x060, bits 0x02, types 0x5
Connection: 2
0x01* 0x04
Node 0x03 [Audio Output] wcaps 0x441: Stereo
Power: 0x0
Node 0x04 [Audio Input] wcaps 0x100511: Stereo
PCM: rates 0x07f, bits 0x06, types 0x1
Power: 0x0
Connection: 1
0x15
Node 0x05 [Pin Complex] wcaps 0x400187: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0x2f 0x2f]
Pincap 0x081173f: IN OUT HP EAPD Detect
Pin Default 0x92174110: [Fixed] Speaker at Int Front
Conn = Analog, Color = Green
Pin-ctls: 0x40: OUT
Connection: 2
0x03 0x0e*
Node 0x06 [Pin Complex] wcaps 0x400185: Stereo Amp-Out
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0x2f 0x2f]
Pincap 0x081f: OUT HP Detect
Pin Default 0x0421201f: [Jack] HP Out at Ext Right
Conn = 1/8, Color = Grey
Pin-ctls: 0xc0: OUT HP
Connection: 2
0x03 0x0e*
Node 0x07 [Pin Complex] wcaps 0x400104: Mono Amp-Out
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0x80]
Pincap 0x0810: OUT
Pin Default 0x410710f0: [N/A] Line Out at Ext Rear
Conn = Analog, Color = Black
Pin-ctls: 0x40: OUT
Connection: 1
0x0f
Node 0x08 [Pin Complex] wcaps 0x400083: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals:
Pincap 0x081727: IN Detect
Pin Default 0x04a12020: [Jack] Mic at Ext Right
Conn = 1/8, Color = Grey
Pin-ctls: 0x24: IN
Node 0x09 [Pin Complex] wcaps 0x400187: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0xbf 0xbf]
Pincap 0x081737: IN OUT Detect
Pin Default 0x0181302e: [Jack] Line In at Ext Rear
Conn = 1/8, Color = Blue
Pin-ctls: 0x20: IN
Connection: 2
0x03* 0x0e
Node 0x0a [Pin Complex] wcaps 0x400301: Stereo Digital
Pincap 0x0810: OUT
Pin Default 0x4145f0f0: [N/A] SPDIF Out at Ext Rear
Conn = Optical, Color = Other
Pin-ctls: 0x40: OUT
Connection: 1
0x02
Node 0x0b [Audio Selector] wcaps 0x300101: Stereo
Connection: 6
0x03 0x0c 0x09 0x0e* 0x05 0x18
Node 0x0c [Audio Mixer] wcaps 0x200101: Stereo
Connection: 2
0x1e 0x1f
Node 0x0d [Audio Selector] wcaps 0x30010c: Mono Amp-Out
Amp-Out caps: ofs=0x0f, nsteps=0x0f, stepsize=0x0b, mute=1
Amp-Out vals: [0x80]
Connection: 2
0x10* 0x16
Node 0x0e [Audio Mixer] wcaps 0x200101: Stereo
Connection: 8
0x0d 0x11 0x12 0x13 0x1a 0x1b 0x1c 0x1d
Node 0x0f [Audio Mixer] wcaps 0x200100: Mono
Connection: 1
0x0b
Node 0x10 [Beep Generator Widget] wcaps 0x700000: Mono
Node 0x11 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x15 0x15]
Connection: 1
0x03
Node 0x12 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x08
Node 0x13 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x09
Node 0x14 [Power Widget] wcaps 0x500500: Mono
Power: 0x0
Connection: 13
0x0d* 0x0e 0x0f 0x10 0x13 0x14 0x15 0x16 0x17 0x18 0x19 0x1a 0x1d
Node 0x15 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 8
0x0c* 0x09 0x0e 0x0f 0x19 0x05 0x18 0x17
Node 0x16 [Pin Complex] wcaps 0x400000: Mono
Pincap 0x0820: IN
Pin Default 0x995711f0: [Fixed] Digital Out at Int ATAPI
Conn = Analog, Color = Black
Pin-ctls: 0x20: IN
Node 0x17 [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x0827: IN Detect
Pin Default 0x5993e0f0: [N/A] Aux at Int ATAPI
Conn = ATAPI, Color = White
Pin-ctls: 0x20: IN
Node 0x18 [Pin Complex] wcaps 0x400187: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x081737: IN OUT Detect
Pin Default 0x59a790f0: [N/A] Mic at Int ATAPI
Conn = Analog, Color = Pink
Pin-ctls: 0x24: IN
Connection: 2
0x03* 0x0e
Node 0x19 [Pin Complex] wcaps 0x400001: Stereo
Pincap 0x0820: IN
Pin Default 0x593310f0: [N/A] CD at Int ATAPI
Conn = ATAPI, Color = Black
Pin-ctls: 0x20: IN
Node 0x1a [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x05
Node 0x1b [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x17
Node 0x1c [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x18
Node 0x1d [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x19
Node 0x1e [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x08
Node 0x1f [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Connection: 1
0x18

-----------------------------------------------------------------------------------------

#159
sparx

sparx

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Computer Type: Laptop Asus M5200AE (M5A)
Sound Card Vendor: Realtek
Sound Card Model: ALC880
Vendor Id: 0x10ec0880

Working: Nothing
Not Working: Mic, Headphones, Speakers

Patcher Version used: 1.20
System Version: Kalyway 10.5.1

After installing beta installer for some 880 volume icon appeared and some internal device was detected in sound settings, however there was no sound, not in speakers and not in headphones.
after using the patcher the volume icon disappeared completley and still no sound.

dump was taken in Knoppix liveCD 5.

i would appreciate any suggestions or advice.

p.s. external cheap chinese usb sound card works but it kind of takes all the mobility out of the laptop.

thanks and keep up the good work !

Attached File  0x10ec0880___Asus_M5200AE__Dump.txt   6.78KB   27 downloads

#160
funkypyro

funkypyro

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Computer Type: Dell Inspiron 6400
Sound Card Vendor: Sigmatel
Sound Card Model: 9200
Vendor Id: 0x83847690

Working: Built-In Speakers
Not Working: Mic, Headphones

Patcher Version used: 1.15 (1.20 doesn't bring up a log-in window or anything)
System Version: iATKOS v1.0i (10.5.1)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy