Jump to content

10.4.8 live/install DVD with semthex kernel


  • Please log in to reply
67 replies to this topic

#61
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,612 posts
  • Gender:Male
  • Location:BCN
Thanks for replaying...!
I think I messup the 'root user' part of the thing. Im trying all again now. I'll post my results.
Do you mean the pasword MUST be 'bootcd'? or could be anything else?

Thanx again.


EDIT: Just wondering, I had a problem in the past when I first tryed to install OSX on my laptop from the DVD drive; "'/com.apple.boot.plist' not found" (due some hardware configuration I guess). I made it work anyway installing from VMware to native partiton, but my question now is; wouldnt be possible to 'fix' this by tweaking the boot sector on the install dvd?.....

Edited by blackchungo, 20 February 2007 - 12:10 PM.


#62
modbin

modbin

    InsanelyMac Geek

  • Developers
  • 119 posts
  • Gender:Male

Thanks for replaying...!
I think I messup the 'root user' part of the thing. Im trying all again now. I'll post my results.
Do you mean the pasword MUST be 'bootcd'? or could be anything else?

The root password is bootcd. The netinfo database inside my files contains it.

#63
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,612 posts
  • Gender:Male
  • Location:BCN
Ok, didnt go much further.
I set the 'root user' to auto login. Password 'bootcd'. Reboot to check. Everything seems OK.

Now, if I use the RC script from the 'PART II' guide (post #35), The boot goes fine. Right after loading the screen drivers (Titan), 'preloading window server' message. The screen goes to blue and then I get the login window, but no way to login (password doesnt work).

If I use the last RC script from post #47, I get 'netinfo connection failed for 127.0.0.1/local' error
and then after loading the screen drivers the blue screen is not coming and I get;

[codebox]'unable to read configuration file /private/etc/cups/cupsd.config'
'......login window started'
'.....login window security agent'
'.....dock updater could not create dock fixup preferences'
'.....unable to open /var/root/library/widgets/'
'.....method_cgsevent in class NSevent is obsolete and will be removed....."[/codebox]

In both cases I tryed deleting and not deleting caches & preferences....

I'll keep on trying...

#64
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,612 posts
  • Gender:Male
  • Location:BCN
YESSSSSS! It worked!!
Used the complete zip from post #47, and followed to the letter the guides....

Thanks modbin for sharing this!!

I'll see if I can mod the boot track so I can use the dvd in my laptop without need of VMWARE ("'/com.apple.boot.plist' not found" boot problem)

Edited by blackchungo, 21 February 2007 - 09:17 PM.


#65
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,612 posts
  • Gender:Male
  • Location:BCN
the method definitely works.
I would like to include a reduced version of the OS X installer.
I put the system/installation folder with some packages inside the dvd but I dont know how to execute the installer....
would this be possible at all?

#66
NeSuKuN

NeSuKuN

    -Zealot

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
It would be nice to post the tutorial in the how-to section or in the wiki with all the updated files and instructions, and clearing the points where the rest had doubts.

#67
modbin

modbin

    InsanelyMac Geek

  • Developers
  • 119 posts
  • Gender:Male

the method definitely works.
I would like to include a reduced version of the OS X installer.
I put the system/installation folder with some packages inside the dvd but I dont know how to execute the installer....
would this be possible at all?

doubleclick osinstall.mpkg
but you need a special fixthesymlinksfortheramdisk.pkg


It would be nice to post the tutorial in the how-to section or in the wiki with all the updated files and instructions, and clearing the points where the rest had doubts.


http://forum.insanel...showtopic=43716

finally the beta test has started :)

Thanks Rammjet for all the fun we had within the last weeks testing this installer.

#68
mushupork5

mushupork5

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
you folks rock!!! way to go, thanks for the awesome beta





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy