Jump to content

[HELP] enable amd R7 260x in Sierra 10.12.6 / High Sierra ?

HELP R7 R7 260x 260x Sierra 10.12.6 gpu amd

  • Please log in to reply
14 replies to this topic

#1
ankursp

ankursp

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male

R7 260x GPU in Sierra 10.12.6 / in any version of High Sierra ?

I have this i7 7700K and asus rog z270e in my rig; So I can install Sierra/High Sierra on it using intel hd630 graphics,

but I want to make use of the only gpu i have right now which is Sapphire R7 260x. And I dont know how to get it started in 10.12.6 / newer macOS?

 

Already tried:

  • Adding 0x66581002 in AMD8000 and 4000 kexts
  • In Clover, you have to set:
    • - FakeID / ATI = full ID (here: 0x66581002)
    • - Inject / ATI = true
    • - FixDisplay = true
  • Configure your iGPU as primary graphics device in bios

All these does not make it work, So

Please let mw know if anybody can help!?

 

 



#2
ctich

ctich

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Kyiv, Ukraine

Try it https://github.com/v...6/Lilu/releases+ https://github.com/vit9696/WhateverGreen 



#3
ankursp

ankursp

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male

 

please also tell how to use it,  WhateverGreen has kern_model.cpp and Lilu is xcode project



#4
ctich

ctich

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Kyiv, Ukraine

please also tell how to use it,  WhateverGreen has kern_model.cpp and Lilu is xcode project

Add kext to efi/clover/kext/10.12 

https://github.com/v...rGreen/releases+ https://github.com/vit9696/Lilu/releases



#5
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,524 posts
  • Gender:Male

R7 260x GPU in Sierra 10.12.6 / in any version of High Sierra ?

I have this i7 7700K and asus rog z270e in my rig; So I can install Sierra/High Sierra on it using intel hd630 graphics,

but I want to make use of the only gpu i have right now which is Sapphire R7 260x. And I dont know how to get it started in 10.12.6 / newer macOS?

 

Already tried:

  • Adding 0x66581002 in AMD8000 and 4000 kexts
  • In Clover, you have to set:
    • - FakeID / ATI = full ID (here: 0x66581002)
    • - Inject / ATI = true
    • - FixDisplay = true
  • Configure your iGPU as primary graphics device in bios

All these does not make it work, So

Please let mw know if anybody can help!?

 

You need to use the 0x665c1002 as the FakeID


0x66581002 is your original device ID you can't use it as the FakeDeviceID it's pointless.



#6
ankursp

ankursp

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male

 

 

Tried for R7 260x on sierra--- NOT WORKING :(



#7
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,524 posts
  • Gender:Male

Do you have a SSDT for your R7 260X GPU?



#8
ankursp

ankursp

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male

Do you have a SSDT for your R7 260X GPU?

 

no, how can i generate that? and will that help?



#9
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,524 posts
  • Gender:Male

no, how can i generate that? and will that help?

your GPU isn't supported by macOS natively I don't think that's gonna help anyway.

You'll have no acceleration.



#10
ankursp

ankursp

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male

your GPU isn't supported by macOS natively I don't think that's gonna help anyway.

You'll have no acceleration.

 

Aww  :worried_anim: , i read people were able to get it working in 10.11,

 Are you certain that its not gonna work in 10.12 anyhow?

and if no, which natively supported GPU I should replace it with. my budget is around 100$



#11
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,524 posts
  • Gender:Male

Aww  :worried_anim: , i read people were able to get it working in 10.11,

 Are you certain that its not gonna work in 10.12 anyhow?

and if no, which natively supported GPU I should replace it with. my budget is around 100$

Well if you know someone that made it work maybe you can ask them to see how they did it.

In general you need to add your device id which is  0x66581002 in AMD8000Controller.kext and the AMDRadeonX4000.kext as you did or spoof your device ID with the 0x665c1002 and use this as the FakeID with FixDisplay=True

 

But if you are going to replace it with a new card these are the best options:

 

R9 270X and R9 280X they work OOB with no kext modification or any extra efforts

 

RX460 and RX 560 have native support but you have to use Lilu.kext 1.1.6 and Whatevergreen.kext 1.0.1 to avoid the black screen issue.

 

I personally have a MSI R9 270X which is working OOB.

 

Stay away from XFX though it will give you the same headache as far as I know.



#12
golephish

golephish

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Gender:Male
  • Location:Marietta,GA

I have the 69 280X and it works natively on 10.12.6 - but can not get it to play nicely with 10.13.



#13
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,524 posts
  • Gender:Male

I have the 69 280X and it works natively on 10.12.6 - but can not get it to play nicely with 10.13.

Why not? what's happening in 10.13?



#14
Loloflat6

Loloflat6

    InsanelyMac Geek

  • Donators
  • 106 posts
  • Gender:Male
  • Location:France
  • Interests:Computing Architecture
    Vintage Cars

I think 

 

I have the 69 280X and it works natively on 10.12.6 - but can not get it to play nicely with 10.13.

 

I think they are supported with WateverGreen :

 

 

static constexpr Model dev6798[] {   {Model::DetectSub, 0x1002, 0x3001, 0x0000, "AMD Radeon R9 280X"},   {Model::DetectSub, 0x1002, 0x4000, 0x0000, "AMD Radeon HD 8970"},   {Model::DetectSub, 0x1043, 0x3001, 0x0000, "AMD Radeon R9 280X"},   {Model::DetectSub, 0x1043, 0x3006, 0x0000, "AMD Radeon R9 280X"},   {Model::DetectSub, 0x1043, 0x3005, 0x0000, "AMD Radeon R9 280X"},   {Model::DetectSub, 0x1462, 0x2775, 0x0000, "AMD Radeon R9 280X"},   {Model::DetectSub, 0x1682, 0x3001, 0x0000, "AMD Radeon R9 280X"},   {Model::DetectSub, 0x1043, 0x9999, 0x0000, "ASUS ARES II"},   {Model::DetectSub, 0x1458, 0x3001, 0x0000, "AMD Radeon R9 280X"},



#15
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,524 posts
  • Gender:Male

I think 

 

 

I think they are supported with WateverGreen

R9 270X and R9 280X GPUs should works OOB without the need on any kexts, although sleep might not work without the Lilu.kext and WhateverGreen.kext, but having these kexts should definitely help.







Also tagged with one or more of these keywords: HELP, R7, R7 260x, 260x, Sierra, 10.12.6, gpu, amd


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy