Jump to content

AMD Switchable Graphics working manually (mirror only) using Clover

switchable graphics amd ati clover laptop

  • Please log in to reply
24 replies to this topic

#1
ghajini08

ghajini08

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

Hi guys, I got something useful for us which needs further investigation, especially for users of AMD Switchable Graphics

I kind of .... got it working ...manually though. Since I am no programmer I need one of you experts to check this out.

So I was playing around ANV's Fixedid app. I use Clover now and I have AMD 6490m/intel hd 3000 graphics in my system. Following are the steps that I used for this to work.

1) I copied the 6490 rom to clover in the EFI partition. That got my system to recognise my card as AMD 6470m 1024mb graphics. In my case the ROM is used just contained information about the Card. It did not have any info about the connectors except that the card used the Ipomoea fb.

2) I selected load vbios in clover. Also, selecting the Patch VBIOS option in clover is necessary too for this to work.

3) I set the Correct Framebuffer for my AMD card. I stumbled onto this because I changed my fb from Hydrilla to Ipomoea. Getting the correct fb is paramount to this working.

3) We need ANV's DisplayMergeNub.kext. Without it this just doesn't work. Delete any previous versions of the kext, wipe caches etc and follow the above steps.. Restart. Create the kext with ANV's  FixEDID app.

4) Install the kext and wipe caches etc and restart.


5) Upon restart Both my cards are detected as working. I am posting screenshots below.

6) In order to get my AMD working, I just go to system preferences and select "mirroring" and now I just change displays between the 2 internal LCD's and I get AMD to work! smile.gif

7) This sticks even after a restart! I just checked.

 

8) However, what must be noted is that the card is only functional in mirror mode. Novabench detects my card as AMD 6470m 1024MB graphics, but benching scores are the same.

 

Thats why i said this needs more investigation.

My BIOS on my hp dv6 does not allow me to disable either card. The option for Fixed/Dynamic exists only for show in BIOS. This discovery just happened by accident.

THE point is that an user no longer needs to go into the BIOS to enable/deisbale either graphics card, I just select it within Mavericks and whatever selection I make sticks.

This works only with CLOVER + mergedisplaynub.kext from ANV's Fixedid app smile.gif

@bcc9 any ideas?

Attached Files



#2
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

Ehy, first of all thanks for sharing your experience! It's something, this, that i searched for long time!

 

But i faced some problems:

I've done everything just like you said, but my mac boots with the intel graphics and not with the ati mobility 5650. I setted "switchable" in graphics mode from bios, as you said "no more disable internal graphics from bios", but even if i've done everything you wrote, i can boot only with intel integrated card...what's the problem? :S



#3
elkin

elkin

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi, you can attach your EFI folder and mergedisplaynub.kext ?



#4
ghajini08

ghajini08

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

Ehy, first of all thanks for sharing your experience! It's something, this, that i searched for long time!

 

But i faced some problems:

I've done everything just like you said, but my mac boots with the intel graphics and not with the ati mobility 5650. I setted "switchable" in graphics mode from bios, as you said "no more disable internal graphics from bios", but even if i've done everything you wrote, i can boot only with intel integrated card...what's the problem? :S

You have to open display preferences as you can see from my screenshots. Now you should see 2 displays .... if you can then do this.

Select "Mirror displays" option in the display preferences page.

Then select the drop down list. You should see 2 displays listed there.

Select the second one. Then go to About mac and in info section your primary display should be the AMD card. If not, go back to mirror setting in display and select the other card. Do this till you find your AMD card. It should work. Post screenshots of what you are doing. After doing this, both your cards should show up in IORegistry dump. Mine does. Good luck and let me know how it works out for you.



#5
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 667 posts
  • Gender:Male
  • Location:Italy

Interesting.

I have a G62 with Intel HD Graphics + HD 5470M. Currently I've disabled the integrated card.

I really want to know if this method works even for my system  :rolleyes:.



#6
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

You have to open display preferences as you can see from my screenshots. Now you should see 2 displays .... if you can then do this.

Select "Mirror displays" option in the display preferences page.

Then select the drop down list. You should see 2 displays listed there.

Select the second one. Then go to About mac and in info section your primary display should be the AMD card. If not, go back to mirror setting in display and select the other card. Do this till you find your AMD card. It should work. Post screenshots of what you are doing. After doing this, both your cards should show up in IORegistry dump. Mine does. Good luck and let me know how it works out for you.

 

well, if i boot osx with both cards activated, my system doesn't recognize two display, but just one...so i can't do any "mirror display" :( even if i click on "detect display", nothing happen :(

If i boot, instead, with the discrete card i have two monitors, but they are the internal laptop display and the external vga display, nothing about the intel since it's disabled by bios :/



#7
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,979 posts
  • Gender:Male

Good start. 



#8
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

You have to open display preferences as you can see from my screenshots. Now you should see 2 displays .... if you can then do this.

Select "Mirror displays" option in the display preferences page.

Then select the drop down list. You should see 2 displays listed there.

Select the second one. Then go to About mac and in info section your primary display should be the AMD card. If not, go back to mirror setting in display and select the other card. Do this till you find your AMD card. It should work. Post screenshots of what you are doing. After doing this, both your cards should show up in IORegistry dump. Mine does. Good luck and let me know how it works out for you.

news: i tried, after booted with both cards activated, to achieve my edid with darwin dumper, but it shows me empty files (at least so says FixEDID app and from finder it displays "Zero byte")...is this usefull?



#9
ghajini08

ghajini08

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

news: i tried, after booted with both cards activated, to achieve my edid with darwin dumper, but it shows me empty files (at least so says FixEDID app and from finder it displays "Zero byte")...is this usefull?

Try this. First delete the mergedisplaynub.kext ....rebuild caches and reboot. Now run Darwin Dumper. It will give you a clean dump. In my case after a clean boot (rebuild caches) it gave me 2 EDID files. But both had exactly the same data as in both cases the internal LVDS display was used. After that i used FixEDID to get the proper kext and then it started working. Try it out and if it doesn't work ...post some screenshots like the ones I have above.

 

Your EDID txt file should be 1kb and the hex file should be around 128 bytes. You need the hex file for fix edid. I will attach a screenshot of Fixedid options needed to be selected.


Good start. 

Yup, I hope this leads to something promising.


Hi, you can attach your EFI folder and mergedisplaynub.kext ?

Here you go.

http://www.sendspace.com/file/8fz4ci (EFI Folder)


Interesting.

I have a G62 with Intel HD Graphics + HD 5470M. Currently I've disabled the integrated card.

I really want to know if this method works even for my system  :rolleyes:.

Try it out. Following the above steps are the only way we can know for sure.

Attached Files



#10
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

Try this. First delete the mergedisplaynub.kext ....rebuild caches and reboot. Now run Darwin Dumper. It will give you a clean dump. In my case after a clean boot (rebuild caches) it gave me 2 EDID files. But both had exactly the same data as in both cases the internal LVDS display was used. After that i used FixEDID to get the proper kext and then it started working. Try it out and if it doesn't work ...post some screenshots like the ones I have above.

 

Your EDID txt file should be 1kb and the hex file should be around 128 bytes. You need the hex file for fix edid. I will attach a screenshot of Fixedid options needed to be selected.

 

ehi ghajini. i tried like you said (i even uninstalled switchresx, as it renamed the system monitor as "switchresx display"), but nothing to do, if i boot with intel graphics=no edid, if i boot with the discrete card (ati mobility 5650) i've got the 1kb txt and 128 bytes hex edid's files :S



#11
ghajini08

ghajini08

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

ehi ghajini. i tried like you said (i even uninstalled switchresx, as it renamed the system monitor as "switchresx display"), but nothing to do, if i boot with intel graphics=no edid, if i boot with the discrete card (ati mobility 5650) i've got the 1kb txt and 128 bytes hex edid's files :S

Thats Funny. Enable switchable graphics in your bios and try it out. Also attach your clover config.plist file here  Iwill have a look at it.



#12
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

Thats Funny. Enable switchable graphics in your bios and try it out. Also attach your clover config.plist file here  Iwill have a look at it.

I re tried again: if i enable switchable graphics, mavericks boots with intel graphics and darwin dumper can't earn the edid. If i boot with discrete card graphic, instead, darwin dumper can find the edid file... :S

 

here's my config.plist. Thanks for having a look :)

Attached Files



#13
ghajini08

ghajini08

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

I re tried again: if i enable switchable graphics, mavericks boots with intel graphics and darwin dumper can't earn the edid. If i boot with discrete card graphic, instead, darwin dumper can find the edid file... :S

 

here's my config.plist. Thanks for having a look :)

 

Try creating edid file with discrete graphics, then follow the other steps and let me know what happens. Post some screenshots after you try it. Did you put your rom file in  /EFI/Clover/Rom ?



#14
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

Try creating edid file with discrete graphics, then follow the other steps and let me know what happens. Post some screenshots after you try it. Did you put your rom file in  /EFI/Clover/Rom ?

thanks, i will try right now!

 

But what rom did i have to put in "Rom" folder? The ati rom or the intel rom? I didn't get it :S

 

edit

 

ok, i get it, now...the ati rom XD

Anyway, i need help with fixedid...the topic don't explain good how to use it. Here's my situation: i've got a laptop with switchable graphics, but i use it with an external vga display plugged in...if i boot with DISCRETE CARD option setted in bios, fixedid detect 2 displays...i don't think that those two displays are the intel and the ati cards, since i disabled it (intel graphics) from bios...Down there are the two screenshots of the two displays detected by fixedid...can you help me with this app?? :( What i have to select when it says "Apple iMac Display"? What in "Display class"? And "override display class"?? And what have i to select for both display?? :S

 

 

Attached Files



#15
ghajini08

ghajini08

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

thanks, i will try right now!

 

But what rom did i have to put in "Rom" folder? The ati rom or the intel rom? I didn't get it :S

 

edit

 

ok, i get it, now...the ati rom XD

Anyway, i need help with fixedid...the topic don't explain good how to use it. Here's my situation: i've got a laptop with switchable graphics, but i use it with an external vga display plugged in...if i boot with DISCRETE CARD option setted in bios, fixedid detect 2 displays...i don't think that those two displays are the intel and the ati cards, since i disabled it (intel graphics) from bios...Down there are the two screenshots of the two displays detected by fixedid...can you help me with this app?? :( What i have to select when it says "Apple iMac Display"? What in "Display class"? And "override display class"?? And what have i to select for both display?? :S

 

No wonder. Does your laptop work without connecting the external display? You first have to create the kext for the internal display since we want both graphics to be detected on your laptop first.

 

Try booting in without the External display.

 

Next, the first screenshot you posted is the one you want. HP laptops usually use displays with vendor id "daf" so select that first.

 

Then select "Macbook pro display" from the drop down list and finally for Display class select "Applebacklight display" then create the kext and follow the last steps above. This should detect both your graphics.

 

And yes you need to put ATI rom file in EFI/clover/rom folder. then select the ati stuff as per my screenshots above in clover configurator.

 

Edit: I just realised that I hae not attache screenshots for Clover configrator settings for this purpose. Will do it when I get home.



#16
Maverick

Maverick

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts
  • Gender:Male
  • Location:india
  • Interests:Caffeine,Hackintosh,
    AMD hackintosh,
    Technology,
I have ATI 6770m 2GB from where i get rom file or any otherway to get rom file ???

#17
ghajini08

ghajini08

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts

I have ATI 6770m 2GB from where i get rom file or any otherway to get rom file ???

 

I have ATI 6770m 2GB from where i get rom file or any otherway to get rom file ???

 

 

http://www.insanelym...radients-fixed/

 

Try this thread. The very second line has instructions on how to extraact your VBIOS .... jsut download the VBIO.zip and watch the video. If that doesn't work.... search that thread for the rom corresponding to your card. Thats what I did and it should work.



#18
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

Edit: I just realised that I hae not attache screenshots for Clover configrator settings for this purpose. Will do it when I get home.


Thanks for the answer! I will do that tomorrow. When you gotta add screenshots for clover for working ati cards?

#19
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

No wonder. Does your laptop work without connecting the external display? You first have to create the kext for the internal display since we want both graphics to be detected on your laptop first.

 

Try booting in without the External display.

 

Next, the first screenshot you posted is the one you want. HP laptops usually use displays with vendor id "daf" so select that first.

 

Then select "Macbook pro display" from the drop down list and finally for Display class select "Applebacklight display" then create the kext and follow the last steps above. This should detect both your graphics.

 

And yes you need to put ATI rom file in EFI/clover/rom folder. then select the ati stuff as per my screenshots above in clover configurator.

 

Edit: I just realised that I hae not attache screenshots for Clover configrator settings for this purpose. Will do it when I get home.

 Nothing to do :( i tried like you said, but my osx reveal just one display, so i can't do the mirror thing. I even tried to change frambuffer (my old one works very well, but i wanted to change anyway, just for try) My last hope now is waiting for your screenshots for ati cards



#20
elya

elya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

@ghajini08 are you still alive?? :o







Also tagged with one or more of these keywords: switchable, graphics, amd, ati, clover, laptop


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy