Jump to content

OS X Mavericks in VirtualBox


  • Please log in to reply
69 replies to this topic

#61
thany

thany

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

First of all, this guide is confusing, being unfamiliar with OSX. You could almost see the question marks hovering above my head. It needs WAY more information without going into needless details.

 

That aside, it doesn't work. I did follow the whole thing, but I'm stuck:

Attached File  OSX Mavericks.png   31.76KB   19 downloads

 

I've tried adding "-v -x" and "-v -x -f" and "-v -x -F", none of these help.

I've put FakeSMC.kext into /System/Library/Extensions.

mach_kernel is in the root.

 

Still, this error. If you look closely, you can see an error about FakeSMC. So perhaps it's broken? I got it from Install109.zip, so I should assume it works. Maybe the problem lies elsewhere, I have no fricking idea to be honest.

 

What should I do to get this thing to work?

(and please, be exact)



#62
smallkeung

smallkeung

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

First of all, this guide is confusing, being unfamiliar with OSX. You could almost see the question marks hovering above my head. It needs WAY more information without going into needless details.

 

That aside, it doesn't work. I did follow the whole thing, but I'm stuck:

attachicon.gifOSX Mavericks.png

 

I've tried adding "-v -x" and "-v -x -f" and "-v -x -F", none of these help.

I've put FakeSMC.kext into /System/Library/Extensions.

mach_kernel is in the root.

 

Still, this error. If you look closely, you can see an error about FakeSMC. So perhaps it's broken? I got it from Install109.zip, so I should assume it works. Maybe the problem lies elsewhere, I have no fricking idea to be honest.

 

What should I do to get this thing to work?

(and please, be exact)

 

 

I have the same issue as yours. However, I found that the image can run on other PC. 

I'm thinking that this is the HASWELL cpu issue.

 

(I tried this option "ahci disk=1 debug=8" It can boot a bit  deeper. but it still hang.



#63
thany

thany

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

I have the same issue as yours. However, I found that the image can run on other PC. 

I'm thinking that this is the HASWELL cpu issue.

 

(I tried this option "ahci disk=1 debug=8" It can boot a bit  deeper. but it still hang.

Mavericks doesn't support Haswell cpu's? I find that hard to believe (although it *is* Apple...)

There's no way to trick the VM into thinking it's running on a different cpu model, is there? 

 

Btw, I'm running Mountain Lion just fine on VB on this machine, but I have to admit the installation for that has been done on a Sandy Bridge based pc.



#64
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,071 posts
  • Gender:Male
  • Location:Manchester UK

Mavericks doesn't support Haswell cpu's? I find that hard to believe (although it *is* Apple...)

There's no way to trick the VM into thinking it's running on a different cpu model, is there? 

 

Btw, I'm running Mountain Lion just fine on VB on this machine, but I have to admit the installation for that has been done on a Sandy Bridge based pc.

 

I posted this in another thread http://www.insanelym...eel/?p=1975352:

VBoxManage modifyvm <vmname> --cpuidset 1 000206a7 02100800 1fbae3bf bfebfbff


#65
thany

thany

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

 

I posted this in another thread http://www.insanelym...eel/?p=1975352:



VBoxManage modifyvm <vmname> --cpuidset 1 000206a7 02100800 1fbae3bf bfebfbff

 

YES, That's the trick :)



#66
smallkeung

smallkeung

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

 

I posted this in another thread http://www.insanelym...eel/?p=1975352:

VBoxManage modifyvm <vmname> --cpuidset 1 000206a7 02100800 1fbae3bf bfebfbff

oh~~~ Thank you very much~~~

it works great~~~  :thumbsup_anim:  :thumbsup_anim:



#67
thany

thany

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Hm, it installed just fine, but now it's getting stuck when booting into OSX:

Attached File  OSX Mavericks.png   28.78KB   9 downloads

 

I'm still using the hackboot iso as described.

(edit: even though it says "reboot", it's not actually rebooting... maybe related)



#68
phireak

phireak

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Please help! Stuck at Installing 18% more than 2h



#69
phoenix73

phoenix73

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Male

I have installed ML and Maverick using others methods on VirtualBox

When I activate EFI, I didn't get  resolution defined in /Extra/org.chameleon.Boot.plist anymore and stick with 1024x768

If I disable EFI, good resolution is back.

 

I didn't see neither Chameleon boot loader.

Any ieas ?



#70
phoenix73

phoenix73

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Male

If hdiutil doesn't work and you get 'hdiutil: makehybrid failed - Operation not permitted'.

Just type 'sudo' :

sudo hdiutil makehybrid -iso -joliet -hfs -o OSXMavericks.iso OSXMavericks.dmg






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy