Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Problem when installing Mavericks on VirtualBox (hfs: summary table not allowed on FS with block size of 2048)

7 posts in this topic

Recommended Posts

My computer config: 

CPU: Intel Core i7 4770 Haswell

Motherboard: ASUS Z87-PLUS


SSD: 256GB


OS: Windows 7 Ultimate

VirtualBox version: 4.3.6 r91406



Error Message:

hfs: summary table not allowed on FS with block size of 2048

hfs: mounted OS X Base System on device root_device

hfs: could not initialize summary table for OS X Base System



1. Create virtual machine (2048MB RAM, new 20GB dynamiclly allocated VDI)

2. Untick Enable EFI

3. Choose HackBoot_Mav.iso for the DVD drive

4. Start the VM

5. Change OSXMavericks.iso for the DVD drive

6. Press F5 and press enter

7. Then the error message shown in the screenshot


I have tried some method and changing the setting but it have the same error message









What should I do? Thank you.

Share this post

Link to post
Share on other sites

don't know the fastest way to fix it, but the way i got to installing Mac OS X Mavericks in vmware fusion was booting the regular 10.8 "InstallESD.dmg" installer, and nothing else (except for the patch found else on this forum) and from that upgraded to 10.9. But, perhaps your install method works fine for virtualbox, i only tested that with linux based hosts as of yet. 

Share this post

Link to post
Share on other sites

This troubled me for long time, previously I installed Mac OS X 10.9 smoothly in my office PC's virtualbox, but always failed at home PC, also stopped here. both PC is ubuntu14.04 running a same version virtualbox, the virtual vm configure also same. at early I thought someting wrong with home harddisk format, but then found it's not related, becuase there's also such logging

"hfs: summary table not allowed on FS with block size of 2048"

  during a sucessfully installation.


then only difference is CPU: my office PC runs a ivybridge i3-3220, but home PC runs a haswell i5-4570, so maybe this is the reason, Mac OS X 10.9.1 not fully support the Haswell serial CPU, but the 10.9.2 does. probably installer can't known some Haswell feature, so stop at this place.


so can try to craft the vbox vm 's parameter, i.e. CPUID, to make installer think it's a 'known' CPU then continue (CPUID defines the whole capability set of a CPU, ref http://en.wikipedia.org/wiki/CPUID)

use virtualbox CLI vboxmanage to,


First check current real CPU ID info:

#vboxmanage list hostcpuids
00000001 000306c3 02100800 7ffafbff bfebfbff

leaf 00000001 reveal the key CPU features,so carefully changed it to a last neneration according CPU's CPUID value, e.g. my haswell i5-4570<-->ivybridge i5-3470 (you can go to find CPU ID here for all intel/AMD serials: www.cpu-world.com/CPUs/Core_i5/Intel-Core i5-3470.html#cpuid)


then start to modify:

#vboxmanage modifyvm <vmname> --cpuidset 1 000306A9 02100800 7FBAE3FF BFEBFBFF          <-(an i5-3470 CPUID)

or just changed to i3-3220's CPUID(a CPU surely can known by installer)
#vboxmanage modifyvm <vmname> --cpuidset 1 000306a9 00100800 3d9ae3bf bfebfbff

Then try restart kickoff installer, yes, I come to installer's welcome GUI page finally ...

Note that try to set a CPU's ID similar as your current CPU, but I guess this still not 100% works, it depends.

of course this method just a workaround, because probably make OS X  "think" it's an old CPU and run limited CPU capability.

Maybe you can try if install succeed, then upgrade to 10.9.2, then change the CPUID back to current real CPU. but I'm not sure if OS X so smart to adapt and work with it.


I've no time to continue try installation until weekend, so maybe you guys can try it, good luck~

(maybe the best way is to make a mavericks 10.9.2 installation *.iso image, which should work with all CPU perfectly.)

Share this post

Link to post
Share on other sites

@xufengpeak: thank you very much, I was stuck at this "hfs: mounted disk0s2 on device root_device" in virtualbox, and your solution worked perfectly in my case!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.