Jump to content

Updating from 10.7.2 to 10.7.4 or 10.7.5

update lion 10.7.5 wifi wi-fi drivers kext not working

  • Please log in to reply
3 replies to this topic

#1
progress44

progress44

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hi,

I have a working hackintosh with Lion installed on it, version 10.7.2
My computer's specs are
intel i3 2310 cpu
nvidia 315m
4GB ram
BT which doesn't work
card reader works OOB
Atheros AR5007 (i think, but it's not a problem cause I have the kext for it)

I start having problems when I update the system to version 10.7.4 or 10.7.5. When I update Mac OSX, the kext for wireless isn't loaded anymore.
So wireless connection stops working.

This is strange because I had 10.7.4 previously and wifi worked. Then I had to install lion from scratch and it is not working if I update it to 10.7.4.

I also am able to install 10.8 but in that case, the graphics card is not recognised along with the wifi. And in the case of 10.8 the IO80211 kext is loaded but doesn't work.

All kexts I use are 64bit.

Can anyone help me with this, because I have installed Lion more than 10 times and updated it to try and make it work.

Thanks

#2
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male
hi progress44

and what about to install 10.7.3 "Delta" at first and if all works good, install 10.7.4 and at the end 10.7.5?

I don't suggest to use the "Combo" updates, even on a real Mac it could cause problems (bad update's install)

#3
progress44

progress44

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Thanks for the reply

I tried installing 10.7.3 and then 10.7.4, but in both cases I used the combo packages. Everything worked on version 10.7.3. Things stop working after that. I'll try updating it with non combo packages as you suggest. maybe it works this way.

It is a lot of time consuming if it doesn't work because I would have to install everything from scratch, but I have no other option.

Thanks
Andy

#4
progress44

progress44

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I updated to 10.7.3 (combo) earlier and for a minute Wifi didn't work then I found a shell script which rebuilds caches. I ran that and wifi started working again. Then I updated to 10.7.4 (client) Wifi stopped again but running the script solved the problem.
Now I have 10.7.4 with wifi.
I'm going to try installing 10.7.5 and run the script afterwards even though 10.7.4 is enough for what I need.

I'm going to upload the script shortly.

Thanks fantomas1

EDIT:
attached the shell script that rebuilds the caches loading only 64bit kexts

Attached Files







Also tagged with one or more of these keywords: update, lion, 10.7.5, wifi, wi-fi, drivers, kext, not working


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy