Jump to content

[Guide] ML on Acer Aspire TimelineX 4830TG (3830TG or 5830TG)

* * * * * 2 votes Mountain lion acer aspire timelineX 4830TG 3830TG 5830TG

  • Please log in to reply
107 replies to this topic

#101
Yuvin

Yuvin

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Going to wait until IATKOS updates to get 10.9.



#102
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 822 posts
  • Gender:Male

I have some ideas for you. You should read this: http://www.insanelym...ort-tonymacx86/ and this: http://www.insanelym...out-tonymacx86/ and also ask after getting problems with your used tools on the developers platform or the developers themthelves for support.

 

Have fun.



#103
Yuvin

Yuvin

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

I have some ideas for you. You should read this: http://www.insanelym...ort-tonymacx86/ and this: http://www.insanelym...out-tonymacx86/ and also ask after getting problems with your used tools on the developers platform or the developers themthelves for support.

 

Have fun.

 

Yup. Sorry about that. I just thought that some others over here might have had a clue/way to inject the Intel HD 3000 kexts from ML into 10.9.



#104
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 822 posts
  • Gender:Male

@ Yuvin

 

No harm meant. The tools you have used, are working as far, as I know, with different default values for PCIRoot and npci, to get their suggest hardware to work and get loaded at early boottime.

I suggest that you should try to switch from chim... to the newest version of one of the bootloaders here in Downloads and also get the i386 files.

In my humble opinion you have also to manually install the neccessary efi files to get the deflaut values of Chameleon or Enoch bootlaoder. A Faq with syntax how to to this, you should find here in the Technical Faq section or with google.

 

Have fun.



#105
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Yes, I'm currently looking for the future kext pack.

I will release them once iATKOS version of mavericks is out.



#106
tytbro

tytbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Bluetooth was working but it's not right now. I tried reinstall kexts… I can turn on or off it can't find any devices and devices can't find notebook… Any solutions?



#107
Yuvin

Yuvin

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

So, anyone know of any other distros that will work for us? I sure as hell won't pay for an OSx86 distro.



#108
dsmturbo

dsmturbo

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Victoria BC Canada
  • Interests:Cars, computers, music

attachicon.gifScreen Shot 2013-02-16 at 5.09.29 PM.pngattachicon.gifGB.pngattachicon.gifLOW VOLT.pngattachicon.gifHigh VOLT.pngattachicon.gifTP.png
Spec:

  • Intel Core i5-2410M @ 2.30 GHz + TurboBoost Up to 2.90GHz
  • 8.00 GB DDR3 1333 MHz RAM
  • 750 GB HDD
  • Atheros 9287 Wifi/ Gigabyte Ethernet
  • HD 3000 GPU / nVidia Optimus GeForce GT540M 2GB
  • Elantech Multitouch TrackPad

Works:

  • CPU with turboboost (Speedstep)
  • Wifi
  • Ethernet
  • HD 3000 GPU (full)
  • 2 USB 2.0 Ports + USB 3.0 Port (See UPDATE 4 for USB 3.0 kext)
  • Audio (Speaker/Headphone) + volume control
  • Shutdown, Restart, Sleep (Lid and button)
  • Brightness control
  • Battery
  • Keyboard/Mouse
  • Multitouch Enable Trackpad
  • Dual Boot with Windows 8
  • WebCam
  • iMessage (FIXED)
  • Bluetooth (See update 5 for download link)

Does't Work:

  • nVidia Optimus GeForce GT540M

Preparation:

Installation:

  • Boot from iATKOS ML2 USB
  • Disk Utilities > Format your OSX Partition to Mac OS Extended (Journaled)
  • Customize, Select, Install and Restart:

Bootloader
Graphics
EnablerBuilt-in
Ethernet
1366*768*32
Original Apple Boot Logo
FakeSMC
Disabler
EvOreBootRTC
PatchMac Model> 8,1 MacBook Pro
SATA/IDE (leave the default select)
PS/2

Battery*****(select this to get native battery working, without voodoo)
nVidia>Disable nVidia
HD3000
Network
-----
Deselect:
Sound
Kernel Cache

Post-Installation:

  • Unzip 4830TG kext.zip
  • Patch all kext Inside Folder [PATCH 1] using Kext Utilities attachicon.gifP1.png
  • Patch all kext Inside Folder [PATCH 2] using Kext Utilities attachicon.gifP2.png
  • Drag all Files inside Extra (in PATCH 2) to ~/Extra and replace all attachicon.gifEXT.png
  • Delete NullCPUPowerManagement.kext inside Extension
  • Rebuild Cache/Repair Permission attachicon.gifScreen Shot 2013-02-16 at 5.21.30 PM.png
  • Install Pleaseslpeep.dmg
  • Reboot with -f
  • After Reboot, Open up Champlist (in your application folder) and select F-boot attachicon.gifFBoot.png
  • For iMessage Fix (Patch 3: http://tekwik.com/20...-fix-chameleon/)

EVERYTHING SHOULD BE WORKING AT THIS POINT

Side Notes:

  • Set Graphics to Integrated instead of Switchable if you want to increase battery life (5 - 7 hr Integrated/2-3 hr Switchable)

attachicon.gifBATT.pngattachicon.gifBATT 2.png

  • Screen Brightness Control: Fn + F12 (down) AND Fn + Pause (Up)

attachicon.gifBT C.pngattachicon.gifBRG CNT.png

  • Headphone sound may be unstable at times (Open up Settings > sound > Mic and just leave the window open)

attachicon.gifHEADPHONE FIX.pngTwitter: @rwu921

[UPDATE 1*] New ElanTech TouchPad kext is out V2.1.3: https://mega.co.nz/#...ACz66THGRdDLniAYou can add/remove different features in the plist!!(or visit official forum: http://forum.osxlati...driver-mac-osx/)

[UPDATE 2*] Turns out after a couple boots, -f (flag boot) is no longer necessary!!

[UPDATE 3*] Feel free to update to 10.8.3 and 10.8.4 via Apps Store. It might show unexpected error, but everything will be fine after restart. attachicon.gifScreen Shot 2013-03-16 at 4.07.38 PM.pngattachicon.gifScreen Shot 2013-06-06 at 1.47.35 PM.png

[UPDATE 4*] NO SLEEP FUNCTION IF YOU APPLY THIS KEXT (for now). USB 3.0 kext tested working!!! Here ya go fellows: https://mega.co.nz/#...ScGbwYryLNqYxVI
attachicon.gifScreen Shot 2013-03-29 at 1.55.51 AM.png

 

[UPDATE 5*] Bluetooth AR3011 tested working...finally! press Fn+F3 to cycle through wireless settings.

***Some of you might need to edit your VID and PID. I have it on VID0489/PIDE02C

Here ya go: https://mega.co.nz/#...WAS3EimLMvO16d0

attachicon.gifScreen Shot 2013-06-16 at 3.58.26 PM.pngattachicon.gifScreen Shot 2013-06-16 at 4.01.13 PM.png

 

[UPDATE 6*] HDMI Audio kext found!

Link: https://mega.co.nz/#...oGJxOsKGD0mGN6I

attachicon.gifScreen Shot 2013-06-17 at 12.04.43 PM.png

 

 

For risk takers (USE IT AT YOUR OWN RISKS):

------------------------------------------------------------------------------------------------------------

DSDT Tutorial (Step 1): http://www.youtube.c...h?v=WseMI07G6_A

 

For Acer 5830TG Mountain Lion Users (Kext Package):

*Fresh install required

Link: https://mega.co.nz/#...ujmEyDzZKtzhxtY

 

Bluetooth kext (not tested/not fully functional): SOLUTION FOUND, SEE UPDATE 5

*Test it on any version beyond 10.8.2

*More files coming soon

*Try to make it recognize by OSX first!

*It goes Wifi + No BT --> Wifi + BT --> No Wifi + BT --> No Wifi + No BT --> Wifi + No BT

Link: https://mega.co.nz/#...hAOSaP8573pLNHQ

 

 

HDMI audio (not tested):   SOLUTION FOUND, SEE UPDATE 6

*Test it on 10.8.0 or 10.8.2 first before moving onto higher version

link: https://mega.co.nz/#...zUf4GecWhI9Ua5Q

 

SSDT Collection:

*use only when the given files (above) doesnt work

*all files are not tested, read readme file first

*Includes:

i3 2310M/2330M/2350M/2370M
i5 2410M/2430M/2450M/2520M/2540M/
i7 2620M/2630QM/2640M/2670QM/2720QM/2760QM/2820QM/2860QM/2920QM/2960QM

Link: https://mega.co.nz/#...5p32VQQUhCLcMU0

 

TrackPad (for 3830TG user) [some report failure, update coming soon]

*Not tested

*Make sure you dont have VoodooPS2 when using this

Link: https://mega.co.nz/#...hOVwOA8LaSC4PHc

 

Wifi Card (5830TG 3830TG users)

*Atheros AR81(31/32/51/52/61/62/71/72)

Link: http://www.insanelym...ver-for-107108/

 

DSDT for 3830TG - WORK IN PROGRESS - By Yuvin

http://www.insanelym...30tg/?p=1934214

 

The Trackpad kexts for 3830TG work on my machine with synaptics trackpad.

 

I however can not seem to get the battery status working.

 

It works properly when I first install ML2 but as soon as I install kexts in patch #1 it just has an X through it.

I even tried to run the battery.pkg from install disk but it kernel panics me at that point on reboot.

 

I am not sure how else I can explain this better here.

In my s/l/e folder I have appleintelcpupowermanagement.kext plus appleintelcpupowermanagement196.0.0.kext from patch 1 folder. It doesn't seem to matter which one I delete.....  after clean install and patch kextxs from patch #1 I can not seem to get battery indicator.







Also tagged with one or more of these keywords: Mountain, lion, acer, aspire, timelineX, 4830TG, 3830TG, 5830TG


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy