Jump to content

[GUIDE] 1st Generation Intel HD Graphics QE/CI

Intel GMA HD Arrandale Intel GMA 5700HD

  • Please log in to reply
929 replies to this topic

#41
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 658 posts
  • Gender:Male
  • Location:Italy
In all the guides, the graphics enabler string isn't needed.

#42
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male

Thank you, I follow the instruction and core image enabled, intelhd kext loaded, but I can not see the transparent menu,when click lunch pad seems freeze,after10sec, then have display.


You have to choose between part 2 or 3. If want to try and get QE/CI skip to part 3 and follow the instructions.

In all the guides, the graphics enabler string isn't needed.


The problem is the variety of hardware. Adding it won't do any harm and it may cause problems for other computers if its not added.

#43
mengrh

mengrh

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
I upgrade to 10.8.3 CI not work, intelhd kext loaded but openGL view only software renderer.

#44
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male

I upgrade to 10.8.3 CI not work, intelhd kext loaded but openGL view only software renderer.


I hope Apple did not make huge changes in the way 10.8.3 handles Intel HD Graphics. I doubt they discovered this and changed it at the last minute.

#45
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
10.8.3 is working ok, have intel "ga" as well don't know if that makes a difference

#46
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male

10.8.3 is working ok, have intel "ga" as well don't know if that makes a difference


Your running the native Intel HD kexts from 10.8.3 right with AppleIntelHDGraphics, AppleIntelHDGraphicsFB, AppleIntelHDGraphicsGLDriver, AppleIntelHDGraphicsVA and AppleIntelHDGraphicsGA? and then you just patched the framebuffer with the singlelink patch?

People are saying it doesn't work, I'm not sure who's right... a screenshot from 10.8.3 would help to confirm.

#47
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Yup and now with a patched 10.8.3 framebuffer i just made Proof in screechshot attached

Set up is No DSDT

Clover latest boot loader "Clover_v2_r1174"

Fakesmc latest 5.1.41

Macbook pro 6,2 15" mid 2010

patched applecpuintelpower

you get the idea.

i tried to stay away from dsdt as i'm not in the mood of late to tinker with it and , with "plnf device" with frambuffer kext = instant reboots.


I removed all entries from natit only left os-info

I dont use any resolutions hacks either...everything graphics related left vanilla of-course with exception of intelFB

Attached Files



#48
baongoc124

baongoc124

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Thank you very much GhostRaider. I used your AppleIntelHDGraphics.kext and AppleIntelHDGraphicsFB.kext (alternate one) with other kexts from manor and now I got full QE/CI working in my Dell Inspiron 1464 now. :D

#49
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male

Yup and now with a patched 10.8.3 framebuffer i just made Proof in screechshot attached

Set up is No DSDT

Clover latest boot loader "Clover_v2_r1174"

Fakesmc latest 5.1.41

Macbook pro 6,2 15" mid 2010

patched applecpuintelpower

you get the idea.

i tried to stay away from dsdt as i'm not in the mood of late to tinker with it and , with "plnf device" with frambuffer kext = instant reboots.


I removed all entries from natit only left os-info

I dont use any resolutions hacks either...everything graphics related left vanilla of-course with exception of intelFB


Thank you for clarifying things 2bad0. B) I successfully upgraded to Mountain Lion 10.8.3 with full QE/CI support.

Thank you very much GhostRaider. I used your AppleIntelHDGraphics.kext and AppleIntelHDGraphicsFB.kext (alternate one) with other kexts from manor and now I got full QE/CI working in my Dell Inspiron 1464 now. :D


Glad that this guide has helped you out and others as well. :)

Alright friends, I have updated the guide to support 10.8.3. For some reason the Intel HD Graphics IGPU seems to run a bit more smoother now. Thank you for your continued support Apple! :smoke:

I just want to clarify something that my guide does not show. I did mention about Natit, and I'm sorry that I haven't talked about it. The Natit kext is not included in none of my downloads because I completely forgot about it.

The thing is, I don't use Natit because I added a DSM method under GFX0 in my DSDT. In there, I have added the os-info that the framebuffer produces.

I'm not sure if that is why some people say that QE/CI is broken on 10.8.3. But just to confirm all is good on 10.8.3, see screenshots:

Attached File  Screenshot1.png   878.33KB   177 downloadsAttached File  Screenshot2.png   684.9KB   166 downloads

#50
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 658 posts
  • Gender:Male
  • Location:Italy

Thank you for clarifying things 2bad0. B) I successfully upgraded to Mountain Lion 10.8.3 with full QE/CI support.



Glad that this guide has helped you out and others as well. :)

Alright friends, I have updated the guide to support 10.8.3. For some reason the Intel HD Graphics IGPU seems to run a bit more smoother now. Thank you for your continued support Apple! :smoke:

I just want to clarify something that my guide does not show. I did mention about Natit, and I'm sorry that I haven't talked about it. The Natit kext is not included in none of my downloads because I completely forgot about it.

The thing is, I don't use Natit because I added a DSM method under GFX0 in my DSDT. In there, I have added the os-info that the framebuffer produces.

I'm not sure if that is why some people say that QE/CI is broken on 10.8.3. But just to confirm all is good on 10.8.3, see screenshots:

Attached File  Screenshot1.png   878.33KB   177 downloadsAttached File  Screenshot2.png   684.9KB   166 downloads


You could include my patcher later in your topic (never mind, see this), the brightness guide from mnorthern and his next work: backlight on wake up.

However i think Natit is not needed because for example i use no DSM method in GFX0 or IGPU on my DSDT and QE/CI works the same (maybe is better remove it because it changed the name of my discrete card with 'Intel HD Graphics').

#51
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Dual link patch available via source

http://www.insanelym...8/#entry1894821

#52
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 658 posts
  • Gender:Male
  • Location:Italy

if anyone need dual link patch paste the current kext and i can look at it if vertek is no there by then.


See this please.. verteks released today a patcher

#53
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Me and brightness = not friends.. pnlf device give me a fancy reboot

for people still experiencing black screen or grey wheel of death should try natit,

because on my end natit is still needed.

#54
mnorthern

mnorthern

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:London, United Kingdom
Does anyone have a HDMI-out working with this card, and how did you achieve it? Thx

#55
mengrh

mengrh

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
My laptop use edp, I only can use CI only, After upgrade to 10.8.3, CI also impossible for edp. I will stay on 10.8.2... Thank you, I am also happy to have full resolution and CI.

#56
red555

red555

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Could anyone speculate why natit.kext is needed for some people?

I get never ending spinning wheel if I dont use it.

#57
red555

red555

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi GhostRaider. I followed your guide and have QE enabled (I think).

But I can't open the "shell" screensaver and redrawing the user interface in Mainstage 2.2. is laggy.

I ran "OpenGL Extensions Viewer 4.0" but the details are different to your screenshot.

Mine says OpenGL version "2.1 APPLE-8.0.61"

But yours says "2.1 INTEL-8.10.44"

If I click on compatibility and change it to core the program quits.

The laptop also "chirps" and whines while OpenGL is being used.

Any ideas? I'm on 10.8.2 and my system otherwise is great, I get no CPU spikes while the GFX lags.

#58
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 365 posts
  • Gender:Male

Hi GhostRaider. I followed your guide and have QE enabled (I think).

But I can't open the "shell" screensaver and redrawing the user interface in Mainstage 2.2. is laggy.

I ran "OpenGL Extensions Viewer 4.0" but the details are different to your screenshot.

Mine says OpenGL version "2.1 APPLE-8.0.61"

But yours says "2.1 INTEL-8.10.44"

If I click on compatibility and change it to core the program quits.

The laptop also "chirps" and whines while OpenGL is being used.

Any ideas? I'm on 10.8.2 and my system otherwise is great, I get no CPU spikes while the GFX lags.


I really think you should check your installation. Again check your kexts, DSDT, SSDT. Describe to me this chirp or whining sound because I'm concerned and I don't know what that sounds like. If I have to add more info here to my guide then I will.

As for OpenGLEV, I'm not sure why. Maybe upgrade to 10.8.3? and well I don't seem to get this "core" menu.

Attached File  CapturFiles_2.png   709.47KB   113 downloads

#59
red555

red555

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
I've update to 10.8.3 and my OpenGLEV specs match yours now.

The Shell screensaver works now too, but the noises are still there and redrawing the user interface in Mainstage 2.2. is still a bit laggy.

#60
beta992

beta992

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male
Hmm.. should this work with a Asus K52 (Optimus) - i5-520M?





Also tagged with one or more of these keywords: Intel GMA HD, Arrandale, Intel GMA 5700HD


6 user(s) are reading this topic

2 members, 4 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy