Jump to content

Generic USB2.0 (EHCI) Driver


  • Please log in to reply
473 replies to this topic

#461
Bob Ajob

Bob Ajob

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts
  • Gender:Male
  • Location:Leeds, UK
  • Interests:tinkering with hackintoshes .... obviously :)
Click here for a link to a USB related thread for solving USB problems where USB devices do not mount but do so if restarted.

Seems probably related to me stupidly using Slice's excellent kexts with the 10.5.5 based voodoo kernel and the vanilla 10.5.6 system.kext - oops!

#462
NaziX

NaziX

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Thank You

#463
MBFtrace

MBFtrace

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 1 posts
How can I put this into an install disk? I cant get past the "Ehci Controller *blahblahblah* Which causes the "Still waiting for root device". BTW I DO NOT HAVE A WORKING COPY OF MACOSX86 OR A MAC TO USE.

#464
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
hy
is there a way to adapt that ideas on last apple iousbfamily code?

that's because last MCP79 invidia have the same issue.. unable to get UIM.
the only method to bypass the problem is to set in bios to use usb low speed or to disable legacy
but is a weird solution

so.. original 10.5.6 iousbfamily works only with those 2 bad solutions.
I got the code of last iousbfamily but I'm scared to change code.. i'm not a programmer.

then, I don't understand why newer mobo are so difficult do use a real standard device!

I tried too to use pcgenusb or 3.0.8 kexts.. but are so old and os do a lot ok errors and don't acivate any usb

sob

#465
louelleg

louelleg

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi thanks, I just realized the file is no longer there! Will re-upload in the evening. I have also had success using the PCGen kext under 10.4.6 . Will post link later. Best.


Has the link been posted already? I like to try it. see if I can get it.


Louelleg
___
Simulation prêt

#466
Alainbo

Alainbo

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi,
sorry but installing IOUSBFamily344_2.kext didn't give me access to my USB disks.
Do i only have to install that file?
Your USBProber only see my mouse and kb.
I'm running Léo 10.5.7.

#467
joe31093

joe31093

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
If I leave legacy USB support on in the BIOS, when the system boots the USB ports do not work. If I disable legacy USB, then everything works. But the problem now is that I can't use my USB keyboard at boot time to select which OS to boot.

Anyone know a fix for this?

10.6.2 Hazard
Intel DQ45CB board

#468
Guest: prozac4312_*

Guest: prozac4312_*
  • Guests
no

#469
zantac105

zantac105

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I had big time usb problems on hazards 10.6.2. No plug and play (always had to reboot to get any functionality). Then I managed to fix that issue and lost my external harddrive. Then I fixed the hard drive thing and lost my bluetooth stuff (mouse and keyboard). Finally I have a working usb system on my machine. That means plug and play + bluetooth + external harddrive  By the way, I found these kexts after scouring the net for days. Turns out they were in a laptop forum. I have a desktop computer and they are working great.

I will attach what i have as kexts and hopefully they can help someone.

i installed these with kexthelperb7 then I ran kextutility then rebooted.




Attached File  WorkingUSBkexts.zip   781.7KB   642 downloads

#470
cu6apum

cu6apum

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Thanks buddy. A really excellent way to murder your hackintosh: it does not see kbd and mouse anymore. Holy {censored}, I spent some nervous minutes with my install disk recovering old kexts from backup... was afraid of reinstalling my well-tuned system...
Remove the file so nobody else get trapped...

#471
Stevie McFly

Stevie McFly

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 7 posts
I can't get that last zip to open. It downloads, then won't extract.

#472
mathq

mathq

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts
  • Gender:Male
  • Location:Quebec
The last zip worked more-than-fine on my LG R590 laptop.

Thank you very much

#473
Evgeniy

Evgeniy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
Hey someone gimme WorkingUSBkexts.zip !!!
file broken ...

#474
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,973 posts
  • Gender:Male
  • Location:Moscow
The thread is too old. Topicstarter is out. Look for other thread, link in topic.
And google for other solutions. In my case 10.6.4 works with vanilla IOUSBFamily after DSDT patch.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy