Jump to content

Lion kernel testing on AMD (don't ask help here: use the Help Topic)


  • Please log in to reply
612 replies to this topic

#521
+ira

+ira

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Brazil
Got a KP on trying to install Xcode from my Snow Leopard Retail DVD, it's a PATA drive so i don't know if we should blame the kernel or the kexts.

Edit:

Added high quality image. Rebooted into rc12 and tried to install Xcode again, no KP during installation.

Posted Image

Edited by juliomoreira, 12 May 2013 - 01:20 AM.


#522
bcobco

bcobco

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts
  • Gender:Male
  • Location:Argentina
congrats Bronya good work!
compu:~ cc$ sudo dmesg | head -22
npvhash=4095
PAE enabled
64 bit mode enabled
Multiplayer detection: family 0x15, model 0x2, stepping 3, extFamily 0x1, extModel 0x0
FSB Detection: calculated Mult 0, cpuFreq 0rtclock_init: Phenom MSR 0xc0010071 returned: 0x8000012400240e
 BUS: Frequency =    200.000000MHz, cvtt2n = 00000005x.00000000x, cvtn2t = 00000000x.33333333x
 TSC: Frequency =   3000.000000MHz, cvtt2n = 00000000x.55555555x, cvtn2t = 00000003x.00000003x, gran = 15
Darwin Kernel Version 11.4.2: \M-P\M-2\M-P\M->\M-Q\M^A\M-P\M-:\M-Q\M^@\M-P\M-5\M-Q\M^A\M-P\M-5\M-P\M-=\M-Q\M^L\M-P\M-5, 12 \M-P\M-<\M-P\M-0\M-Q\M^O 2013 \M-P\M-3. 00:23:20 (MSK); BronzovkaAnVoodoo_Sinetek###:xnu-1699.32.7/BUILD/obj//RELEASE_I386
vm_page_bootstrap: 1017750 free pages and 22634 wired pages
zone leak detection enabled
standard timeslicing quantum is 10000 us
mig_table_max_displ = 73
CPU identification: AMD Athlon(tm) 7850 Dual-Core Processor
CPU features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH MMX FXSR SSE SSE2 HTT SSE3 MON CX16 POPCNT
  HTT: 2 cores per package; 2 logical cpus per package
CPU extended features: SYSCALL XD 1GBPAGE EM64T LAHF RDTSCP TSCI
NullCPUPowerManagement::init: properties=0x7ff9e00
NullCPUPowerManagement::start
kxld[org.netkas.driver.FakeSMC]: The Mach-O file is malformed: Invalid magic number: 0xfeedfacf.
Can't load kext org.netkas.driver.FakeSMC - link failed.
Failed to load executable for kext org.netkas.driver.FakeSMC.
Kext org.netkas.driver.FakeSMC failed to load (0xdc008016).
boot and working pretty good
still testing...
i can make a flood of "32 bit opemu wrong instruction"

#523
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building
What bootflags are you using?

#524
bcobco

bcobco

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts
  • Gender:Male
  • Location:Argentina

What bootflags are you using?

$ cat /Extra/org.chameleon.Boot.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key> <string>mach_kernel-rc15</string>
<key>Kernel Flags</key> <string>arch=i386 npci=0x3000 -v</string>
<key>Timeout</key> <string>3</string>
<key>UseKernelCache</key> <string>No</string>
<key>EthernetBuiltIn</key> <string>Yes</string>
<key>GraphicsEnabler</key> <string>Yes</string>
<key>SMBIOS</key> <string>/Extra/SMBIOS.plist</string>
</dict>
</plist>


#525
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building
thank you... I had to delete IOPCIFamily2.kext, got a kp with it

#526
JahRon

JahRon

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Poland
  • Interests:Ras Tafari, Reggae, OSX86 and fanatic of Apple :D
Fi mi Xcode Works (doesn't crash ) :guitar: Good Job Bronya!!!
I'll check PhotoShop Cs5 Extend :)

#527
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 1,114 posts
  • Gender:Male

Got a KP on trying to install Xcode from my Snow Leopard Retail DVD, it's a PATA drive so i don't know if we should blame the kernel or the kexts.

Edit:

Added high quality image. Rebooted into rc12 and tried to install Xcode again, no KP during installation.

It is problem driver AppleOnboardPCATA.kext .
I same got panic of from driver jmicron, i replaced new my jmicron.kext and fine working ! :)

congrats Bronya good work!

still testing...
i can make a flood of "32 bit opemu wrong instruction"


Tnx ! :)
You got string "32 bit opemu wrong instruction" ? Or it still testing ? )

To all ! working system with flag arch=x86_64 ?

#528
bcobco

bcobco

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts
  • Gender:Male
  • Location:Argentina
im still testing...
  • Xcode fixed!
  • Maxima or brew install maxima makes "32 bit opemu wrong instruction" and "64 bit opemu wrong instruction" bug (reboot needed)
  • Massive 64-bit has heavy audio glitches (beware your ears!)
  • Nvidia 64-bit fails
  • arch=x86_64 without user interface, but screen resolution and mouse pointer are propertly drawn...
salute!



EDIT
my system always reacted sloppy (except real time threads) for some minutes in the first hour of system use
i never could see a message of what caused this, but with this latest kernel build i can (a very good new!)
after those little system freezes, some of this message appears
IOHIDSystem cursor update overdue. Resending.

Edited by bcobco, 12 May 2013 - 06:39 PM.


#529
+ira

+ira

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Brazil
Hi bcobco, did you have any tip on how to fix Xcode, i know the problem i have is pretty standard even on real macs with lion. It's something related with IDE/IPhone/Plugins, will check that exactly. Mine version is 4.6

#530
bcobco

bcobco

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts
  • Gender:Male
  • Location:Argentina

Hi bcobco, did you have any tip on how to fix Xcode, i know the problem i have is pretty standard even on real macs with lion. It's something related with IDE/IPhone/Plugins, will check that exactly. Mine version is 4.6.

Edit:

Here's the copy of the system report, if someone want to check it:

Spoiler

no sorry the only thing i did was just run Xcode and see what happens
before rc15 it crashed after start. now seems to work (credits to Bronya and all the devs)

#531
+ira

+ira

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Brazil

no sorry the only thing i did was just run Xcode and see what happens
before rc15 it crashed after start. now seems to work (credits to Bronya and all the devs)


My fault, my boot.plist was set to rc12 and i didn't noticed it. :bag:
Just set it to boot with rc15 and Xcode worked. I must have done it last night when i had a KP.

Thanks for your attention anyway and thanks Bronya for the kernel! :thumbsup_anim:

#532
JahRon

JahRon

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Poland
  • Interests:Ras Tafari, Reggae, OSX86 and fanatic of Apple :D

To all ! working system with flag arch=x86_64 ?


System boot normal but nVidia graphics doesn't work :wallbash:

#533
+ira

+ira

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Brazil

System boot normal but nVidia graphics doesn't work :wallbash:


I don't remember wich topic i read it, but i guess Bronya uses an ATI card.

#534
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 1,114 posts
  • Gender:Male
Yes , i uses ATI 5770 !
If NVIDIA don't working - i think that it is problem way out video to monitor , because problem buffer MB by total out video memory .
And problem properties preferences kext.

#535
+ira

+ira

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Brazil

Yes , i uses ATI 5770 !
If NVIDIA don't working - i think that it is problem way out video to monitor , because problem buffer MB by total out video memory .
And problem properties preferences kext.


Last night i had succesfully patched my DSDT with my Graphics Card properties now i can boot without GraphicsEnabler and i'll take a look if this could help in x86_64. But my guess is that it can't help that much since i haven't noted any difference between these methods only a very slight difference in performance but i can't state it is true cause i have never used any kind of benchmarker. I'll do some tests later today.

#536
burkett375

burkett375

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts
RC15 works great! speedier system now and fixed some errors with quicktime! Thanks!!

#537
Sannti

Sannti

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
RC15 should work with Phenom II x4 955 ?
I have all time when i would to boot it.

I tried with arch=x86_64 but i have a problem all time.
I have kernel panic when verbose mode show Power management may be incomplete or unsupported, after this i have a KP.

#538
burkett375

burkett375

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts

RC15 should work with Phenom II x4 955 ?
I have all time when i would to boot it.

I tried with arch=x86_64 but i have a problem all time.
I have kernel panic when verbose mode show Power management may be incomplete or unsupported, after this i have a KP.


Should be fine with that proc. I use -nossse3bit, -f, arch=x86_64 -force64 and it works great!

#539
Sannti

Sannti

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
oh, before I'm trying RC15 i Delete -nossse3bit from org.chameleon.boot.
Thanks
I think RC15 dont support -nossse3bit

What SMbios do you use ?

This is my problem: Posted Image

How to fix it ?
I want to use RC15 kernel.

#540
burkett375

burkett375

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts

oh, before I'm trying RC15 i Delete -nossse3bit from org.chameleon.boot.
Thanks
I think RC15 dont support -nossse3bit

What SMbios do you use ?

This is my problem:

How to fix it ?
I want to use RC15 kernel.


You definitely need nossse3bit. Try USBLegacy=off as another bootflag





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy