Jump to content

OS X 10.8.1 Released


  • Please log in to reply
45 replies to this topic

#41
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Update about the update: it broke my Reminders application. When i tried to open it, i got a incompatible OS version warning and, looking at console, i got this:


Dyld Error Message:
Symbol not found: _OBJC_CLASS_$_CLGeocoder
Referenced from: /Applications/Reminders.app/Contents/MacOS/Reminders
Expected in: /System/Library/Frameworks/CoreLocation.framework/Versions/A/CoreLocation
in /Applications/Reminders.app/Contents/MacOS/Reminders

Anyway, this one was an easy one to solve: i have a rescue install of ML 10.8.0 in a 16 GB thumb drive (not an installer, but an installation of OSX. Slow as hell, since the data flows at USB 2.0 speed, but quite useful. Anyway, the installer could also be used; remember: the installer of OSX contains the entire OSX!) so i plugged it in an USB port and, when it mounted, i just navigated to /System/Library/Frameworks/CoreLocation.framework/Versions/A and copied the CoreLocation Unix executable. Then, i just put it in the place of the one which was at /System/Library/Frameworks/CoreLocation.framework/Versions/A of my netbook, and voilà: everything back to normal.

Tip: keep a rescue installation, or at least your OSX installer, always ready!

#42
r15177

r15177

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

The installer started just fine, but when i was prompted to choose a disk to install, all of them were marked with these warning signs, a yellow triangle with a black exclamation. At the dialog box, the reason: java issues. Happened before, when an installer goes awful: i have no probs with java at all. So, i used pacifist and force it to install. I recommend you to do that.


the reason the installer gave me was not a java issue, it said "OS X Update can't be installed on this disk. This volume does not meet the requirements for this update"
going to try the pacifist way and force the install.
i'll report back to let you guys know how it went.

#43
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
I think these "reasons" are random ones, since it looks like a bug, an abnormal behavior. Good luck with the update!

#44
r15177

r15177

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
i forced the install, and so far everything seems to be working fine.
i restarted the computer and nothing messed up so i think it worked great.

side note: i wanted to see what would happen in the installer now that i'm on 10.8.1.
the installer seems to work fine now. it was going to let me install 10.8.1 with no errors this time.

#45
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Good, r15177. Glad to know the Pacifist worked for you!

As i understand, you tested all the features (like the core apps, reboot/restart etc.), right? You're using the 10.8 kernel or replaced it with the 10.8.1 one?

#46
r15177

r15177

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
yep, i went down the list and they all opened, i restarted a couple times just to make sure.
everything seems to be all good here.
btw thanks for posting the things you went through, i didn't know about pacifist

i'm running the new 10.8.1 kernel





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy