Jump to content

How to Install Retail OS X 10.6 "Snow" and OS X 10.7 "Lion" under VMware Workstation 8, Player and Fusion 4


  • Please log in to reply
133 replies to this topic

#101
neuroman

neuroman

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Not sure what the issue is, I have Lion Server running fine on ESXi 5 (just not had time to run it on W8), which is the same code as Workstation 8. There is no Server only install in Lion, you install the client and the use the App Store to add Server. The only thing, I am still on 10.7.1, only because of the issues with 10.7.2, and I have not had the time to apply the fixes to make 10.7.2 work in VMware W8 or E5. I will try going straight to 10.7.3 and see if that solves the .2 issues, I had developer notification today or yesterday for the .3 seed.

[UPDATE] With the release of Workstation 8.0.1, I will see if this resolves the .2 issues.


I finally could not get the server going with VMware Workstation under Windows Server 2008 R2 so I decided to go with vSphere 5 and I have to say it runs very well. The server upgrade kept hanging on configuring services and although I could get it to reboot, I could not get the Server app to work - I had to connect from a separate computer. I actually have both OS running concurrently and have setup the server to auto shutdown and so far this has worked perfectly. I am still on 10.7.1 since Esxi has not been upgraded since August as far as I know. The only bad thing about this is that I had a cheap software raid card in my server that is useless now. Additionally, my backup esata array drive will not work with esxi (I will have to connect it to a NAS).
Just writing this as a follow-up. BTW I had to install SL Server and upgrade from there to get it to work in my hardware: ASUS p7H55 m pro/Xeon x3450 16GB Kingston DDR3 1333MHZ/OCZ 200GB SSD with 7TB HD storage.

#102
Digitalfiend

Digitalfiend

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
New member here and first time OSX user. Thanks to the info in this forum and the excellent work by the folks who developed the patch, I was able to get Lion up and running on my PC with VMWare Workstation 8.0.1. I've been wanting to look into iOS development but wasn't sure that I wanted to buy a Mac Mini - mainly due to space issues; I've already got 3 workstations for work, 4 monitors, and not enough desk space!

I followed the bootable VMDK process, which was quite painless, and have sound working and VMWare Tools installed. My only concern at the moment is that I prefer to buy all my software and while Apple's EULA seems to disallow installation of Lion on a non-Apple computer, I'd still like to be semi-legit. Therefore, my question is how do I go about acquiring a proper Lion license? Will this require a reinstall? Lion appears to only be available through the App Store (or an overly expensive USB stick) so I'm not sure how I can go about paying for a license.

I have a sinking feeling that I might need to buy Snow Leopard, do a clean install, and buy Lion through the App Store and do the update that way. Is that the only way?

All of the info here is very much appreciated.

Thank you.

Edit:

Not sure if it's helpful but I'm running:

i7 2600k/16GB RAM/ASUS P8Z68 Deluxe/GTX 580/Intel 510 SSD+2 WD Black 1TB/Windows 7 64-bit Ultimate (MSDN)/VMWare Workstation 8.0.1

#103
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,923 posts
  • Gender:Male
  • Location:Manchester UK
If you are doing iOS development you will need to have a paid Apple Developer account. I would suggest that you buy the Mac OS X Developer package at the same time. That gives you Lion and Snow Leopard.

#104
Digitalfiend

Digitalfiend

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Ah so when you pay for the developer license you also buy licenses for Lion and Snow Leopard. It's been a long time since I've done C++ and OpenGL development...going to have to brush the cobwebs off the old books (and the old brain.) :)

Do you know if there is a way to change the serial number, post install, in Lion like how you can do with Windows?

Thanks again.

#105
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,923 posts
  • Gender:Male
  • Location:Manchester UK
No serial numbers for Lion!

#106
Digitalfiend

Digitalfiend

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

No serial numbers for Lion!


Good to know, thank you.

I must admit, I'm kind of digging OS X and it is running surprisingly well on my machine. So far, no crashes and the only minor issue I've noticed is the occasional sound stutter/delay when watching a QuickTime video. I also can't get one of my videos on my phone to play either. I can hear the audio but it doesn't render the video stream in iTunes.

I've been a die-hard PC programmer all the way back to Windows 3.1 and writing C programs against the Win16 API. I've never really given Macs much consideration but lately I've been reading more and more good things about Leopard (and now SL/Lion.) After getting an iPhone 4 for my wife and, more recently, a 4S for myself, I think I'm slowly being drawn in... :worried_anim: I've been tinkering with game development using C#/XNA for a while, but the lure of the App Store and mobile/touch-enabled devices seems really appealing.

Anyhow, sorry for going off on a tangent. I'll look into the developer program and go from there.

Thank you for the info.

#107
Digitalfiend

Digitalfiend

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Another question that you might be able to help with. I did a quick search but that didn't yield any meaningful results. I'm currently using whatever default driver was installed with the VMWare Tools from the darwin.iso but I've noticed that I can't play HD movies (say those captures from my iPhone) without dropping a significant number of frames, which I expected. Is there an enhanced driver or some way to take advantage of hardware acceleration? I read about VMsvga2 but it didn't sound like there was a major improvement (or perhaps there is and I just misread some earlier posts.)

I guess I'm expecting too much for video acceleration through my 580 GTX... :)

Thanks again.

#108
anga

anga

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hello:

I am new to installing Mac OS 10.7.2 (Lion) in VMWare Workstation.
Here's what I have done so far.
1. Extracted InstallESD.dmg from the installer using 7z
2. Converted to iso using PowerISO
3. All hashes match
4. Downloaded Donk's unlock-all-v102.zip

I came back to this thread and can't seem to find a set of instructions from MSoK, even after going thru the 6 pages.
Is there a list of instructions that I can follow to install Lion?

My setup: Dell T5500, dual Xeon X5660, W7 x64, Workstation 8.0.1

#109
anga

anga

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
3 weeks and no response!!

#110
yuanlinios

yuanlinios

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Dear all

I met similar issue as rl1024.

My environment is win7 x64 with vmware workstation 8.0.1(unlocker patched), and Mac OSX 10.7.2 version is used.

The boot process hang at "PCI configuration" if -v option is used, or hang at
"BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No such file or directory
Bug: launchctl.c:2406 (25182):30: (dbfd = open(g_job_overrides_db_path, O_RDONLY | O_EXLOCK | O_CREAT, S_IRUSR | S_IWUSR)) != -1"

Does anyone have ideas about this issue?

#111
Mwalimu

Mwalimu

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Hello:

I am new to installing Mac OS 10.7.2 (Lion) in VMWare Workstation.
Here's what I have done so far.
1. Extracted InstallESD.dmg from the installer using 7z
2. Converted to iso using PowerISO
3. All hashes match
4. Downloaded Donk's unlock-all-v102.zip

I came back to this thread and can't seem to find a set of instructions from MSoK, even after going thru the 6 pages.
Is there a list of instructions that I can follow to install Lion?

My setup: Dell T5500, dual Xeon X5660, W7 x64, Workstation 8.0.1


1. Install Workstation then reboot W7
2. Unzip unlock-all-v102.zip
3. Browse to ...\unlock-all-v102\windows directory
4. Right click on install.cmd ->Run as administrator
http://www.insanelym...howtopic=268531

5. Open Workstation: File->New VM->Typical->I will install the OS later->Guest OS choose Apple Mac OS X; Version choose Mac OS X 10.7 64-bit->Next->Next->Next->Customize Hardware

After choosing the Guest OS the next steps you can customize the size of disk you will allocate, location of VM.

On Customize Hardware: RAM should not be less than 2GB
New CD/DVD (IDE) click on Advanced->Virtual Device node choose SCSI-> drop down list choose SCSI 1:0->OK->Connection choose Use ISO image file, then browse to the Lion ISO->OK

I personally prefer to remove Floppy

6. Boot the VM, choose language, partition the disk, install
7. After finishing successfully, unmount the Lion ISO and mount darwin.iso from ...\unlock-all-v102\tools and install VMware Tools
8. Reboot
9. Download VMsvga2_v1.2.4_OS_10.6-7.pkg and guestd_patches.pkg from http://sourceforge.n.../files/Display/
10. Install VMsvga2_v1.2.4_OS_10.6-7.pkg and Reboot OS X
http://www.insanelym...amily.kext&st=0

11. Install guestd_patches.pkg and Reboot OS X
Same Link as 10

You are good to go.

12. To upgrade to 10.7.2 read and follow instructions from:
http://www.insanelym....0&fromsearch=1 (check post #39)

All this I learned in these great forums. Much thanks and credits go to Donk, MSoK and Zenith432

#112
no1youknowz

no1youknowz

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

MSOK did you manage to get any more info from your colleague on running an osx vm on amd?


Yeah, I'd like to know as well.

I've got Workstation 8 patched and im able to boot up Lion 10.7.2, however I can't get past the apple logo.

I've got a Phonem II x6 1045T, I'd love to get this running OS X.

Cheers for any info!

#113
sunbe@r

sunbe@r

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Has anyone found that Youtube videos don't work with MacOS 10.6.8 running on VMWare Workstation 8.0.1? If I try to play a video, Safari hangs with the spinning wheel for about 30 secs and then a black window appears where the video should be. Videos were working fine until I upgraded to 10.6.8 today (in order to install XCode 4.2). Does anyone have a solution to this? Alternatively does anyone have Youtube working successfully on any version of Lion on top of VMWare 8.0.1?

I'm seeing these errors in /var/log/system.log
Jan 16 22:09:33 Marks-Mac [0x0-0xe00e].com.apple.Safari[168]: Mon Jan 16 22:09:33 Marks-Mac.local WebKitPluginHost[172] <Error>: unknown error code: invalid context
Jan 16 22:09:33 Marks-Mac [0x0-0xe00e].com.apple.Safari[168]: Mon Jan 16 22:09:33 Marks-Mac.local WebKitPluginHost[172] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
Jan 16 22:09:33 Marks-Mac [0x0-0xe00e].com.apple.Safari[168]: Mon Jan 16 22:09:33 Marks-Mac.local WebKitPluginHost[172] <Error>: unknown error code: invalid context
Jan 16 22:09:33 Marks-Mac [0x0-0xe00e].com.apple.Safari[168]: 2012-01-16 22:09:33.266 PluginProcess[172:903] -[FP_FPCAOpenGLLayer setBuffer:]: unrecognized selector sent to instance 0x1823e0

It sounds like this is an issue with the graphics. This post seems to say that

VMsvga2 does not work for any version of MacOS > 10.6.7. Does that mean that I will need to revert back to 10.6.7 for video to work?



Thanks!



#114
timofcourse

timofcourse

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hi all-
After a bit of reading of some of the great work thats been done here, I was able to get Mac OS 10.6 working with VMware Workstation 8 pretty effortlessly! I did have a few questions/iisues though that I wasnt able to track down.
  • Any tricks to get sound working? I added the sound card device in the VMware settings, reinstalled the VMware tools after doing so and made sure sound.virtaulDev = "hdaudio" in my vmx as I saw in a couple posts. I also installed the Ensoniq driver from this post but still nothing.
  • Besides the VMware tools included with the darwin.iso, are there any other drivers that should be loaded? I noticed in some of the older threads they had separate downloads for sound and video, but wasn't sure if these were now just bundled with the VMware tools.
  • Should the "Acclerate 3D graphics" option be used? Things seem to be working okay without it enabled, but wasnt sure if there was any benefit to doing so.
  • I noticed a new option under the Processors device in VMware settings "Virtualize Intel VT-x/EPT or AMD-V/RVI". Should this be enabled?
  • Does "Fit Guest Now" work for anyone? If so, anything in particular you did to get it working?
Thanks so much! So psyched to have this working!

#115
class101

class101

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
This discussion is insanely good, especially the two posts below, I must have them first before all the bad informations you can find on sysprobs.com (it excellent to find probs though and loss some hours)

It worked without problems here with OSX 10.7.3 and Workstation 8.0.3, with OS X 10.7 32-bit virtual machine type, after installing vmware tools I had to uncheck "Autofit guest", install VMsvga2_v1.2.4_OS_10.6-7.pkg, and checked "Autofit guest" again

Big thanks to Donk, taker123 and Mwalimu, (To create iso I have choosed the 7zip dmg extraction + conversion with dmg2img discussed above)

I have managed to install Lion in vmware workstation 8.

1. unlock vware workstation 8 using Donk's Workstation 8 and Fusion 4 Mac OS X Unlocker

2. create an iso image of Mac OS X 10.7 Lion.

3. create a new default typical OS X 10.6 64-bit virtual machine.

4. Change the CD drive to SCSI 0:1 and use the Lion iso image.

5. boot to BIOS and go to EFI Boot Manager

6. boot from CDROM and install Lion

7. install vmware tools by mounting darwin.iso inside OS X 10.7 Lion


9. Download VMsvga2_v1.2.4_OS_10.6-7.pkg and guestd_patches.pkg from http://sourceforge.n.../files/Display/
10. Install VMsvga2_v1.2.4_OS_10.6-7.pkg and Reboot OS X
http://www.insanelym...amily.kext&st=0

11. Install guestd_patches.pkg and Reboot OS X

All this I learned in these great forums. Much thanks and credits go to Donk, MSoK and Zenith432



#116
renzo75

renzo75

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hey Guys,
Sorry if I'm doubling up but I've looked everywhere and can't get a good answer...
I have an Acer Aspire 5733z which I initially had Ubuntu installed, but now have installed XP Pro on it with VMware.
I've tried using guides to install a VM version of 10.7.3 and now getting 10.7.1 to try but all I get is a grey screen with a circle and a diagonal line through it...
I've installed Lion on my PC before but couldn't get wifi working, couldn't update etc so thought why not just have a standard XP machine with a VMWare version of Lion so I can resume my mac activities...
Any help would be much appreciated... pulling my hair out!

Thanks.

#117
Sp0oner

Sp0oner

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
Can anyone get the update 10.7.3 to install without killing your vm? If so how do you do it?

Edit - found a way to fix it.

#118
kup

kup

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 319 posts

Can anyone get the update 10.7.3 to install without killing your vm? If so how do you do it?

Edit - found a way to fix it.

Which was?

#119
Sp0oner

Sp0oner

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

Which was?


http://www.insanelym...ic=270140&st=20

specifically post #28 by you - put a reply at the end of that thread to your post :star_sunglasses:

#120
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,923 posts
  • Gender:Male
  • Location:Manchester UK
Use the VMware 2012 Tech Previews. I will have a new Unlocker in a day or so which works with it.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy