Jump to content

[GUIDE] A fast and easy way to install Lion


  • Please log in to reply
612 replies to this topic

#61
jfMac

jfMac

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Not Telling
  • Interests:Everything Apple and OSx86
Thank you Tseug for the "easy way."
I successfully installed Lion on my Shuttle SG31G2 hard drive using your method.
However, I can boot Lion via the USB stick, but cannot boot from the hard drive. Chameleon is rc1003 version. I did run the finalize script.

I've also done a manual install of Chamleon from within the Lion partition itself after ejecting the USB, but that made no difference. Snow Leopard is on the first partition of the drive and uses Chameleon RC3; upon boot, and without the USB Chameleon 3 comes up. I can boot Snow, but not Lion from Chameleon 3. Using the USB stick, I can boot Snow or Lion. I would have thought the boot0 would have overwritten whatever Cham. RC3 had put on dev/rdisk0.

I have 3 partitions on the drive disk0s1 is Snow, disk0s2 is a Snow backup and disk0s3 is Lion.
As I'm writing this it occurs to me... perhaps I should install boot1h on not only the Lion partition, but the Snow and backup partitions as well. Is that the solution? hmmmm... Oh, or remove the boot files from the root of the first 2 partions?

Thoughts, advice, suggestions would be much appreciated.

EDIT... :happymac:
Found a post "somewhere" by oldnapalm which made me realize I needed to install the new Chameleon RC5 on Snow partition. That is the solution; now I can boot Snow or Lion from the HD without the USB stick.
And, again Tseug thank you.

#62
Chriseybear

Chriseybear

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Oops. I accidentally gave you the same version again so you never got the newer FakeSMC.kext :happymac:

I've updated the file in the guide. That is:

v0.4 released 2011-06-15
* Updated FakeSMC.kext



:P haha no problem I'll download that and give it a go now!

Thanks :D

#63
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Thank you Tseug for the "easy way."
I successfully installed Lion on my Shuttle SG31G2 hard drive using your method.
However, I can boot Lion via the USB stick, but cannot boot from the hard drive. Chameleon is rc1003 version. I did run the finalize script.

I've also done a manual install of Chamleon from within the Lion partition itself after ejecting the USB, but that made no difference. Snow Leopard is on the first partition of the drive and uses Chameleon RC3; upon boot, and without the USB Chameleon 3 comes up. I can boot Snow, but not Lion from Chameleon 3. Using the USB stick, I can boot Snow or Lion. I would have thought the boot0 would have overwritten whatever Cham. RC3 had put on dev/rdisk0.

I have 3 partitions on the drive disk0s1 is Snow, disk0s2 is a Snow backup and disk0s3 is Lion.
As I'm writing this it occurs to me... perhaps I should install boot1h on not only the Lion partition, but the Snow and backup partitions as well. Is that the solution? hmmmm... Oh, or remove the boot files from the root of the first 2 partions?

Thoughts, advice, suggestions would be much appreciated.


I don't have my test partition on the same hard drive as the SL partition so I don't know what goes wrong. This is not a problem with this install method, though.

Maybe SL being the first partition somehow have special meaning to Chameleon? I would try to install it there and see what happens.


Thanks Tseug

This method will serve for the final version of Lion? :P


I don't know.

#64
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male
Yet another update:

v0.5 released 2011-06-15
* RTGMac_v2.0.6 causes issues with sleep. Changed to Lnx2Mac's OS X port.

#65
Chriseybear

Chriseybear

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Yet another update:

v0.5 released 2011-06-15
* RTGMac_v2.0.6 causes issues with sleep. Changed to Lnx2Mac's OS X port.



Still trying away, No luck. Actually Got into the install with an #####, but it was hit and miss so im trying to retrace my steps haha.

Thought i'd mention, your v0.5 release, 80% of the files are prefixed with 'install' now so the terminal /mkboot commands dont work! I just renamed them all and works obviously but incase somebody else is trying thought I'd say!

#66
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Still trying away, No luck. Actually Got into the install with an #####, but it was hit and miss so im trying to retrace my steps haha.

Thought i'd mention, your v0.5 release, 80% of the files are prefixed with 'install' now so the terminal /mkboot commands dont work! I just renamed them all and works obviously but incase somebody else is trying thought I'd say!


Oops (again) :) Should be fixed now.

#67
Chriseybear

Chriseybear

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Oops (again) :( Should be fixed now.


Brillaint, all in now didnt use a DSDT and Can boot with -x -y PCIRootUID=1
Now the hard part begins :)
Thanks a lot for your work! :P

#68
Wolf-Mac

Wolf-Mac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Location:Spain
Update new build 11A494A (656,6MB) for DP4 via Apple Software Update on my GA-P35-DS4.

No problems for my, working 100% no KP :)

Posted Image

#69
telepati

telepati

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
  • Gender:Male
  • Location:istanbul
Anyone try this with SandyBridge ?

#70
jenlot

jenlot

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
fantastic, got lion running on the first attempt. Best method yet!! :thumbsup_anim:

Gigabyte GA-H55M-UD2H - i5 2.8GHz

on first boot, every essential things seems to work except sound. Will work on it

#71
psxdadz

psxdadz

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:uk
will this guide work with a asus p8p67 17 sandybridge, because i cant even get the usb to boot

#72
TooSixy

TooSixy

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Anyone try this with SandyBridge ?

Yes, tried it on an P8P67 Deluxe. It works except Sleep, but it was a few days ago, before the scripts were updated yesterday.

#73
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Yes, tried it on an P8P67 Deluxe. It works except Sleep, but it was a few days ago, before the scripts were updated yesterday.


Sleep might work now. I've changed the Realtek NIC kext.

#74
Chriseybear

Chriseybear

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Hey Tseug,

Having a couple of problems and was just wondering if You could shoot some advice? :D

I can't boot without -x

If I try without -x and use -v, PCIRootUID=1 I don't seen any panics, or any errors (a slight usb hang actually).
I get to the end, Grey screen loads and looks promising for about 0.5 seconds before it hands/dots appear.

At the minute I can boot with -x PCIRootUID=1.
But being In safe mode, I'm not sure if it loads any graphics or not? as my 5770 (XFX) is only being recognised as a 5mb 1024x768 card. (could this be rectified with putting some downloaded kexts in /Extra/Extensions?) I have tried a couple but no avail, and read from others 5770 works Out of box.


Also even with -v, I'm not seeing anything obvious is there a way I can check a log from within the desktop?

Thanks again!

- ps Im using a DSDT from auto patcher too.

#75
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Hey Tseug,

Having a couple of problems and was just wondering if You could shoot some advice? :D

I can't boot without -x

If I try without -x and use -v, PCIRootUID=1 I don't seen any panics, or any errors (a slight usb hang actually).
I get to the end, Grey screen loads and looks promising for about 0.5 seconds before it hands/dots appear.

At the minute I can boot with -x PCIRootUID=1.
But being In safe mode, I'm not sure if it loads any graphics or not? as my 5770 (XFX) is only being recognised as a 5mb 1024x768 card. (could this be rectified with putting some downloaded kexts in /Extra/Extensions?) I have tried a couple but no avail, and read from others 5770 works Out of box.


Also even with -v, I'm not seeing anything obvious is there a way I can check a log from within the desktop?

Thanks again!

- ps Im using a DSDT from auto patcher too.


I'm actually thinking of buying that graphics card for Lion, so I'm very interested. Please make sure to report back. :o

What output port are you using? There might be an issue with HDMI.

If you move the card to the other PCI-E port, you should get rid of the PCIRoot option. I actually thought if was 1 by default but I might misremember.

What happens if you don't use a custom DSDT (just let the script generate it)? Note that a DSDT is only created when you run finalize. If you run finalize on /Volumes/Mac\ OS\ X\ Base\ System that ought to install it on the USB so you don't need to install OS X each time. I haven't actually tested this but I'm going to now. That is, boot into the USB with -x and run ./finalize /Volumes/Mac\ OS\ X\ Base\ System instead of installing. Then reboot to USB without -x.

With regards to logs: /var/log contains all the logs. system.log and kernel.log are usually the most interesting.

EDIT: The striked through didn't work. I'll take a look at it and make yet another version. It will probably take a couple of hours because I have to test it as well.

#76
psxdadz

psxdadz

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:uk

Yes, tried it on an P8P67 Deluxe. It works except Sleep, but it was a few days ago, before the scripts were updated yesterday.

i cant even get the usb to boot any ideas

#77
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

i cant even get the usb to boot any ideas


Please follow the section about error reporting in the first post.

#78
psxdadz

psxdadz

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:uk

Please follow the section about error reporting in the first post.

ok asus p8p67mb, i7 sandybridge saphire hd5770 8gb ram, snow leopard installed no probs using Andy guide
when i try and boot from the usb i get this error
boot0:GPT
boot0:test
boot0:test
boot0:GPT
boot0:test
boot0:test
boot0:error

i have put bios back to default setting still the same used your first install and 1.5 same results each time
thanks
i tried removing the hd with snow leopard on and left just one partition hd drive connected but same results

#79
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

ok asus p8p67mb, i7 sandybridge saphire hd5770 8gb ram, snow leopard installed no probs using Andy guide
when i try and boot from the usb i get this error
boot0:GPT
boot0:test
boot0:test
boot0:GPT
boot0:test
boot0:test
boot0:error

i have put bios back to default setting still the same used your first install and 1.5 same results each time
thanks
i tried removing the hd with snow leopard on and left just one partition hd drive connected but same results


Try erasing the USB drive and just install Chameleon. It's available in install/r1003/Install.pkg. Does that give the same result when you boot?

#80
Chriseybear

Chriseybear

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

There might be an issue with HDMI...
If you move the card to the other PCI-E port..



Using DVI for it, 1 monitor.
Also my board is mATX (went for easy/lazy fit in my G5 case!) so 1 PCI-E.

Without PCIRootUID=1 I just get a Matrix style screen, messed up black.

Have tried the other install method on this forum was the same issue so its Kext related?
No expert but strange the way im not seeing panics or anything? the actual crash seems to come when the grey Lion screen loads. Think its definitely graphics? What loads and doesnt load exactly with -x safe mode?

I'll try a few more things and check them logs too.
Thanks.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy