Jump to content

[GUIDE] A fast and easy way to install Lion


  • Please log in to reply
612 replies to this topic

#521
Bregt

Bregt

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Belgium
  • Interests:Mac, Music and Engineering

Brutus, when I download the 1.1 zip, I don't see the mkboot and finalize scripts that are referred to in the step by step instructions. Are you saying that you have these files in your version? If so, could you attach your copy of the zip, please?

I posted about this before (post w/ screenshot: #504) but no one seems to have noticed.

Thanks very much! :D


If you can't see the mkboot and finalize, you probably unpacked the file with the unarchiver or something else. You have to unpack it with the built in unarchiver of apple (for the most people just double click on the archive). Normally you would then have the mkboot and finalize script in the folder.

An update on the DP4 drivers. Flash works now but it is quite unstable as it seems :) . It sometimes jitters and the mac seems to hang sometimes. Also in aperture I see some problems when opening pictures in fullscreen. With the original Lion drivers these things didn't happen but flash doesn't work with these drivers and the 8800GTS.

Has someone else a solution to this problem ? It's getting really annoying when opening webpages with a lot of flash :D.

#522
lobstu

lobstu

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

If you can't see the mkboot and finalize, you probably unpacked the file with the unarchiver or something else. You have to unpack it with the built in unarchiver of apple (for the most people just double click on the archive). Normally you would then have the mkboot and finalize script in the folder.


Incorrect. I used the default Mac one: simply double clicked the file, and got what you see in the file structure screenshot in post #504. The zip file looks precisely like the sort of zip file that the github.com zip service produces, PAX header and all.

Are you saying that your zip doesn't match the structure in the image from post #504?

If so, I ask again, please attach a zip of the files as you extracted them :rolleyes: I'm so very keen to move on to Lion.

Thanks!

#523
Bregt

Bregt

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Belgium
  • Interests:Mac, Music and Engineering

Incorrect. I used the default Mac one: simply double clicked the file, and got what you see in the file structure screenshot in post #504. The zip file looks precisely like the sort of zip file that the github.com zip service produces, PAX header and all.

Are you saying that your zip doesn't match the structure in the image from post #504?

If so, I ask again, please attach a zip of the files as you extracted them :) I'm so very keen to move on to Lion.

Thanks!


Strange. I thought I uploaded the zip, must have forgot the attachment :rolleyes: . Should be ok now. I made a zip file of it in windows sinds I'm on my work so hope this helps. Let me know...

For the flash problem. It seems to help if I restart, but wake from sleep and the drivers act really weird sometimes. I hope there's gonna be a solution for this in the future but for now it will have to do :D.

Attached Files



#524
lobstu

lobstu

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Thank you very much! This zip has the files in it.

#525
erunamo

erunamo

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Thank you very much! This zip has the files in it.


can it be installed on a mbr partition? If so... how?

#526
phin586

phin586

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Hmmm. first boot. Failing at

nstat_lookup_entry failed: 2

looks to be after loading the drivers for the NIC

#527
phin586

phin586

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Ok it was an issue with my video card. Picked up a 560 and its smooth as butter.

Only question. I ran the 10.7.2 combo update. It seems to be running a little quirky now. Should I rerun the finalize script?

I also do not have sound.

#528
June8

June8

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Istanbul, TR
  • In Terminal:
    sudo install/mkboot /Volumes/USB\ Boot/
    This should take ~15 minutes.
---------------------------------------------------------------------------------------------------------------------------------------

I don't understand why the terminal gives "command not found" error. Pretty sure that i wrote correctly.

#529
LS8

LS8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 573 posts
  • Gender:Male
  • Location:Reality Distortion Field
Tseug, you're a genius! Your script worked perfectly on my old P35-DS4, Lion 10.7.2 installed without any issues. Thank you.

#530
Barcode

Barcode

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Melbourne, Australia
Hi. I'm very impressed by this guide. Many thanks, Tseug. I had a few problems initially because I deleted Chameleon when I formatted the partition for Lion, and my USB drive wouldn't boot. Anyway, I get a working installation of Lion 10.7, but when I do the Combo update to 10.7.2, I get a message on restart (after re-applying finalize), that it is waiting for the root device UUID ...... I've tried redoing finalize, same result. This has happened repeatedly, after redoing the process, including the initial installation of Lion. Any suggestions would be appreciated. I haven't tried redoing the Combo update without reapplying finalize.

#531
RedRonin

RedRonin

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
Thank you for this terrific guide and scripts. I'm amazed how much progress has been made on simplifying installs since 10.5. I now have 10.7.2 up and running with only one install hitch which I will describe later.

I have 2 questions.
1) What do I need to do to upgrade the video card in this setup (thinking of Radeon 5670 or 5770)? In 10.5, I used EFI strings.
2) Is there any reason to keep using my RTL8169 ethernet card now that the onboard 8111 seems fully supported?

I document my only install issue in the hope it may help a fellow GA-EP35C-DS3R owner:
After running the finalize step, boot would consistently kernel panic with an error message "No HPETs available ... CPUs configured incorrectly" coming from AppleIntelCPUPowerManagement.

All it took to resolve the issue was to
1) update to the latest F4 BIOS
2) re-enable the onboard LAN
3) boot using the USB boot disk and re-run finalize

Probably the BIOS update is what did it. Also in BIOS, I already had HPET enabled and set to 64bit.

#532
Stellair

Stellair

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 375 posts
  • Gender:Male
Tried to make a new usb stick but I got some weird stuff


Attaching OS X Lion...
expected   CRC32 $B763533B
/dev/disk2           Apple_partition_scheme          
/dev/disk2s1         Apple_partition_map             
/dev/disk2s2         Apple_Driver_ATAPI              
/dev/disk2s3         Apple_HFS                       /Users/svp/Desktop/install/lioninst
Restoring BaseSystem.dmg to /Volumes/USB Boot/...
Validating target...done
Validating source...done
Erasing target device /dev/disk1s2...done
Retrieving scan information...done
Validating sizes...done
Restoring  ....10....20....30....40....50....60....70....80....90....100
Verifying  ....10....20....30....40....50....60....70....80....90....100

Checksum failed.
Expected 56D67C9F
but got EAE71E86
Could not restore - Cannot allocate memory

I downloaded the latest install.tar.gz and used the latest osx 10.7.2 dmg but it gave me this error. Cannot find anything about it :worried_anim:

EDIT: Ok, false alarm, everything went smooth the second time. Got myself an updated 10.7.2 install key. THANKS TSEUG!!

Edited by Stellair, 19 December 2011 - 10:02 PM.


#533
aMuse

aMuse

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
Hi Tseug & everybody,

thanks for this excellent and easy guide. Things certainly have become a lot easier in the last 5 years. I installed Lion on an extra hdd and everything is up and running smoothly, including sleep, etc.

The only issue I have recently noticed is that I lost the ability to hotswap drive via the Gigabyte SATA2 chip. Any thought/comments?

Thanks,
aMuse

#534
xstation1

xstation1

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
Thankyou for this howto

Manged to load eveything on the usb stick did not use a DSDT.aml as I have a cartri bios

I did the ./finalize step
but on restart
I got black screen with a lot of numbers and words but the main error was
Unable to find driver for this platform
\'ACPI "; \n" @/sourcecache/nxu/nxu - 1699.22.73/iokit/kernel/IOPlatformExpert.cpp

Thanks for any feedback

xstation :worried_anim:

#535
xstation1

xstation1

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
I think I know why I got the above erroe it was useing a lion DVD that was from a friend that was a copy of a copy of a copy

This was because I could not download the lion DVD from the apple store

I NOW HAVE PURCHASED the uab stick with lion from apple

since i can no longer access my snowlepoard partition and cannot access lion
what should I do with this new usb with lion following this howto please???/

many thank

xstation

#536
Michigan PI

Michigan PI

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Detroit, MI
By far the easiest Hackintosh load I have ever done!!
From Zero to 10.7.2 Server in 40 minutes INCLUDING configuring the USB stick updating from 10.7 to 10.7.2 and loading Server.


Gigabyte GA-EP35C-DS3R Mobo
(2) 4GB DDR3 1333 RAM
GeForce 8400 GS 512MB Video
Corsair 128GB SSD
Butt-load of high capacity storage drives :)

#537
phin586

phin586

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Still having issues with sound. Any recommendations? Even on just a cheap PCI soundcard?

#538
nopee

nopee

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I wanna give a big thanks to Tseug for making a great how-to and a perfect script. Installation went flawless, keep up the good work.

#539
fristei

fristei

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Can anyone please help me? :))
I have a DELL N5110.
I'm not such a dummy, but i tried for 4 days all tutorials about instaling LION on my PC.
None of them worked.
Can you give me a hint, or a detailed tutorial?
Thanks a lot for your documentation :)

LE: My configuration is:

DELL INSPIRON N5110 (ACPI x64-based PC)
Motherboard: Unknown
BIOS: AMI A09 (updated)
CPU: Intel i7 - 2630QM
Memory: 8099MB
Video Adapter: Intel HD & NVIDIA GeForce 525M
IDE Controller: Intel 6series/C200 sata AHCI
USB1: Renesas Electronics USB 3.0 Host Controller
USB2: USB host
USB device: Dell Wireless 1702 Bluetooth
Network adapter: Realtek PCIe & Dell Wireless 1702

#540
Michigan PI

Michigan PI

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Detroit, MI

Can anyone please help me? :))
I have a DELL N5110.
I'm not such a dummy, but i tried for 4 days all tutorials about instaling LION on my PC.
None of them worked.
Can you give me a hint, or a detailed tutorial?
Thanks a lot for your documentation :)


"This method was created (and tested) for the Gigabyte GA-P35-DS4 motherboard" as the opening sentence states, and I might add is a flawless guide for that particular motherboard.
A simple Google search will yield a wealth of information on installing OSX10.7.x on your specific computer.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy