Jump to content

[GUIDE] A fast and easy way to install Lion


  • Please log in to reply
612 replies to this topic

#481
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Waiting for another brave soul to try updating to 10.7.2 :P

I'm assuming it should be OK on the GA-P35-DS4 board I have, but I thought I read somewhere that Chameleon needs to get updated as well.


I haven't looked at it yet. I probably will tomorrow. My guess would be that a chameleon update is indeed necessary. Also, I've read that there is an issue with iCloud/RAID that needs to be resolved. At the moment it seems that either RAID or iCloud will work but not both.

Stay tuned :)

#482
MOmann

MOmann

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
tried it.. "Wating for root device" after reboot. Had to restore a backup.
Anybody experienced the same problem?

#483
tokra128

tokra128

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 292 posts
  • Gender:Male
Hi guys... what I did .... first, install chimera (it will allow you to use facetime and icloud) - you will get rid of still waiting for root device, then apply the 10.7.2 update ... For sound you have to patch manually the applehda.. MAybe someone can mace a script for us for sound (for p35 - ds4 I mean)!

#484
thebiglebow

thebiglebow

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Belgium

Stay tuned :P


Of course we will ... we want to try iCloud with our iDevices in iOS 5 since yesterday

Cheers

#485
JeanLuc7

JeanLuc7

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Location:Berlin, Germany
Hi,

tried this with the new 10.7.2 Lion image from the Mac App Store that was released today (Oct 13th). Installation on the USB stick went fine. I ignored the messages down below, which appeared every time after the Message "Installing XXX..." (with XXX as "Java 6", "Chameleon" and so on).

My target system is a Gigabyte G41M-ES2L with a ICH7 Intel G41 chipset.

This is what happens: after booting into USB and chamaeleon the grey Mac OS installation screen seems to be shown for a part of a second, then the system reboots instantly without showing a kernel exception or equal. My system automatically boots from the USB, so I get into a permanent reboot loop. When I boot with kernel flag -v, I get all the kext load messages and then one last: "Starting Darwin x86" - then instant reboot.

(Needed to make a video from this and make a frame-by-frame inspection, because it all happens without any delay for reading... - attached a screenshot of the last millisecond.)


Is the new 10.7.2 image responsible for this? And if, will there be an update for the mkboot script available? Or is it about a false DSDT?

Thank you,
JL7

P.S. My target machine ran SL 10.6.8 until last week when it suddenly crashed during booting. This is why I decided to upgrade to Lion.

---

2011-10-13 13:28:50.738 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC Audio Unit plug-in.pkg
2011-10-13 13:28:50.741 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC Support Files.pkg
2011-10-13 13:28:50.742 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC VST plug-in.pkg
2011-10-13 13:28:50.747 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO Audio Unit plug-in.pkg
2011-10-13 13:28:50.748 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO Support Files.pkg
2011-10-13 13:28:50.750 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO VST plug-in.pkg
2011-10-13 13:28:50.751 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO Audio Unit plug-in.pkg
2011-10-13 13:28:50.752 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO Support Files.pkg
2011-10-13 13:28:50.753 Installer[47844:3007] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO VST plug-in.pkg

Attached Files



#486
clarktim

clarktim

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Loaded Lion using the USB method here. Install went pretty smooth actually.
I let the installer make a DSDT.aml for me instead of using my old one. I wanted to see if it worked any better.
Well, it works fine. Very cool indeed.
First boot stopped at 'waiting for root device'.
Upgraded to Chameleon v2.1svn r1547 (found in a post somewhere on this board, can't remember where)
Reboot works fine now. (I removed the verbose boot from the Boot.plist and added a wait time so it would auto boot)
Video is working fine.
on-board sound does not work. Always problems with that. So I use a USB sound device. Works through every upgrade.

Used software update to install 10.7.2 - no issues

Lion "seems" to be much more responsive for me. Windows open quicker. (could be just my imagination)

All-in-all an excellent load. Many thanks to tseug! It worked awesome!

#487
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male
v1.1 released 2011-10-13

* Added darkwake=0 to kernel flags to enable wake from sleep on power button. See http://www.insanelym...p...t&p=1753270
* Bumped Chameleon to r1627 for icloud and facetime fix. See http://www.kexts.com...on_2.1_r1627vs_[icloud_amp;_facetime_fix].html

Guide updated.

#488
MajorApollo

MajorApollo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
You're the man tseug! Worked like a charm. Thanks so much!

#489
thebiglebow

thebiglebow

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Belgium
Tseug ... you are a Guru ;-)

Cheers,
The dude

#490
thejekocomputer

thejekocomputer

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Milan - Italy
Dear Tseug,
thank you for your support, I use this guide to start lion on my GA-P35-DS3P Rev1.1 Motherboard, q6600 and Asus HD5670 and everything went perfect.

Now I need some tips:

1 How can I use all 8 internal sata port, I mean I've try to connect HD an the purple sata port but without success
2 I need use a pci card wit 3 sata port, with the cipset VIA, can you suggest me the right kext to use
3 when you tell us "Note that the current version uses a Chameleon with the so called Facetime and iCloud fix which is reported to cause trouble for RAID installs" you mean hardware raid or also the software raid?

Thank you in advance

Sergio Nada

#491
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Dear Tseug,
thank you for your support, I use this guide to start lion on my GA-P35-DS3P Rev1.1 Motherboard, q6600 and Asus HD5670 and everything went perfect.

Now I need some tips:

1 How can I use all 8 internal sata port, I mean I've try to connect HD an the purple sata port but without success
2 I need use a pci card wit 3 sata port, with the cipset VIA, can you suggest me the right kext to use
3 when you tell us "Note that the current version uses a Chameleon with the so called Facetime and iCloud fix which is reported to cause trouble for RAID installs" you mean hardware raid or also the software raid?

Thank you in advance

Sergio Nada


I can't answer questions concerning hardware I don't own since I have no way of testing it. I would guess that the RAID question is only relevant with software RAID but I have no way of knowing.

#492
browndogfred

browndogfred

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
  • Gender:Male
  • Location:SC
Thanks for sharing this guide. This install went flawlessly on an old Dell XPS410 that had been running Snow Leopard 10.6.8.

I placed my original DSDT.aml file in the /Extra directory and actual copied my kexts over to the /Extra/Extensions directory as well. I think there a total of 8 that I copied over that are related to this system [P965 chipset].

No issues at all. Once I was able to boot cleanly off the USB with no issues in the logs, I got rid of the SL partition and did a full install using the entire HDD with no issues booting up. The only thing I ran into was flakey internet and no sound but I just took the 'Intel82566.kext' and the updated 'AppleHDA.kext' and put them into /S/L/E and I was set. I also used the kernelcache bootflag in the com.apple.Boot.plist so that the system would read off /S/L/E, once I did that internet and sound worked fine.

Anyhow, the guide is simple and works.

Thanks again.

#493
gnomme

gnomme

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Any luck with iCloud on GA P35 DS4?

I can't login in iCloud...

#494
nathandw

nathandw

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Location:Munich / Germany
Yep,
no problems with iCloud after initial problems. iCloud wouldn't accept like another account from this computer or so.
Download Chameleon Wizard and get yourself a new SN in your smbios.plist. The generator will do this for you. After that everything's working jsut fine.

#495
Narayana

Narayana

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Huntington Beach, California
Hello-

I am looking to install OS X on my HTPC when its target SSD arrives tomorrow. mp4 embedded sub support is poor in Windows and I would like to give plex a spin. The system configuration is as follows:

GA-EP45T-USB3P
Intel Core2Quad (Q8300) @ 2.5GHz
Radeon 5770 (MSI Hawk R5770)

I had a few questions regarding this installation method and would greatly appreciate some help:

1. DSDT.aml

The changelog.txt states, "Implemented autogeneration of DSDT.aml. Should work for most motherboards similar to Gigabyte GA-P35-DS4." What is qualified as similar? The differences between the two boards (P35.. vs. EP45...) that I see are the northbridge (P35 vs. P45), southbridge (ICH9R vs. ICH10R), and the audio chipsets (ALC889A vs. ALC889).

Is this sufficiently similar to correctly generate a new DSDT.aml file when running finalize?

2. Will I need different kexts for the ALC889 to work properly vs. the 889A ? Should I just use ##### to resolve this post-installation? Should I remove the 889A kexts from the ALC885_889A_LION folder before I proceed creating my boot drive?

3. Not sure 2 is really important as I plan to run audio through the HDMI on the 5770. Do the newer versions of Chameleon support sound through the 5770's HDMI? Or are DSDT changes still necessary to enable this?

4. I read that the version of Chameleon included with this package has problems with RAID installs. I have a 3ware 9650se-8lpml coming in the day after tomorrow that I plan to run a 5x1.5TB RAID 5 with. As this volume won't be my install volume, I should have no issues, right?

5. This question has nothing to do with the installation method, but just in case anyone knows: Will switching to AHCI mode on the SATA controller of my motherboard permanently break my current ICH10R array? Or will it come back when I go back to RAID mode (which seems to support AHCI disks on it)? Everything is backed up (hopefully!), so it's not too much of a concern.

Thanks in advance and sorry for the many questions!

#496
gnomme

gnomme

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

Yep,
no problems with iCloud after initial problems. iCloud wouldn't accept like another account from this computer or so.
Download Chameleon Wizard and get yourself a new SN in your smbios.plist. The generator will do this for you. After that everything's working jsut fine.

Are you shure you have a GA-P35 DS4???

I used the Chameleon Wizard as well but I still have no luck with iCloud.
Can you post here your steps?

Here is what I get:
(see attachment)
Attached File  icloud.jpg   63.82KB   27 downloads

#497
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Hello-

I am looking to install OS X on my HTPC when its target SSD arrives tomorrow. mp4 embedded sub support is poor in Windows and I would like to give plex a spin. The system configuration is as follows:

GA-EP45T-USB3P
Intel Core2Quad (Q8300) @ 2.5GHz
Radeon 5770 (MSI Hawk R5770)

I had a few questions regarding this installation method and would greatly appreciate some help:

1. DSDT.aml

The changelog.txt states, "Implemented autogeneration of DSDT.aml. Should work for most motherboards similar to Gigabyte GA-P35-DS4." What is qualified as similar? The differences between the two boards (P35.. vs. EP45...) that I see are the northbridge (P35 vs. P45), southbridge (ICH9R vs. ICH10R), and the audio chipsets (ALC889A vs. ALC889).

Is this sufficiently similar to correctly generate a new DSDT.aml file when running finalize?


"Similar" means: If it works it's similar. If it doesn't it's not. :(

An incomplete but more specific answer can be found here.

2. Will I need different kexts for the ALC889 to work properly vs. the 889A ? Should I just use ##### to resolve this post-installation? Should I remove the 889A kexts from the ALC885_889A_LION folder before I proceed creating my boot drive?

3. Not sure 2 is really important as I plan to run audio through the HDMI on the 5770. Do the newer versions of Chameleon support sound through the 5770's HDMI? Or are DSDT changes still necessary to enable this?

4. I read that the version of Chameleon included with this package has problems with RAID installs. I have a 3ware 9650se-8lpml coming in the day after tomorrow that I plan to run a 5x1.5TB RAID 5 with. As this volume won't be my install volume, I should have no issues, right?

5. This question has nothing to do with the installation method, but just in case anyone knows: Will switching to AHCI mode on the SATA controller of my motherboard permanently break my current ICH10R array? Or will it come back when I go back to RAID mode (which seems to support AHCI disks on it)? Everything is backed up (hopefully!), so it's not too much of a concern.

Thanks in advance and sorry for the many questions!


With respect to your other questions I simply don't know. I know how to set up the system in my sig. That it works for other boards out of the box is just a happy coincidence. My intention with publishing the script was that it could be modified to support other hardware setups fairly easily. It's sort of a template script, if you will.

#498
tseug

tseug

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 411 posts
  • Gender:Male

Are you shure you have a GA-P35 DS4???

I used the Chameleon Wizard as well but I still have no luck with iCloud.
Can you post here your steps?

Here is what I get:
(see attachment)
Attached File  icloud.jpg   63.82KB   27 downloads


I just tried a clean install on a test partition. No issues with iCloud.

#499
nathandw

nathandw

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Location:Munich / Germany
Open Cham.Wiz. and click on SMBios in the menu.
Then click on "modify" or so, I got the german translation, anyways, it's the button under the paypal icon.
Choose a premade SMBios, the MacPro3,1. Then generate a serial number and click on "Copy". Your serial now moves to the right side. A click on "Save" will put the data in your smbios.plist.

Reboot and enjoy iCloud. Well at least it worked for me...

#500
gnomme

gnomme

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

I just tried a clean install on a test partition. No issues with iCloud.

But you customize your serial number and so with the wizard?
Second, did you activate your iCloud account in a iPhone or genuine Mac first?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy