Jump to content

Mobility Radeon HD 4650:Full Resolution with QE & CI working on Internal LVDS screen


  • Please log in to reply
692 replies to this topic

#221
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

can you plz post smbios.plist with imac 10.1.

This is smbios.plist with machine identifier set to iMac10,1. Please install it in Extra folder. With iMac10,1 as machine identifier, you should get native speedstep support. You can observed it using an application called MSR Tools in 32bit mode.
Attached File  iMac10_1.zip   510bytes   78 downloads

#222
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

ok I am compare my ioregistery with mucha one in mucha show gfx0 but in mine show vga .did i need dsdt editing?

No need to. It's just cosmetic.

and other problem when i tray to open dvd file with dvd player it kernel panic with atix2000.kext depenency error
iokit . iopcifamiliy
iokit . iondvrsupport
iokit . iographics familiy error

This is hard to troubleshoot. May I know list of legacy/foreign kexts you're using?

i will get my rom dump and post in configuration forum as soon as posible.
thanks

Thank you very much!

#223
Cyrus the Great

Cyrus the Great

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 276 posts
  • Gender:Male
  • Location:tehran
thanks it work for me and now i have gpu control and imac 10.1.
the kext in my /e/e is(AppleACPIBatteryManager.kext AppleACPIPS2Nub.kext FakeSMC.kext GenericBrightness.kext LegacyHDA.kext VoodooPS2Controller.kext )
and also i use usbpcifamiliyfix and usbdriverfix in /s/l/e/
i dont now what is problem when first time i install it dvd player play but now its get error and kernel panic.
thanks

#224
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

thanks it work for me and now i have gpu control and imac 10.1.
the kext in my /e/e is(AppleACPIBatteryManager.kext AppleACPIPS2Nub.kext FakeSMC.kext GenericBrightness.kext LegacyHDA.kext VoodooPS2Controller.kext )
and also i use usbpcifamiliyfix and usbdriverfix in /s/l/e/
i dont now what is problem when first time i install it dvd player play but now its get error and kernel panic.
thanks

I know GenericBrightness.kext but I never tried it. I never heard of usbpcifamiliyfix and usbdriverfix. Try removed these three kexts & see if that cure kernel panic with DVD Player.

BTW, can you post your new IORegistry dump? I just want to look.

#225
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

but when i remove this kext my webcam and some time my usb port dosent work.
is there any whay to get usb work without this kext ?

There are Chameleon's built-in fix for USB. Try boot with USBBusFix=Yes.

#226
Cyrus the Great

Cyrus the Great

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 276 posts
  • Gender:Male
  • Location:tehran
ok thanks.
the dvd player it not matter for me i am using vlc .
this new registery dump

Attached Files



#227
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

ok thanks.
the dvd player it not matter for me i am using vlc .
this new registery dump

Thank you! I'll look into it later. If I found anything you can optimized further, I'll let you know.

http://dl.dropbox.co...rine dump.ioreg
http://dl.dropbox.co...rike dump.ioreg
http://dl.dropbox.co...rvet dump.ioreg

I has look to your IORegistry dumps & I found ATIRadeonX2000.kext is not loaded. Hmmm...I think probably you'll need to solved your Mac OS X setup problem first.

There is one person who have identical notebook as mine (Dell Studio 1557) but he/she have internal Full HD LCD panel (1920x1080). He/she already tried the same modified boot file I gave you which injecting new property for the ATI graphic card but the results still the same; internal LCD blank. Latest 17" MacBookPro8,3 also have internal LCD with higher resolution than 1336x768 & it's used LVDS. So, what is the different with ours???? I know Dell Studio 1557 has LVDS interface which support dual-link/two channel LVDS transmitter because I has the schematic. Probably the OS X's driver only provided support for dual-link LVDS on several GPU only which could explain why we can't get ours to work. I think we will need to examine the iMac's IORegistry since our ATI is 4xxx & 5xxx. I already look in iMac11,1's IORegistry. It's used DP_INT instead of LVDS.

#228
almuras

almuras

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
In system profiler I always see ATIRadeonX2000.kext loaded

#229
nono_nono

nono_nono

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Hey kizwan,can you give me your kexts??,i want to try,is np if is not gonne work,i have radeon hd 4650 1gb ddr3 [0x9480] plzzzzzzzzz plzzzzzzzzz

#230
almuras

almuras

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
No, you are right, kizwan, I do not see ATIRadeonX2000.kext loaded. What can prevent it?
Thanks!

#231
Cyrus the Great

Cyrus the Great

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 276 posts
  • Gender:Male
  • Location:tehran

Hey kizwan,can you give me your kexts??,i want to try,is np if is not gonne work,i have radeon hd 4650 1gb ddr3 [0x9480] plzzzzzzzzz plzzzzzzzzz


this patched frambuffer with shrike this work for me.
Attached File(s) Posted Image ATIFramebuffer.kext.rar
so if your laptop is hp it may work for you try it and dont forgot to do disk premision repair after installin this kext.

#232
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

this new registery dump

You can patch LPC device in DSDT. It help the processor run much cooler. You can go over here to learn how to patch LPC device (in my DSDT the LPC device is named LPCB).

No, you are right, kizwan, I do not see ATIRadeonX2000.kext loaded. What can prevent it?
Thanks!

I'm not sure. Try fix your setup first. Get rid all unnecessary kexts like nullcpupowermanagement.

#233
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

You can patch LPC device in DSDT. It help the processor run much cooler. You can go over here to learn how to patch LPC device (in my DSDT the LPC device is named LPCB).
thanks

i have idt audio like you kizwan can you post your idt kext.
thanks

You can find the audio kext at the same place.

#234
Cyrus the Great

Cyrus the Great

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 276 posts
  • Gender:Male
  • Location:tehran
hi nano_nano this instalation kext-com.apple.boot.plist -smbios -boot file- that i have used and my card get working .
this from 10.6.7 patched kext.before installing update to 10.6.7
place boot file in your mac os x root drive

Attached Files



#235
almuras

almuras

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts

You can patch LPC device in DSDT. It help the processor run much cooler. You can go over here to learn how to patch LPC device (in my DSDT the LPC device is named LPCB).


I'm not sure. Try fix your setup first. Get rid all unnecessary kexts like nullcpupowermanagement.


Kizwan, I fixed the setup, removed all foreign kexts, and reinstal 10.6.7 update. I used your boot files and smbios.
This time all video kexts were loaded as you can see from the dumps. However, I still have only HDMI working.
I attached the dumps.


Will greatly appreciate your help to get LVDS working . Thanks a lot!!! :angry:

http://dl.dropbox.co...rine dump.ioreg
http://dl.dropbox.co...rike dump.ioreg
http://dl.dropbox.co...rvet dump.ioreg

#236
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

Kizwan, I fixed the setup, removed all foreign kexts, and reinstal 10.6.7 update. I used your boot files and smbios.
This time all video kexts were loaded as you can see from the dumps. However, I still have only HDMI working.
I attached the dumps.


Will greatly appreciate your help to get LVDS working . Thanks a lot!!! :(

http://dl.dropbox.co...rine dump.ioreg
http://dl.dropbox.co...rike dump.ioreg
http://dl.dropbox.co...rvet dump.ioreg

That's more like it. OK, there is one person told me he/she got internal LCD screen with resolution 1920x1080 working (have the same notebook as mine, Dell Studio 1557). Please try this standard boot file:-
Attached File  boot.standard.0x9480.shrike.zip   192.49KB   16 downloads
This is standard boot file compiled from trunk. I only set your graphic card to use Shrike framebuffer in this boot file.

#237
Derc

Derc

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
Hi kizman! Help me please with my graphics card! I have a ATI Radeon Mobility 4570 512 mb on a notebook ASUS k40ad. On a laptop only output the VGA and LVDS with a maximum resolution of 1366x768. I tried to use your framebuffer but apparently it does not work for me. Please tell me what I need to do to get my card working? Could you tell me more as I get radeondump? I'll be very grateful for your help!

#238
sydlix

sydlix

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

That's more like it. OK, there is one person told me he/she got internal LCD screen with resolution 1920x1080 working (have the same notebook as mine, Dell Studio 1557). Please try this standard boot file:-
Attached File  boot.standard.0x9480.shrike.zip   192.49KB   16 downloads
This is standard boot file compiled from trunk. I only set your graphic card to use Shrike framebuffer in this boot file.


Kizwan if you look at the radeondump of the person who got the fullhd panel working on 4650 you see he set 02 00 TR/ENC values but it's radeonhd log said "mapping dig2 on uniphyE". DIG2 should be 01, mine says DIG1 and should be 00.

#239
almuras

almuras

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts

That's more like it. OK, there is one person told me he/she got internal LCD screen with resolution 1920x1080 working (have the same notebook as mine, Dell Studio 1557). Please try this standard boot file:-
Attached File  boot.standard.0x9480.shrike.zip   192.49KB   16 downloads
This is standard boot file compiled from trunk. I only set your graphic card to use Shrike framebuffer in this boot file.

It did not work. But we already tried several boot files and framebuffurers.... :)

#240
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

Kizwan if you look at the radeondump of the person who got the fullhd panel working on 4650 you see he set 02 00 TR/ENC values but it's radeonhd log said "mapping dig2 on uniphyE". DIG2 should be 01, mine says DIG1 and should be 00.

May I know who is the person got his/her 4650 & full HD screen working (fully working)? I already tested transmitter 0x02 with two notebooks but none of them works. However, the second person who have the same notebook as mine but with full HD LCD able to get it working with transmitter 0x12. Actually he/she just use my first patched ATIFramebuffer.kext which use different encoder than the one stated in the RadeonHD's log. Almost all notebooks use LVDS for internal LCD panel but looks like not all use the same technology. As for now, based on the test conducted, the encoder & transmitter are not important as long as the link are not conflicted with each other, e.g LVDS vs. HDMI. What important are ControlFlags & senseid.

It did not work. But we already tried several boot files and framebuffurers.... :)

The boot file does work right? but only HDMI is working right?

Based on this success report, I'm going to sent you a patched ATIFramebuffer.kext for you to test. I'll sent it in 30 minutes.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy