Jump to content

ATI Radeon 6xxx, working QE/CI


  • Please log in to reply
784 replies to this topic

#61
checcco

checcco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
k540kkk contacted me via PM and asked me to post this info he extracted from ATI6000Controller.kext from MBP2011

Personality: Pithecia 
ConnectorInfo count in decimal: 3 
Effective address for ConnectorInfo table in dec: 159584 (0x26f60) 
Location in dec: 500444 (0x7a2dc) 
0000000: 0004 0000 0403 0000 0001 0000 2103 0204 ............!... 
0000010: 0400 0000 1402 0000 0001 0000 0000 0403 ................ 
0000020: 1000 0000 1000 0000 0001 0000 0000 0001 ................ 

Personality: Bulrushes 
ConnectorInfo count in decimal: 6 
Effective address for ConnectorInfo table in dec: 159648 (0x26fa0) 
Location in dec: 500508 (0x7a31c) 
0000000: 0004 0000 0403 0000 0001 0000 1102 0101 ................ 
0000010: 0004 0000 0403 0000 0001 0000 2103 0202 ............!... 
0000020: 0004 0000 0403 0000 0001 0000 1204 0303 ................ 
0000030: 0004 0000 0403 0000 0001 0000 2205 0404 ............"... 
0000040: 0004 0000 0403 0000 0001 0000 1000 0505 ................ 
0000050: 0004 0000 0403 0000 0001 0000 2001 0606 ............ ... 

Personality: Cattail 
ConnectorInfo count in decimal: 4 
Effective address for ConnectorInfo table in dec: 159744 (0x27000) 
Location in dec: 500604 (0x7a37c) 
0000000: 0200 0000 4000 0000 2905 0000 0000 0005 ....@...)....... 
0000010: 0004 0000 0403 0000 0001 0000 1102 0101 ................ 
0000020: 0004 0000 0001 0000 0001 0000 2103 0202 ............!... 
0000030: 0004 0000 0001 0000 0001 0000 1204 0303 ................ 

Personality: Hydrilla 
ConnectorInfo count in decimal: 5 
Effective address for ConnectorInfo table in dec: 159808 (0x27040) 
Location in dec: 500668 (0x7a3bc) 
0000000: 0200 0000 0001 0000 0901 0000 1204 0303 ................ 
0000010: 0004 0000 0403 0000 0001 0000 1102 0101 ................ 
0000020: 0004 0000 0403 0000 0001 0000 2103 0202 ............!... 
0000030: 0004 0000 0403 0000 0001 0000 2205 0504 ............"... 
0000040: 0004 0000 0403 0000 0001 0000 1000 0405 ................ 

Personality: Duckweed 
ConnectorInfo count in decimal: 4 
Effective address for ConnectorInfo table in dec: 159904 (0x270a0) 
Location in dec: 500764 (0x7a41c) 
0000000: 0004 0000 0403 0000 0001 0000 1204 0401 ................ 
0000010: 0004 0000 0403 0000 0001 0000 2205 0502 ............"... 
0000020: 0008 0000 0402 0000 0001 0000 1102 0304 ................ 
0000030: 0002 0000 0402 0000 0001 0000 0000 0605 ................ 

Personality: Fanwort 
ConnectorInfo count in decimal: 4 
Effective address for ConnectorInfo table in dec: 159968 (0x270e0) 
Location in dec: 500828 (0x7a45c) 
0000000: 0200 0000 4000 0000 2905 0000 0000 0004 ....@...)....... 
0000010: 0004 0000 0403 0000 0001 0000 1102 0101 ................ 
0000020: 0004 0000 0001 0000 0001 0000 2103 0202 ............!... 
0000030: 0004 0000 0001 0000 0001 0000 1204 0303 ................ 

Personality: Elodea 
ConnectorInfo count in decimal: 5 
Effective address for ConnectorInfo table in dec: 160032 (0x27120) 
Location in dec: 500892 (0x7a49c) 
0000000: 0200 0000 0001 0000 0901 0000 1204 0303 ................ 
0000010: 0004 0000 0403 0000 0001 0000 1102 0101 ................ 
0000020: 0004 0000 0403 0000 0001 0000 2103 0202 ............!... 
0000030: 0004 0000 0403 0000 0001 0000 2205 0404 ............"... 
0000040: 0004 0000 0403 0000 0001 0000 1000 0505 ................ 

Personality: Kudzu 
ConnectorInfo count in decimal: 2 
Effective address for ConnectorInfo table in dec: 160128 (0x27180) 
Location in dec: 500988 (0x7a4fc) 
0000000: 0004 0000 0403 0000 0001 0000 1204 0303 ................ 
0000010: 0008 0000 0402 0000 0001 0000 1102 0101 ................ 

Personality: Gibba 
ConnectorInfo count in decimal: 5 
Effective address for ConnectorInfo table in dec: 160160 (0x271a0) 
Location in dec: 501020 (0x7a51c) 
0000000: 0004 0000 0403 0000 0001 0000 1204 0501 ................ 
0000010: 0004 0000 0403 0000 0001 0000 2205 0402 ............"... 
0000020: 0008 0000 0402 0000 0001 0000 1102 0604 ................ 
0000030: 0002 0000 0402 0000 0001 0000 0000 0305 ................ 
0000040: 0400 0000 0402 0000 0001 0000 1102 0103 ................ 

Personality: Lotus 
ConnectorInfo count in decimal: 3 
Effective address for ConnectorInfo table in dec: 160256 (0x27200) 
Location in dec: 501116 (0x7a57c) 
0000000: 0004 0000 0403 0000 0001 0000 1102 0101 ................ 
0000010: 0004 0000 0001 0000 0001 0000 2103 0202 ............!... 
0000020: 0008 0000 0402 0000 0001 0000 2205 0404 ............"... 

Personality: Ipomoea 
ConnectorInfo count in decimal: 3 
Effective address for ConnectorInfo table in dec: 160320 (0x27240) 
Location in dec: 501180 (0x7a5bc) 
0000000: 0004 0000 0403 0000 0001 0000 1204 0105 ................ 
0000010: 0008 0000 0402 0000 0001 0000 1102 0403 ................ 
0000020: 1000 0000 1000 0000 0001 0000 0000 0002 ................


#62
Guest: ^Andy^_*

Guest: ^Andy^_*
  • Guests

Thanks Andy, I'll try again; any more info about your config is appreciated. Thanks


My System is an Asus P8P67 Pro with an i5 2500k and 8gig of ram. I use a pair of crossfired AMD 6870's - one a Sapphire card the other an OEM (I have flashed them both to use the same slightly overclocked bios image).

I'm using the latest Sandy bridge friendly chameleon build from ##### along with the kernel and kexts from my posts above.

Other than the usual fakesmc.kext and specific kexts for my sata controllers, usb3, network and audio (all of which can be found in ##### for this board) there isn't much to tell. I boot into 64bit with no kernel flags. Looks like the built in bluetooth is detected too (I have the icon in the menu bar at least).

Looking at the spec in your signature st1v you should be able to use the latest ##### cd to boot up but be sure to specify GraphicsEnabler=n as a kernel parameter when you try.
Assuming you are starting from a 10.6.6 install once booted you can install the new kexts using kexthelper (this will install them to /System/Library/Extensions). You can then install chameleon (hunt around for the unofficial rc5 installer package - you shouldn't need the experimental ATI support but it shouldnt matter either way as long as you specify graphicsenabler=no or just delete the <key>GraphicsEnabler</key> and <string>?</string> from your com.apple.Boot.plist file in Extra).
Reboot and fingers crossed you should be done.

#63
st1v

st1v

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Looks like it's working great now,even after several reboots. I used Kext Utility to rebuild caches instead of Kext Helper.
Now, how can I verify if I have QE/CI and OpenGL? The menu bar is translucent and when I add a widget there's the water ripple effect: what does it mean?

Here's every step I did, for people who were in my same situation:
1) burned ##### Legacy (beacuse my VGA isn't supported) on a cd and rebooted with the DVD Rom as the primary booting device
2) switched the ##### cd with Snow Leopard 10.6.0 Retail DVD and pressed F5
3) press Entry on the MAC OS X Install DVD using the GraphicsEnabler=NO flag
4) install on the GUID partition on your hard drive created with Disk Utility from the Menu bar
5) after finishing the install, reboot with the ##### Legacy CD in your dvd rom (again using the the GraphicsEnabler=NO flag)
6) you should see your desktop in 1024x768 resolution
7) download the 10.6.6 Combo Update from Apple website and install it (DO NOT REBOOT after finishing, put the window in background without closing it)
8) download ##### from tonymacx86 site and install it, checking only ##### and the 2 System Utilities (Rebuild caches and Repair System Permissions)
9) go to Extensions/Extra and modify the com.apple.Boot.plist: GraphicsEnabler=NO
10) eject the ##### cd and reboot
11) download the kexts that Andy uploaded and put them in your System/Library/Extensions folder, overwriting everything it asks
12) download Kext Utility 2.4.2 form kexts.com and run it: it should end with "Have a good day(night)", otherwise it failed rebuilding the caches
13) reboot and it should work (at least it did for me)

#64
Guest: ^Andy^_*

Guest: ^Andy^_*
  • Guests

Looks like it's working great now,even after several reboots. I used Kext Utility to rebuild caches instead of Kext Helper.
Now, how can I verify if I have QE/CI and OpenGL? The menu bar is translucent and when I add a widget there's the water ripple effect: what does it mean?


That means it's working - Congrats! :D
To verify you could download cinebench and run the opengl test - it will soon moan at you if it's not working.

#65
st1v

st1v

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Great, thanks for helping me. I'll stick around to help anyone who needs suggestions.
Cheers :D

#66
Hexidecimal

Hexidecimal

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 188 posts
  • Gender:Male
  • Location:Chiron Beta Prime

upload all files used :) your video card is??

steps or process to install... thanks

your X-Fi Titanium Fatalit is?? USB C-Audio adapter is? links?


^Andy^'s uploaded files.

My Process:

Prologue: Set Motherboard to AHCI or RAID in BIOS, Disable Legacy USB.

1. Boot iATKOS s3 v2 (boot with -v & busratio=20 for DX58SO Motherboard)

2. Select Chameleon RC5, SATA AHCI, default patches + USB Patch. Deselect RTC. Do not select any non standard kernels.

3. Boot to OS X 10.6.3.

4. Install 10.6.4, Reboot. Copy IOUSB* Kexts to desktop.

5. Install 10.6.5 Install USB Kexts with Kext Helper, reboot. (Important to do this BEFORE rebooting or you will lose USB port functionality)

6. Install 10.6.6. Install USB Kexts, ATI Kexts, and VoodooHDA for X-FI from this link http://www.tonymacx8...php?f=16&t=5229 using Kext Helper. Reboot.

7. QE/CI All Monitors should now be working, MiniDP to DVI garbled. Unplug and Replug any adapters to resolve at this boot.

8. Install DX58SO Patcher from here: http://www.insanelym...howtopic=231993 Monitors should no longer be garbled at boot.

9. Edit com.apple.Boot.plist in /Extras to set GraphicsEnabler=No and set Native Screen Res (Defaults to 1920x1200x32)

10. Reboot.

Done!

System fully works with Motherboard, Vanilla x64 OS X 10.6.6, Video w/ QE/CI/Res Change/Multiple Monitors, Audio from Creative X-Fi Titanium Fatal1ty Edition works (except input, can't figure out why, using this USB adapter for input, native Mac compatibility:Found Below

Here are links on newegg to all my components:
Video
Audio
Audio Input

Updated via Software Update last night once all manual updates were done with no problems. I've installed Office 11 and Creative Master Suite CS5 both run in x64 mode like a champ.

The only part of my motherboard that isn't supported is the RAID controller. Have to break my RAID for Windows 7 tonight and install to a single drive again. Hope this helps.

The Finished Product:

Attached Files



#67
st1v

st1v

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Some benchmarks:

CINEBENCH 11.5 x64
OPENGL
- Windows: 42.24 fps
- Mac OS: 27.71 fps (good enough for me, I don't plan on playing in Mac, that's what Windows is for)

CPU
- Windows: 1.67
- Mac OS: 1.66 (can't wait for my i5-2500k to arrive next week and double this :) )

#68
Guest: ^Andy^_*

Guest: ^Andy^_*
  • Guests

Some benchmarks:

CINEBENCH 11.5 x64
OPENGL
- Windows: 42.24 fps
- Mac OS: 27.71 fps (good enough for me, I don't plan on playing in Mac, that's what Windows is for)

CPU
- Windows: 1.67
- Mac OS: 1.66 (can't wait for my i5-2500k to arrive next week and double this :) )


When you get your i5 you will need to use the 2011 mbp mach_kernel that I posted otherwise you will have a lot of grief getting it to boot without it.

The Finished Product:


Very nice setup you have there! :(

#69
st1v

st1v

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

When you get your i5 you will need to use the 2011 mbp mach_kernel that I posted otherwise you will have a lot of grief getting it to boot without it.


Yeah I know, I just wanted to try if the C2D worked before selling it, just as an exercise. Thanks for the remainder.
Just a quick question: do you think that installing the OpenGL framework you posted would improve my OpenGL benchmark?

#70
jpa

jpa

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 516 posts
  • Gender:Male
andy is great!!!

nice nice :( happy :)

andy - points in cinebech? Hexidecimal points in cinebech?

novabech?

#71
Guest: ^Andy^_*

Guest: ^Andy^_*
  • Guests

Just a quick question: do you think that installing the OpenGL framework you posted would improve my OpenGL benchmark?


I don't think it will - they are probably exactly the same files but you are welcome to try and then post back with your results.

andy is great!!!

nice nice :P happy ;)

andy - points in cinebech? Hexidecimal points in cinebech?

novabech?


I'll post cinebench results tonight after I run them again but last run I got about 39fps in OS X and 90 something fps in Windows (OS X sucks when it comes to graphics performance which is probably why everybody is trying to get high end cards working lol).

Yeah I know, I just wanted to try if the C2D worked before selling it, just as an exercise. Thanks for the remainder.


Out of interest which motherboard did you buy to go with your 2500k? If it happens to be a P8P67 Pro then I can tell you which kexts to use from ##### for a pretty much 100% working system.

#72
Hexidecimal

Hexidecimal

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 188 posts
  • Gender:Male
  • Location:Chiron Beta Prime

andy is great!!!

nice nice :P happy ;)

andy - points in cinebech? Hexidecimal points in cinebech?

novabech?


Didn't get a chance to run those. I'll put it through it's paces tonight and report back.

#73
jpa

jpa

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 516 posts
  • Gender:Male

Didn't get a chance to run those. I'll put it through it's paces tonight and report back.


##### used is? legacy? the tonix86? upload ##### used to install in mediafire

thanks

your audio works 100%?? 5.1??

thanks
files used and steps for install sound card... upload

sound card works in GA-X58A-UD3R-2.0?? and sound adaptar works??

#74
st1v

st1v

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
@Andy
I haven't tried replacing the OpenGL Framwork because I'm afraid of breaking something, but i did notice that the folder sizes are different (52.4 vs 47.2 MB); no big deal, maybe they just made some optimization... not worth risking, I'll wait the full 10.6.7 update.
And I haven't purchased the 1155 mobo yet because of the Intel chipset problem, they are slowly restocking them in my country, there should be plenty available in a couple of weeks; anyway, I'm planning on buying an Asus, Gigabyte or MSI mobo with P67 chipset, so maybe I'll buy the P8P67 since it's tested and working. I'll let you know.
Thanks

#75
Guest: ^Andy^_*

Guest: ^Andy^_*
  • Guests
Here are my cinebench scores, Windows 7 and Snow Leopard side by side..


Posted Image





@Andy
I haven't tried replacing the OpenGL Framwork because I'm afraid of breaking something, but i did notice that the folder sizes are different (52.4 vs 47.2 MB); no big deal, maybe they just made some optimization... not worth risking, I'll wait the full 10.6.7 update.


I'm feeling reckless so I'm going to try this on my spare hackintosh using a 5870 card that I have just used the new kexts on (so no need for GraphicsEnabler on that system either) - will post back in a minute..

Ok with just the new kexts on my spare hack (a q6600 with an ATI 5870) it scores 20.61fps..

With the new OpenGL Framework it scores 20.51fps lol so I wouldn't bother!

Seeing as I'm still feeling reckless I'm going to dump the latest 10.6.7 beta on and see if that makes any difference.. more to follow

UPDATE - That's interesting, the latest beta of 10.6.7 won't install - it refuses to allow me to select the disk to install to. I use a partion on an mbr formatted drive and it looks like the latest beta has been changed to only install on a guid partitioned drive! I guess I now know what the reversioner package is for lol.

#76
nefilim

nefilim

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
does the latest 10.6.7 beta kernel have sandy bridge support?

how about the MBP2011 install disk? would be great if someone with a sandy bridge mbp could upload their kernel...

#77
Guest: ^Andy^_*

Guest: ^Andy^_*
  • Guests

does the latest 10.6.7 beta kernel have sandy bridge support?

how about the MBP2011 install disk? would be great if someone with a sandy bridge mbp could upload their kernel...



I have already posted the sandy bridge kernel - I posted it along with the ATI kexts on page 3 of this thread but to answer your questions in order no, yes and see above! :wacko:

#78
jpa

jpa

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 516 posts
  • Gender:Male

I have already posted the sandy bridge kernel - I posted it along with the ATI kexts on page 3 of this thread but to answer your questions in order no, yes and see above! :rolleyes:



woow 37 in mac fps wooow, ilike

link your card in newegg.com please

#79
Guest: ^Andy^_*

Guest: ^Andy^_*
  • Guests

woow 37 in mac fps wooow, ilike

link your card in newegg.com please



I can't link it because I have 2 6870's in crossfire - kind of explained this already. One is just a bog standard reference Sapphire 6870 card and the other is an OEM card that I bought from ebay. I have flashed both cards with the same slightly overclocked bios although both cards look identical and are both reference cards.

#80
jpa

jpa

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 516 posts
  • Gender:Male

I can't link it because I have 2 6870's in crossfire - kind of explained this already. On is just a bog standard reference Sapphire 6870 card and the other is an OEM card that I bought from ebay. I have flashed both cards with the same slightly overclocked bios.


thanks

##### used? upload in mediafire...

recomend card for buy now...
http://www.newegg.co...N82E16814102909

http://www.newegg.co...N82E16814161349

http://www.newegg.co...N82E16814150507

thanks





3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy