Jump to content

ATI Radeon 6xxx, working QE/CI


  • Please log in to reply
784 replies to this topic

#681
KineticPlague

KineticPlague

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

You dont need 11c48 - the package will install the kexts from that build anyway. The only requirement really is that you are running lion.

The native package should work regardless of your chameleon build being 6900 series friendly or not (not many builds are that I know of other than ones that I have built myself or shared on here) so you have at least picked the right package.



Alright, well I will give it a try tonight. Would it make a difference if Windows is installed on a different HDD? Or that I have a couple of bootable backups of Snow Leo and Lion? I just always assumed no, but I figured I'd ask since I have your attention.

#682
^Andy^

^Andy^

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 659 posts
  • Gender:Male

Alright, well I will give it a try tonight. Would it make a difference if Windows is installed on a different HDD? Or that I have a couple of bootable backups of Snow Leo and Lion? I just always assumed no, but I figured I'd ask since I have your attention.


Nope you just need to boot then reboot without killing the electrickery lol

#683
KineticPlague

KineticPlague

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Nope you just need to boot then reboot without killing the electrickery lol


Alright, thanks man! I really hope this works because I have been waiting a loooong time lol

#684
^Andy^

^Andy^

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 659 posts
  • Gender:Male

Alright, thanks man! I really hope this works because I have been waiting a loooong time lol


fingers crossed!

#685
KineticPlague

KineticPlague

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

fingers crossed!


IT WORKED!!! I can't believe it! I swear I tried this before... oh well, I am just happy I have full resolution!

Thank you so much!

#686
^Andy^

^Andy^

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 659 posts
  • Gender:Male

IT WORKED!!!


:P

#687
chimitron

chimitron

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hey andy...

those id`s for ATI SAPPHIRE 6750 aren´t in aticontroller6000.kext and ati.c neither..... what is the next step??



Rafa, I've an ATI SHAPPIRE 6790

My device ID: 0x673e

Where I have to put the ID in aticontroller6000.kext ??? Here: ??

<key>IOPCIMatch</key>
<string>0x67681002 0x67701002 0x67791002 0x67601002 0x67611002 0x67501002 0x67581002 0x67591002 0x67401002 0x67411002 0x67451002 0x67381002 0x67391002 0x67201002 0x67221002 0x67181002 0x67191002 0x68401002 0x673e1002</string>

And, where's ati.c ??

Sorry I'm so begginer for this and I can't make works my card on SL 10.6.8 :)

#688
chimitron

chimitron

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Please, I'm going crazy. ;)

I have read every page of this thread and find no solution to run the SAPPHIRE HD6790 in my Snow Leopard. : (

With other cards I have not had many complications, but this can not get it to work, despite having been searching like crazy on this and other forums.

Please, I'd be really grateful if you could help me. Thank you very much in advance.

#689
jamlub1

jamlub1

    InsanelyMac Protégé

  • Validating
  • Pip
  • 1 posts
For anyone that it is of interest to, Starcraft II works if you turn the shaders down to high.

I have a 6950 flashed to 6970 on 10.7.2 FYI

#690
holzer

holzer

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Germany

Please, I'm going crazy. ;)

I have read every page of this thread and find no solution to run the SAPPHIRE HD6790 in my Snow Leopard. : (

With other cards I have not had many complications, but this can not get it to work, despite having been searching like crazy on this and other forums.

Please, I'd be really grateful if you could help me. Thank you very much in advance.


Dear chimitron, :D
my english is very simple, but i have understand that in this thread
is no go for AMD 6950/6970 for Snow Leo, but for Lion!
Now everybody, is that right?
Greetings
Holzer ;)

#691
chimitron

chimitron

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Dear chimitron, :)
my english is very simple, but i have understand that in this thread
is no go for AMD 6950/6970 for Snow Leo, but for Lion!
Now everybody, is that right?
Greetings
Holzer :)


OMG!!!

Then I ask sincere apologies to the forum!

I spent last night reading the whole thread looking for someone who has been able to find the solution and I missed it did not work in SL.

I apologize and thanks for the tip.

Will update here if I get to run the card with Lion.

#692
sapikere

sapikere

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Dear chimitron, :unsure:
my english is very simple, but i have understand that in this thread
is no go for AMD 6950/6970 for Snow Leo, but for Lion!
Now everybody, is that right?
Greetings
Holzer ;)


chimitron talked not about 6950/6970 also, but about 6790.
To bad snow even lion does not support for 6790 yet, I'll change mine ( 6790 ) to another support card

#693
chimitron

chimitron

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

chimitron talked not about 6950/6970 also, but about 6790.
To bad snow even lion does not support for 6790 yet, I'll change mine ( 6790 ) to another support card


Oh no! I have deleted the partition of Snow Leopard and now I'm installing it Lion ... : (

I understand that there is no way to run a SAPPHIRE HD 6790 AMD Snow Leopard or Lion, is it true?

Thanks in advance for any response.

#694
Lilith

Lilith

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 140 posts
  • Gender:Male
  • Location:Sardinia, Italy
Anyone can help me? I have a 6250, and my id is in the info.plist of ati6000.kext, but when i follow the instructions of andy, i'm stuck in the step of booting with -s, because i'm not able. This because i get a black screen, with no cursor and no text line for terminal :\ i've repaired the permissions by kext wizard, but nothing.

Another question, i must use also atisupport.kext and atiframebuffer.kext to make work my video card?
Thanks for replies, guys.
Gabriele.

#695
chimitron

chimitron

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Oh no! I have deleted the partition of Snow Leopard and now I'm installing it Lion ... : (

I understand that there is no way to run a SAPPHIRE HD 6790 AMD Snow Leopard or Lion, is it true?

Thanks in advance for any response.


After going crazy by thousands of tests and not get anything besides read in a thousand places the HD6790 is not supported in Lion, I will change my new HD6790 for a HD6850 and not complicate life more.

Next week we will publish the result of all this.

Regards

#696
thebrac

thebrac

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I understand that the 6790 may be currently not working on Lion, but if it is not working, is there not some way where we can request this to be implemented into the next release??? I currently also have a 6790 and would like to see this working! What can we do in order to make this happen??? I cannot believe that there is something technically wrong with this series of cards that inhibits it from working with Lion.

Please tell us what to do?!?!? I cannot just go out and exchange my 6790 for a card that is working!

#697
zavy

zavy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts
I have to buy a new hack and want to go for the 6950, can someone suggest me the most compatible model? Just 1 requirement, it must have at least 1 mini display port (for use the iMac 27" in target mode)

thank you

#698
alby64

alby64

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
Hello Andy,
can you help me with Sapphire Radeon HD 6970 2048mb?
I had Lion installed with HD 5870 perfectly on usb hd (installation by same usb hd, two partitions, first installation second destination) and now with HD 6970 I have this:
Sorry for my bad english
thanks

Attached Files



#699
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • Retired
  • 1,158 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
@ zavy I'd actually suggest that you get a 6870 (if you don't mind bumping it down a notch) because the 69xx series doesn't seem to have a future ahead of it in os x besides resolution changes with  already preparing for the 7xxx series. Most 6870's with display ports on them are able to output via the DP through the Duckweed framebuffer (has already been tested).

@alby64 As opposed to your 5870 which has full support under Lion, the 69x cards have never been "fully" supported in os x. I honestly don't see the reason for actually switching out the 5870 which has acceleration working for a higher end card that won't have acceleration and which will actually make the system perform worse than the previous card. Netkas has already posted his thoughts on the longevity of this series and it doesn't look all that promising at all.

http://netkas.org/?p=1030

PS:
I'm not the bringer of bad news, I'm just trying to save you time wasting and possible frustration.

#700
geocool

geocool

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Location:Greece
Any news people about 6790 ? I'm using windows again pffff...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy