Jump to content

Intel 845GL Graphics, need files


  • Please log in to reply
36 replies to this topic

#1
Milenco

Milenco

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Since i'm using the bender/broadband DVD, i've lost my Quartz Extreme support for my Intel 845GL Graphics chip. I'm suspecting it has something to do with some files who are missing in the DVD, which were on the deadmoo img. If someone can put this files online, i can test if my Quartz Extreme is working again.

There are 3 files i need from the deadmoo img, all in the folder /System/Library/Extensions/:
AppleIntel830GLDriver.bundle
AppleIntel830.kext
AppleIntel830GA.plugin

Can someone upload these files somewhere? If this is working, i think all Intel 8xx might get Quartz Extreme support back with the bender/broadband DVD.
Thanks in advanced!

#2
Milenco

Milenco

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Seems it works! I tried the files from the Darwin ISO, and it works like a charme now with Quartz Extreme enabled. I uploaded the file, which can be found here: http://www.xs4all.nl.../osx86/kext.zip

To install: Unrar the files and navigate to them via your Terminal. move the files like this:

sudo mv * /System/Library/Extensions/
sudo chown -R root:wheel /System/Library/Extensions/AppleIntel830.kext
sudo chown -R root:wheel /System/Library/Extensions/AppleIntel830GA.plugin
sudo chown -R root:wheel /System/Library/Extensions/AppleIntel830GLDriver.bundle
sudo kextload /System/Library/Extensions/AppleIntel830.kext

Reboot and Quartz Extreme should be working fine again. Remember: I tried it succesfully on a Intel 845GL Graphics chips. I suspect it will work on any Intel 8xx GPU, but i'm not sure. At least it won't do you any harm.

#3
Guest: delweeg_*

Guest: delweeg_*
  • Guests
Sorry, I have a problem with this link. Could you send me them over the e-mail? delweeg<a>nm.ru

Will it work with with Intel Integrated 865G (8X AGP)?

#4
kaiwei

kaiwei

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Downloaded the files but the archive seems funny...winrar complains that it has no files to extract.

#5
Milenco

Milenco

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Seems WinAce doesn't like rarrring...I made a new zip, which can be found here:

http://www.xs4all.nl.../osx86/kext.zip

This one should work (tested)

Don't know if this driver will work on the 865G. Please test it and let me know! It won't do any harm to your system. If the driver doesn't support your GPU, OSX will just leave the kext alone

#6
kaiwei

kaiwei

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Seems WinAce doesn't like rarrring...I made a new zip, which can be found here:

http://www.xs4all.nl.../osx86/kext.zip

This one should work (tested)

Don't know if this driver will work on the 865G. Please test it and let me know! It won't do any harm to your system. If the driver doesn't support your GPU, OSX will just leave the kext alone

<{POST_SNAPBACK}>


YUP. Got it working on my Dell 700M under 855 with your files. The only thing I did was to change the plist.info to 3582 in the AppleIntelIntegrated.kext

THANKS! Eveything seems snappier now.

Attached Files



#7
tbman

tbman

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

YUP. Got it working on my Dell 700M under 855 with your files. The only thing I did was to change the plist.info to 3582 in the AppleIntelIntegrated.kext

THANKS! Eveything seems snappier now.

<{POST_SNAPBACK}>


where you change this???

#8
bigdog

bigdog

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Seems it works! I tried the files from the Darwin ISO, and it works like a charme now with Quartz Extreme enabled. I uploaded the file, which can be found here: http://www.xs4all.nl.../osx86/kext.zip

To install: Unrar the files and navigate to them via your Terminal. move the files like this:

sudo mv * /System/Library/Extensions/
sudo chown -R root:wheel /System/Library/Extensions/AppleIntel830.kext
sudo chown -R root:wheel /System/Library/Extensions/AppleIntel830GA.plugin
sudo chown -R root:wheel /System/Library/Extensions/AppleIntel830GLDriver.bundle
sudo kextload /System/Library/Extensions/AppleIntel830.kext

Reboot and Quartz Extreme should be working fine again. Remember: I tried it succesfully on a Intel 845GL Graphics chips. I suspect it will work on any Intel 8xx GPU, but i'm not sure. At least it won't do you any harm.

<{POST_SNAPBACK}>


Do you have the AppleIntelIntegrated.kext in your /System/Library/Extensions/ folder? or did you remove that?

#9
Amazondani

Amazondani

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
Can somebody tell me, how this works, because, i thougt that the only card working was the intel GMA 900, Am I right to say that if I have a mobo with a chipset intel 845 GV with the Intel Extreme Graphics or the intel Extrem Graphics 2, I will can have Quartz Extreme Enabled??

In witch way this will be good for the system, the video will be faster??

Can somebody give me a clue??
Thaks In advance!

#10
flipsoft

flipsoft

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
I get these blue squares which look like large pixels. Has anyone seen that before?

#11
ivansf

ivansf

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Me and still with that problem

#12
Milenco

Milenco

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

Do you have the AppleIntelIntegrated.kext in your /System/Library/Extensions/ folder? or did you remove that?

<{POST_SNAPBACK}>


AppleIntelIntegrated.kext was included in the bender/br0adband DVD, i didn't touch the file, its still there.


Can somebody tell me, how this works, because, i thougt that the only card working was the intel GMA 900, Am I right to say that if I have a mobo with a chipset intel 845 GV with the Intel Extreme Graphics or the intel Extrem Graphics 2, I will can have Quartz Extreme Enabled??

In witch way this will be good for the system, the video will be faster??

Can somebody give me a clue??
Thaks In advance!

<{POST_SNAPBACK}>


These files where included in the deadmoo dvd image. There normal drivers which came originally from the Darwin 8.1. I didn;t modify the drivers in any way.

In the bender/br0adband DVD, they removed this driver for some reason. When i installed this dvd, i noticed that my QE support has went away. So I uploaded these drivers which can enable them again.

I think it will work on your 845 GPU, as it did worked on mine. I've noticed Expose (you know, the F9/F10/F11 buttons) is reacting faster and runs smoother with QE enabled. Also, the RSS Visualizer screen saver works now (it requires QE). So yes, video runs faster :blink: Allthough i didn't notice any big differences in XBench.

I get these blue squares which look like large pixels. Has anyone seen that before?

<{POST_SNAPBACK}>


The only thing ive noticed with QE enabled is that i get some errors in my console log when the RSS Visualizer is running:

2005-09-07 23:41:48.976 ScreenSaverEngine[470] *** <QCOpenGLContext = 0x003BD570 | renderer = Intel i830/i845 Engine (1.2 APPLE-1.4.0)>: Quartz Composer requires "GL_EXT_texture_rectangle" and "GL_APPLE_pixel_buffer" to be supported

However, my system is running stable as hell, even with these errors. Also, i see no glitches/artifacts whatsoever. RSS Visualizer is looking fine, too.

#13
bluedragon1971

bluedragon1971

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 696 posts
Thanks Milenco! Works great for me with my built-in video. QE working, but no CI (of course). My video scores in XBench actually outperform the baseline system in some areas.

#14
MACFiZ

MACFiZ

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I just dont get it, I'm using the 855 graphics chipset, same as the Dell 700m is using, and although I've followed the directions I get nothing but the stupid big blue square problem.

What is it you guys are doing to make it work?

#15
kaiwei

kaiwei

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
The same thing you did. You'll find that if you boot into windows first, then your OS X will work.

Conclusion, the Intel chipset's dynamic video memory is not allocating enough memory in BIOS to get QE. you need to boot into windows first to get the memory allocation then it'll work.

#16
Merlwiz79

Merlwiz79

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

I just dont get it, I'm using the 855 graphics chipset, same as the Dell 700m is using, and although I've followed the directions I get nothing but the stupid big blue square problem.

What is it you guys are doing to make it work?

<{POST_SNAPBACK}>


http://forum.osx86pr...wtopic=757&st=0
goldenarowana

#17
Zero

Zero

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Hum...
It seems not working on 855GM. Although the Device ID is the same, and I tried boot to Windows first,then OSX. It still not working. System Profiler said that Quartz Extreme is not supported. Is anyone using this chip and have a solution? (BTW, my Notebook is an Asus M2N, Centrino architecture)

#18
Milenco

Milenco

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

Hum...
It seems not working on 855GM. Although the Device ID is the same, and I tried boot to Windows first,then OSX. It still not working. System Profiler said that Quartz Extreme is not supported. Is anyone using this chip and have a solution? (BTW, my Notebook is an Asus M2N, Centrino architecture)

<{POST_SNAPBACK}>


You should ask kaiwei. He got it working with his 855. He said he made some modifications to a file, allthough i dont quite understand what he did exactly.

#19
kaiwei

kaiwei

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
What I did was to edit the plist.info in AppleIntelIntegratred.kext to match my device ID as stated in many threads here on the board. That's all. I can get QE only if i boot into windows first then start OS X. Sigh.

#20
Wipmac

Wipmac

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
someone said u need the latest chipset drivers for xp for the xp/osx86 switch "workaround" .. but it ISNT working for me (855GM on asus m2400n).

cheerio





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy