Jump to content

[GUIDE] Making a DSDT.aml for Dell XPS M1330, XPS M1530, and XPS M1730


  • Please log in to reply
1780 replies to this topic

#1301
G5rocks

G5rocks

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
  • Gender:Male
  • Location:Europe
I think the HD is the problem - it is one of the newer 4k sector size "Advanced Format" HDs

EDIT: indeed this was the problem. I just placed the original 250GB HD back into the M1530 and installed clover on it - works like a charm!

Now the question is has anyone got one of those modern drives working with clover and M1530?

#1302
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
http://www.insanelym...-way-to-fix-it/

install boot1h in binaries

#1303
immo

immo

    Insanely Looking for Time to Hack

  • Members
  • PipPipPipPipPip
  • 276 posts
  • Gender:Male
I suggest you try asking here for help:
http://www.insanelym...eral-discussion

Immo

#1304
G5rocks

G5rocks

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
  • Gender:Male
  • Location:Europe
Immo do you have Dynamic Acceleration activated in BIOS when using Clover? I am getting problems with sound when it is turned on (seems like a problem with the audio clock)

#1305
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida

Immo do you have Dynamic Acceleration activated in BIOS when using Clover? I am getting problems with sound when it is turned on (seems like a problem with the audio clock)

usualy IRQ removals and add 11 to HPET fixes it

slice just posted his inspiron 1525 config (intel x3100) but the rest should apply
http://www.insanelym...25-on-1075-plz/

#1306
apocalypse-666

apocalypse-666

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Hello all,

I am seeking help for my M1330 (with GMA 965 aka X3100). I am currently running 10.7.5 with these kexts http://www.osx86.net...nd_qe-c_...html

It is told that I needed to swith to 32 bit mode for this graphics card but when I do so, I experience black screen problem at the boot. 64 bit mode works but with an incorrect resolution.

Do you think that it is related to my DSDT? I am using the one named : DSDT_M1330_NVIDIA_ANYCPU_20111029.zip

#1307
DarwinX

DarwinX

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 619 posts
  • Gender:Male
  • Location:Florida

Hello all,

I am seeking help for my M1330 (with GMA 965 aka X3100). I am currently running 10.7.5 with these kexts http://www.osx86.net...nd_qe-c_...html

It is told that I needed to swith to 32 bit mode for this graphics card but when I do so, I experience black screen problem at the boot. 64 bit mode works but with an incorrect resolution.

Do you think that it is related to my DSDT? I am using the one named : DSDT_M1330_NVIDIA_ANYCPU_20111029.zip


Hello Satan. For your own benefit, please add your system specifications to your forum signature. Thank You.



#1308
apocalypse-666

apocalypse-666

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Hello Darwin,

I have several machines, the one I am currently trying set up is:

10.7.5 on Dell XPS M1330
CPU
: Intel Core 2 Duo - T7700
MEMORY: 4GB Dual Channel DDR2 SDRAM at 667MHz
VIDEO: Intel GMA965 (a.k.a. X3100)


#1309
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
x3100 is not supported past 10.7.x
slice has 1525 that has same x3100 and he uses 10.6.8
i sorta gave up on the x3100 a yr ago. (update and no video)

#1310
raimdal

raimdal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts
hi man ...I've made a real disaster with my kexts. can you upload for me the following? GeForce.kext, NVDAN50Hal.kext, NVDAResman.kext? thank you a lot....help please

#1311
raimdal

raimdal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts
please help, after updating to 10.8.3 i've used the patch for gpu power mananger but also installing the original kexts from the installer the boot stack after wireless or ethernet message...can you send me the kexts related in the previous post? please

I've also removed the kext for gpupowerm but nothing is changed, it doesn't boot, I'm writing from a copy backup of another hackintosh that boot with m1530 but without qe...also if I've changed dsdt and kexts in this usb backup but there is some other kexts that make this copy different and not installable into internal disk cause it had other kind of problems. help please

#1312
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
use pacifist to extract from .dmg (im on 10.7 so i dont have)

#1313
DarwinX

DarwinX

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 619 posts
  • Gender:Male
  • Location:Florida

hi man ...I've made a real disaster with my kexts. can you upload for me the following? GeForce.kext, NVDAN50Hal.kext, NVDAResman.kext? thank you a lot....help please



Here are all the NVIDIA [8.10.44] kexts from the OS X 10.8.3 along with the properly patched AppleGraphicsPowerManagement.kext:

Attached File  NVIDIA GeForce - 10.8.3 8.10.44.zip   7.02MB   64 downloads

#1314
raimdal

raimdal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts
thank you so much I'm fighting....

#1315
raimdal

raimdal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts
And the winner is MEEEE with a great help from mr DARWINX....you rule man!!! ;)

#1316
raimdal

raimdal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts
OOOOO noooo I've not trasparency....so I think no QE, I'm using your kexts and your dsdt from 10.7.4 and also your smbios and chaleon.org......is not possible I've not QE....this is a damnation.....

#1317
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
chameleon version ?

#1318
DarwinX

DarwinX

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 619 posts
  • Gender:Male
  • Location:Florida

And the winner is MEEEE with a great help from mr DARWINX....you rule man!!! ;)


No problem, I'm glad that it worked for you, I'm always happy to help when I can.

OOOOO noooo I've not trasparency....so I think no QE, I'm using your kexts and your dsdt from 10.7.4 and also your smbios and chaleon.org......is not possible I've not QE....this is a damnation.....


Perhaps you are missing the GeForceGLDriver.bundle which I didn't previously upload due to its large size which exceeds the forum's upload limit of 10 mb.
There is really no way of knowing your system's deficiencies without the kernel log output and other relevant diagnostic data.

#1319
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
upload 2 mediafire.com

#1320
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Long time ago I made a guide for installing Leopard on XPS-M1330, since I got real Macs and Mountain Lion on them, I left the forum before Snow Leopard appeared, now I trying to have Snow Leopard on my XPS, everithing works except audio and I am kind of lost. I tried VoodooHDA with no success, I am confused with the

HDEF patch, how do I make the patch or what do I need to install besides VoodooHDA?



Thanks, and excelent effort with the DSDT.



macgirl


--

Well I got sound but only in the Hearphone Jacks, speakers doesn't produce any sound at all.

Edited by macgirl, 16 April 2013 - 10:15 PM.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy