Jump to content

[AMD] Installing Snow Leopard 10A432 on AMD System


  • Please log in to reply
181 replies to this topic

#101
alex romania

alex romania

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
9/12/09 11:22:12 PM kernel ATA: Device wake up failed (0x09/12/09
11:22:12 PM kernel disk1s5: no such device.0000003), terminating device...
9/12/09 11:22:12 PM kernel NTFS-fs error (device /dev/disk1s5, pid 251): ntfs_mft_record_map_ext(): Failed to read buffer of mft record 0x2e (error 6).9/12/09 11:22:12 PM kernel NTFS-fs error (device /dev/disk1s5, pid 251): ntfs_inode_read(): Failed to map mft record.
9/12/09 11:22:12 PM kernel NTFS-fs error (device /dev/disk1s5, pid 251): ntfs_inode_read(): Failed (error 6) for inode 0x2e. Run chkdsk.
9/12/09 11:22:12 PM kernel NTFS-fs error (device /dev/disk1s5, pid 251): ntfs_vnop_lookup(): Failed to get inode 0x2e (error 6).


this is what im getting on my sata hdd which contains ntfs partitions, any clue whats this about ? the ext usb drive which is also formated in ntfs doesen't have any problems. I will try to do a chkdsk see if it helps.

later edit:

yea that was it, now it works well so never mind .

#102
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia
glad to hear that..

#103
dunkmaster

dunkmaster

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
no 64-bit kernel??? i'll wait a little bit

#104
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia
not yet...

#105
Subrat Nayak

Subrat Nayak

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Great work.....Just amazing....Thanks I finally load Snow Leopard and Every thing Work just Perfectly.....Thanks Again.....Posted Image

#106
G. Steel

G. Steel

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Its working for me Thanks!
use modbin test 7 kernel

#107
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia
nice.... glad that my guide can be usefull.....

#108
.__.

.__.

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Weird. This fixed it for me. What's the bug this is a workaround for?

I have 8GBs of RAM. Is that too much? :-)

Nope, nothing weird.
You are running Hac in 32-bit mode, thus user-space tools are limited with 4GB of address space.


Actually, this is fsck_hfs faulting on checks with RAM >4GB. And it fails only for the root partition.
Just boot in single-user mode and do:
# mv /sbin/fsck_hfs{,.orig}# printf '#!/bin/bash\nexec /sbin/fsck_hfs.orig -c512m "$@"' > /sbin/fsck_hfs# chmod +x /sbin/fsck_hfs#

Enjoy full RAM over 4GB!

#109
majinvegeta

majinvegeta

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

Nope, nothing weird.
You are running Hac in 32-bit mode, thus user-space tools are limited with 4GB of address space.


Actually, this is fsck_hfs faulting on checks with RAM >4GB. And it fails only for the root partition.
Just boot in single-user mode and do:

# mv /sbin/fsck_hfs{,.orig}# printf '#!/bin/bash\nexec /sbin/fsck_hfs.orig -c512m "$@"' > /sbin/fsck_hfs# chmod +x /sbin/fsck_hfs#

Enjoy full RAM over 4GB!


This not work for me... shutdown immediatly :P

#110
.__.

.__.

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

This not work for me... shutdown immediatly :D

Does manual checking in single-user mode work with 'fsck_hfs /dev/diskXsY'?
It should not now report a error like with 'fsck_hfs.orig /dev/diskXsY'.

#111
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
  • Gender:Male
Installation report:

Thanks for mach_kernel.test7, I could install Snow on some AMD motherboards, though I used Chameleon RC3.
Chameleon "GraphicsEnabler=Yes" works with GeForce 7600/8600/9500/9600.
Radeon 2600XT works when device-propertis is set and X2000.kext is removed.

"GraphicsEnabler=Yes" works.
Asus M4A78 Plus
Gigabyte GA-MA770-DS3, AHCI
Gigabyte GA-MA78G-DS3H, AHCI

"GraphicsEnabler=Yes" does not work and device-properties was needed.
Gigabyte GA-M720-US3, AHCI ( because PCIe is attached to PciRoot(0x0)/PCI(0x10,0x0) ? )
--- edit ---
DSDT is PciRoot(0x1)/PCI(0x10,0x0) and fixed by DSDT patch. - Thanks to Kabyl.

I installed all of them on working 10.5.x.
As I attach USB audio, I do not patch DSDT for sound.
VoodooPower (AMD patched) works . All the CPUs are K10 (Phenom, Athlon II) and arch=i386 (32 bit).

#112
John K.

John K.

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Penang, Malaysia

Well I got the graphics working good but the internet is still dragging quite bad. Im using a netgear ethernet card because on leopard the built in nforce ethernet had problems running.


hey CrimsonAngel, u can use a gigabyte card. It's more compatible :(

nice.... glad that my guide can be usefull.....


Hey Arya, after I install SL, can I use back my own DSDT.aml (from 10.5.6) or do I need to search for a new DSDT?

#113
amador

amador

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Gender:Male

Updated to 10.6.1

Posted Image



Bro, would you mind make a step by step installation procedure on how to run snow leopard on AMD system.
if you could also please include in your guide the kext needed and some of the files like boot file etc,it alot easier to get the files via mediafire than rapidshare. it will be a great help for most of the people here using AMD system ..

thanks alot for your help :)

#114
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia

Bro, would you mind make a step by step installation procedure on how to run snow leopard on AMD system.
if you could also please include in your guide the kext needed and some of the files like boot file etc,it alot easier to get the files via mediafire than rapidshare. it will be a great help for most of the people here using AMD system ..

thanks alot for your help :)


installation process in in 1st post..

#115
CrimsonAngel

CrimsonAngel

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male

Bro, would you mind make a step by step installation procedure on how to run snow leopard on AMD system.
if you could also please include in your guide the kext needed and some of the files like boot file etc,it alot easier to get the files via mediafire than rapidshare. it will be a great help for most of the people here using AMD system ..

thanks alot for your help ;)

lol, you're not serious?

#116
GFOnyX

GFOnyX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 133 posts
  • Gender:Male
I made it too on AMD old school hardware :thumbsup_anim:

Here are the specs

AMD A64 3000+
ASUS A8N SLi Deluxe
nVidia 6600GT
SATA HD & DVD


Everything is working fine as fas as i can tell.I also edited my dsdt to get rid of the cmos reset and replaced APplenforceATA to make my sata dvd recorder work properly.Everything else (sound,graphics,internet etc) worked from leoaprd installation packages.

Everything is really really fast and responsive.i also updated to 10.6.1 and i must mention that from the moment i booted i have not got not a single KP screen.

I have been completely Snow Leopardized since 10.6.1 is runnin on my intel laptop too.

Attached Files

  • Attached File  3.png   1.7MB   36 downloads


#117
loungefly

loungefly

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hey,

For those that can't go beyond the kernel panic, maybe what happened to me may help.

I have 2 HDs (3 actually, but only 2 matter here).
On the 1st one I have Leopard installed and running well, with Chameleon.
On the 2nd drive I installed Snow Leopard, the "boot" file, the kernel and Chameleon as well.

I was getting a kernel panic because I was actually booting from HD #1, and then in Chameleon I selected the Snow Leopard HD. The thing is, when you do this, the modified "boot" file won't be read/used, and hence Snow Leopard won't run.

What you have to do is to make sure you boot from the appropriate disk, even if you have a boot loader such as Chameleon installed in another HD.

Once I selected the appropriate HD at boot time (in my case, F8 at boot), Snow Leopard finally loaded.

Though, and I have a problem and I hope someone can help me with this:

For some reason, whenever I boot using the modified "boot" file, my BIOS settings get reset to the defaults. Any ideas why this can be happening and how to fix it?

EDIT: Nevermind, I just read about this problem and fixed it with a modified dsdt.aml

BTW, XNU sources are released already:
http://opensource.ap.../xnu-1456.1.26/

#118
Maniac10

Maniac10

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 972 posts
  • Gender:Not Telling
@GFOnyX

I have a very similar pc, athlon 64 3000+ asus a8n-sli, nvidia 8400GS. Everything is working like on the old 10.5.8 leopard but I'm having a small problem with the sound. I can't change the volume from the slider or with my keyboard, when I move the slider, it goes back to it's position. Also it's really strange that I can use the slider from the audio preferences :o.

Could you try and tell me if that works for you? Also, could you upload your audio kext?

#119
G. Steel

G. Steel

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
A couple of problems so far to with Energy Saver:

1. System does not wake up from sleep at all
2. When the monitor goes to sleep it comes back in 800x600; the option list does not show 1600 x 900, though it shows many other incompatible resolutions

non-optimal Workaround: set Energy saver to never sleep

Does anybody have a solution? What should I try next?

Thanks!

--g

#120
InhumanElmo

InhumanElmo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I tried installing on my laptop, but everytime i boot up wit -x32 -v It stalls at "com.apple.AppleFSCompressionTypeZlib load succeeded". I tried dropping the hdd into my desktop and chameleon doesn't even show and my computer just reboots. help?

Laptop:
Toshiba Satellite L305D-S5900

Desktop:
CPU: AMD Phenom II x4 940
Mobo: Asus M4A78 Pro
Ram: 8 Gigs Corsair XMS2 800 mhz
Video Card: ATI Radeon HD 4670





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy