Jump to content

Marvell Yukon 8001 - the driver


  • Please log in to reply
406 replies to this topic

#401
ADMiNZ

ADMiNZ

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Moscow
D-Link DGE-530T and OS X Lion 10.7.1 All that I have tried does not work :D How to start it?

#402
Bansaku

Bansaku

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
  • Gender:Male
  • Location:Edmonton
  • Interests:Lots

The attached skge.kext works for me on 10.7 in arch=i386 installed in /S/L/E.
skge.kext_02g_release.zip = Release build 10.6 & 10.7, arch = i386 & x86_64.
skge.kext_02g_debug.zip = Debug build 10.6 & 10.7, arch = i386 & x86_64.
The instructions are the same as the first post for installation.

Changes to the Info.plist to allow loading on 10.7 otherwise I got:
11/08/11 2:27:31.000 AM kernel: kxld[com.musashi.skge]: ___stack_chk_fail
11/08/11 2:27:31.000 AM kernel: kxld[com.musashi.skge]: ___stack_chk_guard

The main alterations are com.apple.kpi.*

<key>OSBundleLibraries</key>
<dict>
<key>com.apple.iokit.IONetworkingFamily</key>
<string>1.0.0b1</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>1.0.0b1</string>
<key>com.apple.kpi.bsd</key>
<string>8.0.0b1</string>
<key>com.apple.kpi.iokit</key>
<string>8.0.0b1</string>
<key>com.apple.kpi.libkern</key>
<string>8.0.0b1</string>
</dict>


So I got the next to show in the kernel log. Seems my D-Link DGE-530T. Seem that it has a different device ID (0x43021186 vs 0x4C001186), hence why I could not get the next to show in post. However, the card will not work.

Sep 11 20:12:20 Bansakus-iMac kernel[0]: skgeosx: SKGE for OSx86 v0.2e ---- M.Musashi ©2007
Sep 11 20:12:20 Bansakus-iMac kernel[0]: skgeosx: VendorID:1186 DeviceID:4302 Rev:10
Sep 11 20:12:20 Bansakus-iMac kernel[0]: skgeosx ERR: unsupported chip type 0x47
Sep 11 20:12:20 Bansakus-iMac kernel[0]: skgeosx ERR: board reset failed
Sep 11 20:12:20 Bansakus-iMac kernel[0]: skgeosx: Stopped!

#403
ADMiNZ

ADMiNZ

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Moscow
Who realties managed to run the D-Link DGE-530T on OS X Lion ?

#404
driver69

driver69

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Gracias ¡¡¡ 88e8001 on 10.6.8

#405
claros.it

claros.it

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Who realties managed to run the D-Link DGE-530T on OS X Lion ?


Followed the kimnzl instruction to modify info.plist according to my os version (lion 10.7.2) and solved a kernel panic on startup.
Attached is my modified kext, use kext helper to install on S/L/E.

BUT THE ADAPTER WORKS VERY BADLY AND VERY SLOWLY

Still trying another solution...

Ciao

Attached Files



#406
vamose

vamose

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
DGE-530T with a Marvell Yukon 88E8001 chipset - drivers for El Capitan - 10.11 
 
The system is abl to pick up the network card, but constantly assigns self IP, and I am unable to move forward.
 
HAve delete the firewall files, network cache files etc.
 
Any help witll be appreciated. The SKGE.kext driver worked perfectly fine in Yosemite, 10.10.5
 


#407
uusseerr

uusseerr

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
My board is P5Q-E with 2 LANs. One is 88e8056, another is 88e8001. The 8056 works while 8001 not yet. I downloaded the source code of skge_02g_source.zip from here. In xcode after checking deployment target 10.11 and build, a lot of warnings and a few errors. By autofix in xcode, it can easily finish building. Putting the kext built from xcode in EFI/clover/kext/10.11, uncheck fix LAN, the 8001 works in 10.11.3. I upgraded to capitan 10.11.6, it still works! I am happy both LANs working. I did not test the performance because I use 8056 as main LAN. Great appreciate this source code and effort from pioneers! I attached the kext. You may need enable untrusted kext be loaded to the kernel to make it work. No guarantee and support. You may choose build it by yourself.
oops, the attachment here.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy