Jump to content

Driver for Laptop Card-Readers (Internal PCI Bus)


  • Please log in to reply
152 replies to this topic

#41
tivimac

tivimac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Gender:Male
  • Location:Dominican Republic
The new version (v3) works without problems (you'll have to change the id on the kext though)

To Do for this kext: Memory Stick/XD

Also with this revision, is possible to boot with with the SD Card inserted.

#42
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,978 posts
  • Gender:Male
  • Location:Moscow

I test this new release here are results:

1.- Minimum Processor usage (less 10%)
2.- Double speed rate (read/write)
3.- Support SDHC Cards (Still no tested)

I used the Xbench v1.3 Application below some screenshots

Attach the new release with string 0x08221180 already changed.



Thanks to all developers for this great work.

Thank you for this! Works fine!
Read ~ 1,65Gb @ 160sec Write 32Mb @ 5 sec.
I think you need to update the topic.

#43
aliasa_anderson

aliasa_anderson

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts

Thank you for this! Works fine!
Read ~ 1,65Gb @ 160sec Write 32Mb @ 5 sec.
I think you need to update the topic.



I dont know why but it doesnt seem to work for me!!!
When i reboot after changing perm/ownerships,deleting the mkext and doing kextcache -k /S/L/E .
I find that the meaasges during verbose scroll slowly,then i get IOKitTimeouts and black screen only,i had to remove the kext.I used the kext with 0x08221180.
Am I missing something ?

:unsure:

#44
hackinthebox

hackinthebox

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Im getting almost the same problem... I'm getting these messages:

class "AppleEHCIedMemoryBlock" is duplicate
Duplicate class
kmod_control/start failed for com.orByte.driver.PCGenUSBEHCI; destroying kmod
Failed to load extension com.orByte.driver.PCGenUSBEHCI.
Class "AppleEHCIedMemoryBlock" is duplicate

I can't find a duplicate kext, and everything seems to fail after I load the iosdhciblockdevice kext...
I have to go into -s mode, delete kext, clear extensions cache and then reboot, otherwise
I get a blue screen forever and evers. Can someone help meeee??

I don't know what I'm doing wrong... here is my output from lspci if it helps:

00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)
00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 0c)
00:19.0 Ethernet controller [0200]: Intel Corporation 82566MM Gigabit Network Connection [8086:1049] (rev 03)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 [8086:2843] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 [8086:2845] (rev 03)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 [8086:2847] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller [8086:2811] (rev 03)
00:1f.2 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller [8086:2828] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 03)
03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5212 802.11abg NIC [168c:1014] (rev 01)
15:00.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev ba)
15:00.1 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 04)
15:00.2 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 21)
15:00.3 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 11)
15:00.4 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 11)
15:00.5 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 11)

#45
gondor69

gondor69

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi, tried it with:

07:06.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
07:06.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
07:06.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]

No success so far...

#46
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,978 posts
  • Gender:Male
  • Location:Moscow

class "AppleEHCIedMemoryBlock" is duplicate
Duplicate class
kmod_control/start failed for com.orByte.driver.PCGenUSBEHCI; destroying kmod
Failed to load extension com.orByte.driver.PCGenUSBEHCI.
Class "AppleEHCIedMemoryBlock" is duplicate

Don't use com.orByte.driver.PCGenUSBEHCI. It is too old! And conflict with AppleUSBEHCI.kext.
Both located in IOUSBFamily/Contents/PlugIns/

Hi, tried it with:

07:06.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
07:06.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
07:06.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]

No success so far...

This kext is not for Texas, only for Ricoh.

#47
Boombeng

Boombeng

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:France
Thanks!

I confirm it works now with SDHC (tested with 4GB EMTEC class 4)
When i boot with a card in, i can not unmount it

SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 22)
System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 12)
System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 12)
System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 12)

#48
gondor69

gondor69

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Don't use com.orByte.driver.PCGenUSBEHCI. It is too old! And conflict with AppleUSBEHCI.kext.
Both located in IOUSBFamily/Contents/PlugIns/


This kext is not for Texas, only for Ricoh.


And there's no way to adapt it to Texas, right??

too bad...

#49
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

And there's no way to adapt it to Texas, right??

too bad...


Yeahh! Too bad.... :blink:

Can we add vendor & device id for Texas Instrument card reader in the source code & compile it? Or do we need know more like memory address used by the device?

kizwan

#50
Cris900

Cris900

    iDeneb Team Maker

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,246 posts
  • Gender:Male
  • Location:Teramo
this driver work with this
PCI\VEN_1180&DEV_0822&SUBSYS_01211025&REV_22
PCI\VEN_1180&DEV_0822&SUBSYS_01211025
PCI\VEN_1180&DEV_0822&CC_080500
PCI\VEN_1180&DEV_0822&CC_0805
?????
My notebook is Acer Aspire 5920G....thanks

#51
MiniBUU

MiniBUU

    Inspiron 1525 User

  • Members
  • PipPipPip
  • 104 posts
  • Gender:Male
  • Location:New Jersey (U.S.A.)
Just installed the latest drivers on my Dell Inspiron 1525 and glad to say I can now see my 4gig sd card with no problem. Thanks a million quinielascom for the find and efforts to bring this project to light.

#52
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Thanks, will test, although my SD card is not HC :)

#53
nvanberkel

nvanberkel

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Only tested SD Card, working on HPDV6700. Thanks!

#54
BenJii

BenJii

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Just Tested SD cards and SD-HC cards, and working realy fine on Hp Dv2500..... Thanks so much ciao

#55
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Still no luck, everything freezes when I insert the SD card :(

#56
djmastera2000

djmastera2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts

Still no luck, everything freezes when I insert the SD card :D


Same here...:( Which IOPCIFamily do you use?

#57
Boombeng

Boombeng

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:France
I use the original 10.5.6 IOPCIfamily and the driver works well with SD and SDHC, i just tested the latest version with sleep support (needed to edit device in plist) and still working well...

#58
djmastera2000

djmastera2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
"Final" Candidate 1 released: http://sourceforge.n...lease_id=651471

Not tested yet...

#59
Boombeng

Boombeng

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:France
I didn't test neither, but they don't tell what is the new stuff in it... a surprise ? :lol:

#60
djmastera2000

djmastera2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
Sorry, didn't find any changes yet... :wacko:

But with this version still freezes if card inserted, used with last chunnans' iopcmciafamily.kext.
With vanilla iopcifamily(leo 10.5.6) no boot(freez, no crash, no errors) with no card inserted!

I don't know why it freezes...:(


PS: Pre-patched fc1 version with 0x08221180 id attached.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy