Jump to content

AppleHDA for ALC269VB (10.9 GM + ML 10.8.4) 2.5.2fc2 + 2.3.7fc4

File Information

  • Rate File: * * * * * 1 Votes
  • Submitted: Oct 07 2013 03:40 PM
  • Last Updated: Oct 11 2013 03:20 AM
  • File Size: 2.1MB
  • Views: 10602
  • Downloads: 1,365

Previous Versions

  • 07 Oct 2013 Download AppleHDA for ALC269VB (10.9 GM) 2.5.2fc2

Download AppleHDA for ALC269VB (10.9 GM + ML 10.8.4) 2.5.2fc2 + 2.3.7fc4



Screenshots
AppleHDA ALC269 Mavericks 10.9 Mountain Lion 10.8

Codec: Realtek ALC269VB
Address: 0
Vendor Id: 0x10ec0269
Subsystem Id: 0x10431517
Revision Id: 0x100100
Device (HDEF)
            {
                Name (_ADR, 0x001B0000)  // _ADR: Address
                OperationRegion (HDAR, PCI_Config, 0x4C, 0x10)
                Field (HDAR, WordAcc, NoLock, Preserve)
                {
                    DCKA,   1, 
                    Offset (0x01), 
                    DCKM,   1, 
                        ,   6, 
                    DCKS,   1, 
                    Offset (0x08), 
                        ,   15, 
                    PMES,   1
                }

                Method (_PRW, 0, NotSerialized)  // _PRW: Power Resources for Wake
                {
                    Return (GPRW (0x0D, 0x04))
                }

                Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                {
                    Store (Package (0x06)
                        {
                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                                "onboard-1"
                            }, 

                            "layout-id", 
                            Buffer (0x04)
                            {
                                 0x1C, 0x00, 0x00, 0x00
                            }, 

                            "PinConfigurations", 
                            Buffer (Zero) {}
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }
            }
Not wok, try to patch HPET:
                    Name (_HID, EisaId ("PNP0103"))  // _HID: Hardware ID
                    Name (_UID, Zero)  // _UID: Unique ID
                    Name (BUF0, ResourceTemplate ()
                    {
                        IRQNoFlags ()
                            {0}
                        IRQNoFlags ()
                            {8}
                        IRQNoFlags ()
                            {11}
                        IRQNoFlags ()
                            {15}
                        Memory32Fixed (ReadWrite,
                            0xFED00000,         // Address Base
                            0x00000400,         // Address Length
                            _Y10)
                    })


Screenshots

Screenshots


Hey thanks for this. Didn't think it would because I understand there is slight different versions of ALC269, anyways thought I would give it a go. I did have everything working within 10.8 apart from my microphone with a custom patched AppleHDA.kext, however this does not work inside of Mavericks. I tried taking the layout28.xml.zlib out with some others from the patched one and inserting into the updated AppleHDA.kext, but I only managed to get Speakers working.

 

I installed your kext just to try it out, and seems everything is working fine, I've tested, Speakers, Microphone, Headphones. I will try the others later on, but it seems its working fine for me. 

 

I have Intel HD3000 so I need to patch AppleIntelSNBGraphicsFB.kext but I took the file from my patched one and inserted into the updated Mavericks one. I am yet to test it though. Would be good if you could patch that too and create a package with along with this AppleHDA.

 

Thanks a lot for this. Will look forward to upcoming Mavericks updates with your patched kext.

 

EDIT: Just checked my current patched AppleIntelSNBGraphicsFB.kext (moved the patched files into Mavericks kext) and I get display but no sound. HDMI audio does not show up in System Preferences > Sound. Here's the thread http://www.insanelym...-on-other-kext/

Sorry, I dont have HD3000 for test. Try this guide, it should work.

 

http://forum.osxlati...tel-hd3000-gpu/

my netbook Asus A43SV AppleHDA.kext work,but mic No work

@iaihc: Old version Mic In not work. Try to download new version.

i have an error on this line when I compile the dsdt "Return (GPRW (0x0D, 0x04))"

object GPRW doesn't exist

i have an error on this line when I compile the dsdt "Return (GPRW (0x0D, 0x04))"

object GPRW doesn't exist

Try add Method (_DSM, 4, NotSerialized) only.



@iaihc: Old version Mic In not work. Try to download new version.

Hi, with the old version my Mic work perfectly, but with new version it does not work, can you share the patching info with me for future updates? 

 

Also I got my HDMI audio working, it seemed that the AppleHDA you uploaded was patched correctly. I just removed the file inside of my already patched 10.8.2 AppleIntelSNBGraphicsFB.kext and pasted it inside of the new vanilla 10.9 kext. 

Here it is if anyone wanted it: http://www.insanelym...kext/?p=1954651

Hi, with the old version my Mic work perfectly, but with new version it does not work, can you share the patching info with me for future updates? 

 

Also I got my HDMI audio working, it seemed that the AppleHDA you uploaded was patched correctly. I just removed the file inside of my already patched 10.8.2 AppleIntelSNBGraphicsFB.kext and pasted it inside of the new vanilla 10.9 kext. 

Here it is if anyone wanted it: http://www.insanelym...kext/?p=1954651

You can follow this guide to patch. Old version i get from here, the new version i repatch to matched with my card. Each codec has many revisions, so nodes can vary.

http://forum.osxlati...patching-guide/

 

Script to patch AppleHDA:

http://www.insanelym...8109/?p=1953762

Hi, I have 10.8.5 , will this kext work for me as i am really trying to make my audio work for 4 days now :( but i am not getting it to have sound or mic at all :(

GOOD JOB, i have the same audio card with you, i manage it work by using 2.1.7, but can't make it works under 2.3.7 (ML 10.8.3). 

Try the way you have done, it works like a charm both output and input. 

THX mate.


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy