Jump to content

ASRock 4CoreDual-VSTA, 4CoreDual-SATA2, 4CoreDual-SATA2R2, 775Dual-VSTA, 775Dual-880Pro

22 posts in this topic

Recommended Posts

Just thought I would start a new thread to collect all information on installing OSx86 on ASRock mobos.

I myself have the 4CoreDual-SATA2 and I am interested in info from other users of these boards that use mostly the same VIA chipsets:

ASRock 775Dual-VSTA, 4CoreDual-VSTA, 4CoreDual-SATA2, 4CoreDual-SATA2R2, 775Dual-880Pro


Why use ASRock when it can't even run the vanilla kernel?

1. Reputation for reliabilty.

2. Great for reusing old parts (20pin PIII PSU can be used, AGP video cards, 2 IDE bus, cheap Celeron D)

3. Good for slowly upgrading to newer parts (PCIe 16x video cards, 2 SATA bus, Quad Core2 support)

4. The boards themselfs are fairly inexpensive.

5. They have their own built in boot menu (at least my 4CoreDual-SATA2 does). Press F11 at powerup.


Needed patches:

TheStevo4 patch works well on Kalyway 10.5.1 for fully supported (at least for 775Dual-VSTA) SATA/ATA, Sound, LAN

TheStevo3 patch works on top of Brazil patched 10.5 retail

TheStevo2.1 patch works on Uphuck 10.4.9 1.3r1 (if you can find it still seeded anywhere?)

There are individual patches that can be manually integrated with JaS 10.4.8 available.


My motivation:

I installed Kalyway 10.5.1 w/Stevo4 on my 4CoreDual-SATA2 and all went well except for video.

I have an MSI NX 7300 LE PCIe video card but I can only use VESA video (no QE/CI) even though it is listed as working in HCL_10.5.x

I think I've tried every trick out there (added vend/dev ids to extentions, used Natit, Titan, NVInject, added GFX strings, permissions all set correctly).

Nothing seems to work!

After the grey Apple logo, my screen goes black!

There is at least one other user here that is having the same problem with a 4CoreDual-VSTA and 7300 LE.

Is there some BIOS setting we need to change?

Does anyone with any of these boards have a fully working (QE/CI) video card on 10.5.1?

If so what model & brand.

What BIOS version is on your motherboard? What BIOS Settings are you using?


Any info for using these with OSx86 would be appreciated.

For instance:

I had to turn on "Legacy USB support" in BIOS for USB to work properly.


Links to relevant patches:

Thread about manually patching JaS 10.4.8

775Dual-VSTA PPF for JaS 10.4.8 w/ppf1

775Dual-VSTA PPF v2.1 for Uphuck's v1.3

theStevo v3.0 PPF for BrazilMac patched 10.5.0

theStevo v4.0 PPF for Kalyway 10.5.1

theStevo v4.5 PPF for Kalyway 10.5.2 (full ISO not the update)

Thanks theStevo!


Links to ASRock pages on the wiki site:




I hope this thread will be a useful and unified thread for these fine ASRock boards.



Link to comment
Share on other sites

  • 3 weeks later...

MSI NX 7300 LE PCIe was no good (at least with my ASRock mobo).

Also, there are several versions of this card so your results may vary.

I would avoid the 7300 LE if you are purchasing a new card and get the GS or GT instead.

Link to comment
Share on other sites


i have a mobo AsRockcoredual-vsta(with good BIOS setting, HPET table enabled), with one ide drive and two ide optical drive. (and E4400 o/c, 2gb ram pc5300, geforce fx 5700VE)

i used kalyway 10.5.2 patched with TheStevo 4.5 patch.

i had a lots of problems :

I had to move my windows partition to the right of the disk (using Gparted) and create my leopard partition on the left of the windows partition.(if I didn't do that it didn't work, probably because of primary partition and logical partition or something like that, i didn't understand)

so then i booted from DVD, it worked fine, i formated my partitions to HFS+ (non-journalized, about 10GB) and my selection of package during install was : kernel : default (all are installed by default)

graphic : i choosed nvinject 256mo as i have a 256mo graphic card

network : i didn't choose wifi carf because i haven't one, but i let selected the network card driver that were selected (maybe it's an error from me, tell me plz)

mobo chipset : i let selected all the packages here because there were selected by default (maybe it's an error too, tell me plz)

i didn't select jas 10.4.8 packages

i didn't select AMD packages

i selected TheStevo patch

for the audio i let selected the packages that were selected by default(i had no sound so i did a mistake here but i have an external sound-card so it doesn't matter)

and i think that's all, install worked fine

i rebooted, i removed the DVD from the drive, i typed -v at the boot, it booted fine, i saw the welcome video (very nice), i created my account, etc..., all worked fine, i discovered the desktop (fantastic), i tried to connect to internet, it worked. BUT i had to go away for a meeting, so i let my computer powered on. And then when i came back my computer was block on sleep -.-

so i rebooted, i typed -v, and i had the "still waiting for root device " error, because of something like VIAATA and VIAsomething were blocking something (i don't remember well).

so i booted from a linux live cd, i googled this error, i found no solutions (tell me if you have infos )

i tried to boot with several option like -s, -x, kernel=sleep, kernel=nforce, but it didn't work, finally i booted with "-v -s -x kernel=vanillakernel", i had to write something (-fy, -uw, mount , i don't remember well) and it booted fine, so i was back to my desktop.

i tried internet, it worked fine, but about 30min later internet disapeared ( i think it's the "ethernet drop" bug in kalyway 10.5.2)

i entered in sleep mode to see if it worked fine , it didn't, it were blocked in sleep, so i have reset.

next time i booted with only the -v flag, it booted fine (oh!) but a message box told me via rhine extension couldn't be used because it weren't installed fine, i tried to reinstall with kexthelper but i couldn't. i had no internet so i rebooted, and HERE is where i am now, i get only a blank cursor at the boot, no ways to select an OS-.-

here i'm writing from my linux live cd, asking help.

so plz tell me which packages you selected and how you installed it...

i think that i let selected too much packages and there were conflict between them, but i'm not sur about it...

thanks for help me

Link to comment
Share on other sites

  • 3 months later...

Hi, I tried to intall Leo 10.5.1 but I always get a reboot while loading the files for the installation ("-v"). Then I tried to boot with a modified Stevo4 iso, but it just did not boot from it. So I read read and read and tried to install with tohkernel, but he does not except it and makes nothing. How can I solve my prob?


My system:


Intel 2 Dual Core E6750


ATI X1950Pro (AGP)

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...

My experience with an ASRock 4CoreDual-Sata2


I have had experience with installing Winblows for 10 years or so. After I bought an iPhone I found myself longing for the Mac experience. A friend had recently installed kallyway so i quickly bought an SSE3 cpu along with a mobo and some ram.


I had tried to install kalyway 10.5.2 about 8 times without success. A fresh install with no changes to default selections of patches and kernels had OS X up and running. :( Used isusbfamily thing to get USB working propperly and simply got the graphics working with nvinject 256.


I had everything working (didnt try sleep [no need]) but after a while it started to randomly freeze. After hours of searching through the forums I tried a few things with no joy. In the end I decided to download iDeneb v1.3 10.5.5 to see if that was any different. Unfortunately that did not work, I got as far as apple logo with no-entry sign, and with various different selections in install, gave different errors. After about 18 tries I gave up with 10.5.5 and tried Kalyway again. Oh dear, more problems. This time it would loop the welcome screens, I searched the forums and found nothing was fixing the problem. With great dissapointment I gave up and installed XP. :)


In the next couple of weeks I will try again but with a Hitachi Deskstar 500GB SATA drive and a Pioneer SATA DVD+/-RW DL drive. Im stuck running Winblows for now.


The Specs:


Intel Pentium Dual Core E2200 2.2GHz

Value Crucial 667MHz DDR2

ASRock 4CoreDual-Sata2 (with bios downgraded to v1.9)

2x 40GB Seagate Barracuda IV ATA Drives and 1x 60GB version (the OS Drive)

Gainward nVidia GeForce 7600GT AGP Golden Sample

(borrowed for internet) Netgear WG311T WiFi card (had to do diagnostics every reboot for wifi to connect)


Im not giving up that easy! The amount of Ball-Ache ive had with Winblows in the past has makes me want OS X more! I will be trying again with a 500GB SATA hard drive and a SATA DVD Drive plus a Dabs Value WIFI Card that is apparently Mac Compatible.




PS. First post on here

Link to comment
Share on other sites

  • 3 weeks later...

Just an update...


I now have Kalyway 10.5.2 running fine (-wifi) on a 40gb IDE drive (named MACOS), also XP SP3 on a seperate 60gb IDE.


My 500gb SATA contains 4 parts. MACOS2 is the first part and formatted to Mac OS X Journaled, which I intend to put iDeneb 10.5.5 (v1.3) on, or iPC 10.5.6 when it finishes downloading.


My IDE Kalyway is fine working with SATA after adding kexts (both the HDD and the DVD) and have tried using this OS to install Kalyway and iDeneb onto my SATA, Kalyway wont install through the OS (random install menu loop), but iDeneb does, although I cannot get it to boot fully.


If I try to install Kalyway or iDeneb the usual root it just wont boot the disk, not having SATA support for my ASRock board I guess. I have tried to patch the ISO's but without success.


Specs now:


Intel Pentium Dual Core E2200 2.2GHz

2GB Crucial Value 667MHz DDR2

ASRock 4CoreDual-Sata2 (with bios downgraded to v1.9)

60GB Seagate Barracuda IV IDE - XP SP3

40GB Seagate Barracuda IV IDE - Kalyway 10.5.2

40GB Seagate Barracuda IV IDE - Files

500GB Hitachi Deskstar P7K500 SATA - Partitioned:

-1 100GB - Mac OS formatted

-2 150GB - Files

-3 150GB - Files

-4 65GB - Music

Gainward nVidia GeForce 7600GT AGP Golden Sample

Belkin F5D7000 v6000 - Not working on OS X


Still waiting for Mac Compatible WiFi card to arrive through the post...




Finaly got iDeneb working, only in safe mode tho.


patches/kernals/fixes/chipsets used :


- 9.2.0 sleep kernal

- selected all the chipsets

- only smbios 667mhz in fixes

- alc 889 audio

- broadcom wifi

- all apps except firefox, irc and IM apps

- fonts and x11


main thing that got it working was not selecting video drivers or usb fix

Link to comment
Share on other sites

Okay, iDeneb was being a pain so I used my 500gb for 3 parts Win XP SP3 Corp, Files, and Music.


Literally 1 hour ago iPC OSx86 10.5.6 had finished downloading and so I installed it via my Kalyway 10.5.2 instalation onto another 40GB IDE drive.

I selected 9.4.0 StageXNU Kernal and SMBIOS 667, nothing else selected apart from a load of apps. Took a bit longer than iDeneb did to install, installed fine, loaded into the welcome with no welcome loop as I had experienced with iDeneb and Kaly.


So far I am pleased with how easy this install went. All I have to do now is to install Audio, Video and mabe SATA, along with checking the USB's and eventualy overall stability.


its looking like iPC is "The One"...




Oh yea, when I was re-aranging my hdds in my case, I noticed that some drives were set as cable select, and some were set as Slave. This could have been the cause of my problems with previous attempts. (not being stupid, I had understood that jumpers could have been an issue, but just ruled them out because I was sure they were all set as cable select).

Link to comment
Share on other sites

  • 5 months later...

ooohhhh what the hell



Did Bios update to 2.30 official one and updated to 10.5.7 aaaaaaannnnnnnnddddd know it comes



IT RUNS VANILLA KERNEL ... first time ever.. know the only thing is the 4x pciE graphic port.. my Asus Magic Silent 3650 512mb ddr2 resist to work...




Link to comment
Share on other sites


I have almost everything running very well.

My specs are:

4coredual-VSTA 2.30 bios HPET & XD on

Pentium D 930 @ 3.0ghz

2048mb DDR2 667mhz Dual Channel


Kalyway 10.5.2 + TheStevo 4.5 patch

Had to install another viarhine.kext because the one from TheStevo patch didn't work.

First boot didn't work so i rebooted with -v and had to do "mount -uw /" & "/movevideodrivers"

Now it boots but i can't change resolution & activate CI/QE.

I tried several kext and injectors for my MSI 8500GT 256mb video card without success.

Had to remove them to have a funcional desktop.


I think the only problem with this mobo is the pci express slot being only 4x.

When i boot with a nvidia driver it freezes with those messages:

NVDA::start(PCE1) <1> failed

PCE1: family specific matching fails

Anyone had success having CI/QE on this board with a PCIE card ?

Link to comment
Share on other sites

  • 3 weeks later...

Has anyone gotten an nvidia pci express card to work on any of these motherboards? I'm having the same video problem everyone else is reporting. I'm using a 4CoreDual-SATA2 with iPC 10.5.6. Any help would be sweet.

Link to comment
Share on other sites

  • 2 weeks later...

I have a 775VSTA Asrock board, running Kalyway 10.5.2




I plan to go to 10.5.6 with iPC.  


I am using SATA drives though.  According to the post above, " 9.4.0 StageXNU Kernal and SMBIOS 667, nothing else selected apart from a load of apps." should work for me?  Or do I need to select something else for SATA?  




Tips welcome!

Link to comment
Share on other sites

ooohhhh what the hell

Did Bios update to 2.30 official one and updated to 10.5.7 aaaaaaannnnnnnnddddd know it comes

IT RUNS VANILLA KERNEL ... first time ever.. know the only thing is the 4x pciE graphic port.. my Asus Magic Silent 3650 512mb ddr2 resist to work...




where is this bios ive been looking to know avail , i got the same pci video problem i just got a bfg 260 216 goes black right after boot. worked fine till i installed the drivers , my 1900 pro agp died so i though i did better lol


where is this bios ive been looking to know avail , i got the same pci video problem i just got a bfg 260 216 goes black right after boot. worked fine till i installed the drivers , my 1900 pro agp died so i though i did better lol


i just saw we don't have the same mother board all though when i first got it i was using the bois from ur board i will have to see if it still dose

Link to comment
Share on other sites

  • 2 months later...

Sorry all,

I kind of abandoned this thread after getting my 4CoreDual-SATA2 running well (10.5.6), selfish I know. I also got an MSI Wind and have been tweaking OSX on that, and keeping the ASRock as my stable workhorse.

I believe I used all update packs after Kalyway 10.5.2. I bought an ASUS NVidia 7300 and used the latest NVInject to get fully accelerated video and just used theStevo's KEXT packs and ALC888 (older 6 port version) after each update. It's been running great since with working Sleep, USB, etc... But I'm thinking of updating soon.

Going to 10.5.8 and I might even try snow leopard on another drive.

Link to comment
Share on other sites

I too left this thread a long time ago, but that was because i ditched the mobo and got something more OS X friendly! this board is 10.5 capable, but i could never get it 100% stable.


Anyways P5QL-Pro FTW, they must be pretty cheap now!


Good luck to all those who keep on ASRockin'

Link to comment
Share on other sites

  • 2 weeks later...

After countless hours, finally got this board fully stable and working.


This is the only way i got it working


MB= 4coredual-sata2 rev. 2


bios= 1.9






Distro: IPC 10.5.6 PPF5




Kernel = 9.5.0 Voodoo


Chipset = VIA (it is the universal 1 for many other chipsets)


Ethernet = VIA Rhine


Sound = Didn't bother with onboard sound since i used external sound.


Notes: I didn't choose any video kexts because that was the option that kept giving me trouble. I have a GeFroce FX 5200 AGP 128MB and the way i got it working is by not selecting any kexts at install, and using NVKUSHcomplete package after install and it worked great!


I tried to update to 10.5.7 and bricked it!! so i stayed at 10.5.6 and upgraded kernel to 9.6.0!

Link to comment
Share on other sites

  • 4 months later...



is there any way to install snow leopard on the 4 core dual sata2 rev. 1 mobo with an agp ati radeon

x1950 pro gpu and an intel core 2 quad 6600 cpu? I tried it with snow leopard by hazard, the installation works

but everytime i try to boot the system i get a kernel panic :censored2:. Thanks for your help.


regards Killuminati

Link to comment
Share on other sites

  • 4 months later...
  • 1 month later...

I've managed to get almost everything running with 4coredual sata-R2.



-In order to boot your boot cd (or chameleon ) MUST include the VIAATA drivers:

you could find it on this forum or


in order to get sata working you must add your id as said:



- Network: will disconnect after few minutes unless you don't use it! Only fix is to run with cpus=1. (no other fix works, using a network pci card=same problem but using an usb adaptater does the trick)

- Sound: Despite efffort I was unable to get the AppleHDA working with snow leopard,

1/snow-leopard -> voodoohda 32/64bits works although some version will produce random kernel panic; Azalia works but is only 32 bits

2/leopard; applehda works with taruga patcher





I've (re)compiled a real 32/64bit driver for snow leopard:




I recommended to flash your mobo with the smith bios: (at least you could use it as a dsdt base)




Good luck.

Link to comment
Share on other sites

  • 2 months later...

Thank You very much Rafirafi!

I did install Snow Leo on a spare drive and it installed and ran OK, but no SATA drive. I never really bothered to look for a fix (until now). Actually, I'm having stability issues on 10.5.8 with the AppleVIA (stevo) based SATA, was thinking of downgrading back to 10.5.6 'cause it was pretty solid for me back then.

Link to comment
Share on other sites

  • 2 months later...

  • Create New...