Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Front Row broken

8 posts in this topic

Recommended Posts

on a 15" iMac core duo...

I just updated to 10.4.5 and the new iLife and all the rest today, and it seems that my frontrow's gone a little strange. The Movie Trailer browser (which I actually use quite a bit) wont come up at all. Rather than show me all those little movie posters to choose from, it just gives me a black screen telling me the server is not responding.


Thanks for the help and all.



EDIT - After repeated attempts, and finally posting up here, looks as though everything's functioning smoothly again. Not entirely sure what the problem was, but i suspect the server was down for updating, or something.

Share this post

Link to post
Share on other sites
I'm getting the same error message. Did you reinstall 10.4.5?


I didnt, i just waited a while (hoping the problem was on their end). with furthur use, however, it seems that i've been getting that error every once in a while even still. i'm not sure what the problem is, and if it's with my machine personally, the 10.4.5 update, or someting on their end. I wonder if anyone still using earlier versions could check for any problems and report.

Share this post

Link to post
Share on other sites

I am having the problem on my new mbp and have read various forums posts on it. This looks like it could be a problem with apple servers. Other suggestions involve manually setting your connection speed under the quicktime settings, deleting the front row cache from ~/Library/Caches/Front Row, creating a quicktime exception rule in the firewall etc but none of these solutions have worked for me.

I got the movie trailers to work last night but they are not working again this morning.


Quite irritating. People have also reported that front row works flawlessly in apple stores and that they may be getting preferential access to the akamai servers which host the content.


Apple apparently knows about the issue but isn't commenting.

Share this post

Link to post
Share on other sites

It's a server problem. Apple won't admit it, but they're having problems. I sproadically am able to view trailers, so I know Front Row is working.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.