Jump to content

mistakenly updated to 10.5.2 through Software Update from Kalyway 10.5.1 install


7 posts in this topic

Recommended Posts



By mistake, my girlfriend tried to update to 10.5.2 through Software Update while I was on holidays and the system does not start anymore.



I think I managed to install the kalyway 10.5.2 combo and new kernel by:


- booting from the Kalyway 10.5.1 Leopard DVD

- open a Terminal

- launching:

/Volumes/MAC/usr/sbin/installer -pkg KalywayUpdCombo10.5.2.pkg /Volumes/MAC

/Volumes/MAC/usr/sbin/installer -pkg kalyway_10.5.2_kernels.mpkg /Volumes/MAC


Still, the system would not boot:

Package 0 didn't get an HPET

panic (cpu 0 caller 0x449B0D5D): No HPETs available CPU(s) configured incorrectly @/SourceCache/AppleIntelCPUPowerManagement/AppleIntelCPUPowerManagement-33/pmThread.c:95


From another post, I also tried (knowing that had 99% chances to fail) to remove the /System/Library/Extensions/AppleIntelCPUPowerManagement.kext, delete the /System/Library/Extensions.mkext, reboot ... and this does not circumvent the problem...



I would like to avoid to re-install from scratch as after the Kalyway install (great job Kaly btw !), I would need to tweak the kexts for the audio, Wifi, Ethernet boards, etc...


Anyone found a solution ?




Link to comment
Share on other sites

I've got the same problem, I removed the AppleIntelCPUPowerManagement.kext, but now startup halts after:

BSD root: disk3s1, major 14, minor 9

jnl: unknown-dev: journal start/end pointers reset! (jnl 0x4cdcf00; s 0xf50e00 e 0xf50e00)


and I don't get the HPET error anymore.


Also i can see in your screenshot "Mac OS version 9C__". Mine was still 9B18. So at least your kernel got updated :(.


edit: looks like my problem might be because I used macdrive to delete the kext and it didn't write the journal properly.


2nd edit: fsck fixed the 'journal' error, but i still can't get past the BSD root message. also now the root has changed to disk1s1.

Link to comment
Share on other sites

REinstall is the only way I know, Wish I had better news


Same thing happened to me, If you had time machine running ,just start the install again and when you get to the Kalyway welcome screen chose "restore" from the drop down menu.

Don;t worry about the warning about loosing everthing, I picked a restore point 1 hour back.

When it rebooted everything was working perfect again. If you use time machine, make sure it runs on a seperate partition or even better ,on a different drive.

It;s saved me a few times......

Link to comment
Share on other sites

  • 1 year later...

Have the same "CPU lost HPET" after Chameleon tweek...


I'm afraid the fresh install will be the fastest way to recover...

.. will start my Snow re-install now

anyway go to Snow, its terrific, and worth it!


take care

Link to comment
Share on other sites


  • Create New...