Jump to content

Realtek ALC888 - No Audio


9 posts in this topic

Recommended Posts



i have the following problem: I have no audio. I used the ALC888 pkg from the sticky Audio Thread in the Tutorials section. It says installation succesfull. Then he reboots my pc but without any effects. What should i do now ?


My audio card:


Realtek High Definition Audio





Thanks for help!

Link to comment
Share on other sites

  • 3 weeks later...

I have success with the driver, but it does not show up in the systeminfo.

Go to Audio/MIDI setup and create a combined device (cmd-shift-A).

Add all channels to the device

Choose config-speakers in the open window

Choose multichannel

Choose 7.1

Set all channels to 96khz / 20bit

You must check wether the channels match the plugs on the back of your machine. You can alter them as you like. I feel the standard layout matches the rear-panel, but I did not check it thoroughly.


First I ran this one:


I chose both 6 channel options

Than I ran this one:

Alc888.pkg (but I have no idea where I found it).

So I don't know if both are nessecary, but the stuff did not work with just step 1.

Link to comment
Share on other sites

  • 11 months later...
  • 4 weeks later...

Different computers have different layout even the CodeID is same so try different drivers if you cant compile your own. You'll finally get what you need. Good luck. BTW, I have driver for ALC888s. Search the forum if you need it.

Link to comment
Share on other sites


  • Create New...