Jump to content

[Guide + Software] Gigabyte GA-P35-DS3P/R (10.4.11 + EFI)


31 posts in this topic

Recommended Posts

*NEW* The completely revised and much more detailed guide in PDF and DOC formats and all the software required (network and sound drivers, EFI) and extras (FrontRow) have been packaged together and are available for download --> here


For some reason if you want the old guide that was posted here earlier back, its attached below as oldguide.txt. The new guide has been completely revised and much more detail has been put into it like step by step installation, etc. Its strongly recommended that you use the new guide ;) This guide is also now compatible with the DS3R series.


Whats included in the package?:

  • 5 page complete installation guide in both PDF and editable DOC (Word) formats
  • ALC889A sound drivers
  • Realtek R8111B network drivers
  • PC EFI v8 by netkas
  • FrontRow OSx86 Installer Package by Xosx86
  • Kext Helper b7 by delish

Download size: 7.02MB (ZIP archive)

Download here

If for some reason the download link doesn't work, please PM me and I'll reupload it.


For your convenience, pc_efi_v80 and the hardware drivers are still individually attached below.


**NEWS**: If anyone cares, I'm doing a 10.5.2 version of this guide just as soon as I update successfully and get most of the kinks worked out. I'm happy to report though that I've gotten Kalyway 10.5.1 working fully aside from some minor sleep, shutdown and restart issues :)






Edited by ~pcwiz
Link to comment
Share on other sites

Differences between DS3P and DS3L:


1. DS3P has ICH9R SATA while the DS3L has just ICH9

2. DS3P has 2 PCIe slots, DS3L has one

3. DS3L has 3 PCI slots, DS3P only has 2 because of the extra PCIe slot

4. DS3L has COM and LPT ports, DS3P starting from Rev. 2.0 doesn't have these, although Rev 1.1 does

5. DS3P has 4 more USB ports than the DS3L for a grand total of 8 ports

6. DS3P has 2 FireWire ports, DS3L has none


Those are all the differences, but this guide should work just as well with the DS3L :)

Link to comment
Share on other sites

Well, I was originally going to install 10.5. Even had the iATKOS v1.0iR2 DVD downloaded which took 2 days to download...then the worst possible thing happened: The DVD image turned out to be corrupt. It was too much work to download and do everything again, so I just installed Tiger from the DVDs I had downloaded earlier (Uphuck).


Don't think I'll download Leopard unless theres a must have in Leopard.


P.S. Typing this from Tiger now :)

Link to comment
Share on other sites

Thanks pcwiz, I already know those specs from Giabyte site, what I meant is what differences in terms of this guide.


I asking because I read in other threads that there is no "support" to AHCI for the ICH9 but for the ICH9R, and using the AppleVIAATA kexts gives you only 2 SATA ports.

Link to comment
Share on other sites

pcwiz. I shake you by the hand for providing the kexts for the Audio since your kexts make the Mic work in Leopard ;). Massive thanks for linking to them. Speech, Here we come.

Link to comment
Share on other sites

  • 3 weeks later...
Just a little update, I'm gonna attempt Leopard now. Kalyway 10.5.1 is 92% done, a couple more hours and I'm gonna give it a shot. Might even write a guide :P



Hey PCWIZ, long time


I have shutdown and reboot working fine with my method and files

Link to comment
Share on other sites

  • 2 weeks later...

Hi pcwiz!


Thanks very much for your detailed guide and package. It's great!


I'm building another hack (not the one on my signature) for a mate at work with this specs:


- Gigabyte GA-EP35-DS3R (Rev 2.1)

- Q6600

- 8Gb 800Hz Ram

- 3x 500Gb SATA Drives

- Pioneer SATA CD/DVD

- GF 8800 GTX 1.5gb



Before attempting this guide, I went through many issues trying to install Kalyway.


- 500Gb Disk recognised as 128Gb

- Waiting for root device

- SATA Drive taking a looong time to read - Install said 2.30hs to install

- tried Installing XP first but the install allways crashed (blue screen) - had AHCI enabled


hehe, I think I went through almost everything.



Then on Friday I found this guide and everything went smoothly.... UNTIL I get to the step of installing 10.5.2. Installation went fine but after restart it got stuck without booting... I booted again with GParted thinking that It was the Boot Flag that was gone and.... surprise!!! the partitions were gone and the disk was shown as unknown.


My aim is to have XP/Leo Dualbooting.


Only thing I did before following your guide was run Gparted to partition my drive in an attempt to solve the 128Gb problem:


3 FAT32 partitions 50gb - 50gb - 400gb


1st for Leopard - Primary

2nd or XP - Primary

3rd for DATA - Extended


Then when followed your guide I repartitioned, and followed it step by step.


Not sure where I went wrong. I'll start from scratch again on monday (The machine is at work).


I read that I should install XP first to make dualbooting, but I'd hate to do that and the loose my partitions again. So I'd like to know if there is a way to setup dualbooting after installing Leopard.


Thanks a lot for your help!

Link to comment
Share on other sites

Will the alc889a work for DS3L 2.0 in Leopard? Well, I downloaded it and I'm gonna try it now. That leopard version of the pack sounds nice, care to post a link?CheersWell, I installed the kexts using the kexthelper that came with Kalyway 10.5.1 and rebooted. Still, it dosen't recognize any in our out audio. Hmmm.

Link to comment
Share on other sites


  • Create New...