Jump to content

Help with iATKOS!


11 posts in this topic

Recommended Posts

Hi, I am brand new here, and I have tried to install iATKOS on my system. Problem is, when I try to boot OSX, i just get the flashing cursor. I have tried every single install option i can think of, and I have set the drive to boot every time, but I always get that cursor. My question is, what can I do to make OSX boot???



Gateway m520hx

Intel P4 3.06 Ghz w/ HT

512 MB memory

60 GB HD


Anyone have a clue of what I can do? I heard something about a patch or something like that, but I'm not sure what it is or how to install it. As of now, I have just re-installed windows xp.




Link to comment
Share on other sites

Did you install the Darwin Boot Loader. In iATKOS you have to manually install it through the terminal.

I'm having the same problem, using iAtkos 1.0ir2. There is an option in the installer for Darwin X86 bootloader and Darwin EFI, both of which I tried. When I boot from the OSX partition, I just get a grey cursor.


I also tried doing the manual bless/startupfiletool/dd stuff like from Brazilmac, but no success.


I thought the iAtkos/uphuck releases were supposed to be easy?

Link to comment
Share on other sites

I had this same problem with iATKOS.

The first time I installed it I used the disk utility to make my partitions and used MBR like the directions said, but got the blinking cursor problem. Then I used Gparted Live CD to created the partitions making sure my partition where I would install Leopard was flagged to boot. After that was done I booted from the iATKOS DVD again and used disk utility only to erase my partition and make it the correct file system. Then I installed the Darwin Boot Loader and selected no for the EFI option. After that I finished installing Leopard and it boots fine now.

The computer I installed it on is a completely stock Compaq SR5350F.

Link to comment
Share on other sites

One thing you can do is leave the install DVD in when you boot - if everything boots OK with the DVD in, then you know that everything is basically OK & you just have to work on setting the boot flag & getting the Darwin boot loader installed correctly(or you can just leave th DVD in & let the Darwin boot loader on the DVD do the job.

Link to comment
Share on other sites


i had tried setting the partition active with fdisk, gparted, cfdisk, partition magic, Acronis disk director....


in the end, boots fine with the DVD; I had to use rd=/dev/rdisk0s2 (I installed to the second partition of my drive, after WinXP).


any ideas why the usual

dd if=boot1h of=/dev/rdiskXsY



didn't work? and why the automatic installer didn't work? i mean it didn't even write anything to my MBR or boot sector of the OSX partition as far as I can tell.

Link to comment
Share on other sites

Which version of iATKOS?


I know this fix helped me with ver 1.0i..should work with 1.0ir2.


Boot the insallation DVD, type in -s at the prompt. Then at the prompt type in

fdisk -e /dev/rdiskx (replace with your disk info)


f 1




Link to comment
Share on other sites

  • 3 weeks later...

  • Create New...