Jump to content

ACPI_SMC_PlatformPlugin Problem : Expert Guidance Please


37 posts in this topic

Recommended Posts

I think this is a very common problem among osx86 installers in laptops. I could find several posts by users having the same problem but no satisfactory solution.


While booting from the install DVD the system hangs mid-way.


ACPI CA 20060421

AppleACPICPU: ProcessorApicId=1 LocalApicId=0 Enabled

AppleACPICPU: ProcessorApicId=2 LocalApicId=1 Enabled

AppleACPICPU: ProcessorApicId=3 LocalApicId=130 Disabled

AppleACPICPU: ProcessorApicId=4 LocalApicId=131 Disabled

Loading security extension com.apple.nke.applicationfirewall

Loading security extension com.apple.security.seatbelt

calling mpo_policy_init for mb

Seatbelt MACF policy initialized

Security policy loaded: Seatbelt Policy (mb)

Loading security extension com.apple.security.TMSafetyNet

calling mpo_policy_init for TMSafetyNet

Security policy loaded: Safety net for Time Machine (TMSafetyNet)

Copyright © 1982, 1986, 1989, 1991, 1993

The Regents of the University of California. All rights reserved.


MAC Framework successfully initialized

using 10485 buffer headers and 4096 cluster IO buffer headers

dsmos: Starting...

Extension "com.apple.driver.ACPI_SMC_PlatformPlugin" has immediate dependencies on both com.apple.kernel and com.apple.kpi components; use only one style.

IOAPIC: Version 0x20 Vectors 64:87

ACPI: System State [s0 S3 S4 S5] (S3)

ACPI_SMC_CtrlLoop::initCPUCtrlLoop - pmCPUControl (PMIOCSETPSTATETABLE) returned 0x2c62a00


I think this problem is related to "Extension "com.apple.driver.ACPI_SMC_PlatformPlugin" has immediate dependencies on both com.apple.kernel and com.apple.kpi components; use only one style." and the laptop ACPI.


I am using a Leopard AMD 10.5.1 DVD but this problem is common with other users booting from iATKOS, Kalyway, ToH etc.


Some similar posts I could find having the same problem:


http://forum.insanelymac.com/index.php?showtopic=77327 (HP NC8000 laptop)


http://forum.insanelymac.com/index.php?showtopic=77380 (Acer travelmate 8204wlmi)


My system specs:


Toshiba Sattelite A215-S4697

AMD Turion64 X2 1.6 Ghz


Radeon X1200


And no, I do not have any options to disable ACPI from bios.


Any help would be greatly appreciated!


Thank you very much



Link to comment
Share on other sites

This problem has been around since Tiger.


I finally read some where about how to fix it. It would seem you can do one of two things. Delete the kext file that relates to that and try and pull the old Kext files from 10.4.8 if they had worked for you.


And the second method I am only aware of it working on Asus laptops but it should work on others I would expect. Try the different BIOS updates for your laptops, some F series laptops from Asus work only with BIOS 203 some other, might be 207.


I have a G2S and I am on BIOS 205 and I get the same error... until I reload Vista I cannot downgrade or upgrade my BIOS. I will also try the kalyway release, I have heard some differing success with it to get past the ACPI as well.

Link to comment
Share on other sites



Had the same problem on a ASROCK Conroe 1333-D667 1.0 motherboard, with iATKOS (10.5), Kaly (10.5), (and even with uphuck - 10.4). Installer (with -v) hangs on ACPI_SMC... or reboots. The solution I found was to downgrade the bios, in my case from the latest 1.80 to 1.10, this is still a work in progress, but after the downgrade the iATKOS dvd booted without any problem and proceeded to install. The problem now is tweaking the rest :)


Is this some sort of OEM action to stop OSX86? :(

Link to comment
Share on other sites



I have an Asus F3 series laptop and I'm getting this error when I boot up the BrazilMac patched DVD... and I tried all the different BIOS versions (203, 204, 206, 207) with no success. Does anyone know where the file is so I can try and replace it?




Link to comment
Share on other sites

Hi everyone, first post! :)


I'm trying to make Leopard on my G2S, but still no luck... I've tried both of the solutions mentioned here (BIOS upgrade and files removal) but even the latest 212 BIOS update doesn't change a thing...Also, I've tried to use 10.4.8 ACPI libraries, said to solve the problem in most cases... nothing changed...


"Luckily", my system boots using the install DVD, but it's obviously very slow.


So... any news?

Link to comment
Share on other sites

  • 2 weeks later...

Hey guys,


I got this to work eventually, but I didn't reply back to this thread =/


For my Asus F3 series laptop, I had to pull AppleACPIPlatform.kext and AppleAPIC.kext from the 10.4.8 install and boot using a .mkext file.


After having no luck with this, I tried remaking my BrazilMac DVD by replacing the 2 kexts again... and I got it to load past this error (it still appeared)... and it hanged somewhere else.


I replaced the 2 kexts another time (remade my mkext file) and made the DVD AGAIN... finally it booted into the DVD!


I don't know if this will help anyone at all, but that's how I solved my problem =/


Good luck!


Link to comment
Share on other sites



I have the same problem with an Inspiron 8600. Did anyone figure this out? Is the fuile in attachement working for you guys? I will try to replace those files in the DVD Image I have, but I'm in Windows, not sure it'll work.


If any one has a clue on how to fix this please let me know,


Link to comment
Share on other sites

  • 3 weeks later...

I have got the same problem on my ASUS G1S. I have managed to install Leopard using the Kalyway 10.5.1 DVD but when I reboot I can't get the system to boot without the DVD. I've tried many time to replace the Kext with no success, they get restored from somewhere even when I empty the cache through Terminal.

Link to comment
Share on other sites

Hello. I have ASUS A8Js notebook, and had a problem after installing new 9.2 kernel, getting panic like at 1st post here. (com.apple.driver.ACPI_SMC_PlatformPlugin"). I found this plugin into the IOPlatformPluginFamily.kext and just delete it first. And had booting! Just long time boot, around 3-4 min. Then i just replace IOPlatformPluginFamily.kext from 10.5.1 Leo and got normal, fast boot and working system 10.5.2 Leo with 9.2 kernel. Maybe this help someone.

Link to comment
Share on other sites

To those that have done this. Did this allow you to use both CPUs? particulary on Asus Core 2 Duo laptops?

Asus core 2 duo laptops (mostly F3 series and AFAIK probably G series) have not been known to be able to use both cores. Bios compatibility problems with new ACPI and APIC kexts is the issue. Let me know if you know anyone who has both cores running!

Link to comment
Share on other sites

  • 1 month later...

Hi, Sorry - noob here. been using PCs for ages but this is new to me. I got the update file (Leo_ACPI_APIC_SMBIOS.zip) because I have the same problem as above. I have read to put these on the original ISO (will try Magic ISO - I have it already) but where do I put the files in the ISO? Sorry to be a pain. Would appreciate any help. Thanks. Ben.

Link to comment
Share on other sites


  • Create New...